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1 Introduction 


1.1 About This Manual 
 
Because of the size of this manual (and because it is constantly being updated as new versions of 
HERO™ CMS are released), printing it is not recommended.  Instead, it should ideally be 
viewed using a program such as Microsoft Word.  To obtain the latest version of this manual, 
contact HTN (see section “HTN”). 
 
This manual contains many sections, and many “hyperlinks” from one section to another (or 
sometimes a hyperlink will point to a web site).  For example, to add a patient to your database, 
see section “Add a Patient”.  As you can see, the hyperlinks are usually displayed in a different 
colour (e.g. blue or pink instead of black), and underlined.  In Microsoft Word, you can generally 
follow a hyperlink (to jump to the referenced manual section or web site) by holding down 
CTRL while clicking on the hyperlink with the mouse, or by placing the insertion point in the 
hyperlink and pressing Enter (this also works in the Table of Contents).  This convenient feature 
may not be available in other programs. 
 


1.2 What is HERO™ CMS? 
 
As a complete Clinical Management System (CMS), HERO™ CMS has two major components: 
 


1. Electronic Medical Records (EMR) / Electronic Health Records (EHR) / Cumulative 
Patient Profile (CPP) / Core Data Set (CDS):  Contains medical information about your 
patients, such as diagnoses, procedures, prescriptions, lab test requisitions/results, 
immunizations, allergies, family medical history, etc.  This is the type of information that 
might be shared among multiple providers working for the same patient (for example, a 
general practitioner and a specialist). 


 
2. Practice Management System (PMS):  Contains information for internal clinical use, such 


as appointments, bills (HCP, RMB, WSIB, Private, or Insurer), payments, patients’ 
insurance policies, patients’ contact information, tasks, etc. 


 
Depending on your configuration, some features may be enabled/disabled.  For more 
information, contact HTN (see section “HTN”). 
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1.3 Data Flow Structure 
 


 
 
HERO™ CMS has three major components: 
 


1. Workstation – A computer that runs the HERO™ CMS client, where a user can 
enter and view data.  Workstations are usually located in your office, but can be 
located anywhere, e.g. at a different office, at home, etc.  Any number of workstations 
can access the same database simultaneously. 


2. Site Server – A computer that runs the HERO™ CMS server, where the database is 
actually stored.  This can be on the same computer as the HERO™ CMS client (see 
above), or the two can communicate over a network (e.g. LAN, Internet).  The Site 
Server is probably located in your office, but can be located anywhere. 


3. FMS (Facility Management Site) – A powerful server run by HTN (see section 
“HTN”) which performs several functions: 
a. Communicates with MOHLTC, e.g. creates/sends batches and OBEC requests, 


and receives the responses (RAs, error claim files, batch acknowledgments, and 
OBEC responses) and incorporates them into your database. 


b. Communicates with labs, e.g. sends lab requisitions and receives lab test results. 
c. Maintains a partial backup of your database.  If you ever experience data loss on 


your Site Server for any reason, HERO™ CMS might be able to restore (some of) 
your data from the FMS. 
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d. Allows HTN (see section “HTN”) to send you information such as procedure 
codes (see section “Procedure Codes”), diagnosis codes (see section “Diagnosis 
Codes”), ICD-9 codes (see section “ICD-9 Codes”), software updates (see section 
“Update”), drug/allergy database (see section “Drugs” or “Allergy Codes”), etc. 


 
The Site Server communicates with the FMS through transmissions (see section 
“Transmissions”). 
 
This manual only deals with the HERO™ CMS client that runs on the workstations.  For 
assistance managing your Site Server, contact HTN (see section “HTN”). 
 


1.4 Before You Begin 
 
Generally, when you buy HERO™ CMS, it is installed for you by HTN (see section “HTN”).  
For installation assistance, contact HTN. 
 
When you run HERO™ CMS, the database needs to know who you are.  In other words, each 
HERO™ CMS user should be identified with a unique username, and each user account should 
be associated with a password to protect it.  There are several reasons for this: 
 


1. Tasks:  For a user to send (or receive) a task, HERO™ CMS must know his/her 
username.  See section “Tasks”. 


2. Security:  In HERO™ CMS, you can choose which users have access to which features 
or data.  For example, billing staff might have access to bills and payments, while 
receptionists might have access to appointments, but not vice versa.  Or, Dr. A’s secretary 
might have access to Dr. A’s data, and Dr. B’s secretary might have access to Dr. B’s 
data, but not vice versa.  The possibilities are limitless.  Most of these settings are 
configured in the Provider window, Security tab (see section “Provider Window, Security 
Tab”).  You can also choose which users are allowed to run HERO™ CMS. 


3. Audit:  Whenever a user launches the HERO™ CMS client and connects to your 
HERO™ CMS database, and/or whenever a user opens or saves a record (e.g. patient, 
appointment, bill, payment, etc.) in HERO™ CMS, a record of this is made in the audit 
log, if the audit is enabled.  The audit log indicates which user performed each action 
(connecting, opening, or saving a record), and their domain (see section “Domain”).  See 
section “Audit”. 


4. For all patient-specific records (e.g. Appointments, Bills, Payments, etc.) in your 
database, HERO™ CMS keeps track of who last modified them, even if your Audit is 
disabled (see section “Audit”).  This information can be viewed on any tab the Patient 
window (except Demographic and Lab), in the User and Domain fields (see section 
“Patient Window”).  The user field stores the user’s username.  For more information on 
the Domain field, see section “Domain”. 


 
When you run HERO™ CMS, there are two ways authenticate: 
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1. Manual Log On:  If the “Require Log On” option is on (see section “Configuration”), 
every time HERO™ CMS is launched, a HERO Log On dialog box will open (see 
section “HERO Log On Dialog Box”).  (Also, the HERO Log On dialog box will 
appear again if you use the Lock Session feature – see section “Lock Session”.)  Enter 
a username and password, and then select OK or press Enter. 


2. Automatic Log On:  If the “Require Log On” option is off (see section 
“Configuration”), HERO™ CMS will automatically identify you with your Windows 
username. 


 
Once you are authenticated, your username will appear in the HERO™ CMS title bar (see 
section “General”). 
 
For more information on authentication, contact your server/network administrator.  To change 
your password, see section “Change Password”. 
 
HERO™ CMS also supports “user groups.”  A user group is a way of configuring security 
settings, or assigning tasks, for a group of users simultaneously, instead of for each one 
individually.  A user group is not the same as a group of providers that is assigned a 4-character 
identifier by MOHLTC (see section “Provider Window, Demographic Tab, Role List”). 
 
HERO™ CMS supports these user groups: 
 
Hero Administrators 
Hero Billers 
Hero Locums 
Hero Nurses 
Hero Providers 
Hero Reception 
Hero Group1 
Hero Group2 
Hero Group3 
Hero Group4 
Hero Group5 
 
Anyone in the “Hero Administrators” group can access any data or function in HERO™ CMS.  
Also, HERO™ CMS has the following security restrictions: 
 


 Only a user in the “Hero Administrators” group can attach a database (see section “Server 
Initialization Dialog Box”). 


 Only a user in the “Hero Administrators” group can manage system-wide security 
settings (see section “Domain Users Dialog Box”). 


 Only a user in the “Hero Administrators” group can manage system-wide configuration 
settings (see section “Miscellaneous Dialog Box”). 


 Only a user in the “Hero Administrators,” “Hero Providers,” and/or “Hero Billers” 
groups can send bills in a transmission (see section “Transmissions”). 
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 Only a user in the “Hero Administrators” group can reorganize your database (see section 
“Reorganize”). 


 Only a user in the “Hero Administrators” group can use the HERO™ CMS backup 
feature (see section “Backup”). 


 Only a user in the “Hero Administrators” group can obtain an audit log (see section 
“Audit”). 


 Only a user in the “Hero Administrators” group can use the Data Port features (see 
section “Export” or “Import”). 


 
Other than access to these functions, the user groups listed above have no special meaning or 
significance in HERO™ CMS, and can be used any way you want.  For example, you could put 
everyone who sits at the front desk in your office into the group “Hero Reception”.  Then you 
could assign “Hero Reception” permissions to add patients and book appointments (but not enter 
bills or payments), and send tasks to “Hero Reception” to remind all of those users to turn off the 
lights in the waiting room at the end of the day, to check the fax machine for incoming faxes, etc.  
Those security settings and tasks will be assigned to all users in the “Hero Reception” group. 
 
A user can be a member of multiple user groups simultaneously.  Also, a user group can have 
any number of members. 
 
To configure which users are in which groups, contact your server/network administrator. 
 


1.4.1 Domain 
 
In this manual, “domain” generally refers to a Windows Server Domain, which is a method used 
for controlling security on a network.  This is not the same thing as an Internet domain name 
(e.g. htninc.com). 
 
For all patient-specific records (e.g. Appointments, Bills, Payments, etc.) in your database, 
HERO™ CMS keeps track of who last modified them, even if your Audit is disabled (see section 
“Audit”).  This information can be viewed on any tab in the Patient window (except 
Demographic and Lab), in the User and Domain fields (see section “Patient Window”).  The user 
field stores the user’s username.  The domain field stores either the name of the computer where 
the record was last modified, or the domain under which the user (who last modified the record) 
was authenticated (logged in), depending on your network configuration. 
 
To find out if your network has a domain, and more information about (logging into) the domain, 
contact your server/network administrator. 
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1.5 General 
 


 
 
The HERO™ CMS window contains the following components: 
 


 Title Bar – This is a standard Windows title bar which contains a control menu (Restore, 
Move, Size, Minimize, Maximize, Close), program name and version number, and 
minimize, maximize, and close buttons.  For more information, check your Windows 
help or documentation.  The title bar also includes the user’s username, and (in brackets) 
any user groups the user belongs to (see section “Before You Begin”). 


 Menu Bar (see section “Pull-Down Menus”). 
 Main Toolbar (see section “Main Toolbar”). 
 Action Bar (see section “Action Bar”). 
 TreeView Bar (see section “TreeView Bar”). 
 Main Area – contains all open windows (e.g. Patient, Appointment, Bill, Payment, etc.). 
 Status Bar (see section “Status Bar”). 


 


1.6 Pull-Down Menus (Menu Bar) 
 
The menu bar appears just below the title bar at the top of the HERO™ CMS window (see 
section “General”).  The pull-down menus are launched from the menu bar.  The menu items are: 
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File → New → Patient (Ctrl-T) – Add a patient (see section “Patient Window”). 
 
File → New → Appointment (Ctrl-A) – Add an appointment (see section “Appointment 
Window”). 
 
File → New → Bill (Ctrl-B) – Add a bill (see section “Bill Window”).  NOTE:  If the insertion 
point is in a notes field, the shortcut key Ctrl-B is used to make text bold, not to add a bill.  See 
section “Notes Fields”. 
 
File → New → Payment (Ctrl-Y) – Add a payment (see section “Payment Window”). 
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File → New → Encounter (Ctrl-E) – Add an encounter (see section “Encounter Window”). 
 
File → New → Rx (Ctrl-R) – Add a prescription (see section “Rx Window”). 
 
File → New → Requisition (Ctrl-Q) – Add a lab requisition (see section “Requisition 
Window”). 
 
File → New → Task (Ctrl-K) – Add a task (see section “Task Window”). 
 
File → New → Referral (Ctrl-F) – Add a referral (see section “Referral Window”). 
 
File → New → Attachment (Ctrl-H) – Add an attachment (see section “Attachment Window”). 
 
File → New → Setup → Provider – Add a provider (see section “Provider Window”). 
 
File → New → Setup → Insurer – Add an insurer (see section “Insurer Window”). 
 
File → New → Setup → Report – Add a report (see section “Report Designer Window”). 
 
File → New → Setup → Template – Add a template (see section “Template Window”). 
 
File → New → Setup → Code → Diagnosis – Add a diagnosis code (see section “Diagnosis 
Window”). 
 
File → New → Setup → Code → Procedure – Add a procedure code (see section “Procedure 
Window”). 
 
File → New → Setup → Code → Drug – Add a drug (see section “Drug Window”). 
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File → Open → Patient (Ctrl-Shift-T) – View/modify a patient.  If you select this, a Find 
Patient dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then 
select OK or press F9, or double-click on a patient, and then a Patient window will open (see 
section “Patient Window”). 
 
File → Open → Appointment (Ctrl-Shift-A) – View/modify an appointment.  If you select this, 
a Find Appointment dialog box will open (see section “Find Appointment Dialog Box”).  Select 
an appointment and then select OK or press F9, or double-click on an appointment, and then an 
Appointment window will open (see section “Appointment Window”). 
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File → Open → Bill (Ctrl-Shift-B) – View/modify a bill.  If you select this, a Find Bill dialog 
box will open (see section “Find Bill Dialog Box”).  Select a bill and then select OK or press F9, 
or double-click on a bill, and then a Bill window will open (see section “Bill Window”). 
 
File → Open → Payment (Ctrl-Shift-Y) – View/modify a payment.  If you select this, a Find 
Payment dialog box will open (see section “Find Payment Dialog Box”).  Select a payment and 
then select OK or press F9, or double-click on a payment, and then a Payment window will open 
(see section “Payment Window”). 
 
File → Open → Setup → Configuration – Configure HERO™ CMS (see section 
“Configuration”). 
 
File → Open → Setup → Provider – View/modify a provider.  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Each provider will only 
be displayed once on the list, even providers that have more than one role (see section “Provider 
Window, Demographic Tab, Role List”).  Select a provider and then select OK or press F9, or 
double-click on a provider, and then a Provider window will open (see section “Provider 
Window”). 
 
File → Open → Setup → Insurer – View/modify an insurer.  If you select this, a Find Insurer 
dialog box will open (see section “Find Insurer Dialog Box”).  Select an insurer and then select 
OK or press F9, or double-click on an insurer, and then an Insurer window will open (see section 
“Insurer Window”). 
 
File → Open → Setup → Report – View/modify a report.  If you select this, a Find Report 
dialog box will open (see section “Find Report Dialog Box (to view/modify a report)”).  Select a 
report and then select OK or press F9, or double-click on a report, and then a Report Designer 
window will open (see section “Report Designer Window”). 
 
File → Open → Setup → Template – View/modify a template.  If you select this, a Find 
Template dialog box will open (see section “Find Template Dialog Box”).  Select a template and 
then select OK or press F9, or double-click on a template, and then a Template window will open 
(see section “Template Window”). 
 
File → Open → Setup → Color – View/modify a colour.  If you select this, a Find Color dialog 
box will open (see section “Find Color Dialog Box”).  Select a colour and then select OK or 
press F9, or double-click on a colour, and then a Color window will open (see section “Color 
Window”). 
 
File → Open → Setup → Code → Diagnosis – View/modify a diagnosis code.  If you select 
this, a Find Diagnosis dialog box will open (see section “Find Diagnosis Dialog Box”).  Select a 
diagnosis code and then select OK or press F9, or double-click on a diagnosis code, and then a 
Diagnosis window will open (see section “Diagnosis Window”). 
 
File → Open → Setup → Code → Procedure – View/modify a procedure code.  If you select 
this, a Find Procedure dialog box will open (see section “Find Procedure Dialog Box”).  Select a 
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procedure code and then select OK or press F9, or double-click on a procedure code, and then a 
Procedure window will open (see section “Procedure Window”). 
 
File → Open → Setup → Code → Drug – View/modify a drug.  If you select this, a Find Drug 
dialog box will open (see section “Find Drug Dialog Box”).  Select a drug and then select OK or 
press F9, or double-click on a drug, and then a Drug window will open (see section “Drug 
Window”). 
 


File → List → Patient – List patients (see 
section “List Patients”). 
 
File → List → Appointment – List 
appointments (see section “List 
Appointments”). 
 
File → List → Bill – List bills (see section 
“List Bills”). 
 
File → List → Payment – List payments 
(see section “List Payments”). 
 
File → List → Encounter – List encounters 
(see section “List Encounters”). 
 
File → List → Rx – List prescriptions (see 
section “List Prescriptions”). 
 
File → List → Lab – List lab results (see 
section “List Lab Results”). 
 
File → List → Recall – List recalls (see 
section “List Recalls”). 
 
File → List → Task – List tasks (see section 
“List Tasks”). 
 
File → List → Referral – List referrals (see 
section “List Referrals”). 
 
File → List → Attachment – List 
attachments (see section “List 
Attachments”). 
 


File → List → File – List billing files (batches, RAs, etc.).  See section “List Files”. 
 
File → Provider – Log in as a provider (see section “Log in as a Provider”). 
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File → Lock Session (F1) – Minimize HERO™ CMS, such that a password is needed to 
restore it.  See section “Lock Session”. 
 
File → Transmit – Do a transmission (see section “Transmissions”). 
  
File → Save (Ctrl-S) – Save the currently open record. 
 
File → Save and Close (Ctrl-L) – Save the currently open record and close the window. 
 
File → Copy – Make a duplicate copy of the currently open record. 
 
File → Delete (Ctrl-D) – Delete the currently open record. 
 
File → E-mail – E-mail a report (see section “E-mail a Report”). 
 
File → Fax – Fax a report (see section “Fax a Report”). 
 
File → Print (Ctrl-P) – Print a report (see section “Print a Report”). 
 
File → Print Preview (Ctrl-Shift-P) – Preview a report (see section “Preview a Report”). 
 
File → Printer Setup – Set print options (see section “Print Dialog Box”). 
 
File → Reorganize – Performs a maintenance procedure on your database.  See section 
“Reorganize”. 
 
File → Backup – Make a backup copy of your HERO™ CMS database.  See section 
“Backup”. 
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File → Audit → Access – Export a record of 
accesses to your database.  See section “Audit”. 
 
File → Audit → Edit – Export a record of 
writes to your database.  See section “Audit”. 
 
File → Audit → Past EMR – Reserved for 
future use. 
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File → Data Port → Export – Export 
electronic medical records from your HERO™ 
CMS database into files which can then be 
imported into another medical database.  See 
section “Export”. 
 
File → Data Port → Import – Import 
electronic medical records into your HERO™ 
CMS database from files (which were 
presumably exported from another medical 
database).  See section “Import”. 
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File → Export → PDF – Export a report in PDF 
format (see section “Export a Report”). 
 
File → Export → RTF – Export a report in RTF 
format (see section “Export a Report”). 
 
File → Export → Text – Export a report in plain 
text format (can be opened in a word processor, 
text editor, e-mail program, etc.)  See section 
“Export a Report”. 
 
File → Export → XLS – Export a report in XLS 
format (see section “Export a Report”). 
 
File → Export → XML – Export a report in 
XML format (see section “Export a Report”). 
 
File → Change Password – Change your 
HERO™ CMS password (see section “Change 
Password”). 
 
File → Update – Upgrade your workstation’s 
version of HERO™ CMS (see section “Update”). 
 
File → Close (Ctrl-F4) – Close the currently open 
window. 
 
File → Exit (Alt-F4) – Close HERO™ CMS. 


 
Edit → Undo (Ctrl-Z) – Undo all changes made since the current 
record was last opened/refreshed/saved (not just the most recent 
change).  NOTE:  If the insertion point is in a notes field, the 
shortcut key Ctrl-Z will undo only the last change to that field, not 
all changes to that record.  See section “Notes Fields”. 
 
Edit → Set Default – Set a default value for the selected field.  


See section “Defaults”. 
 
Edit → Default from Patient – Configure the selected field to automatically copy information 
from the relevant patient record.  See section “Defaults”. 
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Edit → Clear Default – Configure the selected field to have no default value.  See section 
“Defaults”. 
 


View → Refresh (F5) – Reload the data for the currently 
open window from the database. 
 
View → TreeView Bar – Enable/disable the TreeView 
Bar (see section “TreeView Bar”). 
 
View → Action Bar – Enable/disable the Action Bar 
(see section “Action Bar”). 
 
View → Status Bar – Enable/disable the status bar (see 
section “Status Bar”). 
 
View → Color On/Off – Enable/disable colours (see 
section “Colours”) when viewing a list of items (see 


section “Viewing a List of Items”). 
 
View → Color All Views – Choose whether colours should be used on all lists (see section 
“Viewing a List of Items”), or only on lists with heterogeneous items (e.g. items with different 
statuses, dates, types, etc.).  This option is only available if the “Color On/Off” option is on.  See 
section “Colours”. 
 
View → Reset → Defaults – Reset all defaults (see section “Defaults”), and then exit HERO™ 
CMS. 
 
View → Reset → Form Sizes – Reset all sizes/positions for all windows back to their default 
values, and then exit HERO™ CMS. 
 
View → Reset → Grid Layouts – Reset all sizes/positions for all lists (see section “Viewing a 
List of Items”) back to their default values, and then exit HERO™ CMS. 
 
View → Reset → Print Options – Reset all print options (e.g. printer, print range, copies) back 
to their default values, and then exit HERO™ CMS (see section “Print Dialog Box”). 
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Window → Cascade – Arrange all open windows 
in HERO™ CMS such that each window’s title bar 
is slightly below and to the right of the title bar of 
the window behind it: 


 


Window → Tile Horizontally – Arrange all open windows in 
HERO™ CMS above/below each other to fill up the entire 
HERO™ CMS window with no overlap: 
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Window → Tile Vertically – 
Arrange all open windows in 
HERO™ CMS side-by-side to 
fill up the entire HERO™ 
CMS window with no overlap: 


 
Window → Arrange Icons – Arrange all 
minimized windows in a grid with no 
overlap: 
 
At the bottom of the Window menu is a list of all open windows in HERO™ CMS.  The active 
window has a checkmark beside it.  Select one of those entries to jump to the corresponding 
window.  If at least 9 windows are open, only the first 9 will be displayed, and the last option 
will be “More Windows” which will open a Select Window dialog box (see section “Select 
Window Dialog Box”). 
 


Help → About Hero CMS – Display information (including version 
number) about HERO™ CMS. 


 


1.6.1 Select Window Dialog Box 
 


 Displays a list of all open windows in HERO™ 
CMS.  Select a window and select OK (or double-
click on a window) to jump to that window. 
 


 


1.7 Main Toolbar 
 
The Main Toolbar appears just below the menu bar (see section “Pull-Down Menus”) at the top 
of the HERO™ CMS window (see section “General”).  Some windows within HERO™ CMS 
(e.g. Patient, Appointment, Bill, Payment) also have their own toolbars.  To see the 
name/function of a button on any toolbar (and any shortcut key that can also be used to trigger 
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that same function), point to it with the mouse, and after a short delay a Tooltip will appear 


displaying the information, e.g.:   
 
The buttons in the Main Toolbar are: 
 


New → Patient (Ctrl-T) – Add a patient (see section “Patient 
Window”). 
 
New → Appointment (Ctrl-A) – Add an appointment (see section 
“Appointment Window”). 
 
New → Bill (Ctrl-B) – Add a bill (see section “Bill Window”).  NOTE:  
If the insertion point is in a notes field, the shortcut key Ctrl-B is used 
to make text bold, not to add a bill.  See section “Notes Fields”. 
 
New → Payment (Ctrl-Y) – Add a payment (see section “Payment 
Window”). 
 
New → Encounter (Ctrl-E) – Add an encounter (see section 
“Encounter Window”). 
 


New → Rx (Ctrl-R) – Add a prescription (see section “Rx Window”). 
 
New → Requisition (Ctrl-Q) – Add a lab requisition (see section “Requisition Window”). 
 
New → Task (Ctrl-K) – Add a task (see section “Task Window”). 
 
New → Referral (Ctrl-F) – Add a referral (see section “Referral Window”). 
 
New → Attachment (Ctrl-H) – Add an attachment (see section “Attachment Window”). 
 


Open → Patient (Ctrl-Shift-T) – View/modify a patient.  If you 
select this, a Find Patient dialog box will open (see section “Find 
Patient Dialog Box”).  Select a patient and then select OK or press 
F9, or double-click on a patient, and then a Patient window will 
open (see section “Patient Window”). 
 
Open → Appointment (Ctrl-Shift-A) – View/modify an 
appointment.  If you select this, a Find Appointment dialog box 
will open (see section “Find Appointment Dialog Box”).  Select an 


appointment and then select OK or press F9, or double-click on an appointment, and then an 
Appointment window will open (see section “Appointment Window”). 
 
Open → Bill (Ctrl-Shift-B) – View/modify a bill.  If you select this, a Find Bill dialog box will 
open (see section “Find Bill Dialog Box”).  Select a bill and then select OK or press F9, or 
double-click on a bill, and then a Bill window will open (see section “Bill Window”). 
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Open → Payment (Ctrl-Shift-Y) – View/modify a payment.  If you select this, a Find Payment 
dialog box will open (see section “Find Payment Dialog Box”).  Select a payment and then select 
OK or press F9, or double-click on a payment, and then a Payment window will open (see 
section “Payment Window”). 
 
Open → Provider – View/modify a local provider (not a referring provider).  If you select this, 
a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Each local 
provider will only be displayed once on the list, even providers that have more than one role (see 
section “Provider Window, Demographic Tab, Role List”).  (Referring providers will not be 
displayed at all.)  Select a provider and then select OK or press F9, or double-click on a provider, 
and then a Provider window will open (see section “Provider Window”). 
 


List → Patient – List patients (see section “List Patients”). 
 
List → Appointment – List appointments (see section “List Appointments”). 
 
List → Bill – List bills (see section “List Bills”). 
 
List → Payment – List payments (see section “List Payments”). 
 
List → Encounter – List encounters (see section “List Encounters”). 
 
List → Rx – List prescriptions (see section “List Prescriptions”). 
 
List → Lab – List lab results (see section “List Lab Results”). 
 
List → Recall – List recalls (see section “List Recalls”). 
 
List → Task – List tasks (see section “List Tasks”). 
 


List → Referral – List referrals (see section “List Referrals”). 
 
List → Attachment – List attachments (see section “List Attachments”). 
 
List → File – List billing files (batches, RAs, etc.).  See section “List Files”. 


 
Copy – Make a duplicate copy of the currently open record. 


 
Delete – Delete the currently open record. 
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Print → E-mail – E-mail a report (see section “E-mail a Report”). 
 
Print → Fax – Fax a report (see section “Fax a Report”). 
 
Print → Print (Ctrl-P) – Print a report (see section “Print a 
Report”). 
 
Print → Print Preview (Ctrl-Shift-P) – Preview a report (see 


section “Preview a Report”). 
 


Close – Close the currently open window. 
 
Undo (Ctrl-Z) – Undo all changes made since the current record was last 
opened/refreshed/saved (not just the most recent change).  NOTE:  If the insertion point is 


in a notes field, the shortcut key Ctrl-Z will undo only the last change to that field, not all 
changes to that record.  See section “Notes Fields”. 
 


Refresh (F5) – Reload the data for the currently open window from the database. 
 
Transmit – Do a transmission (see section “Transmissions”). 
 
TreeView Bar – Enable/disable the TreeView Bar (see section “TreeView Bar”). 
 
Action Bar – Enable/disable the Action Bar (see section “Action Bar”). 
 
Status Bar – Enable/disable the status bar (see section “Status Bar”). 
 


Color On/Off – Enable/disable colours (see section “Colours”) when viewing a list of items 
(see section “Viewing a List of Items”). 
 
Color All Views – Choose whether colours should be used on all lists (see section 
“Viewing a List of Items”), or only on lists with heterogeneous items (e.g. items with 


different statuses, dates, types, etc.).  This option is only available if the “Color On/Off” option is 
on.  See section “Colours”. 


 
Lock Session – Minimize HERO™ CMS, such that a password is required to restore it.  See 
section “Lock Session”. 
 
Select Provider – Log in as a provider (see section “Log in as a Provider”).  
 


The provider that is currently logged in (see section “Log in as a Provider”) will appear to the 
right of the buttons in the Main Toolbar. 
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1.8 Action Bar 
 
The Action Bar is an optional toolbar (disabled by default) that appears just below the Main 
Toolbar (see section “Main Toolbar”).  To enable/disable the Action Bar, go in the View menu to 
Action Bar (see section “Pull-Down Menus”), or select Action Bar in the Main Toolbar (see 
section “Main Toolbar”).  To see the name/function of a button on any toolbar (and any shortcut 
key that can also be used to trigger that same function), point to it with the mouse, and after a 


short delay a Tooltip will appear displaying the information, e.g.:   
 
The buttons in the Action Bar are: 
 


New Patient (Ctrl-T) – Add a patient (see section “Patient Window”). 
 
New Appointment (Ctrl-A) – Add an appointment (see section “Appointment Window”). 
 
New Bill (Ctrl-B) – Add a bill (see section “Bill Window”).  NOTE:  If the insertion point 
is in a notes field, the shortcut key Ctrl-B is used to make text bold, not to add a bill.  See 


section “Notes Fields”. 
 
New Payment (Ctrl-Y) – Add a payment (see section “Payment Window”). 
 
New Encounter (Ctrl-E) – Add an encounter (see section “Encounter Window”). 
 
New Rx (Ctrl-R) – Add a prescription (see section “Rx Window”). 
 
New Requisition (Ctrl-Q) – Add a lab requisition (see section “Requisition Window”). 


 
New Task (Ctrl-K) – Add a task (see section “Task Window”). 


 
New Referral (Ctrl-F) – Add a referral (see section “Referral Window”). 
 
New Attachment (Ctrl-H) – Add an attachment (see section “Attachment Window”). 
 
Open Patient (Ctrl-Shift-T) – View/modify a patient.  If you select this, a Find Patient 
dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then 


select OK or press F9, or double-click on a patient, and then a Patient window will open (see 
section “Patient Window”). 
 


Open Appointment (Ctrl-Shift-A) – View/modify an appointment.  If you select this, a 
Find Appointment dialog box will open (see section “Find Appointment Dialog Box”).  


Select an appointment and then select OK or press F9, or double-click on an appointment, and 
then an Appointment window will open (see section “Appointment Window”). 
 


Open Bill (Ctrl-Shift-B) – View/modify a bill.  If you select this, a Find Bill dialog box 
will open (see section “Find Bill Dialog Box”).  Select a bill and then select OK or press 
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F9, or double-click on a bill, and then a Bill window will open (see section “Bill Window”). 
 


Open Payment (Ctrl-Shift-Y) – View/modify a payment.  If you select this, a Find 
Payment dialog box will open (see section “Find Payment Dialog Box”).  Select a payment 


and then select OK or press F9, or double-click on a payment, and then a Payment window will 
open (see section “Payment Window”). 
 


Open Provider – View/modify a local provider (not a referring provider).  If you select 
this, a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Each 


local provider will only be displayed once on the list, even providers that have more than one 
role (see section “Provider Window, Demographic Tab, Role List”).  (Referring providers will 
not be displayed at all.)  Select a provider and then select OK or press F9, or double-click on a 
provider, and then a Provider window will open (see section “Provider Window”). 
 


List Patient – List patients (see section “List Patients”). 
 
List Appointment – List appointments (see section “List Appointments”). 
 
List Bill – List bills (see section “List Bills”). 
 
List Payment – List payments (see section “List Payments”). 
 
List Encounter – List encounters (see section “List Encounters”). 
 
List Rx – List prescriptions (see section “List Prescriptions”). 
 
List Lab – List lab results (see section “List Lab Results”). 


 
List Recall – List recalls (see section “List Recalls”). 


 
List Task – List tasks (see section “List Tasks”). 
 
List Referral – List referrals (see section “List Referrals”). 
 
List Attachment – List attachments (see section “List Attachments”). 
 
List File – List billing files (batches, RAs, etc.).  See section “List Files”. 
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1.9 TreeView Bar 
 


 


The TreeView Bar is an optional bar that appears on the left side of 
the HERO™ CMS window (see section “General”) and lists all open 
windows, sorted by type.  See section “Viewing a Tree of Items”. 
 
Select a window name to jump to that window. 
 
To change the size of the TreeView Bar, point to the border between 
the TreeView Bar and the main area (see section “General”) with the 
mouse, and click and hold with the left mouse button while dragging 
the border to a new location. 
 
To enable/disable the TreeView Bar, go in the View menu to 
TreeView Bar (see section “Pull-Down Menus”), or select TreeView 
Bar in the Main Toolbar (see section “Main Toolbar”). 


 


1.10 Status Bar 
 
The status bar appears at the bottom of the HERO™ CMS window (see section “General”) and 
displays the progress of a transmission (see section “Transmissions”) on the left side, and the 
current date (see section “Date Fields”) and time (see section “Time Fields”) on the right side. 
 
To enable/disable the status bar, go in the View menu to Status Bar (see section “Pull-Down 
Menus”), or select Status Bar in the Main Toolbar (see section “Main Toolbar”). 
 


1.11 Log in as a Provider 
 
HERO™ CMS allows you to “log in” as a provider.  The provider that is logged in will appear 
on the right side of the Main Toolbar (see section “Main Toolbar”).  Whenever you open a 
window (or dialog box) which requires you to choose a local provider (e.g. when you add, search 
for, or list appointments, bills, payments, etc.), the logged in provider will be automatically 
chosen.  This is an optional feature which may save you time (as opposed to selecting a provider 
manually in each window). 
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To log in, go in the File menu to Provider (see section “Pull-Down Menus”), or select “Select 
Provider” in the Main Toolbar (see section “Main Toolbar”).  A Find Provider dialog box will 
open (see section “Find Provider Dialog Box”).  All local roles for all providers (that match the 
search criteria) will be displayed (see section “Provider Window, Demographic Tab, Role List”), 
i.e. a matching provider with multiple local roles will show multiple matches.  Select a 
provider/role and then select OK or press F9, or double-click on a provider/role.  (To clear this 
field, select Clear and then OK.)  
 


2 Configuration 
 
Go in the File menu to Open → Setup → Configuration (see section “Pull-Down Menus”). 
 


WARNING:  It is recommended that you 
close all other windows in HERO™ CMS 
before modifying any data in the 
Configuration window, otherwise unsaved 
data may be lost. 
 
The fields are: 
 
Site # – A string of text assigned by HTN 
(see section “HTN”) to identify your 
database (required). 
 
SSL – If this option is on, the connection 
between this Workstation and the Site Server 
(see section “Data Flow Structure”) will be 
encrypted using a Secure Socket Layer.  For 
more information about SSL, contact your 
server/network administrator. 
 
Site URL – The computer name, 
host/domain name, or IP address of your Site 
Server computer.  If this is left blank, the 
value “localhost” (“127.0.0.1”) will be used 


(i.e. this assumes that your workstation and Site Server are on the same computer).  For more 
information, contact your server/network administrator. 
 
Site DB – The name of your HERO™ CMS database.  If this is left blank, the value 
“HEROCMS” will be used.  For more information, contact your server/network administrator. 
 
Site WS – The name of the web service used to access your HERO™ CMS database.  If this is 
left blank, the value “HeroWebService” will be used.  For more information, contact your 
server/network administrator. 
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Site User – If the username that you use to log into Windows is the same as your HERO™ CMS 
username (see section “Before You Begin”), but the passwords are different, enter your 
username in this field (unless Require Log On is on – see below).  Otherwise, leave this field 
blank. 
 
Password – If the username that you use to log into Windows is the same as your HERO™ 
CMS username (see section “Before You Begin”), but the passwords are different, enter your 
HERO™ CMS password in this field (unless Require Log On is on – see below).  Otherwise, 
leave this field blank. 
 
FMS User – A username that your Site Server uses to log on to the FMS (see section “Data 
Flow Structure”) during your transmissions (see section “Transmissions”).  Enter the value 
assigned by HTN (see section “HTN”). 
 
Password – A password that your Site Server uses to log on to the FMS (see section “Data Flow 
Structure”) during your transmissions (see section “Transmissions”).  Enter the value assigned 
by HTN (see section “HTN”). 
 
SMTP – If you want to send e-mail from HERO™ CMS (see section “E-mail a Report”), enter 
your SMTP server (should be provided by your Internet provider or server/network 
administrator).  If this field is left blank, Windows may use defaults from an e-mail program 
such as Outlook Express. 
 
Return – If you want to send e-mail from HERO™ CMS (see section “E-mail a Report”), enter 
your (return) e-mail address (should be provided by your Internet provider or server/network 
administrator).  If this field is left blank, Windows may use defaults from an e-mail program 
such as Outlook Express. 
  
Fax Server – If you want to send faxes from HERO™ CMS (see section “Fax a Report”), enter 
the computer name, host/domain name, or IP address of a computer on your network which has 
the Windows fax service installed and running (and, if necessary, shared for network use).  
(Also, the fax server computer requires a modem connected to a phone line.)  If this field is left 
blank, the value “localhost” (“127.0.0.1”) will be used (i.e. this assumes that your workstation 
and fax server are on the same computer).  For more information, check your Windows help or 
documentation, or contact your server/network administrator. 
 
Cover – The name of a cover page to use when sending faxes from HERO™ CMS (see section 
“Fax a Report”), e.g. “confdent”, “confident”, “urgent”, “fyi”, “generic”.  If this field is left 
blank, no cover page will be used.  For more information, check your Windows help or 
documentation, or contact your server/network administrator. 
 
Require Log On – Asks the user for a username and password every time HERO™ CMS is 
launched.  See section “Before You Begin”. 
 
Auto Lock – Specify how many minutes of idle time to wait before your HERO™ CMS will be 
automatically locked.  This option is only available if “Require Log On” is enabled (see above).  
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See section “Lock Session”. 
 
Card Reader – Indicate if your computer has a magnetic health card reader (connected to your 
computer’s keyboard port or USB port, not a serial port).  See section “Health Card Readers”.  If 
this option is on, and you ever need to type a percent sign (%) in HERO™ CMS (except in a 
dialog box), you will have to type the percent sign twice. 
 
Server – Opens a Server Initialization dialog box (see section “Server Initialization Dialog 
Box”), to attach your HERO™ CMS database.  Only users in the user group “Hero 
Administrators” can access this option (see section “Before You Begin”). 
 
Domain – Opens a Domain Users dialog box (see section “Domain Users Dialog Box”).  Only 
users in the user group “Hero Administrators” can access this option (see section “Before You 
Begin”). 
 
Misc – Opens a Miscellaneous dialog box (see section “Miscellaneous Dialog Box”).  Only users 
in the user group “Hero Administrators” can access this option (see section “Before You 
Begin”). 
 
NOTE:  The data entered in this window is stored in the Windows registry.  If all or part of the 
Windows registry is lost/deleted/altered, or HERO™ CMS is transferred/reinstalled to a new 
computer/disk or fresh copy of Windows, you may need to re-enter these values.  It is 
recommended that you record these values in a safe place in case you need them again in the 
future. 
 
To save changes to any of the above fields, go in the File menu to Save, or press Ctrl-S, or close 
the Configuration window, or close HERO™ CMS.  Once the changes are saved, HERO™ CMS 
will automatically close (any unsaved data will be lost).  You must then restart HERO™ CMS 
manually. 
 


2.1 Server Initialization Dialog Box 
 


 
 
The Server Initialization dialog box is used to attach your HERO™ CMS database, (i.e. to tell 
your Site Server where your HERO™ CMS database is located).  Usually, this procedure is 
performed only once:  during the HERO™ CMS installation, by HTN staff (see section “HTN”).  
Generally, you should not perform this procedure again, once HERO™ CMS has been installed.  
If you need to re-attach your database for some reason, you should first contact HTN (see section 
“HTN”). 
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Attaching your database should only be done on your Site Server computer (see section “Data 
Flow Structure”).  Performing this procedure on a remote workstation is not recommended. 
 
To attach your database, select File.  An Open dialog box will open (see section “Open Dialog 
Box”).  Select the location of your HERO™ CMS database (it’s usually “C:\Program 
Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\HEROCMS.MDF”) and then select Open 
(or double-click on the HERO™ CMS database).  Then select OK. 
 
The database will be attached under the database name that appeared in the “Site DB” field in the 
Configuration window (see section “Configuration”) when you launched HERO™ CMS.  If that 
field has changed since you launched HERO™ CMS, you must first restart HERO™ CMS before 
attaching a database. 
 
Once the database has been attached, you must exit and restart HERO™ CMS.  You can not 
attach another database without first restarting HERO™ CMS. 
 
Only users in the user group “Hero Administrators” can attach a database (see section “Before 
You Begin”). 
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2.2 Domain Users Dialog Box 
 


 
 
See section “Viewing a List of Items”. 
 
There are two ways to control security in your HERO™ CMS database: 
 


1. Windows authentication:  Only users with a valid username/password combination 
can access your HERO™ CMS database.  This option is recommended. 


2. Anonymous authentication:  Anyone can access your HERO™ CMS database, using 
any username and password.  The username doesn’t have to match any Windows 
account, and the password doesn’t have to be valid (correct).  This option is not 
recommended, especially if your Site Server is accessible via a large network (e.g. the 
Internet). 


 
To choose your security configuration, contact your server/network administrator.  For more 
information about security, see section “Before You Begin”. 
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If you use Windows authentication, then the contents of the Domain Users dialog box are 
irrelevant.  Just use the default settings, as per the sample image above.  Security can be 
controlled through Windows (contact your server/network administrator), and through the 
Provider window, Security tab (see section “Provider Window, Security Tab”). 
 
If you use anonymous authentication, then you can use the Domain Users dialog box to control 
which users on which computers are allowed to access which user groups (see section “Before 
You Begin”).  For example, to allow a user named “JOHN” on a computer named “SMITH” 
access to the user group “Hero Providers” (but no others), enter “JOHN” in the User field, 
“SMITH”, in the Domain field, and set the “Prov.” field to Allow, and the other fields to Deny. 
 
If you want to set permissions for all users of a particular computer (or domain – see section 
“Domain”), enter an asterisk (*) in the User field.  If you want to set permissions for a particular 
user, regardless of which computer (or domain) (s)he uses, enter an asterisk in the Domain field.  
If you want to set permissions for all users on all computers, enter asterisks in both the User and 
Domain fields.  Do not enter an asterisk in combination with any other text in either field.  Also, 
do not enter a question mark (?) in either field. 
 
To change a value in any field (except User or Domain) on this list, double-click in the field, or 
select the field and then enter/modify any text, or press F2 or F9.  A LookUp Access dialog box 
will open (see section “LookUp Access Dialog Box (Configuration)”). 
 
To delete an entry on the list, press Ctrl-Del. 
 
NOTE:  In order to prevent you from “locking yourself out” of your own database, if the list is 
blank, or if the word “Allow” does not appear in any of the “Admin.” fields, then all users are 
allowed to be in all groups. 
 
Only users in the user group “Hero Administrators” can access the Domain Users dialog box (see 
section “Before You Begin”). 
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2.3 Miscellaneous Dialog Box 
 
Only users in the user group “Hero Administrators” can access the Miscellaneous dialog box (see 
section “Before You Begin”). 
 


OBEC Freq. – The number of days before a patient’s 
appointment an OBEC request should be generated (to 
see if that patient’s health card number is valid).  See 
section “OBEC”. 
 
Letter 1 Wait – The number of days after sending out a 
first letter to the patient before a recall’s status will 
automatically change from “Letter1 Sent” to “Letter2 
ToDo”.  See section “How to use Recalls”, step #5. 
 
Letter 2 Wait – The number of days after sending out a 
second letter to the patient before a recall’s status will 
automatically change from “Letter2 Sent” to “Phone 
ToDo”.  See section “How to use Recalls”, step #9. 
 
Bill Wait – The number of days after phoning the patient 
before a recall’s status will automatically change from 


“Phone Done” to “Billable”.  See section “How to use Recalls”, step #13. 
 
Auto Inc. Chart # – If this option is on, every time a new patient is saved (with the Chart # field 
blank), that patient will be automatically assigned a chart number (see section “Patient Window, 
Demographic Tab, Misc. Section”) which is one higher than the chart number of the last new 
patient saved.  See section “Chart Numbers”. 
 
RAS Disconnect – If this option is on, and a transmission (see section “Transmissions”) 
automatically triggers a network connection (e.g. dial-up, Internet, or Virtual Private Network), 
then that network connection will be automatically disconnected when the transmission is 
complete. 
 
Audit LogOn – Keep a log of every time a user launches the HERO™ CMS client and connects 
to the database.  See section “Audit”. 
 
Audit Lab – Keep a log of all saves (creations/modifications) of lab requisitions.  See section 
“Audit”. 
 
Audit Access – Keep a log of all accesses of all records in the database.  See section “Audit”. 
 
Audit Referral – Keep a log of all saves (creations/modifications) of referrals.  See section 
“Audit”. 
 
Audit Provider – Keep a log of all saves (creations/modifications) of providers.  See section 
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“Audit”. 
 
Audit Encounter – Keep a log of all saves (creations/modifications) of encounters.  See section 
“Audit”. 
 
Audit Cds – Keep a log of all saves (creations/modifications) of patients.  See section “Audit”. 
 
Audit Attachment – Keep a log of all saves (creations/modifications) of attachments.  See 
section “Audit”. 
 
Audit Bill – Keep a log of all saves (creations/modifications) of bills/payments.  See section 
“Audit”. 
 
Audit Appointment – Keep a log of all saves (creations/modifications) of appointments.  See 
section “Audit”. 
 
Audit Rx – Keep a log of all saves (creations/modifications) of prescriptions.  See section 
“Audit”. 
 
Audit Task – Keep a log of all saves (creations/modifications) of tasks.  See section “Audit”. 
 


3 Providers 


3.1 Add a Provider 
 
Go in the File menu to New → Setup → Provider (see section “Pull-Down Menus”).  A Provider 
window will open (see section “Provider Window”). 
 


3.2 View/Modify a Provider 
 
To view/modify any provider, go in the File menu to Open → Setup → Provider (see section 
“Pull-Down Menus”).  Or, to view/modify a local provider (not a referring provider), go to Open 
→ Provider in the Main Toolbar (see section “Main Toolbar”), or select Open Provider in the 
Action Bar (see section “Action Bar”).  A Find Provider dialog box will open (see section “Find 
Provider Dialog Box”).  Each provider will only be displayed once on the list, even providers 
that have more than one role (see section “Provider Window, Demographic Tab, Role List”).  (If 
you accessed this function via the Main Toolbar or Action Bar instead of the pull-down menus, 
only local providers, not referring providers, will be displayed.)  Select a provider and then select 
OK or press F9, or double-click on a provider, and then a Provider window will open (see 
section “Provider Window”). 
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3.3 Find Provider Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Last – Provider’s last name. 
 
First – Provider’s first name. 
 
Provider # – Provider number. 
 
If any text is entered in the Last and/or First fields, the Provider # field is greyed out 
(unavailable), and vice versa. 
 
Other 
 
OK button – Chooses the selected provider and closes the window.  If no providers are 
displayed, searches for providers that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a provider (see section “Provider Window”). 
 
Cancel button – Closes the window without choosing a provider. 
 
Clear button – Clears the provider list and all fields in the “Criteria” section. 
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Find button – Searches for providers that match the specified criteria. 
 
Provider List – Lists providers that match the specified criteria (see section “Viewing a List of 
Items”).  Select a provider and then select OK or press F9, or double-click on a provider, to 
choose that provider and close the window.  For a description of the fields, see section “Provider 
Window”.  NOTE:  If you searched for a provider by name, providers that are not “approved” 
might not appear on this list.  (For approval, contact HTN – see section “HTN”.)  If you can’t 
find the provider you’re looking for, try searching by provider number instead. 
 


3.4 Provider Window 


3.4.1 Demographic Tab 
 


 
 
Toolbar 
 


New Provider (Ctrl-N) – Add a provider. 
 
Open Provider (Ctrl-O) – View/modify a provider.  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Each provider will only be 


displayed once on the list, even providers that have more than one role (see section “Role List”).  
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Select a provider and then select OK or press F9, or double-click on a provider. 
 


Save (Ctrl-S) – Save the provider. 
 
Save and Close (Ctrl-L) – Save the provider and close the Provider window. 
 
LookUp on Item (F9) – Choose an entry for the selected field on the role list. 
 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected item on the role list 
(if no item is selected, the first item will be deleted).  Pressing Ctrl-Del will delete: 


 
 (on the role list) the selected item. 
 (in a text field) the selected text, or, if no text is selected, all text between the insertion 


point and the end of the field. 
 
NOTE:  You cannot delete a role that has other records (e.g. bills) associated with it.  You must 
first delete those records, or remove the association (e.g. associate them with a different role or 
provider). 


 
Prepare MRI Disk – Create (a) batch(es) (to send to MOHLTC via floppy diskette) for 
this provider (see section “Create a Batch”).  The batch(es) will be created on your next 


transmission (see section “Transmissions”).  This option is only available for providers that send 
their billing using floppy diskettes (not EDT).  If this option is enabled, after your next 
transmission this option will be disabled, and the new batch(es) will appear in the Files window 
(see section “List Files”). 
 
Name Section 
 
Last – Provider’s last name.  If you want to view/modify a provider, you can double-click in this 
field, and a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Each 
provider will only be displayed once on the list, even providers that have more than one role (see 
section “Provider Window, Demographic Tab, Role List”).  Select a provider and then select OK 
or press F9, or double-click on a provider.  This field is required if the First field is blank (see 
below). 
 
First – Provider’s first name.  If you want to view/modify a provider, you can double-click in 
this field, and a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  
Each provider will only be displayed once on the list, even providers that have more than one 
role (see section “Provider Window, Demographic Tab, Role List”).  Select a provider and then 
select OK or press F9, or double-click on a provider.  This field is required if the Last field is 
blank (see above). 
 
Title – Provider’s title, e.g. Mr., Ms., Mrs., Miss, Dr., Prof.  You can choose a title from the 
drop-down list box, or enter a title. 
 
Middle – Provider’s middle name. 
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Misc. Section 
 
Provider # – Provider’s 6-digit billing number assigned by MOHTLC (required).  (This is not 
the same as a 4-character group identifier, or a 5-digit identification number assigned by the 
College of Physicians and Surgeons.)  If the provider does not have a billing number (can’t do 
HCP/WSIB billing), enter a “dummy value” such as “DR001” (it must be unique from all other 
providers in your database).  Do not omit leading zeros, e.g. do not enter “1” instead of 
“000001”.  If you want to view/modify a provider, you can double-click in this field, and a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Each provider will only 
be displayed once on the list, even providers that have more than one role (see section “Provider 
Window, Demographic Tab, Role List”).  Select a provider and then select OK or press F9, or 
double-click on a provider. 
 
Op. Code – Provider’s 6-digit operator ID assigned by MOHLTC (if applicable). 
 
Office Code – A letter indicating which MOHLTC office the provider deals with.  This value is 
assigned by MOHLTC.  If the provider has not been assigned a district office, enter any 
character (Private/Insurer billing ONLY).  This field is required for local providers (not required 
for referring providers). 
 
Beg. Date – The earliest possible service date for HCP/WSIB bills that can be sent to MOHLTC 
for this provider.  Only bills with all service items on or after this date (see section “Bill 
Window, Invoice Tab, Service Item List”) will be sent to MOHLTC.  This date is set by HTN 
(see section “HTN”).  To modify this date, contact HTN.  If this field is left blank, all eligible 
HCP/WSIB bills for this provider (with all service items on or before the Expiry Date) will be 
sent to MOHLTC. 
 
Expiry Date – The latest possible service date for HCP/WSIB bills that can be sent to MOHLTC 
for this provider.  Only bills with all service items on or before this date (see section “Bill 
Window, Invoice Tab, Service Item List”) will be sent to MOHLTC.  This date is set by HTN 
(see section “HTN”).  To modify this date, contact HTN.  If this field is left blank, all eligible 
HCP/WSIB bills for this provider (with all service items on or after the Beg. Date) will be sent to 
MOHLTC. 
 
If both of the above items are blank, all eligible HCP/WSIB bills for this provider will be sent to 
MOHLTC, regardless of their service dates. 
 
Address Section 
 
Line 1 – Provider’s address (e.g. street number/name). 
 
Line 2 – Provider’s address (e.g. suite/apartment number). 
 
City – Provider’s city. 
 







 47


Postal – Provider’s postal code. 
 
Province – Provider’s province.  Choose a province abbreviation from the drop-down list box, or 
enter a province abbreviation (up to 2 characters). 
 
Country – Provider’s country.  Choose a country from the drop-down list box, or enter a 
country. 
 
Contact Section 
 
Primary – Provider’s primary area code, exchange, telephone number, extension, and phone 
number type (e.g. work, home, fax, cellular, etc.).  The phone number type field can also be used 
to store an e-mail address. 
 
Other – Provider’s secondary area code, exchange, telephone number, extension, and phone 
number type (e.g. work, home, fax, cellular, etc.).  The phone number type field can also be used 
to store an e-mail address. 
 
E-mail – Provider’s e-mail address. 
 
Other 
 
Submit To – The latest possible bill date for HCP/WSIB bills that can be sent to MOHLTC for 
this provider.  Only bills with Date fields equal to or earlier than this date (see section “Bill 
Window, Invoice Tab”) will be sent to MOHLTC.  You can use this field to prevent bills from 
being sent to MOHLTC until they’ve been reviewed to ensure accuracy.  For example, you 
could: 
 


 Set the Submit To date to January 1. 
 Enter all the HCP/WSIB bills for January 2.  Even if those bills are transmitted (see 


section “Transmissions”) to the FMS (see section “Data Flow Structure”), they will not 
be sent to MOHLTC, because their Date fields (January 2) are later than the Submit To 
date (January 1). 


 Review all the HCP/WSIB bills for January 2.  Once you’re sure that they’re accurate and 
complete, and ready to be sent, set the Submit To date to January 2, and do a transmission 
(see section “Transmissions”), and the new HCP/WSIB bills will be sent to MOHLTC. 


 Now you are ready to enter the HCP/WSIB bills for January 3, etc. 
 
Or, you could: 
 


 Set the Submit To date to a “dummy date” in the distant past, such as January 2, 1900 
(don’t use January 1, 1900, or anything earlier).  This means that NO bill can be batched 
for that provider (unless the bill’s date is less than or equal to the Submit To date, which 
is unlikely). 


 When you’re ready to make a batch:  
o Set the Submit To date to the current date. 
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o Do a transmission (see section “Transmissions”).  The selected provider’s Open 
bills will be batched, and their status will change to Pending (see section “The 
Billing Cycle”, step 2).  Once the transmission is done, there will probably be no 
more bills of status Open for the selected provider (see section “List Bills”). 


o Set the Submit To date back to your “dummy date” (see above). 
 
If this field is left blank, all eligible HCP/WSIB bills for this provider will be sent to MOHLTC, 
regardless of their Date fields. 
 
Role List 
 
At the bottom is the role list.  This is a list of groups to which the provider belongs, and the 
provider’s role and speciality for each group.  Since a provider can have multiple specialities, 
and can belong to multiple groups, and/or do both solo billing and group billing, this list can 
have multiple entries.  Multiple roles can also be used to keep two different types of billing 
separate (e.g. for accounting purposes).  For example, if a provider does some work for a 
hospital/clinic and some work on his/her own, you can create two roles for that provider to keep 
the billing separate.  Each provider must have at least one role.  See section “Viewing a List of 
Items”.  NOTE:  You cannot modify or delete a role that has other records (e.g. patients, bills) 
associated with it.  You must first delete those records, or remove the association (e.g. associate 
them with a different role or provider). 
 
The fields are: 
 
Grp. (Group #) – A 4-character group identifier assigned by MOHLTC (required).  Select this 
field and type in the text.  For solo billing, enter 0000. 
 
Role / Role Description – The provider’s role, e.g. Physician, Primary Care Provider, 
Admitting, Specialist, Referring (required).  The Role field is not displayed by default.  Select 
either field and enter/modify any text or press Enter or F2 or F9 (or right-click on any item in the 
list and select Edit or LookUp, or select LookUp on Item in the Provider toolbar), or double-click 
in either field, and a LookUp Role dialog box will open (see section “LookUp Role Dialog 
Box”).  The Referring role is used for providers who refer patients to your local providers, and 
for providers to whom your local providers refer patients.  The rest of the roles are for local 
providers and can be assigned any way you wish.  (A provider can be both a local provider and a 
referring provider.  Presumably this would imply that your database contains multiple local 
providers.)  This information will not be sent to MOHLTC.  The role must be different for each 
entry on the role list. 
 
Loc. (Location Code) – A 4-digit location code assigned by MOHLTC (leave blank if not 
applicable).  This is not the same as a Location Code for an appointment (see section “Location 
Codes”).  Select this field and type in the text.  (This will replace any existing text in that field.  
To correct/delete a location code, select the Loc. Field and then press F2 or right-click on any 
item in the list and select Edit, and then make the desired changes.) 
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Sp. (Speciality) / Speciality Description – The provider’s field of practice, represented by a 2-
digit code assigned by MOHLTC (required).  The Sp. (Speciality) field is not displayed by 
default.  To choose a speciality, select either field and enter/modify any text or press Enter or F2 
or F9, or double-click in either field.  A LookUp Speciality dialog box will open (see section 
“LookUp Speciality Dialog Box”). 
 
S. (Suffix) / Suffix Description – The provider’s default procedure code suffix.  This value will 
automatically appear in the S. (Suffix) fields on the Service Item Lists in all bills associated with 
this role (see section “Bill Window, Invoice Tab, Service Item List”).  The S. (Suffix) field is not 
displayed by default.  To choose a suffix, select either field and enter/modify any text or press 
Enter or F2 or F9, or double-click in either field.  A LookUp Suffix dialog box will open (see 
section “LookUp Suffix Dialog Box”). 
 


3.4.2 Schedule Tab 
 


 
 
Toolbar 
 


New Type (Ctrl-N) – Add an appointment type (see section “(Appointment) Type 
Window”). 


 
Open Type (Ctrl-O) – View/modify an appointment type.  If you select this, a Find 
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(Appointment) Type dialog box will open (see section “Find (Appointment) Type Dialog Box”).  
Select an appointment type and then select OK or press F9, or double-click on an appointment 
type (see section “(Appointment) Type Window”). 
 


Save (Ctrl-S) – Save the provider. 
 
Save and Close (Ctrl-L) – Save the provider and close the Provider window. 
 
Lookup on Item (F9) – Choose an entry for the selected field (Date, Beg., End, Type, or 
Type Description) on the schedule list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected item on the schedule 
list.  Pressing Ctrl-Del will delete the entire field (in a date field in the Select or Repeat 


sections), or the selected item (on the schedule list). 
 
Select Section 
 
From – The start of the date range for schedule list items to be displayed (if you select Refresh) 
or copied (if you select Copy Selection in the Repeat section).  If this field is blank, all schedule 
items before the To date (inclusive) will be displayed/copied.  See section “Date Fields”. 
 
To – The end of the date range for schedule list items to be displayed (if you select Refresh) or 
copied (if you select Copy Selection in the Repeat section).  If this field is blank, all schedule 
items after the From date (inclusive) will be displayed/copied.  See section “Date Fields”. 
 
If both of the above items are blank, all schedule items will be displayed/copied. 
 
Refresh – Limits the Schedule List to only items between the From and To dates (above), 
inclusive. 
 
Repeat Section 
 
From – The start of the target date range for copying schedule items (via the Copy Selection 
button). 
 
To – The end of the target date range for copying schedule items (via the Copy Selection button). 
 
Copy Selection – Copy all schedule items in the date range specified in the Select section into 
the date range specified in the Repeat section. 
 
Other 
 
Round to weeks – With this option enabled, the Select and Repeat date ranges are “rounded off” 
to the nearest calendar week (Sunday to Saturday), i.e., any From date entered that is not a 
Sunday is converted to the previous Sunday, and any To date entered that is not a Saturday is 
converted to the next Saturday. 
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Delete Selection – Delete all schedule items displayed on the Schedule List. 
 
Schedule List 
 
Lists the hours that the provider is available to book appointments (see section “Viewing a List 
of Items”).  If an appointment is booked outside these hours, the appointment will be allowed, 
but a warning will be displayed (see section “Appointment Window”).  The time slots defined on 
this list can appear in the Find Schedule dialog box (see section “Find Schedule Dialog Box”) 
and the Appts. window (see section “List Appointments”).  The fields are: 
 
Date – The date of the scheduled hours (required).  See section “Date Fields”. 
 
Day – The day of the week for the scheduled hours.  This field is automatically calculated based 
on the Date field and cannot be manually modified. 
 
Beg. (Begin Time) – The beginning of the scheduled hours (e.g. 9:00 AM).  Select this field, 
enter a time as per section “Time Fields”, and then press Enter, Escape, or Tab (or click 
elsewhere).  This field is required. 
 
End (End Time) – The end of the scheduled hours (e.g. 5:00 PM).  Select this field, enter a time 
as per section “Time Fields”, and then press Enter, Escape, or Tab (or click elsewhere).  NOTE:  
12:00 AM refers to the beginning of the day.  If you want to enter the end of the day, use 11:59 
PM (or 12:00 AM the next day).  This field is required. 
 
Type / Type Description – The purpose/type of the scheduled hours.  This will become the 
default appointment type for appointments booked during these hours from the Appts. window, 
Day tab (see section “List Appointments, Day Tab”).  (Appointments booked during these 
scheduled hours are not required to have the same appointment type as the scheduled hours.)  If 
you select either field and press Enter or F2 or F9 or enter/modify any text, or double-click in 
either field, a Find (Appointment) Type dialog box will open (see section “Find (Appointment) 
Type Dialog Box”).  Select an appointment type and then select OK or press F9, or double-click 
on an appointment type.  To clear these fields, select Clear and then OK. 
 
B (Blocked) – Reserve the scheduled hours such that they will never appear in a Find Schedule 
dialog box (see section “Find Schedule Dialog Box”) and they will be marked as blocked in the 
Appts. window (see section “List Appointments”).  Also, if a user tries to book an appointment 
during those hours, a warning will be displayed (but the appointment can still be booked).  Select 
this field and press Enter, F2, or Space, or double-click in this field, to toggle this option on/off. 
 
Dur. (Duration) – The length of time (in minutes) in between appointment time slots (required).  
This must be a whole number from 1 to 999 (0 will not be accepted).  For example, if the 
provider has hours from 9:00 AM to 5:00 PM with a Duration of 15, then valid time slots for 
appointments are 9:00 AM, 9:15 AM, 9:30 AM, etc. 
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Def. (Default Duration) – The default length of time (in minutes) of an appointment booked in 
these hours through the Appts. window, Day tab (see section “List Appointments, Day Tab”).  
This value will also appear on the Appts. window, Day tab (though not displayed by default).  
This must be a whole number from 1 to 999 (0 will not be accepted).  This field is required. 
 
O.B. (OverBook % Warning) – How much appointments are allowed to “overlap” before 
displaying warnings to the user.  If this is set to 100, then warnings will be displayed on any 
overbooking (e.g. when trying to put more than 15 minutes of appointments in a 15-minute time 
slot).  If this is set to 200, then time slots can hold double their length in appointments, e.g. two 
15-minute appointments can be booked in one 15-minute time slot (with no warning displayed).  
If this is set to 300, then triple-booking is allowed, etc.  If this is set to a value less than 100, 
warnings will be displayed before users can “fill up” a provider’s schedule with appointments.  
For example, if this is set to 0, then any appointment booking will evoke a warning, or if it’s set 
to 90, then a 20-minute time slot could only hold 18 minutes of appointments (before a warning 
is displayed).  This field must contain a whole number from 0 to 999.  The default (original 
value) is 100, but if the field is left blank, it reverts to 0. 
 
Description – Any information/notes specific to this particular schedule item. 
 
Cancel (Cancel Period) – Reserved for future use (not displayed by default). 
 
A (Access) – Reserved for future use (not displayed by default). 
 
How to Set Up a Provider’s Schedule 
 
First, choose a range of time for which to set up the provider’s schedule, for example one year.  
As the end of that year approaches, you can set up the schedule for the following year.  It is not 
recommended to choose a huge amount of time such as 100 years, as this can degrade computer, 
network, and database performance, both when setting up the schedule, and when searching for a 
time slot for an appointment (see section “Find Schedule Dialog Box”), due to the large amount 
of data involved. 
 
Suppose that the provider works from 9:00 AM to 5:00 PM every weekday.  Entering this would 
require one schedule entry per weekday, 5 entries per week, over 250 per year.  Entering this 
manually would be cumbersome and time-consuming.  Instead, you can set up the schedule for a 
shorter period of time, such as a week, and then set this schedule to repeat over a larger period of 
time, such as a year, by using the Copy Selection function. 
 
So you might set up a schedule that looks something like this: 
 
Date Day Beg. End 
January 2, 2000 Sun (none) 
January 3, 2000 Mon 9:00 AM 5:00 PM 
January 4, 2000 Tue 9:00 AM 5:00 PM 
January 5, 2000 Wed 9:00 AM 5:00 PM 
January 6, 2000 Thu 9:00 AM 5:00 PM 
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January 7, 2000 Fri 9:00 AM 5:00 PM 
January 8, 2000 Sat (none) 
 
Now you want to copy this schedule into the rest of the year (e.g. 2000).  First, select the range to 
copy in the Select section, e.g. From January 2, 2000 to January 8, 2000.  Next, select the target 
(destination) range for the copy in the Repeat section, e.g. From January 9, 2000 to December 
30, 2000.  Then, select Copy Selection, and the schedule will automatically be set up for the 
whole year. 
 
In fact, if the provider’s schedule is the same every day, you can use the Copy Selection function 
twice:  first set up the schedule for one day (e.g. Monday), then copy that schedule to the rest of 
the week (e.g. Tuesday to Friday), and then copy the schedule for that week to the rest of the 
year (as above).  To copy the schedule from Monday to the rest of the week, first disable the 
“Round to weeks” option, then enter the Monday’s date (e.g. January 3, 2000) in both fields 
(From and To) in the Select section, and enter the rest of the week (e.g. from January 4, 2000 to 
January 7, 2000) in the Repeat section, and then select Copy Selection. 
 
Now, suppose you want to create a break in the schedule, for example, reserve 12:00 PM to 1:00 
PM for lunch every day.  One possibility is to create blocking appointments (see section “Add an 
Appointment”).  However, if you don’t want those time slots to exist at all, you’ll need to break 
up the provider’s hours into multiple segments for each day.  For example, instead of 9:00 AM to 
5:00 PM, you could make two entries:  9:00 AM to 12:00 PM, and 1:00 PM to 5:00 PM. 
 
If you want to delete a range of schedule items, select a date range in the Select section and 
select Refresh and then Delete Selection.  This can be useful if you want to schedule a holiday 
for a provider.  Or, if you want to modify a provider’s schedule over a large period of time (e.g. a 
year), first delete the existing entries, and then create new ones (you can use the Copy Selection 
function as above). 
 
You can also copy and delete schedule slots from the Appts. window, Month tab (see section 
“List Appointments, Month Tab”). 
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3.4.3 Security Tab 
 


 
 
Toolbar 
 


Save (Ctrl-S) – Save the provider. 
 
Save and Close (Ctrl-L) – Save the provider and close the Provider window. 
 
Lookup on Item (F9) – Choose an entry for the selected field on the access list. 
 
Delete Item (Ctrl-Del) – Delete the selected item on the access list. 


 
Access List 
 
Indicates what information each HERO™ CMS user has access to view/modify for this provider 
(e.g. appointments, bills, payments, etc.).  If this list is blank, all HERO™ CMS users will have 
full access (view and modify) to this provider’s data.  If there are any entries on the list, only the 
listed users will have access to view/modify this provider’s data, and that access will be limited 
by the settings on the list.  Also, all users in the group “Hero Administrators” have full access 
(view and modify) to all data in HERO™ CMS (see section “Before You Begin”). 
 
The fields are: 
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Role / Role Description – Indicate which of the provider’s roles the permissions on that row 
should apply to.  If this field is left blank, all of the provider’s roles will be affected.  To modify 
these fields, select either field and press Enter or F2 or F9 (or enter any text), or double-click in 
either field, and a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  
All local roles for all providers (that match the search criteria) will be displayed (see section 
“Provider Window, Demographic Tab, Role List”), i.e. a matching provider with multiple local 
roles will show multiple matches.  Select a role for the same provider opened in the Provider 
window (do not select a different provider) and then select OK or press F9, or double-click on a 
role.  (To clear this field, select Clear and then OK.)  These fields are not displayed by default. 
 
User/Role – Indicates which user(s) are subject to the permissions on that row.  To modify this 
field, select it and press Enter or F2 or F9 (or enter any text), or double-click in it, and a LookUp 
User/Role dialog box will open (see section “LookUp User/Role Dialog Box”). 
 
To modify a value for any of the fields below, select the field and press Enter or F2 or F9 (or 
enter any text), or double-click in the field, and a LookUp Access dialog box will open (see 
section “LookUp Access Dialog Box (Provider)”).  The Description fields are not displayed by 
default. 
 
Provider / Provider Description – Indicates what access the selected user/group has the 
selected provider’s settings (demographic and schedule). 
 
Security / Security Description – Indicates what access the selected user/group has to the 
selected provider’s security settings. 
 
Demo. (Demographic) / Demo. (Demographic) Description – Indicates what access the 
selected user/group has to demographic information for patients whose primary provider is the 
selected provider. 
 
Roster / Roster Description – Indicates what access the selected user/group has to assign the 
selected provider to be a patient’s primary provider (whether or not the patient is in a Primary 
Care Renewal Group such as a Family Health Network/Team/Organization/Group). 
 
Cds / Cds Description – Indicates what access the selected user/group has to problems, 
immunizations, allergies, risks, alerts, family medical history, and attachments for the selected 
provider’s patients. 
 
Billing / Billing Description – Indicates what access the selected user/group has to the selected 
provider’s bills. 
 
Appt. (Appointment) / Appt. (Appointment) Description – Indicates what access the selected 
user/group has to the selected provider’s appointments. 
 
Rx / Rx Description – Indicates what access the selected user/group has to the selected 
provider’s prescriptions. 







 56


 
Lab / Lab Description – Indicates what access the selected user/group has to the selected 
provider’s lab results. 
 
Task / Task Description – Indicates what access the selected user/group has to tasks associated 
with patients whose primary provider is the selected provider. 
 
Encnt. (Encounter) / Encnt. (Encounter) Description – Indicates what access the selected 
user/group has to the selected provider’s encounters. 
 
Referral / Referral Description – Indicates what access the selected user/group has to the 
selected provider’s referrals. 
 
Recall / Recall Description – Indicates what access the selected user/group has to the selected 
provider’s recalls. 
 


3.5 Delete a Provider 
 
View/modify a provider as per section “View/Modify a Provider”, and then go in the File menu 
to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D. 
 
NOTE:  You cannot delete a provider that has other records (e.g. patients, appointments, bills, 
payments) associated with it.  You must first delete the other records, or remove the association 
(e.g. associate them with a different provider). 
 


4 Patients 


4.1 Add a Patient 
 
Go in the File menu to New → Patient (see section “Pull-Down Menus”), or go to New → 
Patient in the Main Toolbar (see section “Main Toolbar”), or select New Patient in the Action 
Bar (see section “Action Bar”), or press Ctrl-T.  A Patient window will open (see section 
“Patient Window”). 
 


4.2 View/Modify a Patient 
 
Go in the File menu to Open → Patient (see section “Pull-Down Menus”), or go to Open → 
Patient in the Main Toolbar (see section “Main Toolbar”), or select Open Patient in the Action 
Bar (see section “Action Bar”), or press Ctrl-Shift-T.  A Find Patient dialog box will open (see 
section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or double-
click on a patient, and then a Patient window will open (see section “Patient Window”). 
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4.3 Find Patient Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Last – Patient’s last name. 
 
First – Patient’s first name. 
 
Health # – Patient’s health card number. 
 
Chart # – Patient’s chart number. 
 
Phone # – Patient’s phone number. 
 
Birthdate – Patient’s birth date. 
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Other 
 
OK button – Chooses the selected patient and closes the window.  If no patients are displayed, 
searches for patients that match the specified criteria, chooses the first one, and closes the 
window. 
  
New button – Add a patient (see section “Patient Window”). 
 
Cancel button – Closes the window without choosing a patient. 
 
Clear button – Clears the patient list and all fields in the “Criteria” section. 
 
Find button – Searches for patients that match the specified criteria. 
 
Patient List 
 
Lists patients that match the specified criteria (see section “Viewing a List of Items”).  Select a 
patient and then select OK or press F9, or double-click on a patient, to choose that patient and 
close the window.  NOTE:  If you are searching for a patient by name, this list may display 
patients with names that sound similar to the name you entered, but are not necessarily exact 
matches.  For example, if you search for “SMITH”, you might find “SMYTH” instead.  If you 
want the list to display only exact matches, then use the Post Data Retrieval Convergence (see 
section “Searching for a Record”), i.e. type in extra text in the Last and/or First fields after you 
select Find. 
 
The fields are: 
 
Last – Patient’s last name. 
 
Middle – Patient’s middle name. 
 
First – Patient’s first name. 
 
Birthdate – Patient’s birthdate. 
 
Health # – Patient’s health card number. 
 
Chart # – Patient’s chart number. 
 


4.4 Patient Window 
 
Each tab in the Patient window (except Demographic) has an icon indicating whether there are 
any items on that tab.  For example, the icon on the Appt. tab indicates whether the patient has 
any appointments.  The possible icons are: 
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 indicates that there are no items. 
 


 indicates that there are only inactive items (no active items). 
 


 indicates that there are active items. 
 


4.4.1 Demographic Tab 
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Toolbar 
 


New → Patient (Ctrl-N) – Add a patient. 
 
New → Appointment (Ctrl-A) – Add an appointment for this patient 
(see section “Appointment Window”). 
 
New → Bill (Ctrl-B) – Add a bill for this patient (see section “Bill 
Window”).  NOTE:  If the insertion point is in a notes field, the 
shortcut key Ctrl-B is used to make text bold, not to add a bill.  See 
section “Notes Fields”. 
 
New → Encounter (Ctrl-E) – Add an encounter for this patient (see 
section “Encounter Window”). 
 
New → Rx (Ctrl-R) – Add a prescription for this patient (see section 
“Rx Window”). 


 
New → Task (Ctrl-K) – Add a task for this patient (see section “Task Window”). 
 
New → Referral (Ctrl-F) – Add a referral for this patient (see section “Referral Window”). 
 
New → Attachment (Ctrl-H) – Add an attachment for this patient (see section “Attachment 
Window”). 


 
Open Patient (Ctrl-O) – View/modify a patient.  If you select this, a Find Patient dialog 
box will open (see section “Find Patient Dialog Box”).  Select a patient and then select OK 


or press F9, or double-click on a patient. 
 
Save (Ctrl-S) – Save the patient. 


 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
Goto Referring (F8) – View/modify the patient’s referring provider (referring provider 
must first be selected in the Referring field).  See section “Provider Window”. 


 
Re-transmit/OBEC – Send an OBEC request for this patient (see section “OBEC”).  The 
request will be sent after your next transmission (see section “Transmissions”). 


 
Insert into List – Add this patient to a Patient List (see section “Add a Patient to a Patient 
List”).  If you select this, a Find Patient List dialog box will open (see section “Find Patient 


List Dialog Box”).  Select a patient list and select OK or press F9, or double-click on a patient 
list. 
 


Add to HERO Patient Membership – Reserved for future use. 
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Name Section 
 
Last – Patient’s last name (required).  If you want to view/modify a patient, you can double-click 
in this field, and a Find Patient dialog box will open (see section “Find Patient Dialog Box”).  
Select a patient and then select OK or press F9, or double-click on a patient.  This field is 
required if the First field is blank (see below). 
 
First – Patient’s first name.  If you want to view/modify a patient, you can double-click in this 
field, and a Find Patient dialog box will open (see section “Find Patient Dialog Box”).  Select a 
patient and then select OK or press F9, or double-click on a patient.  This field is required if the 
Last field is blank (see above). 
 
Title – Patient’s title, e.g. Mr., Ms., Mrs., Miss, Dr., Prof., etc.  This field supports defaults (see 
section “Defaults, Patient Window”). 
 
Middle – Patient’s middle name. 
 
Address Section 
 
Line 1 – Patient’s address (e.g. street number/name). 
 
Line 2 – Patient’s address (e.g. suite/apartment number). 
 
City – Patient’s city.  Select this field and enter the text.  Or, double-click in this field, and a 
Find City dialog box will open (see section “Find City Dialog Box”).  Select a city and then 
select OK or press F9, or double-click on a city.  To clear this field, select Clear and then OK.  
This field supports defaults (see section “Defaults, Patient Window”). 
 
Postal – Patient’s postal code.  This field supports defaults (see section “Defaults, Patient 
Window”). 
 
Prov. – Patient’s province/state/territory.  This field might not indicate the jurisdiction that 
issued the patient’s health card (see the “Prov.” field in the “Misc.” section.) 
 
Country – Patient’s country. 
 
Misc. Section 
 
Health # - Patient’s health card number in the first field (required for HCP billing), patient’s 
health card version code in the second field.  If you want to view/modify a patient, you can 
double-click in the first field, and a Find Patient dialog box will open (see section “Find Patient 
Dialog Box”).  Select a patient and then select OK or press F9, or double-click on a patient. 
  
Prov. – The jurisdiction that issued the patient’s health card.  You must choose a province 
abbreviation (or “XX” for outside Canada) from the drop-down list box.  This field might not 
indicate the patient’s actual location (see the “Prov.” field in the “Address” section). 
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Sex – Patient’s gender (required for HCP billing).  You must choose from the drop-down list 
box:  M (Male), F (Female), or X (unknown/unspecified).  This field supports defaults (see 
section “Defaults, Patient Window”). 
 
Expiry – Patient’s health card expiry date (see section “Date Fields”). 
 
OBEC status – To the right of the Expiry field, the patient’s OBEC status is displayed, indicating 
if the patient’s health card is valid.  See section “OBEC”.  Or, instead of an OBEC response, one 
of these may be displayed: 
 


 Converted (patient was converted from another medical database program). 
 Incomplete (no health card number). 
 Open (ready to be OBEC verified). 
 Non-MOHLTC (health card is not from Ontario). 
 Pending (an OBEC request has been sent, but no response has been received). 


 
Birthdate – Patient’s date of birth (see section “Date Fields”).  Required for HCP billing. 
 
Age – To the right of the Birthdate field, the patient’s age is displayed. 
 
Death – Patient’s date of death (see section “Date Fields”). 
 
Chart # – Patient’s chart number (see section “Chart Numbers”) and sub-chart number. 
 
Contact Section 
 
The contact section is used to enter/view the patient’s phone numbers.  The contact section has 
two modes: 
 


Collapsed (default): 
(Displays 2 phone numbers) 


 
  


Expanded: 
(Displays 4 phone numbers) 


 
 
To switch from Collapsed mode to Expanded mode, Select the + button. 
To switch from Expanded mode to Collapsed mode, Select the - button. 
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NOTE:  When the Contact section is in Expanded mode, the PCRG, E-mail, Inactive, and 
Primary fields are unavailable (see below). 
 
Each phone number displayed has 6 fields:  type (the first one is Primary, the others 
must each have a different type selected from the drop-down list box:  Other, Home, 
Work, Cell, Fax, Alt. 1, Alt. 2), area code, exchange, suffix, extension, and memo 
(the memo field can be used to store information about the phone number, e.g. 
“Cottage” or “After 6PM”, etc.).  The area code and exchange fields for the first two 
phone numbers support defaults (see section “Defaults, Patient Window”). 
 
Other 
 
PCRG – Whether or not the patient is enrolled in a Primary Care Renewal Group (such as a 
Family Health Network/Team/Organization/Group), and the date that the patient was enrolled.  
NOTE:  This field is not visible if the Contact Section is expanded (see above). 
 
E-mail – Patient’s e-mail address.  NOTE:  This field is not visible if the Contact Section is 
expanded (see above). 
 
Referring – Patient’s referring provider.  If you select the Referring button, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with Referring 
roles will be displayed on the list (see section “Provider Window, Demographic Tab, Role List”).  
Select a provider and then select OK or press F9, or double-click on a provider.  To clear this 
field, select Clear and then OK.  If there is a provider selected in this field, and you double-click 
in the field that contains the provider’s name and billing number (not on the Referring button 
itself), a Provider window will open for that provider (see section “Provider Window”). 
 
Inactive – You can use this field for any purpose, e.g. to keep track of which patients that have 
switched to another provider/clinic, or which patients no longer have ongoing medical problems, 
etc.  NOTE:  This field is not visible if the Contact Section is expanded (see above). 
 
Primary – If the PCRG option (above) is on, this field indicates the provider to whom this 
patient is rostered, otherwise this field indicates this patient’s primary provider.  This field is 
required.  If you select this, a Find Provider dialog box will open (see section “Find Provider 
Dialog Box”).  All local roles for all providers (that match the search criteria) will be displayed 
(see section “Provider Window, Demographic Tab, Role List”), i.e. a matching provider with 
multiple local roles will show multiple matches.  Select a provider/role and then select OK or 
press F9, or double-click on a provider/role.  NOTE:  This field is not visible if the Contact 
Section is expanded (see above). 
 
Notes 
 
At the bottom is the expanded notes field.  This field can be used to store any information 
specific to this patient.  See section “Notes Fields”. 
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4.4.1.1 Chart Numbers 
 
If the “Auto Inc. Chart #” option is on (see section “Miscellaneous Dialog Box”), every time a 
new patient is saved (with the Chart # field blank), that patient will be automatically assigned a 
chart number which is one higher than the chart number of the last new patient saved. 
 
To change the “default” chart number, save a new patient with a specified chart number (with the 
“Auto Inc. Chart #” option on).  The next chart number automatically assigned will be one 
number higher than this default. 
 
You cannot change the default chart number without saving a new patient.  Also, if the “Auto 
Inc. Chart #” option is on, you cannot save a new patient with a specified chart number without 
changing the default chart number. 
 
Re-saving (i.e. modifying) an existing patient record will not automatically assign a chart 
number to that patient or change the default chart number. 
 
It is possible for multiple patients to have the same chart number, though a warning will be 
displayed when saving a patient with the same chart number as another patient. 
 
NOTE:  If the assigned chart numbers reach a “maximum” possible value for the number of 
digits used (e.g. 999), they will not increment by using additional digits (e.g. 1000), but instead 
they will recycle back around to the lowest possible value using the same number of digits (e.g. 
000), even if those chart numbers have already been used. 
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4.4.2 Contact Tab 
 


 
 
Toolbar 
 


New → Contact – Add a contact code (see section “Contact Window”). 
 
 
 
Open → Contact – View/modify a contact code.  If you select this, a Find 
Contact dialog box will open (see section “Find Contact Dialog Box”).  Select a 
contact code and then select OK or press F9, or double-click on a contact code.  
See section “Contact Window”. 


 
Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
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LookUp on Item (F9) – Choose an entry for the selected field (Date, Code, Description, 
Last, First, or Middle) on the contact list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected contact.  Pressing 
Ctrl-Del will delete: 


 
 (on the contact list) the selected contact. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 


Contact List 
 
Lists all contacts for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Date – The effective date of the contact information (required).  For example, if a patient tells 
you that his emergency contact information will be changing as of January 1, 2000, then you 
could add an entry on this list with a date of January 1, 2000.  See section “Date Fields”.  This 
field is not displayed by default. 
 
Contact / Description – An abbreviation representing this contact’s relationship with this 
patient, and a full description of that relationship (required).  Select the Code field and enter the 
contact code.  (This will replace any existing text in that field.  To correct/delete a contact code, 
select the Code field and then press F2 or right-click on any item in the list and select Edit, and 
then make the desired changes.)  Or, select the Description field and press Enter or F2 (or right-
click on any item in the list and select Edit), or select either field and press F9 (or select LookUp 
on Item in the Patient toolbar, or right-click on any item in the list and select LookUp), or 
double-click in either field, and a Find Contact dialog box will open (see section “Find Contact 
Dialog Box”).  Select a contact code and then select OK or press F9, or double-click on a contact 
code.  To clear these fields, select Clear and then OK.  The Description field is not displayed by 
default. 
 
Last / First / Middle – The contact’s last name (required), first name, and middle name.  Select 
any of these fields and enter a name.  (This will replace any existing text in that field.  To 
correct/delete a name, select the desired field and then press F2 or right-click on any item in the 
list and select Edit, and then make the desired changes.)  Or, select any of these fields and press 
F9 (or select LookUp on Item in the Patient toolbar, or right-click on any item in the list and 
select LookUp), or double-click in any of these fields, and a Find Patient dialog box will open 
(see section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or 
double-click on a patient, and that patient’s information (name, address, and primary phone 
number) will automatically be copied into the appropriate fields.  (If the selected patient record 
later changes, the Contact List will not be automatically updated.)  To clear these fields (name, 
address, and primary phone number), select Clear and then OK.  The Middle field is not 
displayed by default. 
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Title – The contact’s title, e.g. Mr., Ms., Mrs., Miss (not displayed by default). 
 
(   ) (Area Code) – The contact’s area code. 
 
--- (Phone Prefix) – The contact’s telephone exchange (3-digit). 
 
---- (Phone Suffix) – The last 4 digits of the contact’s telephone number. 
 
Ex. (Phone Extension) – The contact’s telephone extension. 
 
Memo (Phone Memo) – The contact’s phone number type (e.g. Work, Home, Fax, etc.). 
 
Address1 – The first line of the contact’s address (not displayed by default). 
 
Address2 – The second line of the contact’s address (not displayed by default). 
 
City – The contact’s city (not displayed by default). 
 
Postal – The contact’s postal code (not displayed by default). 
 
Prov. – The contact’s province (not displayed by default). 
 
Country – The contact’s country (not displayed by default).  The default is “Canada”. 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this contact was last modified (not displayed by default).  These fields are 
automatically updated whenever the contact is modified.  These fields cannot be manually 
modified.  
 
User – The user who last modified this contact (see section “Before You Begin”).  This field is 
automatically updated whenever the contact is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this contact was last modified, or the domain under which the user 
(who last modified this contact) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the contact is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected contact on the list (see above).  If there are no contacts on the list, this 
field will be blank.  See section “Notes Fields”. 
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4.4.3 Insurance Tab 
 


 
 
Toolbar 
 


New → Insurer – Add an insurer (see section “Insurer Window”). 
 
 
 
Open → Insurer – View/modify an insurer.  If you select this, a Find Insurer 
dialog box will open (see section “Find Insurer Dialog Box”).  Select an insurer 
and then select OK or press F9, or double-click on an insurer.  See section 
“Insurer Window”. 


 
 Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
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LookUp on Item (F9) – Choose an entry for the selected field on the insurer list. 
 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected insurer on the insurer 
list.  Pressing Ctrl-Del will delete: 


 
 (on the insurer list) the selected insurer. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 


Insurer List 
 
Lists the patient’s insurance policies (see section “Viewing a List of Items”).  The fields are: 
 
Identifier – A random code generated by HERO™ CMS to uniquely identify the insurer (not 
displayed by default). 
 
Insurer – The insurer’s name (required).  Select this field and then enter/modify any text, or 
press Enter or F2 or F9 (or right-click on any item in the list and select Edit or LookUp, or select 
LookUp on Item in the Patient toolbar), or double-click in this field, and a Find Insurer dialog 
box will open (see section “Find Insurer Dialog Box”).  Select an insurer and then select OK or 
press F9, or double-click on an insurer.  To clear this field, select Clear and then OK. 
 
Policy # – The insurance policy number. 
 
Claim # – The number of this patient’s claim against this insurance policy. 
 
Date – The date of the incident (e.g. accident/injury) that triggered this insurance claim.  See 
section “Date Fields”. 
 
Last – The last name of a contact person at this insurer. 
 
First – The first name of a contact person at this insurer. 
 
Title – The title (e.g. Mr., Ms., Mrs., Miss) of a contact person at this insurer (not displayed by 
default). 
 
(   ) (Area Code) – The contact’s area code.  This is not necessarily the same information that 
appears in the Insurer window, Contact section (see section “Insurer Window, Contact Section”). 
 
--- (Phone Prefix) – The contact’s telephone exchange (3-digit).  This is not necessarily the 
same information that appears in the Insurer window, Contact section (see section “Insurer 
Window, Contact Section”). 
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---- (Phone Suffix) – The last 4 digits of the contact’s telephone number.  This is not necessarily 
the same information that appears in the Insurer window, Contact section (see section “Insurer 
Window, Contact Section”). 
 
Ex. (Phone Extension) – The contact’s telephone extension.  This is not necessarily the same 
information that appears in the Insurer window, Contact section (see section “Insurer Window, 
Contact Section”). 
 
Memo (Phone Memo) – The contact’s phone number type (e.g. Work, Home, Fax, etc.). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that the selected item on the insurer list was last modified (not displayed by default).  
These fields are automatically updated whenever the item is modified.  These fields cannot be 
manually modified.  
 
User – The user who last modified this insurance policy (see section “Before You Begin”).  This 
field is automatically updated whenever the insurance policy is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this insurance policy was last modified, or the domain under which 
the user (who last modified this insurance policy) was authenticated (logged in) at the time.  See 
section “Domain”.  This field is automatically updated whenever the insurance policy is 
modified.  This field cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected insurer on the list (see above) and patient.  If there are no insurers on the 
list, this field will be blank.  See section “Notes Fields”. 
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4.4.4 Appt. Tab 
 


 
 
Toolbar 
 


New → Appointment (Ctrl-N) – Add an appointment for this patient 
(see section “Appointment Window”). 
 
 
Open → Appointment (Ctrl-O) – View/modify an appointment for 
this patient (appointment must be selected on the list first).  See section 
“Appointment Window”. 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s appointments in the future (or on the current 
day). 
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All Items – Display all appointments for this patient. 


 
Appointment List 
 
Lists all matching appointments for this patient (see section “Viewing a List of Items”).  To 
view/modify an appointment on the list, select it and then press Enter or Ctrl-O or F9 or select 
Open → Appointment in the Patient toolbar, or double-click on the appointment (see section 
“Appointment Window”).  To add an appointment for this patient, press Ctrl-N or select New → 
Appointment  in the Patient toolbar (see section “Appointment Window”).  The fields are: 
 
Date – The Date field from the Appointment window (see section “Appointment Window”).  
See section “Date Fields”. 
 
Day – The appointment’s day of the week.  This is automatically calculated based on the Date 
field and cannot be manually modified. 
 
Beg. – The Time field from the Appointment window (see section “Appointment Window”).  
See section “Time Fields”. 
 
Dur. – The Duration field from the Appointment window (see section “Appointment Window”). 
 
Status – The Status field from the Appointment window (see section “Appointment Window”). 
 
Priority – The Priority field from the Appointment window (see section “Appointment 
Window”). 
 
Type / Description – The Type field from the Appointment window (see section “Appointment 
Window”).  The Description field is not displayed by default. 
 
Re – The Re field from the Appointment window (see section “Appointment Window”). 
 
Provider – The Provider field from the Appointment window (see section “Appointment 
Window”). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this appointment was last modified (not displayed by default).  These fields are 
automatically updated whenever the appointment is modified.  These fields cannot be manually 
modified.  
 
User – The user who last modified this appointment (see section “Before You Begin”).  This 
field is automatically updated whenever the appointment is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this appointment was last modified, or the domain under which the 
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user (who last modified this appointment) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the appointment is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected appointment on the list (see above).  If there are no appointments on the list, this 
field will be blank.  This field cannot be manually modified.  To change the notes field for an 
appointment, view/modify the appointment (see above).  See section “Notes Fields”. 
 


4.4.5 Bill Tab 
 
Toolbar 
 


New → Bill (Ctrl-N) – Add a bill for this patient (see section “Bill 
Window”). 
 
New → Payment (Ctrl-Y) – Add a payment for this patient (see section 
“Payment Window”). 


 
Open → Source (Ctrl-O) – Open the selected bill/payment (see section 
“Bill Window” or “Payment Window”). 
 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window).  This 
button is only available if Bills (not Items) is selected in the Patient toolbar (see below). 


 
Type – The type of bills/payments to display:  HCP, WSIB, Private, Insurer, or All. 
 
All – Display bills/payments for ALL providers.  If this option is off, only bills/payments for the 
provider selected in the Provider field will be displayed.  If you turn this option on, the Provider 
field will go blank (see below).  If you turn this option off, the Provider field will be 
automatically set to the patient’s Primary provider selected on the Demographic tab (see section 
“Demographic Tab”). 
 
Provider – The provider whose bills/payments to be displayed (only available if the All option is 
off – see above).  If you select this, a Find Provider dialog box will open (see section “Find 
Provider Dialog Box”).  Only providers with at least one local role will be displayed on the list 
(see section “Provider Window, Demographic Tab, Role List”), however, each provider will only 
be displayed once on the list (even providers that have more than one local role).  Select a 
provider and then select OK or press F9, or double-click on a provider.  This field cannot be left 
blank - instead, it will default to the patient’s Primary provider selected on the Demographic tab 
(see section “Demographic Tab”).  If you want to display bills/payments for ALL providers, turn 
on the All option. 
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Total – The total from all “Total” fields on the Bill/Payment List (see below). 
 
Paid – The total from all “Paid” fields on the Bill/Payment List (see below). 
 
Open – The total from all “Open” fields on the Bill/Payment List (see below). 
 
Payment – The total from all “Payment” fields on the Bill/Payment List (see below).  This field 
is only visible if Bills (not Items) is selected in the Patient toolbar (see below). 
 
UnApplied – The total from all “UnApplied” fields on the Bill/Payment List (see below).  This 
field is only visible if Bills (not Items) is selected in the Patient toolbar (see below). 
 
Bills – Displayed Bills and Payments on the list below (see section “Bill Tab, Bills”). 
 
Items – Display Service Items on the list below (see section “Bill Tab, Items”). 
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4.4.5.1 Bills 
 


 
 
Bill/Payment List 
 
Lists all bills/payments for this patient that match the criteria in the toolbar (see section 
“Viewing a List of Items”).  If the Type field in the toolbar is set to Private, then only bills whose 
Payor field is set to the selected patient will be displayed (irrespective of the bill’s Patient field).  
Otherwise, only bills whose Patient field is set to the selected patient will be displayed 
(irrespective of the bill’s Payor field).  See section “Bill Window, Invoice Tab”. 
 
To view/modify a bill or payment on the list, select it and then press Enter or Ctrl-O or F9 or 
select Open → Source in the Patient toolbar, or double-click on the bill/payment (see section 
“Bill Window” or “Payment Window”).  To add a bill for this patient, press Ctrl-N or select New 
→ Bill in the Patient toolbar (see section “Bill Window”).  To add a payment for this patient, 
press Ctrl-Y or select New → Payment in the Patient toolbar (see section “Payment Window”). 
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The fields are: 
 
Date – The date of the bill or payment. 
 
Invoice #/Ref. – The “Invoice #” field from the bill (see section “Bill Window, Invoice Tab”), or 
the “Reference” field from the payment (see section “Payment Window”). 
 
Total – The total amount billed (for all service items) in that bill (tax, less Adjustments). 
 
Paid – The total amount paid for that bill. 
 
Open – The total amount owing for that bill (this is the Total field minus the Paid field). 
 
Payment – The Paid field from the Payment (see section “Payment Window”). 
 
UnApplied – The amount of that payment that has not been applied to any bills.  This is the Paid 
field from the payment minus the Applied field from the payment (see section “Payment 
Window”). 
 
Name – The patient (last name, then first initial) for whom the services were performed (this is 
not necessarily the same as the patient paying for the services). 
 
Last – The last name of the patient for whom the services were performed (this is not necessarily 
the same as the patient paying for the services).  This field is not displayed by default. 
 
First – The first name of the patient for whom the services were performed (this is not 
necessarily the same as the patient paying for the services).  This field is not displayed by 
default. 
 
Provider – The provider (last name, then first name) who provided the services (not displayed 
by default). 
 
Type – The Type field from the bill (see section “Bill Window, Invoice Tab”).  This field is not 
displayed by default. 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this bill was last modified (not displayed by default).  These fields are automatically 
updated whenever the bill is modified.  These fields cannot be manually modified.  
 
User – The user who last modified this bill (see section “Before You Begin”).  This field is 
automatically updated whenever the bill is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this bill was last modified, or the domain under which the user (who 
last modified this bill) was authenticated (logged in) at the time.  See section “Domain”.  This 
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field is automatically updated whenever the bill is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected bill or payment on the list (see above).  If there are no bills or payments on the list, 
this field will be blank.  This field cannot be manually modified.  To change the notes field for a 
bill or payment, view/modify the bill or payment (see above).  See section “Notes Fields”. 
 


4.4.5.2 Items 
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Service Item List 
 
Lists all service items from all bills for this patient that match the criteria in the toolbar (see 
section “Viewing a List of Items”).  If the Type field in the toolbar is set to Private, then only 
service items from bills whose Payor field is set to the selected patient will be displayed 
(irrespective of the bill’s Patient field).  Otherwise, only service items from bills whose Patient 
field is set to the selected patient will be displayed (irrespective of the bill’s Payor field).  See 
section “Bill Window, Invoice Tab”. 
 
To view/modify a bill whose service item appears on the list, select the service item and then 
press Enter or Ctrl-O or F9 or select Open → Source in the Patient toolbar, or double-click on 
the service item (see section “Bill Window”).  To add a bill for this patient, press Ctrl-N or select 
New → Bill in the Patient toolbar (see section “Bill Window”).  For a description of the fields, 
see section “Bill Window, Invoice Tab, Service Item List”). 
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4.4.6 Encounter Tab 
 


 
 
Toolbar 
 


New → Encounter (Ctrl-N) – Add an encounter for this patient (see 
section “Encounter Window”). 
 
 
Open → Encounter (Ctrl-O) – View/modify the selected encounter.  
See section “Encounter Window”. 
 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s encounters of status Draft or Reviewed. 
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All Items – Display all encounters for this patient. 


 
Encounter List 
 
Lists all matching encounters for this patient (see section “Viewing a List of Items”).  To 
view/modify an encounter on the list, select it and then press Enter or Ctrl-O or F9 or select 
Open → Encounter in the Patient toolbar, or double-click on the encounter (see section 
“Encounter Window”).  To add an encounter for this patient, press Ctrl-N or select New → 
Encounter in the Patient toolbar (see section “Encounter Window”).  The fields are: 
 
Date – The Date field from the Encounter window (see section “Encounter Window”). 
 
Status – The Status field from the Encounter window (see section “Encounter Window”). 
 
Provider – The Provider field from the Encounter window (see section “Encounter Window”). 
 
Template – The Description of the last Notes template that was inserted into the Notes field (see 
below).  See section “Notes Fields, Templates”.  This field cannot be manually modified. 
 
Type – The general purpose of the encounter, e.g. Surgery, Consultation, Prescription, etc.  
Enter/modify any text (or double-click) in this field, and a Find (Encounter) Type dialog box will 
open (see section “Find (Encounter) Type Dialog Box”).  Select an encounter type and then 
select OK or press F9, or double-click on an encounter type.  To clear this field, select Clear and 
then OK. 
 
Re – The specific purpose of the encounter, e.g. Back Pain, Check-up, Flu Shot, etc.  Select this 
field and enter the text.  Or, select this field and press F9, or double-click in this field, and a Find 
(Encounter) Re dialog box will open (see section “Find (Encounter) Re Dialog Box”).  Select an 
encounter re code and then select OK or press F9, or double-click on an encounter re code.  To 
clear this field, select Clear and then OK. 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this encounter was last modified (not displayed by default).  These fields are 
automatically updated whenever the encounter is modified.  These fields cannot be manually 
modified.  
 
User – The user who last modified this encounter (see section “Before You Begin”).  This field 
is automatically updated whenever the encounter is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this encounter was last modified, or the domain under which the 
user (who last modified this encounter) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the encounter is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
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Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected encounter on the list (see above).  If there are no encounters on the list, this field will 
be blank.  This field cannot be manually modified.  To change the notes field for an encounter, 
view/modify the encounter (see above).  See section “Notes Fields”. 
 


4.4.7 Problem Tab 
 


 
 
Toolbar 
 


New → Bill (Ctrl-N) – Add a bill for this patient (see section “Bill 
Window”). 
 
New → Problem – Add a problem code (see section “Problem Window”). 
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Open → Bill (Ctrl-O) – … 
 
Open → Problem – View/modify a problem code.  If you select this, a 
Find Problem dialog box will open (see section “Find Problem Dialog 
Box”).  Select a problem code and then select OK or press F9, or double-


click on a problem code, and then a Problem window will open.  See section “Problem 
Window”. 
 


Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
LookUp on Item (F9) – Choose an entry for the selected field on the Problem list. 
 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected item on the Problem 
List.  Pressing Ctrl-Del will delete: 


 
 (on the Problem List) the selected item. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only items with a status of Active or Chronic, that have no End 
Date (or an End Date in the future or on the current day). 


 
All Items – Display all items in this patient’s medical history. 


 
Problem List 
 
Lists the patient’s medical history. 
 
Some items came from bills… 
 
The fields are: 
 
Begin Date – The date on which the problem/procedure/symptom started/occurred.  See section 
“Date Fields”. 
 
End Date – The date that the problem/procedure/symptom was resolved/controlled/completed.  
See section “Date Fields”. 
  
Status / Status Description – The status of the problem/procedure/symptom.  To choose a 
status, select either field and enter/modify any text or press Enter or F2 or F9, or double-click in 
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either field.  A LookUp Status dialog box will open (see section “LookUp Status Dialog Box 
(For Problems)”). 
 
Problem / Description / Class – A medical problem/symptom that affected the patient, or a 
medical procedure that was performed on the patient.  These fields are required.  Select the 
Problem or Description field and press Enter or F2 or F9 or type any text (or right-click on any 
item in the list and select Edit or LookUp, or select LookUp on Item in the Patient toolbar), or 
double-click in either field, and a Find Problem dialog box will open (see section “Find Problem 
Dialog Box”).  Select a problem/procedure/ICD-9 code, and then select OK or press F9, or 
double-click on a problem/procedure/ICD-9 code.  To clear these fields, select Clear and then 
OK.  The Class field indicates the type of code:  problem (“UDF”) (see section “Problem 
Codes”), procedure (“MOHFEE”) (see section “Procedure Codes”), or ICD-9 (“ICD-9”) (see 
section “ICD-9 Codes”), diagnosis (“MOHICD”)… 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this problem/procedure/symptom was last modified (not displayed by default).  
These fields are automatically updated whenever the problem/procedure/symptom is modified.  
These fields cannot be manually modified.  
 
User – The user who last modified this problem/procedure/symptom (see section “Before You 
Begin”).  This field is automatically updated whenever the problem/procedure/symptom is 
modified.  This field cannot be manually modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this problem/procedure/symptom was last modified, or the domain 
under which the user (who last modified this problem/procedure/symptom) was authenticated 
(logged in) at the time.  See section “Domain”.  This field is automatically updated whenever the 
problem/procedure/symptom is modified.  This field cannot be manually modified.  This field is 
not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected problem/procedure/symptom on the list (see above).  If there are no 
problems/procedures/symptoms on the list, this field will be blank.  See section “Notes Fields”. 
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4.4.8 Rx Tab 
 


 
 
Toolbar 
 


New → Rx (Ctrl-N) – Add a prescription for this patient (see section “Rx 
Window”). 
 
 
Open → Rx (Ctrl-O) – View/modify a prescription for this patient 
(prescription must be selected on the list first).  See section “Rx Window”. 
 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s prescriptions with an “End Date” in the future (or 
on the current day), and also the ones with the L (Long Term) option on (see section “Rx 
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Window, Script Tab”). 
 


All Items – Display all prescriptions for this patient. 


 
Prescription List 
 
Lists this patient’s prescription history (see section “Viewing a List of Items”).  To view/modify 
a prescription, select an item on the list and then press Enter or Ctrl-O or F9 or select Open → 
Rx in the Patient toolbar, or double-click on the item (see section “Rx Window”).  To add a 
prescription for this patient, press Ctrl-N or select New → Rx in the Patient toolbar (see section 
“Rx Window”).  The fields are: 
 
Rx Date – The date on which the prescription was written (see section “Date Fields”).  This field 
is not displayed by default. 
 
Date (Begin Date) – The date on which the patient started taking the prescribed drug (see 
section “Date Fields”). 
 
End Date – The date on which the patient finished taking the prescribed drug (see section “Date 
Fields”).  This field is not displayed by default. 
 
Drug – This field is the same as the Brand field (see below), unless the Brand field is blank, in 
which case this field is the same as the Generic field (see below). 
 
Generic – The generic name of the drug that was prescribed to the patient, e.g. acetaminophen 
(not displayed by default). 
 
Brand – The brand name of the drug that was prescribed to the patient, e.g. Tylenol (not 
displayed by default). 
 
Strength – The strength (e.g. how many milligrams per pill, etc.) of the drug that was prescribed 
to the patient. 
 
Form – The form (e.g. tablet, paste, gel, solution, etc.) of the drug that was prescribed to the 
patient (not displayed by default). 
 
Route – The method (e.g. oral, topical, inhalation, etc.) that the patient should use to administer 
the prescribed drug (not displayed by default). 
 
# (Quantity) – The total number of doses of the specified drug the patient should take. 
 
SIG – A SIG relevant to this prescription item. 
 
Dose – The number of doses (e.g. pills) of the drug the patient should take at a time. 
 
Rep. (Repeat) – How many times this prescription can be renewed. 
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L (Long Term) – Indicates that the patient is taking this drug indefinitely, and therefore this 
prescription item will always be considered “active” and included in the Drug Utilization Review 
(see section “DUR Tab” or “Drug Utilization Review Dialog Box”). 
 
C (Compliance OK) – Indicates that the patient has been taking the drug as prescribed (not 
displayed by default). 
 
Dur. (Duration) – The number of days for which the patient should take the prescribed drug. 
 
Provider – The last name and then first name of the provider who prescribed this drug. 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this prescription was last modified (not displayed by default).  These fields are 
automatically updated whenever the prescription is modified.  These fields cannot be manually 
modified.  
 
User – The user who last modified this prescription (see section “Before You Begin”).  This 
field is automatically updated whenever the prescription is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this prescription was last modified, or the domain under which the 
user (who last modified this prescription) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the prescription is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the prescription associated with the selected item on the list (see above).  If there are no items on 
the list, this field will be blank.  This field cannot be manually modified.  To change the notes 
field for a prescription, view/modify the prescription (see above).  See section “Notes Fields”. 
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4.4.9 Requisition Tab 
 


 
 
Toolbar 
 


New → Requisition (Ctrl-N) – Add a lab requisition for this patient (see 
section “Requisition Window”). 
 
 
Open → Requisition (Ctrl-O) – View/modify a lab requisition for this 
patient (lab requisition must be selected on the list first).  See section 
“Requisition Window”. 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s lab requisitions of status Pending. 
 







 88


All Items – Display all lab requisitions for this patient. 


 
Lab Requisition List 
 
Lists all of this patient’s lab requisitions (see section “Viewing a List of Items”).  To 
view/modify a lab requisition, select it and then press Enter or Ctrl-O or F9 or select Open → 
Requisition in the Patient toolbar, or double-click on it (see section “Requisition Window”).  To 
add a lab requisition for this patient, press Ctrl-N or select New → Requisition in the Patient 
toolbar (see section “Requisition Window”).  The fields are: 
 
Date – The Date field from the Requisition window (see section “Requisition Window”). 
 
Status – The Status field from the Requisition window (see section “Requisition Window”). 
 
Provider – The Provider field from the Requisition window (see section “Requisition 
Window”). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this lab requisition was last modified (not displayed by default).  These fields are 
automatically updated whenever the lab requisition is modified.  These fields cannot be manually 
modified.  
 
User – The user who last modified this lab requisition (see section “Before You Begin”).  This 
field is automatically updated whenever the lab requisition is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this lab requisition was last modified, or the domain under which 
the user (who last modified this lab requisition) was authenticated (logged in) at the time.  See 
section “Domain”.  This field is automatically updated whenever the lab requisition is modified.  
This field cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected lab requisition on the list (see above).  If there are no lab requisitions on the list, this 
field will be blank.  See section “Notes Fields”. 
 


4.4.10 Lab Tab 
 
Toolbar 


 
Notes – Display/hide the expanded notes field (at the bottom of the patient window).  The 
notes field is only visible if List is selected (see below). 
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Active Items – Display only this patient’s labs with the status set to “Unread” or with a 
“(Result) Date” less than 28 days old. 


 
All Items – Display all labs for this patient. 
 


List – Display lab results in an interactive list (see section “List”). 
 
Table – Display lab results in a table (see section “Table”). 
 
Graph – Display lab results in a graph (see section “Graph”). 
 
Test Types – A drop-down list box used to select which types of lab results to display on the 
table or graph.  This field is only available if Table or Graph is selected (see above).  To display 
all types of lab results, select All at the bottom of the list.  To clear the table or graph, select 
Clear at the top of the list. 
 
From – The minimum date for lab results to display on the table or graph (see section “Date 
Fields”).  This field is only available if Table or Graph is selected (see above). 
 
If this patient has lab results that do not show up on the Lab Tab, see section “Lab Results with 
no associated Patients”. 
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4.4.10.1 List 
 


 
 
If the List option is selected in the Patient Toolbar, that patient’s lab results will be displayed in 
an interactive list, as shown above. 
 
Lab List 
 
Lists all matching lab results for this patient (see section “Viewing a List of Items”).  The fields 
are: 
 
Req. Date – The date that this test was requested (not displayed by default). 
 
Req. # – A unique serial number assigned by the lab to identify the lab requisition that requested 
the tests that produced these results (not displayed by default). 
 
Lab/Loc. – The lab or location where the tests were performed (not displayed by default). 
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E (Edited) – Indicates that these results are a modification or correction of previous results (for 
the same patient/sample/requisition).  This field is not displayed by default. 
 
F (Final) – Indicates that no further testing will be performed, i.e. these results are not subject to 
future modification. 
 
Group – The category of tests, e.g. CHEMISTRY, HEMATOLOGY, URINALYSIS, 
MICROBIOLOGY, AUTOIMMUNE, REFERREDTEST(S), SEROLOGY, IMMUNOASSAY, 
RIA, HISTOLOGY, WET PREPARATION, REFERRED, URINECHEMISTRY, 
REFERREDTESTS, PORPHYRINS-URINE (QUANT), TOXICOLOGY (not displayed by 
default). 
 
Test Date – The date the test was performed (not displayed by default). 
 
Test Code – An abbreviation representing the type of test that was performed (not displayed by 
default).  See “What is the difference between Test Code/Description and Result 
Code/Description?” below. 
 
Test Description – A full description of the test that was performed (not displayed by default).  
See “What is the difference between Test Code/Description and Result Code/Description?” 
below. 
 
Date (Result Date) – The date that the test yielded the results. 
 
N (Note Indicator) – Indicates that there are notes associated with this test result, which can be 
viewed in the expanded Notes field (see below). 
 
Code (Result Code) – An abbreviation representing the type of test that was performed (not 
displayed by default).  See “What is the difference between Test Code/Description and Result 
Code/Description?” below. 
 
Result (Result Description) – A full description of the test that was performed.  See “What is 
the difference between Test Code/Description and Result Code/Description?” below. 
 
Value – The (numerical) result of the test. 
 
Units – The units used to express the test result. 
 
Ref. Range – The range of expected or normal values for this type of test.  If the test result falls 
outside this range, the result is considered abnormal. 
 
Ab. (Abnormal Code) – Indicates that the results are outside the standard reference range for 
this type of test. 
 
Abnormal (Abnormal Description) – This field is not used (not displayed by default). 
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S (Status Code) / Status (Status Description) – If this is N (Preliminary), this test result is 
subject to future modification, i.e. further testing will be performed.  If this is Y (Final), no 
further testing will be performed.  The Status Description field is not displayed by default. 
 
Provider – The provider to whom the lab sent the lab results.  This should be the same provider 
that requested the lab tests in the first place. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any notes associated 
with this lab result.  If there are no lab results on the list, this field will be blank.  See section 
“Notes Fields”. 
 
What is the difference between Test Code/Description and Result Code/Description? 
 
On the Lab Result List (see above), there are fields Test Code, Test Description, Code (Result 
Code), and Result (Result Description).  Normally, Test Code and Result Code are the same, and 
Test Description and Result Description are the same.  However, sometimes a test will have 
multiple sub-tests underneath it, i.e. a single test will yield multiple results.  For example: 
 
Test Code Test Description Result Code Result Description 
397 RBC INDICES:  MCV 397 RBC INDICES:  MCV 
397V MCH 397V               MCH 
397H MCHC 397H               MCHC 
372 DIFFERENTIAL WBC'S 372&15          NEUTROPHILS 
372 DIFFERENTIAL WBC'S 372&16          LYMPHOCYTES 
372 DIFFERENTIAL WBC'S 372&17          MONOCYTES 
372 DIFFERENTIAL WBC'S 372&18          EOSINOPHILS 
372 DIFFERENTIAL WBC'S 372&19          BASOPHILS 
 
The first three tests above fall into the same category (RBC INDICES).  In this case, the Test 
Codes and Result Codes are the same, and the Test Descriptions and Result Descriptions are the 
same, except spaces have been added in two of the Result Descriptions to make the test sub-
types (MCV, MCH, and MCHC) “line up” nicely (they only line up nicely when viewed in a 
monospaced font such as Courier). 
 
The last five tests above fall into the same category (DIFFERENTIAL WBC'S).  In this case, the 
Result Code includes the Test Code (372), but also includes, after an ampersand (&), an extra 
code (15, 16, 17, 18, 19) to identify the test sub-type (NEUTROPHILS, LYMPHOCYTES, 
MONOCYTES, EOSINOPHILS, or BASOPHILS).  Also, the Test Description only indicates 
the test category (DIFFERENTIAL WBC'S), and the Result Description only indicates the test 
sub-type (with spaces added to differentiate them from other tests). 
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4.4.10.2 Table 
 


 
 
If Table is selected in the Patient Toolbar, that patient’s lab results will be displayed in a table 
format, as above. 
 
Note that dates in the table are displayed in the format DD/MM/YY, regardless of your Windows 
date format settings (see section “Date Fields”). 
 







 94


4.4.10.3 Graph 
 


 
 
If Graph is selected in the Patient Toolbar, that patient’s lab results will be displayed in a graph 
format, as above. 
 
Note that dates on the graph are displayed in the format DD/MM/YY, regardless of your 
Windows date format settings (see section “Date Fields”). 
 







 95


4.4.11 Imm. Tab 
 


 
 
Toolbar 
 


New → Immunization – Add an immunization code (see section 
“Immunization Window”). 
 
 
Open → Immunization – View/modify an immunization code.  If you select 
this, a Find Immunization dialog box will open (see section “Find 
Immunization Dialog Box”).  Select an immunization code and then select 
OK or press F9, or double-click on an immunization code.  See section 


“Immunization Window”. 
 


Save (Ctrl-S) – Save the patient. 
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Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
LookUp on Item (F9) – Choose an entry for the selected field (Date, Code, or Description) 
on the immunization list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected immunization.  
Pressing Ctrl-Del will delete: 


 
 (on the immunization list) the selected immunization. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the patient window). 


 
Immunization List 
 
Lists all immunizations for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Date – The date of the immunization (required).  See section “Date Fields”. 
 
R (Refused) – Indicates that the patient chose not to have the specified immunization performed.  
Select this field and press Enter, F2, or Space, or double-click in this field, to toggle this option 
on/off. 
 
Immunization / Description – An abbreviation representing the immunization, and a full 
description of the immunization (see section “Immunization Window”).  These fields are 
required.  Select the Code field and enter the immunization code.  (This will replace any existing 
text in that field.  To correct/delete an immunization code, select the Code field and then press 
F2 or right-click on any item in the list and select Edit, and then make the desired changes.)  Or, 
select the Description field and press Enter or F2 (or right-click on any item in the list and select 
Edit), or select either field and press F9 (or select LookUp on Item in the Patient toolbar, or 
right-click on any item in the list and select LookUp), or double-click in either field, and a Find 
Immunization dialog box will open (see section “Find Immunization Dialog Box”).  Select an 
immunization code and then select OK or press F9, or double-click on an immunization code.  
To clear these fields, select Clear and then OK. 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this immunization was last modified (not displayed by default).  These fields are 
automatically updated whenever the immunization is modified.  These fields cannot be manually 
modified. 
 
User – The user who last modified this immunization (see section “Before You Begin”).  This 
field is automatically updated whenever the immunization is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
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Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this immunization was last modified, or the domain under which the 
user (who last modified this immunization) was authenticated (logged in) at the time.  See 
section “Domain”.  This field is automatically updated whenever the immunization is modified.  
This field cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected immunization on the list (see above).  If there are no immunizations on 
the list, this field will be blank.  See section “Notes Fields”. 
 


4.4.12 Allergy Tab 
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Toolbar 
 


New → Allergy – Add an allergy code (see section “Allergy Window”). 
 
New → Reaction – Add a reaction code (see section “Reaction Window”). 
 
 
Open → Allergy – View/modify an allergy code.  If you select this, a Find 
Allergy dialog box will open (see section “Find Allergy Dialog Box”).  Select an 
allergy code and then select OK or press F9, or double-click on an allergy code.  
See section “Allergy Window”. 
 


Open → Reaction – View/modify a reaction code.  If you select this, a Find Reaction dialog box 
will open (see section “Find Reaction Dialog Box”).  Select a reaction code and then select OK 
or press F9, or double-click on a reaction code.  See section “Reaction Window”. 
 


Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
LookUp on Item (F9) – Choose an entry for the selected field (Date, Code, Description, 
Severity, Severity Description, Reaction, or Reaction Description) on the allergy list. 
 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected allergy on the allergy 
list.  Pressing Ctrl-Del will delete: 


 
 (on the allergy list) the selected allergy. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 


Allergy List 
 
Lists all allergies for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Seq. – A substance identification number assigned by First Data Bank (not displayed by default).   
 
Allergy – The substance to which the patient is allergic (required).  Select this field and 
enter/modify any text, or press Enter or F2 or F9 (or select LookUp on Item in the Patient 
toolbar, or right-click on any item in the list and select Edit or LookUp), or double-click in the 
field, and a Find Allergy dialog box will open (see section “Find Allergy Dialog Box”).  Select 
an allergy and then select OK or press F9, or double-click on an allergy.  To clear this field, 
select Clear and then OK. 
 
Type – Brand, Group, Ingredient, Generic, Base, UDF… 
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Severity / Severity Description – The severity of the allergy (required).  Select either field and 
enter/modify any text or press Enter or F2 or F9 (or right-click on any item in the list and select 
Edit or LookUp, or select LookUp on Item in the Patient toolbar), or double-click in either field, 
and a LookUp Severity dialog box will open (see section “LookUp Severity Dialog Box”).  The 
Severity Description field is not displayed by default. 
 
Reaction / Reaction Description – An abbreviation representing the patient’s allergic reaction, 
and a full description of the reaction (see section “Reaction Window”).  Select the Reaction field 
and enter the reaction code.  (This will replace any existing text in that field.  To correct/delete a 
reaction code, select the Reaction field and then press F2 or right-click on any item in the list and 
select Edit, and then make the desired changes.)  Or, select the Reaction Description field and 
press Enter or F2 (or right-click on any item in the list and select Edit), or select either field and 
press F9 (or select LookUp on Item in the Patient toolbar, or right-click on any item in the list 
and select LookUp), or double-click in either field, and a Find Reaction dialog box will open (see 
section “Find Reaction Dialog Box”).  Select a reaction code and then select OK or press F9, or 
double-click on a reaction code.  To clear these fields, select Clear and then OK.  The Reaction 
Description field is not displayed by default. 
 
Date – The date that the allergy was developed/discovered/recorded (required).  See section 
“Date Fields”. 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this allergy was last modified (not displayed by default).  These fields are 
automatically updated whenever the allergy is modified.  These fields cannot be manually 
modified. 
 
User – The user who last modified this allergy (see section “Before You Begin”).  This field is 
automatically updated whenever the allergy is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this allergy was last modified, or the domain under which the user 
(who last modified this allergy) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the allergy is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected allergy on the list (see above).  If there are no allergies on the list, this 
field will be blank.  See section “Notes Fields”. 
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4.4.13 Risk Tab 
 


 
 
Toolbar 
 


New → Risk – Add a risk code (see section “Risk Window”). 
 
 
 
Open → Risk – View/modify a risk code.  If you select this, a Find Risk dialog box 
will open (see section “Find Risk Dialog Box”).  Select a risk code and then select 
OK or press F9, or double-click on a risk code. 
 


Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
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LookUp on Item (F9) – Choose an entry for the selected field (Begin Date, End Date, 
Code, or Description) on the risk list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected risk.  Pressing Ctrl-
Del will delete: 


 
 (on the risk list) the selected risk. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the Patient window). 
 
Active Items – Display only this patient’s risks with no “End Date” or with an “End Date” 
in the future (or on the current day). 


 
All Items – Display all risks for this patient. 
 


Risk List 
 
Lists all matching risks for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Begin Date – The date the risk began (see section “Date Fields”). This field is required. 
 
End Date – The date the risk ended (see section “Date Fields”). 
  
Quantity – The quantity of the risk, for example, how often the dangerous behaviour occurs, or 
how much of the dangerous substance is used/ingested. 
  
Risk / Description – An abbreviation representing the risk, and a full description of the risk (see 
section “Risk Window”).  These fields are required.  Select the Risk field and enter the risk code.  
(This will replace any existing text in that field.  To correct/delete a risk code, select the Risk 
field and then press F2 or right-click on any item in the list and select Edit, and then make the 
desired changes.)  Or, select the Description field and press Enter or F2 (or right-click on any 
item in the list and select Edit), or select either field and press F9 (or select LookUp on Item in 
the Patient toolbar, or right-click on any item in the list and select LookUp), or double-click in 
either field, and a Find Risk dialog box will open (see section “Find Risk Dialog Box”).  Select a 
risk code and then select OK or press F9, or double-click on a risk code.  To clear these fields, 
select Clear and then OK. 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this risk was last modified (not displayed by default).  These fields are 
automatically updated whenever the risk is modified.  These fields cannot be manually modified. 
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User – The user who last modified this risk (see section “Before You Begin”).  This field is 
automatically updated whenever the risk is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this risk was last modified, or the domain under which the user 
(who last modified this risk) was authenticated (logged in) at the time.  See section “Domain”.  
This field is automatically updated whenever the risk is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected risk on the list (see above).  If there are no risks on the list, this field will 
be blank.  See section “Notes Fields”. 
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4.4.14 Alert Tab 
 


 
 
Toolbar 
 


New → Alert – Add an alert code (see section “Alert Window”). 
 
 
 
Open → Alert – View/modify an alert code.  If you select this, a Find Alert dialog 
box will open (see section “Find Alert Dialog Box”).  Select an alert code and then 
select OK or press F9, or double-click on an alert code.  See section “Alert 
Window”. 


 
Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
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LookUp on Item (F9) – Choose an entry for the selected field (e.g. Begin Date, End Date, 
Code, Description) on the alert list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected alert.  Pressing Ctrl-
Del will delete: 


 
 (on the alert list) the selected alert. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s alerts with no “End Date” or with an “End Date” 
in the future (or on the current day). 


 
All Items – Display all alerts for this patient. 
 


Alert List 
 
Lists all matching alerts for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Begin Date – The date the alert began (see section “Date Fields”). This field is required. 
 
End Date – The date the alert ended (see section “Date Fields”). 
 
Alert / Description – An abbreviation representing the alert, and a full description of the alert 
(see section “Alert Window”).  These fields are required.  Select the Alert field and enter the 
alert code.  (This will replace any existing text in that field.  To correct/delete an alert code, 
select the Alert field and then press F2 or right-click on any item in the list and select Edit, and 
then make the desired changes.)  Or, select the Description field and press Enter or F2 (or right-
click on any item in the list and select Edit), or select either field and press F9 (or select LookUp 
on Item in the Patient toolbar, or right-click on any item in the list and select LookUp), or 
double-click in either field, and a Find Alert dialog box will open (see section “Find Alert Dialog 
Box”).  Select an alert code and then select OK or press F9, or double-click on an alert code.  To 
clear these fields, select Clear and then OK. 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this alert was last modified (not displayed by default).  These fields are 
automatically updated whenever the alert is modified.  These fields cannot be manually 
modified. 
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User – The user who last modified this alert (see section “Before You Begin”).  This field is 
automatically updated whenever the alert is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this alert was last modified, or the domain under which the user 
(who last modified this alert) was authenticated (logged in) at the time.  See section “Domain”.  
This field is automatically updated whenever the alert is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected alert on the list (see above).  If there are no alerts on the list, this field will 
be blank.  See section “Notes Fields”. 
 







 106


4.4.15 Family Tab 
 


 
 
Toolbar 
 


New → Problem – Add a problem code (see section “Problem Window”). 
 
New → Relation – Add a relation code (see section “Relation Window”). 
 
New → Treatment – Add a treatment code (see section “Treatment Window”). 
 
Open → Problem – View/modify a problem code.  If you select this, a Find 
Problem dialog box will open (see section “Find Problem Dialog Box”).  Select 
a problem code and then select OK or press F9, or double-click on a problem 
code, and then a Problem window will open (see section “Problem Window”). 
 
Open → Relation – View/modify a relation code.  If you select this, a Find 
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Relation dialog box will open (see section “Find Relation Dialog Box”).  Select a relation code 
and then select OK or press F9, or double-click on a relation code.  See section “Relation 
Window”. 
 
Open → Treatment – View/modify a treatment code.  If you select this, a Find Treatment 
dialog box will open (see section “Find Treatment Dialog Box”).  Select a treatment code and 
then select OK or press F9, or double-click on a treatment code.  See section “Treatment 
Window”.  
 


Save (Ctrl-S) – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
LookUp on Item (F9) – Choose an entry for the selected field (Date, Relation, Relation 
Description, Code, Description, Treatment, or Treatment Description) on the Family 


Medical History List. 


Delete Item (Ctrl-Del) – Selecting this button will delete the selected item on the Family 
Medical History List.  Pressing Ctrl-Del will delete: 


 
 (on the Family Medical History List) the selected item. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Family Medical History List 
 
Lists the patient’s family’s medical history (see section “Viewing a List of Items”).  The fields 
are: 
 
Date – The date on which the specified family member was afflicted by the specified medical 
condition.  See section “Date Fields”.  This field is not displayed by default. 
 
Relation / Relation Description – Indicates to whom in the patient’s family this entry applies.  
These fields are required.  Select the Relation field and enter the relation code.  (This will replace 
any existing text in that field.  To correct/delete a relation code, select the Relation field and then 
press F2 or right-click on any item in the list and select Edit, and then make the desired changes.)  
Or, select the Relation Description field and press Enter or F2 (or right-click on any item in the 
list and select Edit), or select either field and press F9 (or select LookUp on Item in the Patient 
toolbar, or right-click on any item in the list and select LookUp), or double-click in either field, 
and a Find Relation dialog box will open (see section “Find Relation Dialog Box”).  Select a 
relation code and then select OK or press F9, or double-click on a relation code.  To clear these 
fields, select Clear and then OK.  The Relation Description field is not displayed by default. 
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Age – The age at which the specified family member was afflicted by the specified medical 
condition.  Must be a whole number from 0 to 999.  The default is 0. 
 
Problem / Description / Class – A medical problem/diagnosis that affected the specified family 
member, or a medical procedure that was performed on the specified family member.  These 
fields are required.  Select the Problem or Description field and press Enter or F2 or F9 or type 
any text (or right-click on any item in the list and select Edit or LookUp, or select LookUp on 
Item in the Patient toolbar), or double-click in either field, and a Find Problem dialog box will 
open (see section “Find Problem Dialog Box”).  Select a problem/procedure/ICD-9 code, and 
then select OK or press F9, or double-click on a problem/procedure/ICD-9 code.  To clear these 
fields, select Clear and then OK.  The Class field indicates the type of code:  problem (“UDF”) 
(see section “Problem Codes”), procedure (“MOHFEE”) (see section “Procedure Codes”), or 
ICD-9 (“ICD-9”) (see section “ICD-9 Codes”). 
 
Treatment / Treatment Description – Indicates what treatment, if any, the family member was 
given as a result of their condition.  Select the Treatment field and enter the treatment code.  
(This will replace any existing text in that field.  To correct/delete a treatment code, select the 
Treatment field and then press F2 or right-click on any item in the list and select Edit, and then 
make the desired changes.)  Or, select the Treatment Description field and press Enter or F2 (or 
right-click on any item in the list and select Edit), or select either field and press F9 (or select 
LookUp on Item in the Patient toolbar, or right-click on any item in the list and select LookUp), 
or double-click in either field, and a Find Treatment dialog box will open (see section “Find 
Treatment Dialog Box”).  Select a treatment code and then select OK or press F9, or double-click 
on a treatment code.  To clear these fields, select Clear and then OK.  These fields are not 
displayed by default. 
 
C (Confidential) – Reserved for future use (not displayed by default). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that the selected item on the family medical history list was last modified (not displayed 
by default).  These fields are automatically updated whenever the selected item on the family 
medical history list is modified.  These fields cannot be manually modified.  
 
User – The user who last modified the selected item on the family medical history list (see 
section “Before You Begin”).  This field is automatically updated whenever the selected item on 
the family medical history list is modified.  This field cannot be manually modified.  This field is 
not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where the selected item on the family medical history list was last 
modified, or the domain under which the user (who last modified the selected item on the family 
medical history list) was authenticated (logged in) at the time.  See section “Domain”.  This field 
is automatically updated whenever the selected item on the family medical history list is 
modified.  This field cannot be manually modified.  This field is not displayed by default. 
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Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected family medical history item on the list (see above).  If there are no items 
on the list, this field will be blank.  See section “Notes Fields”. 
 


4.4.16 Recall Tab 
 


 
 
Toolbar 
 


New → Recall – Add a recall type (see section “Recall Window”). 
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Open → Recall – View/modify a recall type.  If you select this, a Find Recall 
dialog box will open (see section “Find Recall Dialog Box”).  Select a recall type 
and then select OK or press F9, or double-click on a recall type. 
 


Save – Save the patient. 
 
Save and Close (Ctrl-L) – Save the patient and close the Patient window. 
 
LookUp on Item (F9) – Choose an entry for the selected field (Due Date, Completed, 
Code, Description, Letter 1/2,. Letter 1/2 Code, Letter 1/2 Description, Phone, Phone Code, 


or Phone Description) on the recall list. 
 


Delete Item (Ctrl-Del) – Selecting this button will delete the selected recall.  Pressing Ctrl-
Del will delete: 


 
 (on the recall list) the selected recall. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s recalls with no “Completed” date or with a 
“Completed” date in the future (or on the current day), and don’t include any recalls with 


the Letter 1 Description, Letter 2 Description, and/or Phone Description field set to Refused. 
 


All Items – Display all recalls for this patient. 
 


Recall List 
 
Lists all matching recalls for this patient (see section “Viewing a List of Items”).  The fields are: 
 
Due Date – The date the recall was created (see section “Date Fields”).  This is the same as the 
Date field in the Recalls window (see section “List Recalls”). 
 
I (Ineligible) – Indicates that this patient is not eligible for the selected medical procedure.  For 
example, a patient who has had a hysterectomy might not be eligible for a pap smear, or a patient 
who has had a mastectomy might not be eligible for a mammogram. 
 
T (Target) – Indicates whether this recall was added by the Auto-Generate function (see section 
“List Recalls”).  This field cannot be manually modified.  This field is not displayed by default. 
 
Code / Description – The purpose of the recall (see section “Recall Window”).  These fields are 
required.  Select the Code field and enter the recall code.  (This will replace any existing text in 
that field.  To correct/delete a recall code, select the Code field and then press F2 or right-click 
on any item in the list and select Edit, and then make the desired changes.)  Or, select the 
Description field and press Enter or F2 (or right-click on any item in the list and select Edit), or 
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select either field and press F9 (or select LookUp on Item in the Patient toolbar, or right-click on 
any item in the list and select LookUp), or double-click in either field, and a Find Recall dialog 
box will open (see section “Find Recall Dialog Box”).  Select a recall type and then select OK or 
press F9, or double-click on a recall type.  To clear these fields, select Clear and then OK.  The 
Description field is not displayed by default. 
 
Letter 1 – Indicates the date a first letter was sent to the patient, to remind them to get the 
required medical procedure.  See section “Date Fields”. 
 
(Letter 1 Code) / Letter 1 (Letter 1 Description) – Indicates the patient’s response to the first 
letter (see section “LookUp Response Dialog Box”).  The Letter 1 Description field is not 
displayed by default. 
 
Letter 2 – Indicates the date a second letter was sent to the patient, to remind them to get the 
required medical procedure.  See section “Date Fields”. 
 
(Letter 2 Code) / Letter 2 (Letter 2 Description) – Indicates the patient’s response to the first 
letter (see section “LookUp Response Dialog Box”).  The Letter 2 Description field is not 
displayed by default. 
 
Phone – Indicates the date the patient was telephoned, to remind them to get the required 
medical procedure.  See section “Date Fields”. 
 
(Phone Code) / Phone (Phone Description) – Indicates the patient’s response to the telephone 
call (see section “LookUp Response Dialog Box”).  The Phone Description field is not displayed 
by default. 
 
# (# of Immunizations) – If the Code (see above) is set to IMM (Immunization), this field 
indicates the number of immunizations the patient has had (babies are supposed to get 5 
immunizations).  If the Code (see above) is set to COL (Colorectal screening), this field is used 
to indicate whether the patient had a colonoscopy (enter any positive integer) or a colorectal 
screening (enter 0).  This field is not displayed by default.  Must be a whole number from 0 to 9.  
The default is 0. 
 
Completed – The date that the patient responded to the recall (letter or phone call), i.e. the date 
that the patient agreed or refused to have the selected medical procedure.  See section “Date 
Fields”. 
 
Last Date – When recalls are automatically generated (see section “List Recalls”), this field will 
be set to the last Completed date of all recalls of the same type for the same patient.  This field is 
not displayed by default, and cannot be manually modified. 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this recall was last modified (not displayed by default).  These fields are 
automatically updated whenever the recall is modified.  These fields cannot be manually 
modified. 
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User – The user who last modified this recall (see section “Before You Begin”).  This field is 
automatically updated whenever the recall is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this recall was last modified, or the domain under which the user 
(who last modified this recall) was authenticated (logged in) at the time.  See section “Domain”.  
This field is automatically updated whenever the recall is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays any information/notes 
specific to the selected recall on the list (see above).  If there are no recalls on the list, this field 
will be blank.  See section “Notes Fields”. 
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4.4.17 Task Tab 
 


 
 
Toolbar 
 


New → Task (Ctrl-N) – Add a task for this patient (see section “Task 
Window”). 
 
 
Open → Task (Ctrl-O) – View/modify a task for this patient (task must be 
selected on the list first).  See section “Task Window”. 
 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s tasks that have status Draft, Open, or Incomplete. 
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All Items – Display all tasks for this patient. 


 
Task List 
 
Lists all of this patient’s tasks (see section “Viewing a List of Items”).  To view/modify a task, 
select it and then press Enter or Ctrl-O or F9 or select Open → Task in the Patient toolbar, or 
double-click on it (see section “Task Window”).  To add a task for this patient, press Ctrl-N or 
select New → Task in the Patient toolbar (see section “Task Window”).  The fields are: 
 
Due – The Due field from the Task window (see section “Task Window”). 
 
Status – The Status field from the Task window (see section “Task Window”). 
 
Priority – The Priority field from the Task window (see section “Task Window”). 
 
Re – The Re field from the Task window (see section “Task Window”). 
 
Assignee – The Assignee field from the Task window (see section “Task Window”). 
 
Assignor – The Assignor field from the Task window (see section “Task Window”). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this task was last modified (not displayed by default).  These fields are 
automatically updated whenever the task is modified.  These fields cannot be manually modified. 
 
User – The user who last modified this task (see section “Before You Begin”).  This field is 
automatically updated whenever the task is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this task was last modified, or the domain under which the user 
(who last modified this task) was authenticated (logged in) at the time.  See section “Domain”.  
This field is automatically updated whenever the task is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected task on the list (see above).  If there are no tasks on the list, this field will be blank.  
This field cannot be manually modified.  To change the notes field for a task, view/modify the 
task (see above).  See section “Notes Fields”. 
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4.4.18 Ref. Tab 
 


 
 
Toolbar 
 


New → Referral (Ctrl-N) – Add a referral for this patient (see section 
“Referral Window”). 
 
 
Open → Referral (Ctrl-O) – View/modify a referral for this patient 
(referral must be selected on the list first).  See section “Referral Window”. 
 
 


Notes – Display/hide the expanded notes field (at the bottom of the patient window). 
 
Active Items – Display only this patient’s referrals with the status set to “To Book”, 
“Booked”, “Confirmed”, or “Faxed”. 
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All Items – Display all referrals for this patient. 


 
Referral List 
 
Lists all of this patient’s referrals (see section “Viewing a List of Items”).  To view/modify a 
referral, select it and then press Enter or Ctrl-O or F9 or select Open → Task in the Patient 
toolbar, or double-click on it (see section “Referral Window”).  To add a referral for this patient, 
press Ctrl-N or select New → Referral in the Patient toolbar (see section “Referral Window”).  
The fields are: 
 
Date – The Date field from the Referral window (see section “Referral Window”). 
 
Provider – The Provider field from the Referral window (see section “Referral Window”) 
 
Referred – The Referred field from the Referral window (see section “Referral Window”) 
 
Status – The Status field from the Referral window (see section “Referral Window”) 
 
Re – The Re field from the Referral window (see section “Referral Window”) 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this referral was last modified (not displayed by default).  These fields are 
automatically updated whenever the referral is modified.  These fields cannot be manually 
modified. 
 
User – The user who last modified this referral (see section “Before You Begin”).  This field is 
automatically updated whenever the referral is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this referral was last modified, or the domain under which the user 
(who last modified this referral) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the referral is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays the Notes field from 
the selected referral on the list (see above).  If there are no referrals on the list, this field will be 
blank.  This field cannot be manually modified.  To change the notes field for a referral, 
view/modify the referral (see above).  See section “Notes Fields”. 
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4.4.19 Attach. Tab 
 


 
 
Toolbar 
 


New → Attachment (Ctrl-N) – Add an attachment for this patient (see 
section “Attachment Window”). 
 
 
Open → Attachment (Ctrl-O) – View/modify an attachment for this 
patient (attachment must be selected on the list first).  See section 
“Attachment Window”. 
 


Active Items – Display only this patient’s attachments with status “Read” (with the 
Received date less than 30 days old), and those with status “Unread”. 


 
All Items – Display all attachments for this patient. 
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Attachment List 
 
Lists all of this patient’s attachments (see section “Viewing a List of Items”).  To view/modify 
an attachment, select it and then press Enter or Ctrl-O or F9 or select Open → Attachment in the 
Patient toolbar, or double-click on it (see section “Attachment Window”).  To add an attachment 
for this patient, press Ctrl-N or select New → Attachment in the Patient toolbar (see section 
“Attachment Window”).  The fields are: 
 
Created – The Created field from the Attachment window (see section “Attachment Window”). 
 
Received – The Received field from the Attachment window (see section “Attachment 
Window”) 
 
Type / Type Description – The Type field from the Attachment window (see section 
“Attachment Window”).  The Type Description field is not displayed by default. 
 
Status – The Status field from the Attachment window (see section “Attachment Window”) 
 
Priority – The Priority field from the Attachment window (see section “Attachment Window”) 
 
Source – The Source field from the Attachment window (see section “Attachment Window”) 
 
Description – The Description field from the Attachment window (see section “Attachment 
Window”) 
 
Provider – The Provider field from the Attachment window (see section “Attachment Window”) 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this attachment was last modified (not displayed by default).  These fields are 
automatically updated whenever the attachment is modified.  These fields cannot be manually 
modified. 
 
User – The user who last modified this attachment (see section “Before You Begin”).  This field 
is automatically updated whenever the attachment is modified.  This field cannot be manually 
modified.  This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this attachment was last modified, or the domain under which the 
user (who last modified this attachment) was authenticated (logged in) at the time.  See section 
“Domain”.  This field is automatically updated whenever the attachment is modified.  This field 
cannot be manually modified.  This field is not displayed by default. 
 
View Toolbar 
 
- – Zoom out the page in the Preview Area (see below). 
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+ – Zoom in the page in the Preview Area (see below). 
 
Between the + and View buttons is the Page Number field.  This indicates which page of the 
scanned document to display in the Preview Area (see below).  If no document has been scanned, 
this field will be unavailable, and/or will show 0.  To enter a page number, type a positive integer 
using the keyboard, or use the up/down arrow buttons or arrow keys to increase or decrease the 
page number displayed. 
 
View… – Open the file that was imported into the attachment selected on the Attachment List 
(see above), whose file name appears in the file name field (see below).  (If that field is blank, 
the View button is unavailable.)  Windows will automatically choose an external program to 
open the file based on the extension at the end of the file name.  For example, if the file name 
ends with “.TXT”, Windows will most likely open it using a text editor such as Notepad.  For 
more information on file type associations, check your Windows help or documentation. 
 
To the right of the View button appears the name of the file that was imported into the 
attachment selected on the Attachment List (see above), if applicable. 
 
Notes 
 
Below the View Toolbar is the expanded notes field (if enabled).  This field displays the Notes 
field from the selected attachment on the list (see above).  If there are no attachments on the list, 
this field will be blank.  This field cannot be manually modified.  To change the notes field for 
an attachment, view/modify the attachment (see above).  See section “Notes Fields”. 
 
Preview Area 
 
At the bottom is the preview area which displays (one page of) the scanned document (if an 
attachment which contains a scanned document has been selected on the Attachment List – see 
above).  Select a page number in the Page Number field in the View Toolbar above, and that 
page will be displayed in the Preview Area.  If the Page Number field shows 0, the Preview Area 
will be blank. 
 







 120


4.4.20 CPP Tab 
 


 
 
The CPP Tab consists of 6 sections: 
 


 Problems (top row, left side) – this is the same as the Problem Tab (see section “Problem 
Tab”), except that only the Begin Date, Status, Problem, and Description fields are 
displayed by default. 


 Alerts (top row, right side) – this is the same as the Alert Tab (see section “Alert Tab”), 
except that only the Alert and Description fields are displayed by default. 


 Prescriptions (middle row, left side) – this is the same as the Rx Tab (see section “Rx 
Tab”), except that only the Begin Date, Drug, and Long Term fields are displayed by 
default. 


 Risks (middle row, right side) – this is the same as the Risk Tab (see section “Risk Tab”), 
except that only the Risk, Description, Quantity, and Begin Date fields are displayed by 
default. 
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 Allergies (bottom row, left side) – this is the same as the Allergy Tab (see section 
“Allergy Tab”), except that only the Allergy and Severity fields are displayed by default. 


 Family Medical History (bottom row, right side) – this is the same as the Family Tab (see 
section “Family Tab”), except that only the Relation, Age, Problem, and Description are 
displayed by default. 


 
The expanded Notes fields are disabled by default on the CPP Tab.  To enable an expanded 
Notes field, select the Notes button in the appropriate toolbar. 
 


4.4.21 Prog. Tab 
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Toolbar 
 


New → Appointment (Ctrl-A) – Add an appointment for this patient 
(see section “Appointment Window”). 
 
New → Encounter (Ctrl-E) – Add an encounter for this patient (see 
section “Encounter Window”). 
 
New → Rx (Ctrl-R) – Add a prescription for this patient (see section 
“Rx Window”). 
 
New → Requisition (Ctrl-Q) – Add a lab requisition for this patient 
(see section “Requisition Window”). 
 


New → Task (Ctrl-K) – Add a task for this patient (see section “Task Window”). 
 
New → Referral (Ctrl-F) – Add a referral for this patient (see section “Referral Window”). 
 
New → Attachment (Ctrl-H) – Add an attachment for this patient (see section “Attachment 
Window”). 
 


Open → Source (Ctrl-O) – View/modify the selected record on the 
Progress List (see section “Appointment Window”, “Encounter Window”, 
“Rx Window”, “Requisition Window”, “Task Window”, “Referral 
Window”, or “Attachment Window”).  This function has no effect on lab 


results. 
 
Active Items – Display only active records of the selected type(s) for this patient. 
 


All Items – Display all records of the selected type(s) for this patient. 
 


Appt. – Choose whether or not to display this patient’s appointments on the Progress List. 
 
Encnt. – Choose whether or not to display this patient’s encounters on the Progress List. 
 
Rx – Choose whether or not to display this patient’s prescriptions on the Progress List. 
 
Req. – Choose whether or not to display this patient’s lab requisitions on the Progress List. 
 
Lab – Choose whether or not to display this patient’s lab results on the Progress List. 
 
Task – Choose whether or not to display this patient’s tasks on the Progress List. 
 
Ref. – Choose whether or not to display this patient’s referrals on the Progress List. 
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Attach. – Choose whether or not to display this patient’s attachments on the Progress List. 
 
Progress List 
 
Lists all records for this patient of the type(s) selected in the Patient toolbar (e.g. appointments, 
encounters, prescriptions, lab requisitions, lab results, tasks, referrals, and/or attachments).  See 
section “Viewing a List of Items”.  To view/modify a record (other than a lab result), double-
click on it, or select it and press Enter or Ctrl-O or F9.  An Appointment, Encounter, Rx, 
Requisition, Task, Referral, or Attachment window will open (see section “Appointment 
Window”, “Encounter Window”, “Rx Window”, “Requisition Window”, “Task Window”, 
“Referral Window”, or “Attachment Window”). 
 
The fields are: 
 
Date – The date of the record. 
 
Type – The type of record, i.e. Appointment, Encounter, Rx (prescription), (lab) Requisition, 
Lab (results), Task, Referral, or Attachment. 
 
Provider – The provider with whom the record is associated (tasks are not associated with 
providers). 
 
Edit Date / Edit Time – The date (see section “Date Fields”) and time (see section “Time 
Fields”) that this record was last modified (not displayed by default).  These fields are 
automatically updated whenever the record is modified.  These fields cannot be manually 
modified. 
 
User – The user who last modified this record (see section “Before You Begin”).  This field is 
automatically updated whenever the record is modified.  This field cannot be manually modified.  
This field is not displayed by default. 
 
Domain – Depending on your network configuration, the Domain field will show either the 
name of the computer where this record was last modified, or the domain under which the user 
(who last modified this record) was authenticated (logged in) at the time.  See section “Domain”.  
This field is automatically updated whenever the record is modified.  This field cannot be 
manually modified.  This field is not displayed by default. 
 
Notes 
 
At the bottom is the expanded Notes field (if enabled).  This field displays all the details from the 
selected record on the list (see above).  If there are no records on the list, this field will be blank.  
This field cannot be manually modified.  To edit a record on the list, view/modify the record (see 
above). 
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4.4.22 Import Tab 
 
The Import Tab displays data that was imported (from XML files) using the Import feature (see 
section “Import”). 
 
Toolbar 
 
Report – Display the imported data in a human-readable format (see section “Report”). 
 
Import – Display (all of) the imported data in “raw” (XML) format (see section “Import”). 
 


4.4.22.1 Report 
 


 
 
Displays data that was imported (from XML files) using the Import feature (see section 
“Import”). 
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4.4.22.2 Import 
 


 
 
Displays data that was imported (from XML files) using the Import feature (see section 
“Import”).  The data is displayed in “raw” (XML) format, in a “tree” that functions similar to 
(but not exactly the same as) the rules described in “Viewing a Tree of Items”. 
 
Viewing XML data may be confusing for some users;  to see the same data in a more human-
readable format, select Report in the Patient toolbar (see section “Import Tab” or “Report”). 
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4.5 Delete a Patient 
 
View/modify a patient as per section “View/Modify a Patient”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D. 
 
NOTE:  You cannot delete a patient that has other records (e.g. appointments, bills, payments) 
associated with it.  You must first delete the other records, or remove the association (e.g. 
associate them with a different patient). 
 


4.6 List Patients 
 
Go in the File menu to List → Patient (see section “Pull-Down Menus”), or go to List → Patient 
in the Main Toolbar (see section “Main Toolbar”), or select List Patient in the Action Bar (see 
section “Action Bar”). 
 


 
 
Toolbar 
 
\ – View the first 500 patients that match the specified criteria.  This option is only available if 
the Status field is set to Incomplete, Open, or Error, and there are at least 500 patients to display 
on the Patient List. 
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+ – View the next 500 patients that match the specified criteria.  This option is only available if 
the Status field is set to Incomplete, Open, or Error, and there are at least 500 patients to display 
on the Patient List. 
 
Status – Choose which patients to display: 


 Incomplete (no health card number). 
 Open (ready to be OBEC verified – see section “OBEC”). 
 Pending (an OBEC request has been sent, but no response has been received – see section 


“OBEC”). 
 Error (OBEC rejected – see section “OBEC”).   This list will not include patients marked 


as Inactive or with a Death date entered (see section “Patient Window, Demographic 
Tab”). 


 List (view/modify the contents of a Patient List – see section “Patient Lists”). 
 
Insert – Add a patient to the selected patient list (in the List field).  If Status is not set to List, the 
selected patient will be added.  If Status is set to List, a Find Patient dialog box will open (see 
section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or double-
click on a patient.  See section “Add a Patient to a Patient List”. 
 
Delete – Remove the selected patient from the selected patient list (in the List field).  (Status 
must be set to List.)  See section “Delete a Patient from a Patient List”.  NOTE:  This does not 
delete the patient record. 
 
Query – Add patients to the selected patient list.  This feature only works if the Status field is set 
to List, and a patient list is selected in the List field, and a provider is specified in the Main 
Toolbar (see section “Log in as a Provider”).  If you select this button: 


1. A Query dialog box will open (see section “Query Dialog Box”).  Enter criteria to specify 
which patients to add to the selected patient list, and then select OK.  Only patients for 
the logged-in provider will be added to the selected patient list, unless you remove that 
criteria from the SQL field (e.g. by 
selecting “Clear Criteria”). 


2. A dialog box will ask “Delete existing 
patients on this list beforehand?”  Select 
Yes to remove all patients from the 
selected patient list before adding the 
new patients, or select No if you don’t 
want to remove any patients from the 
selected patient list, or select Cancel if you don’t want to add any patients to the selected 
patient list. 


See section “Patient Lists”. 
 
List – Select a patient list to view the contents of that patient list (Status must be set to List), or 
to add a patient to that patient list, or to remove a patient from that patient list (Status must be set 
to List).  See section “Add a Patient to a Patient List”, “View the Contents of a Patient List”, or 
“Delete a Patient from a Patient List”.  Enter/modify any text (or double-click) in this field, and a 







 128


Find Patient List dialog box will open (see section “Find Patient List Dialog Box”).  Select a 
patient list and then select OK or press F9, or double-click on a patient list.  To clear this field, 
select Clear and then OK. 
 
Patient List 
 
Lists all patients that match the specified criteria (see section “Viewing a List of Items”).  The 
Patients window title bar will show (in brackets) the number of patients displayed.  If the Status 
field is set to Incomplete, Open, or Error, and there are at least 500 patients to display, only the 
first 500 patients (sorted alphabetically by surname and then first name) will be displayed, and 
the title bar will say “Patients (500+)”.  If that happens, to view the next 500 patients, select the 
“+” button.  Or, select the “\” button to jump to the top of the list again. 
 
To view/modify a patient, select that patient and press Enter or F9, or double-click on that patient 
(see section “Patient Window”).  For a description of the fields, see section “Patient Window, 
Demographic Tab”. 
 


5 Appointments 


5.1 Add an Appointment 
 
Go in the File menu to New → Appointment (see section “Pull-Down Menus”), or go to New → 
Appointment in the Main Toolbar (see section “Main Toolbar”), or select New Appointment in 
the Action Bar (see section “Action Bar”), or press Ctrl-A.  An Appointment window will open 
(see section “Appointment Window”). 
 


5.2 View/Modify an Appointment 
 
Go in the File menu to Open → Appointment (see section “Pull-Down Menus”), or go to Open 
→ Appointment in the Main Toolbar (see section “Main Toolbar”), or select Open Appointment 
in the Action Bar (see section “Action Bar”), or press Ctrl-Shift-A.  A Find Appointment dialog 
box will open (see section “Find Appointment Dialog Box”).  Select an appointment and then 
select OK or press F9, or double-click on an appointment, and then an Appointment window will 
open.  See section “Appointment Window”. 
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5.3 Find Appointment Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Patient – Choose a patient.  If you select this, a Find Patient dialog box will open (see section 
“Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or double-click on a 
patient.  To clear this field, select Clear and then OK. 
 
Provider – Choose a provider.  If you select this, a Find Provider dialog box will open (see 
section “Find Provider Dialog Box”).  Only providers with at least one local role will be 
displayed on the list (see section “Provider Window, Demographic Tab, Role List”), however, 
each provider will only be displayed once on the list (even providers that have more than one 
local role).  Select a provider and then select OK or press F9, or double-click on a provider.  To 
clear this field, select Clear and then OK. 
 
If both of the above fields are blank, no appointments will be displayed. 
 
From – The minimum date for appointments to be displayed (see section “Date Fields”).  If this 
field is blank, all matching appointments before the To date (inclusive) will be displayed. 
 
To – The maximum date for appointments to be displayed (see section “Date Fields”).  If this 
field is blank, all matching appointments after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching appointments will be displayed. 
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Other 
 
OK button – Chooses the selected appointment and closes the window.  If no appointments are 
displayed, searches for appointments that match the specified criteria, chooses the first one, and 
closes the window. 
  
Cancel button – Closes the window without choosing an appointment. 
 
Clear button – Clears the appointment list and the resets the fields in the “Criteria” section back 
to their original/default values. 
 
Find button – Searches for appointments that match the specified criteria. 
 
Appointment List – Lists appointments that match the specified criteria (see section “Viewing a 
List of Items”).  Select an appointment and then select OK or press F9, or double-click on an 
appointment, to choose that appointment and close the window.  For a description of the fields, 
see section “Appointment Window”. 
 


5.4 Appointment Window 
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Toolbar 
 


New → Appointment (Ctrl-N) – Add an appointment. 
 
New → Type – Add an appointment type (see section “(Appointment) 
Type Window”). 
 
New → Re – Add an appointment re code (see section “(Appointment) 
Re Window”). 
 
New → Location – Add a location code (see section “Location 


Window”). 
 


Open → Appointment (Ctrl-O) – View/modify an appointment.  If 
you select this, a Find Appointment dialog box will open (see section 
“Find Appointment Dialog Box”).  Select an appointment and then 
select OK or press F9, or double-click on an appointment. 
 
Open → Type – View/modify an appointment type.  If you select this, 
a Find (Appointment) Type dialog box will open (see section “Find 


(Appointment) Type Dialog Box”).  Select an appointment type and then select OK or press F9, 
or double-click on an appointment type.  See section “(Appointment) Type Window”. 
 
Open → Re – View/modify an appointment re code.  If you select this, a Find (Appointment) Re 
dialog box will open (see section “Find (Appointment) Re Dialog Box”).  Select an appointment 
re code and then select OK or press F9, or double-click on an appointment re code.  See section 
“(Appointment) Re Window”. 
 
Open → Location – View/modify a location code.  If you select this, a Find Location dialog box 
will open (see section “Find Location Dialog Box”).  Select a location code and then select OK 
or press F9, or double-click on a location code.  See section “Location Window”. 


 
Save (Ctrl-S) – Save the appointment. 


 
Save and Close (Ctrl-L) – Save the appointment and close the Appointment window. 
 
 Goto patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
LookUp Schedule, Re, or Location (F9) – If the Re or Location field is selected, this 
function will open a Find (Appointment) Re or Find Location dialog box (see section “Find 


(Appointment) Re Dialog Box” or “Find Location Dialog Box”).  Select an appointment re code 
or a location code and then select OK or press F9, or double-click on an appointment re code or a 
location code.  To clear the selected field (Re or Location), select Clear and then OK.  If neither 
the Re or Location field is selected, this function is used to find an available time slot for the 
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appointment (see section “Find Schedule Dialog Box”). 
 


Recurrent – Set this appointment to recur at regular intervals, e.g. every week.  This 
option is only available if the appointment has already been saved.  If you select this, a 


Recurrent dialog box will open (see section “Recurrent Dialog Box”). 
 
Other 
 
Date – Choose a date for the appointment (see section “Date Fields”).  Required.  This field 
supports defaults (see section “Defaults, Appointment Window”). 
 
Patient – Choose a patient for the appointment.  If you select this, a Find Patient dialog box will 
open (see section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or 
double-click on a patient.  To clear this field, select Clear and then OK.  If no patient is selected, 
it will be a blocking appointment.  If there is a patient selected in this field, and you double-click 
in the field that contains the patient’s name, birthdate, age, health card number, and version code 
(not on the Patient button itself), a Patient window will open for that patient (see section “Patient 
Window”). 
 
Time – Choose a time for the appointment (see section “Time Fields”).  Required. 
 
Provider – Choose a provider for the appointment (required).  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role), i.e. the appointment will be associated with the provider in general, not 
a specific role.  Select a provider and then select OK or press F9, or double-click on a provider.  
To clear this field, select Clear and then OK. 
 
Duration – The length of the appointment in minutes (a whole number from 0 to 1440).  If no 
number is entered, 0 will be assumed.  If you double-click in this field, a Find Schedule dialog 
box will open (see section “Find Schedule Dialog Box”). 
 
Referring – The provider that referred this patient to you.  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
Referring role will be displayed on the list (see section “Provider Window, Demographic Tab, 
Role List”).  Select a provider and then select OK or press F9, or double-click on a provider.  To 
clear this field, select Clear and then OK.  If there is a provider selected in this field, and you 
double-click in the field that contains the provider’s name and billing number (not on the 
Referring button itself), a Provider window will open for that provider (see section “Provider 
Window”).  This field supports defaults (see section “Defaults, Appointment Window”). 
 
Status – Choose a status for the appointment.  From the drop-down list box, select one of: 


 Arrived – The patient has arrived and is waiting to see the provider. 
 Cancelled – The appointment has been cancelled. 
 Closed – A bill has been generated for this appointment. 
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 Closed/N.S. – The patient missed the appointment, and a bill has been generated for this 
appointment (some providers have a policy of charging patients for missed 
appointments). 


 Completed – The provider has seen the patient. 
 Confirmed – The patient has been reminded of the appointment. 
 Examining – The provider is seeing the patient. 
 No Show – The patient missed the appointment. 
 Reschedule – The patient wishes to change the appointment to a different date/time. 
 To Confirm – The appointment is tentative.  The patient needs to be reminded of the 


appointment. 
This field supports defaults (see section “Defaults, Appointment Window”). 
 
Priority – The appointment’s importance:  Low, Normal, or High. 
 
Type – The general purpose of the appointment, e.g. Surgery, Consultation, Prescription, etc.  
Enter/modify any text (or double-click) in this field, and a Find (Appointment) Type dialog box 
will open (see section “Find (Appointment) Type Dialog Box”).  Select an appointment type and 
then select OK or press F9, or double-click on an appointment type.  To clear this field, select 
Clear and then OK. 
 
Re – The specific purpose of the appointment, e.g. Back Pain, Check-up, Flu Shot, etc.  Select 
this field and enter the text.  Or, select this field and press F9, or double-click in this field, and a 
Find (Appointment) Re dialog box will open (see section “Find (Appointment) Re Dialog Box”).  
Select an appointment re code and then select OK or press F9, or double-click on a re code.  To 
clear this field, select Clear and then OK. 
 
Location – Where the appointment will take place (e.g. building/room).  Select this field and 
enter the text.  Or, select this field and press F9, or double-click in this field, and a Find Location 
dialog box will open (see section “Find Location Dialog Box”).  Select a location code and then 
select OK or press F9, or double-click on a location code.  To clear this field, select Clear and 
then OK. 
 
Notes 
 
At the bottom is the notes field.  This field can be used to store any information specific to this 
appointment.  See section “Notes Fields”. 
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5.4.1 Find Schedule Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Provider – The provider whose time slots will be displayed.  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role).  Select a provider and then select OK or press F9, or double-click on a 
provider.  To clear this field, select Clear and then OK.  If this field is left blank, all matching 
time slots for all providers will be displayed. 
 
Duration – The length of the appointment in minutes (a whole number from 1 to 999).  This 
field is required. 
 
Type – The general purpose of the appointment, e.g. Surgery, Consultation, Prescription, etc.  If 
you enter/modify any text (or double-click) in this field, a Find (Appointment) Type dialog box 
will open (see section “Find (Appointment) Type Dialog Box”).  Select an appointment type and 
then select OK or press F9, or double-click on an appointment type.  To clear this field, select 
Clear and then OK. 
 
From – The earliest possible date for the appointment (see section “Date Fields”).  Only time 
slots on or after this date will be displayed.  If this field is blank, all available time slots (that 
match the other criteria) will be displayed. 
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To –  The latest possible date for the appointment (see section “Date Fields”).  Only time slots 
before (but not on) this date will be displayed.  This field is required. 
 


Choose a day of the week for the appointment, or choose “Any” for any day.  
 
Choose a time range (start and end) for the appointment (see section “Time Fields”).  
Only time slots between these times (inclusive) will be displayed.  These fields are 
required.  NOTE:  In the second field, “12:00 AM” means the end of the day, not the 
beginning, so you can enter “12:00 AM” for both start and end to display all time 
slots matching the rest of the criteria. 
 


Other 
 
OK button – Chooses the selected time slot and closes the window.  If no time slots are 
displayed, searches for time slots that match the specified criteria, chooses the first one, and 
closes the window. 
 
Cancel button – Closes the window without choosing a time slot. 
 
Clear button – Clears the time slot list and resets all fields in the “Criteria” section back to their 
default values. 
 
Find button – Searches for time slots that match the specified criteria. 
 
Time Slot List – Lists available time slots that match the specified criteria (see section “Viewing 
a List of Items”).  Select a time slot and then select OK or press F9, or double-click on a time 
slot, to choose that time slot and close the window.  For a description of the fields, see section 
“Provider Window, Schedule Tab”. 
 


5.4.2 Recurrent Dialog Box 
 


 
 
Occurrences – The number of appointments that should be added.  Must be a positive integer 
from 1 to 999. 
 
From – The beginning of the date range in which the appointments will be added (see section 
“Date Fields”). 
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To – The end of the date range in which the appointments will be added (see section “Date 
Fields”). 
  
Every __ week(s) – The number of weeks in between appointments.  Must be a positive integer 
from 1 to 52. 
 
Sun/Mon/Tue/Wed/Thu/Fri/Sat – The days of the week on which the new appointments will 
be created. 
 
OK – Create the selected appointments and close the Recurrent dialog box. 
 
Cancel – Close the Recurrent dialog box without creating new appointments. 
 


5.5 Delete an Appointment 
 
View/modify an appointment as per section “View/Modify an Appointment”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D. 
 


5.6 List Appointments (Calendar/Schedule) 
 
Go in the File menu to List → Appointment (see section “Pull-Down Menus”), or go to List → 
Appointment in the Main Toolbar (see section “Main Toolbar”), or select List Appointment in 
the Action Bar (see section “Action Bar”). 
 
Toolbar 
 


Prior Year – Jump back one year. 
 
Prior Month (PgDown) – Jump back one month. 
 
Prior Week – Jump back one week. 
 
Prior Day (Ctrl-Down Arrow) – Jump back one day. 
 
Today (Home) – Jump to the current day. 
 
Next Day (Ctrl-Up Arrow) – Jump ahead one day. 
 
Next Week – Jump ahead one week. 
 
Next Month (PgUp) – Jump ahead one month. 
 
Next Year – Jump ahead one year. 
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Provider – The provider whose schedule to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one local role will be displayed on the list (see section “Provider Window, Demographic 
Tab, Role List”), however, each provider will only be displayed once on the list (even providers 
that have more than one local role).  Select a provider and then select OK or press F9, or double-
click on a provider.  To clear this field, select Clear and then OK.  If this field is left blank, no 
time slots or appointments will be displayed. 
 
Date – The date of appointments and time slots to be displayed (see section “Date Fields”). 
 
Auto-bill – Automatically creates an incomplete bill for each appointment with status Completed 
for the specified provider on the specified date, and changes the status for those appointments to 
Closed (see section “Closing Appointments”).  This feature only works if the Day tab is selected 
(see section “Day Tab”), and the same provider is specified in both the Main Toolbar (see 
section “Log in as a Provider”) and the Appts. toolbar (see Provider field, above).  The bills will 
be associated with the role selected in the Main Toolbar. 
 
Billable – With this option on, only appointments of status Confirmed, Arrived, Examining, 
Completed, or No Show will be displayed on the Day tab (see section “Day Tab”).  With this 
option off, appointments of any status will be displayed. 
 
No Personal – Determines whether the Status, Priority, and Re fields are available on the Day 
tab (see section “Day Tab”). 
 
No Slots – If this option is on, only appointments, but not time slots, will be displayed on the 
Day tab (see section “Day Tab”), and multiple appointments that start in the same time slot (or at 
the same time) will be displayed on separate rows.  If this option is off, both appointments and 
time slots will be displayed, and multiple appointments that start in the same time slot (or at the 
same time) will be displayed on the same row. 
 
No Synch. – If this option is off, and you change the date in any Appts. window, all other open 
Appts. windows will change to the selected date as well.  Also, if you scroll up or down in any 
Appts. window (Day tab - see section “Day Tab”), the Day tabs of any other open Appts. 
windows will scroll up or down accordingly.  But if this option is on, then such changes in one 
Appts. window will not affect any other Appts. window. 
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5.6.1 Day Tab 
 


 
 
Lists all of the specified provider’s appointments for the specified date.  Also, if “No Slots” is off 
(see section “List Appointments”), lists all time slots in the specified provider’s office hours on 
the specified date (see section “Provider Window, Schedule Tab”).  See section “Viewing a List 
of Items”.  The Appts. window title bar will show (in brackets) the number of appointments 
displayed. 
 
The fields are: 
 
Time – The beginning of the time slot or appointment. 
 
Type / Type Description – The Type and Type Description fields from the corresponding entry 
on the provider’s Schedule List (see section “Provider Window, Schedule Tab”).  The Type 
Description field is not displayed by default. 
 
B (Blocked) – Indicates whether the time slot is blocked on the provider’s Schedule List (see 
section “Provider Window, Schedule Tab”) and/or contains a blocking appointment. 
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O. (Open (Minutes)) – The number of minutes in this time slot that are available for booking 
appointments.  This is automatically calculated by multiplying the length of the time slot by the 
OverBook % Warning field (divided by 100), and then subtracting the number of minutes of 
(non-cancelled) appointments that have already been booked in this time slot.  For example, if 
the time slot is 15 minutes long, with an OverBook % Warning of 200, with 20 minutes of 
booked appointments, then this field will display “10” (15 × 200 ÷ 100 – 20).  If a time slot has 
been overbooked (beyond the OverBook % Warning), a negative value will be displayed.  For 
example, if three 15-minute appointments have been booked in a 15-minute time slot with an 
OverBook % Warning of 200, then this field will display “-15” ((15 × 200 ÷ 100) – (3 × 15)).  If 
0 minutes are available, this field will be blank. 
 
# (# of Appointments) – The number of (non-cancelled) appointments booked in that time slot 
or at that time. 
 
Def. (Default Duration) – The Default Duration field from the corresponding entry on the 
provider’s Schedule List (see section “Provider Window, Schedule Tab”).  This field is not 
displayed by default. 
 
O.B. (OverBook % Warning) – The OverBook % Warning field from the corresponding entry 
on the provider’s Schedule List (see section “Provider Window, Schedule Tab”).  This field is 
not displayed by default. 
 
Description – The Description field from the corresponding entry on the provider’s Schedule 
List (see section “Provider Window, Schedule Tab”).  This field is not displayed by default. 
 
Patient # X – The patient from an appointment in that time slot or at that time (see section 
“Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 appointments can 
be displayed for each time slot or time.  By default, the Patient fields are only displayed where X 
is 1 or 2.)  These fields are blank for blocking appointments.  To view/modify a patient who has 
an appointment on the list, select that appointment’s Patient field and press Enter or F9, or 
double-click in that appointment’s Patient field (see section “Patient Window”). 
 
EC (Patient Status # X) – The OBEC response for a patient with an appointment in that time 
slot or at that time (see section “OBEC”).  This is the same as the OBEC status field in the 
Patient window, Demographic tab, Misc. section (see section “Patient Window, Demographic 
Tab, Misc. Section”).  (X can be any whole number from 1 to 8.  Up to 8 appointments can be 
displayed for each time slot or time.  These fields are not displayed by default.)  The Patient 
Status fields are only available if the “No Personal Data” option is off (see section “List 
Appointments”).  To view/modify a patient who has an appointment on the list, select that 
appointment’s Patient Status field and press Enter or F9, or double-click in that appointment’s 
Patient Status field (see section “Patient Window”). 
 
Dur. (Duration # X) – The Duration field from an appointment in that time slot or at that time 
(see section “Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 
appointments can be displayed for each time slot or time.  By default, the Duration fields are 
only displayed where X is 1 or 2.)  To view/modify an appointment, select that appointment’s 
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Duration field and press Enter or F9, or double-click in that appointment’s Duration field (see 
section “Appointment Window”). 
 
Status (Status # X) – The status of an appointment in that time slot or at that time (see section 
“Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 appointments can 
be displayed for each time slot or time.  By default, the Status fields are only displayed where X 
is 1 or 2.)  The Status fields are only available if the “No Personal Data” option is off (see 
section “List Appointments”).  To modify the status of an appointment, select the Status field for 
that appointment and press Enter or F9, or double-click in the Status field for that appointment.  
A LookUp Status dialog box will open (see section “LookUp Status Dialog Box (For 
Appointments)”). 
 
Priority (Priority # X) – The priority of an appointment in that time slot or at that time (see 
section “Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 
appointments can be displayed for each time slot or time.  These fields are not displayed by 
default.)  The Status fields are only available if the “No Personal Data” option is off (see section 
“List Appointments”).  To view/modify an appointment, select that appointment’s Priority field 
and press Enter or F9, or double-click in that appointment’s Priority field (see section 
“Appointment Window”). 
 
Location (Location # X) – The Location field from an appointment in that time slot or at that 
time (see section “Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 
appointments can be displayed for each time slot or time.  These fields are not displayed by 
default.)  To modify the location of an appointment, select the Location field for that 
appointment and press Enter or F9, or double-click in the Location field for that appointment.  A 
Find Location dialog box will open (see section “Find Location Dialog Box”).  Select a location 
and then select OK or press F9, double-click on a location.  To clear the selected field, select 
Clear and then OK. 
 
Re (Re # X) – The Re field from an appointment in that time slot or at that time (see section 
“Appointment Window”).  (X can be any whole number from 1 to 8.  Up to 8 appointments can 
be displayed for each time slot or time.  These fields are not displayed by default.)  These fields 
are only available if the “No Personal Data” option is off (see section “List Appointments”).  To 
view/modify an appointment, select that appointment’s Re field and press Enter or F9, or double-
click in that appointment’s Re field (see section “Appointment Window”). 
 
To add an appointment in a time slot (or at the same time as an existing appointment), select any 
field (except a Patient, Duration, Status, Priority, Location, or Re field for an existing 
appointment) and then press Enter or F9, or double-click in the field.  A dialog box will ask 
“Add an appointment at this date and time?”: 
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Select “Yes”.  An Appointment window will open (see section “Appointment Window”). 
 


5.6.2 Month Tab 
 


 
 
Displays a calendar for the selected month, showing the provider’s scheduled hours (see section 
“Provider Window, Schedule Tab”) and appointments on each day.  The calendar has a light 
grey background.  A white line represents an available (or only partially booked) time slot.  A 
dark grey line represents a fully booked (or blocked) time slot, or a length of time in between two 
scheduled time slots that doesn’t contain any scheduled time slots (e.g. a break).  A light grey 
rectangle indicates that (the last time slot of) the day is “blocked”, i.e. to prevent appointments 
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from being booked.  The description field from (the last time slot of) the “blocked” day will 
appear in the grey rectangle. 
 
The days are numbered using black digits.  The digits for the selected day (as indicated in the 
Date field in the Appts. toolbar) appear in blue.  You can click on a day to select it, and the Date 
field in the Appts. toolbar will change accordingly.  If you double-click on a day, it will select 
that day and jump to the Day tab (see section “Day Tab”).  The digits for the current day (today) 
appear in red (unless the current day is selected).  Below the day number is the number of 
appointments booked for the selected provider on that day (if any). 
 
In the sample image above, Dr. Kimble has office hours booked (with a break for lunch) on all 
weekdays (but none on weekends), except for the fourth week of the month, which is “blocked” 
because Dr. Kimble is “Away” that week.  Also, Dr. Kimble has appointments booked on 
August 29, 2005, but none on any other day that month. 
 
If you right-click on a day on the calendar, that day will become selected 
(and the Date field in the Appts. toolbar will change accordingly), and (if a 
provider is selected in the Provider field) a pop-up menu will open with 
the following options: 
 
Copy day – Copies all time slots for the selected provider for the selected 
day to the HERO™ CMS clipboard (to be pasted into another day – see 
below). 
 
Copy week – Copies all time slots for the selected provider for the 
selected week to the HERO™ CMS clipboard (to be pasted into another 
week, or a range of consecutive days – see below). 
 
Paste day – Pastes the time slots (that were copied to the HERO™ CMS 
clipboard using “Copy day” – see above) into the selected day. 
 
Paste week – Pastes the time slots (that were copied to the HERO™ CMS clipboard using 
“Copy week” – see above) into the selected week. 
 
Paste from (Sun) – Indicates that the beginning (Sunday) of the selected week should be the 
start of a range of consecutive days into which the time slots (that were copied to the HERO™ 
CMS clipboard using “Copy week” – see above) should be pasted.  The paste will not actually be 
completed until the end of the range of consecutive days is selected (using “Paste to” – see 
below). 
 
Paste to – Pastes the time slots (that were copied to the HERO™ CMS clipboard using “Copy 
week” – see above) into a range of consecutive days, starting with the beginning (Sunday) of the 
week that was selected using “Paste from (Sun)” (see above), to the day (not necessarily the end 
of the week) that was selected using “Paste to”. 
 
Edit – Allows you to view/modify the time slots for the selected provider for the selected day by 
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opening a Provider window (Schedule tab) for the selected provider, and setting the From and To 
fields in the Select section to the selected day, and disabling the “Round to weeks” option (see 
section “Provider Window, Schedule Tab”). 
 
Clear – Deletes all time slots for the selected provider for the selected day. 
 
Block – If you select this, a Block dialog box will open (see section “Block Dialog Box”). 
 
Unblock – Turns off the Blocked option (and removes the Description) for all time slots for the 
selected provider for the selected day (see section “Provider Window, Schedule Tab”). 
 
How to copy a provider’s schedule 
 
First, choose a range of time for which to set up the provider’s schedule, for example one year.  
As the end of that year approaches, you can set up the schedule for the following year.  It is not 
recommended to choose a huge amount of time such as 100 years, as this can degrade computer, 
network, and database performance, both when setting up the schedule, and when searching for a 
time slot for an appointment (see section “Find Schedule Dialog Box”), due to the large amount 
of data involved. 
 
Suppose that the provider works from 9:00 AM to 5:00 PM every weekday.  Entering this would 
require one schedule entry per weekday, 5 entries per week, over 250 per year.  Entering this 
manually would be cumbersome and time-consuming.  Instead, you can set up the schedule for a 
shorter period of time, such as a week, and then set this schedule to repeat over a larger period of 
time, such as a year, by using the copy/paste functions in the pop-up menu (see above). 
 
So you might set up a schedule (using the Provider window, Schedule tab – see section “Provider 
Window, Schedule Tab”) that looks something like this: 
 
Date Day Beg. End 
January 2, 2000 Sun (none) 
January 3, 2000 Mon 9:00 AM 5:00 PM 
January 4, 2000 Tue 9:00 AM 5:00 PM 
January 5, 2000 Wed 9:00 AM 5:00 PM 
January 6, 2000 Thu 9:00 AM 5:00 PM 
January 7, 2000 Fri 9:00 AM 5:00 PM 
January 8, 2000 Sat (none) 
 
Now you want to copy this schedule into the rest of the year (e.g. 2000).  First, right-click 
somewhere in the week you want to copy (e.g. January 2, 2000 to January 8, 2000) and select 
“Copy week”.  Then, right-click somewhere in the first week of the rest of the year (e.g. January 
9, 2000 to January 15, 2000) and select “Paste from (Sun)”.  Then, right-click on the last day of 
the year (e.g. December 31, 2000) and select “Paste to”.  The schedule will automatically be set 
up for the whole year. 
 







 144


In fact, if the provider’s schedule is the same every day, you can use the copy/paste functions 
twice:  first set up the schedule for one day (e.g. Monday), then copy that schedule to the rest of 
the week (e.g. Tuesday to Friday), and then copy the schedule for that week to the rest of the 
year (as above).  To copy the schedule from Monday to the rest of the week: 
 


1. Right-click on the Monday (January 3, 2000) and select “Copy day” 
2. Right-click on the Tuesday (January 4, 2000) and select “Paste day” 
3. Right-click on the Wednesday (January 5, 2000) and select “Paste day” 
4. Right-click on the Thursday (January 6, 2000) and select “Paste day” 
5. Right-click on the Friday (January 7, 2000) and select “Paste day” 


 
Now, suppose you want to create a break in the schedule, for example, reserve 12:00 PM to 1:00 
PM for lunch every day.  One possibility is to create blocking appointments (see section “Add an 
Appointment”).  However, if you don’t want those time slots to exist at all, you’ll need to break 
up the provider’s hours into multiple segments for each day.  For example, instead of 9:00 AM to 
5:00 PM, you could make two entries:  9:00 AM to 12:00 PM, and 1:00 PM to 5:00 PM. 
 
If you want to delete a day’s time slots, right-click on that day and select Clear.  This can be 
useful if you want to schedule a holiday for a provider.  Or, if you want to modify a provider’s 
schedule over a large period of time (e.g. a year), you can use the Copy/Paste features as above, 
and the new schedule will overwrite the old schedule. 
 
You can also copy and delete schedule slots from the Provider window, Schedule tab (see section 
“Provider Window, Schedule Tab”). 
 


5.6.2.1 Block Dialog Box 
 


 
 
Enter any text in the Description field (e.g. to describe the reason that the provider is not 
available that day, for example “Vacation”), and then select OK.  This will trigger the following 
changes to all time slots for the selected provider, for the selected day (see section “Provider 
Window, Schedule Tab”): 


 The Blocked option will be turned on. 
 The Description field(s) will be changed to match the Description field in the Block 


dialog box.  This Description will also appear in the Appts. window, Month tab (see 
section “List Appointments, Month Tab”). 


 
If there are no time slots for the selected day, a time slot will be added (starting at 1:00 AM, up 
to 5 hours long), with the Blocked option on, and with the Description field set as per above. 
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5.7 Closing Appointments 
 
“Closing” an appointment means changing its status to “Closed” (or from “No Show” to 
“Closed/N.S.”), to indicate that a bill has been entered for that appointment.  It is a good idea to 
always close an appointment when you enter a bill for that appointment.  That way, any 
appointment whose status is anything other than “Closed” or “Closed/N.S.” has not been billed. 
 
To close an appointment manually, view/modify the appointment (see section “View/Modify an 
Appointment”), and, in the Appointment window (see section “Appointment Window”), set the 
Status field to “Closed” or “Closed/N.S.” 
 
Also, appointments will be closed automatically under the following conditions: 
 


 When using the Auto-bill feature in the Appts. Window (see section “List 
Appointments”), an incomplete bill is created for each appointment with status 
Completed for the specified provider on the specified date, and the status for those 
appointments is changed to Closed. 


 From the Appts. Window, Day tab (see section “List Appointments, Day Tab”), if you 
launch a LookUp Status dialog box (see section “LookUp Status Dialog Box (For 
Appointments)”) from an appointment’s Status field and select Closed, a Bill window 
will open (see section “Bill Window”).  When that bill is first saved, the selected 
appointment is closed, only if the bill and appointment are for different providers, and 
even if the bill is for a different patient and/or date than the appointment!  Note:  The 
appointment will be closed even if the “Close Appointment” option is off, but the 
appointment will not be closed until the bill is saved. 


 When you save a bill (with the Close Appointment option on – see section “Bill Window, 
Invoice Tab”), all appointments for the same patient, provider, and date are automatically 
closed. 


 


6 Bills 


6.1 Add A Bill 
 
NOTE:  HERO™ CMS can automatically create incomplete bills for all completed appointments 
for a particular provider on a particular day (see section “List Appointments”). 
 
To create a bill manually, go in the File menu to New → Bill (see section “Pull-Down Menus”), 
or go to New → Bill in the Main Toolbar (see section “Main Toolbar”), or select New Bill in the 
Action Bar (see section “Action Bar”), or press Ctrl-B.  A Bill window will open (see section 
“Bill Window”).  NOTE:  If the insertion point is in a notes field, the shortcut key Ctrl-B is used 
to make text bold, not to add a bill.  See section “Notes Fields”. 
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6.2 View/Modify a Bill 
 
Go in the File menu to Open → Bill (see section “Pull-Down Menus”), or go to Open → Bill in 
the Main Toolbar (see section “Main Toolbar”), or select Open Bill in the Action Bar (see 
section “Action Bar”), or press Ctrl-Shift-B.  A Find Bill dialog box will open (see section “Find 
Bill Dialog Box”).  Select a bill and then select OK or press F9, or double-click on a bill, and 
then a bill window will open.  See section “Bill Window”. 
 


6.3 Find Bill Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Patient – Choose a patient.  If you select this, a Find Patient dialog box will open (see section 
“Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or double-click on a 
patient.  To clear this field, select Clear and then OK. 
 
Provider – Choose a provider.  If you select this, a Find Provider dialog box will open (see 
section “Find Provider Dialog Box”).  All local roles for all providers (that match the search 
criteria) will be displayed (see section “Provider Window, Demographic Tab, Role List”), i.e. a 
matching provider with multiple local roles will show multiple matches.  Select a provider/role 
and then select OK or press F9, or double-click on a provider/role.  To clear this field, select 
Clear and then OK. 







 147


 
Invoice # – Site Invoice Number, e.g. 20000001 (see section “Invoice Numbers”). 
 
If any text is entered in the Invoice field, the Patient and Provider fields are greyed out 
(unavailable).  If a patient and/or provider is selected, the Invoice field is greyed out 
(unavailable). 
 
Other 
 
OK button – Chooses the selected bill and closes the window.  If no bills are displayed, searches 
for bills that match the specified criteria, chooses the first one, and closes the window. 
  
Cancel button – Closes the window without choosing a bill. 
 
Clear button – Clears the bill list and all fields in the “Criteria” section. 
 
Find button – Searches for bills that match the specified criteria. 
 
Bill List – Lists bills that match the specified criteria (see section “Viewing a List of Items”).  
Select a bill and then select OK or press F9, or double-click on a bill, to choose that bill and 
close the window.  For a description of the fields, see section “Bill Window, Invoice Tab”. 
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6.4 Bill Window 


6.4.1 Invoice Tab 
 


 
 
Toolbar 
 


New → Bill (Ctrl-N) – Add a bill. 
 
New → Payment (Ctrl-Y) – Add a payment for the selected patient (see 
section “Payment Window”). 
 
New → Facility – Add a facility (see section “Facility Window”). 
 
New → Procedure – Add a procedure code (see section “Procedure 
Window”). 
 
New → Diagnosis – Add a diagnosis code (see section “Diagnosis 
Window”). 
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New → SuperCode – Add a SuperCode (see section “SuperCode Window”). 
 


Open → Bill (Ctrl-O) – View/modify a bill.  If you select this, a 
Find Bill dialog box will open (see section “Find Bill Dialog Box”).  
Select a bill and then select OK or press F9, or double-click on a 
bill. 
 
Open → Payment (Ctrl-Shift-Y) – View/modify a payment.  If you 
select this, a Find Payment dialog box will open (see section “Find 
Payment Dialog Box”).  Select a payment and then select OK or 
press F9, or double-click on a payment.  See section “Payment 
Window”. 
 


Open → Facility – View/modify a facility.  If you select this, a Find Facility dialog box will 
open (see section “Find Facility Dialog Box”).  Select a facility and then select OK or press F9, 
or double-click on a facility.  See section “Facility Window”. 
 
Open → Procedure – View/modify a procedure code.  If you select this, a Find Procedure 
dialog box will open (see section “Find Procedure Dialog Box”).  Select a procedure code and 
then select OK or press F9, or double-click on a procedure code.  See section “Procedure 
Window”. 
 
Open → Diagnosis – View/modify a diagnosis code.  If you select this, a Find Diagnosis dialog 
box will open (see section “Find Diagnosis Dialog Box”).  Select a diagnosis code and then 
select OK or press F9, or double-click on a diagnosis code.  See section “Diagnosis Window”. 
 
Open → SuperCode – View/modify a SuperCode.  If you select this, a Find SuperCode dialog 
box will open (see section “Find SuperCode Dialog Box”).  Select a SuperCode and then select 
OK or press F9, or double-click on a SuperCode.  See section “SuperCode Window”. 


 
Save (Ctrl-S) – Save the bill.  When the bill is saved, this will automatically close 
appointments according to the rules described in section “Closing Appointments”. 
 
Save and Close (Ctrl-L) – Save the bill and close the Bill window.  When the bill is saved, 
this will automatically close appointments according to the rules described in section 


“Closing Appointments”. 
 
Goto Patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 
 
LookUp on Item (F9) – Choose an entry for the selected field (Date, Procedure, Procedure 
Description, Suffix, Suffix Description, Diagnosis, or Diagnosis Description) on the 


service item list. 
 


Delete Item (Ctrl-Del) – Selecting this button will delete the selected service item (if no 
service item is selected, the first service item will be deleted).  Pressing Ctrl-Del will 
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delete: 
 


 (in the Date or Admitted fields) the entire field. 
 (on the service item list) the selected service item. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 


Copy Item (Ctrl-V) – Make a copy of the selected service item.  This will add another 
service item to this bill.  If you select this, a Copy Item Calendar dialog box will open (see 


section “Copy Item Calendar Dialog Box”). 
 
Notes – Display/hide the notes field (at the bottom of the Bill window). 
 
Manual Review – Indicates that the notes in the notes field should be sent to MOHLTC 
(e.g. to explain why this bill should be paid).  Note that the notes are not sent to MOHLTC 


automatically; you can use a report (see section “Run a report”) to send the notes manually (e.g. 
fax, mail, etc.). 
 


 Hold – Prevents this bill from being batched (i.e. it won’t be sent to MOHLTC).  This will 
also change the Status field to Hold (if the bill is ready to be issued). 


 
Re-transmit/submit – Change this bill’s status (from Pending, Error, Reconcile, Archive, 
or possibly Incomplete) to Open (so that it will be resubmitted to MOHLTC).  Only 


applicable for HCP/WSIB bills. 
 


 Bill from List – Make one copy of this bill for each patient on a patient list (see section 
“Bill from a Patient List”).  If you select this, a Find Patient List dialog box will open (see 


section “Find Patient List Dialog Box”).  Select a patient list and then select OK or press F9, or 
double-click on a patient list.  
 


SuperCode (Ctrl-U) – Insert service items from a SuperCode into this bill.  If you select 
this, a Find SuperCode dialog box will open (see section “Find SuperCode Dialog Box”).  


Select a SuperCode and then select OK or press F9, or double-click on a SuperCode. 
 
Other 
 
Date – The date of the bill (required).  This will become the default date for all service items 
entered.  See section “Date Fields”.  This date will not be sent to MOHLTC.  This field supports 
defaults (see section “Defaults, Bill Window”). 
 
Patient – The patient for whom the services were performed (required).  If you select this, a Find 
Patient dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then 
select OK or press F9, or double-click on a patient.  To clear this field, select Clear and then OK.  
If there is a patient selected in this field, and you double-click in the field that contains the 
patient’s name, birthdate, age, health card number, and version code (not on the Patient button 
itself), a Patient window will open for that patient (see section “Patient Window”).  NOTE:  You 







 151


must select a patient for every bill.  For non-patient specific claims (e.g. Primary Care Incentive 
Payments), use any patient with Health # 0000000000.  You can make up ANY values for 
patient name (e.g. "Incentive Payments") birth date (e.g. January 1, 2000), and sex (M or F).  See 
section “Patient Window, Demographic Tab”. 
 
Invoice # – Site Invoice Number (a unique 8-digit number that identifies the bill, e.g. 20000001).  
This field is automatically assigned when the bill is first saved, and cannot be manually 
modified.  This number is not sent to MOHLTC.  See section “Invoice Numbers”. 
 
Provider – Who provided the services (required).  If you select this, a Find Provider dialog box 
will open (see section “Find Provider Dialog Box”).  All local roles for all providers (that match 
the search criteria) will be displayed (see section “Provider Window, Demographic Tab, Role 
List”), i.e. a matching provider with multiple local roles will show multiple matches.  Select a 
provider/role and then select OK or press F9, or double-click on a provider/role.  To clear this 
field, select Clear and then OK. 
 
Admitted – The date that the patient was admitted to the facility.  See section “Date Fields”.  
This field supports defaults (see section “Defaults, Bill Window”). 
 
Facility – Where the services were performed.  If you select this, a Find Facility dialog box will 
open (see section “Find Facility Dialog Box”).  Select a facility and then select OK or press F9, 
or double-click on a facility.  To clear this field, select Clear and then OK.  This field supports 
defaults (see section “Defaults, Bill Window”). 
 
Status – The status of the bill:  Incomplete (does not have enough information to be issued), 
Open (ready to be issued), Hold (contains enough information to be issued, but the Hold option 
in the Bill toolbar is on, so the bill can’t be issued), Pending (has been put in a batch to be sent to 
MOHLTC), Error (has been returned by MOHLTC due to incorrect information, with one or 
more 3-character error codes), Reconcile (has been partially paid, and/or returned in an RA with 
one or more 2-character explanatory codes), or Archive (all service items have been 
paid/reconciled).  HERO™ CMS automatically determines the bill’s status.  This field cannot be 
manually modified. 
 
Referring – The provider that referred this patient for these services.  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one Referring role will be displayed on the list (see section “Provider Window, 
Demographic Tab, Role List”).  Select a provider and then select OK or press F9, or double-click 
on a provider.  To clear this field, select Clear and then OK.  If there is a provider selected in this 
field, and you double-click in the field that contains the provider’s name and billing number (not 
on the Referring button itself), a Provider window will open for that provider (see section 
“Provider Window”).  This field supports defaults (see section “Defaults, Bill Window”). 
 
Type – The type of the bill:  HCP, WSIB, Private, or Insurer.  This field supports defaults (see 
section “Defaults, Bill Window”). 
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Payor – Who is paying the bill (required for bills of type private/insurer;  not applicable to other 
bill types).  If you select this in a Private bill, a Find Patient dialog box will open (see section 
“Find Patient Dialog Box”).  If you select this in an Insurer bill, a Find Insurer dialog box will 
open (see section “Find Insurer Dialog Box”).  Select a patient or insurer and then select OK or 
press F9, or double-click on a patient or insurer.  To clear this field, select Clear and then OK.  
This field supports defaults (see section “Defaults, Bill Window”). 
 
Total – The total of all the Bill, Pst, and Hst fields, minus all the Adjust fields, from the Service 
Item List (see below). 
 
Paid – The total of all the Paid fields from the Service Item List (see below). 
 
Open – The Total field (see above) minus the Paid field (see above). 
 
Close Appointment – If this option is on, whenever the bill is saved, any appointment(s) with 
the same patient, provider, and date will have its/their status automatically changed to Closed (or 
from No Show to Closed/N.S.).  NOTE:  Even if this option is off, an appointment may still be 
closed.  See section “Closing Appointments”.  This field supports defaults (see section “Defaults, 
Bill Window”). 
 
Hst – If this option is on, then the Hst fields on the Service Item List (see below) will be 
automatically calculated, whenever the Procedure or Quantity field changes on the same row (for 
Private/Insurer bills only).  If this option is off, then no automatic calculation will be done, and 
you must enter the Hst value manually.  This field supports defaults (see section “Defaults, Bill 
Window”). 
 
Service Item List 
 
Lists all services that are being invoiced on this bill (see section “Viewing a List of Items”).  The 
fields are: 
 
Date – The date the service was performed (required).  See section “Date Fields”. 
 
Proc. (Procedure) / Procedure Description – The service that was performed (required).  The 
Procedure Description field is not displayed by default.  Select the Procedure field and enter the 
procedure code.  (This will replace any existing text in that field.  To correct/delete a procedure 
code, select the Procedure field and then press F2 or right-click on any item in the list and select 
Edit, and then make the desired changes.)  Or, select the Procedure Description field and press 
Enter or F2 (or right-click on any item in the list and select Edit), or select either field and press 
F9 (or select LookUp on Item in the Bill toolbar, or right-click on any item in the list and select 
LookUp), or double-click in either field, and a Find Procedure dialog box will open (see section 
“Find Procedure Dialog Box”).  Select a procedure code and then select OK or press F9, or 
double-click on a procedure code.  To clear these fields, select Clear and then OK.  This field 
supports defaults (see section “Defaults, Bill Window”). 
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S. (Suffix) / Suffix Description – Indicates whether the specified provider was the main 
(General) provider for this service (A), or provided Technical (B) or Professional (C) assistance 
to the main provider.  These fields are generally irrelevant for Private/Insurer bills.  The Suffix 
Description field is not displayed by default.  The default value is the one specified on this 
provider’s role list (see section “Provider Window, Demographic Tab, Role List”).  To modify 
this value, select either field and then type any text or press F2 or F9 or Enter or right-click on 
any item in the list and select Edit or LookUp (or double-click in either field).  A LookUp Suffix 
dialog box will open (see section “LookUp Suffix Dialog Box”). 
 
Diag. (Diagnosis) / Diagnosis Description – The diagnosis associated with this service.  Some 
procedure codes require a diagnosis code (see section “Procedure Window”).  The Diagnosis 
Description field is not displayed by default.  Select the Diagnosis field and enter the diagnosis 
code.  (This will replace any existing text in that field.  To correct/delete a diagnosis code, select 
the Diagnosis field and then press F2 or right-click on any item in the list and select Edit, and 
then make the desired changes.)  Or, select the Diagnosis Description field and press Enter or F2 
(or right-click on any item in the list and select Edit), or select either field and press F9 (or select 
LookUp on Item in the Bill toolbar, or right-click on any item in the list and select LookUp), or 
double-click in either field, and a Find Diagnosis dialog box will open (see section “Find 
Diagnosis Dialog Box”).  Select a diagnosis code and then select OK or press F9, or double-click 
on a diagnosis code.  To clear these fields, select Clear and then OK.  This field supports defaults 
(see section “Defaults, Bill Window”). 
 
# (Quantity) – The number of times that the specified procedure was performed for the specified 
patient on the specified date, or the amount of time that was spent performing the specified 
procedure for the specified patient on the specified date (required).  Must be a whole number 
from 1 to 99.  A default value will be calculated automatically (see section “Unit Price and 
Quantity Fields”), but a different value can be specified. 
 
% (Percentage) – What percentage of the normal amount to bill for this service item (not 
displayed by default).  For example, when billing multiple procedures with the same provider, 
patient, service date, and diagnosis code, it may be necessary to bill all but the first procedure at 
85% of their normal value.  In that case, enter 85 in the Percentage field.  When a number is 
entered in this field, the Bill field is automatically calculated by multiplying the Quantity, 
Percentage, and Unit Price fields, and then dividing by 100.  For example, if you enter 2 in the 
Quantity field, and 85 in the Percentage field, and the Unit Price is $10.00, then the Bill field will 
be automatically set to $17.00.  Once this calculation is done, the Percentage field is cleared out 
(the number entered is not displayed on the screen or stored in the database – this field is only 
used to assist in calculating the Bill amount). 
 
Unit Price – The amount to bill for each time this procedure was performed (not displayed by 
default).  This value is automatically calculated (see section “Unit Price and Quantity Fields”) 
and cannot be manually modified. 
 
Bill – The amount to bill for this service.  The default is the Quantity field multiplied by the 
Percentage field (divided by 100) multiplied by the Unit Price field, but a different amount can 
be specified. 
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Pst – Provincial Sales Tax (generally only used for Private/Insurer bills that were issued before 
July 1, 2010).  This field is not displayed by default. 
 
Hst – Harmonized Sales Tax.  If the Hst checkbox is on (see above), then this will be 
automatically calculated (whenever the Procedure or Quantity field changes on the same row) as 
the appropriate percentage (e.g. 13%) of the Bill amount (for Private/Insurer bills only).  Or, you 
can manually enter any amount. 
 
Adjust – How much of the amount billed has been “written off” (because it will never be paid) 
or discounted.  This field is not displayed by default.  When the Reconcile field is turned on, this 
field is automatically calculated by adding the Bill, Pst, and Hst fields, and then subtracting the 
Paid field.  When the Reconcile field is turned off, this field is set to zero.  Or, you can manually 
enter any amount. 
 
Paid – The amount that has been paid for this service item.  For Private/Insurer bills, this is 
automatically calculated based on the payments that have been applied to this service item (see 
section “Payments”).  For HCP/WSIB bills, this is automatically calculated based on the RAs 
that contained payments for this bill.  This field cannot be manually modified. 
 
R (Reconcile) – Whether or not this service item has been fully paid or “written off”.  If you turn 
this option on, then any amount owing for this service item will be automatically “written off”, 
i.e. HERO™ CMS will assume that it will never be paid but no longer consider the amount 
outstanding (owing), and that amount will appear in the Adjust field.  (If you turn this option off, 
the Adjust field is set to zero.)  When all service items on the bill have been Reconciled (or fully 
paid), the bill’s Status automatically changes to Archive.  Select this field and press Enter, F2, or 
Space, or double-click in this field, to toggle this option on/off. 
 
C (To CDS) – Determines whether or not the procedure/diagnosis… code from this service item 
will appear in the Patient window, Problem tab (see section “Patient Window, Problem Tab”).  
By default, this field is off, but not displayed.  Select this field and press Enter, F2, or Space, or 
double-click in this field, to toggle this option on/off.  This field supports defaults (see section 
“Defaults, Bill Window”). 
 
Process / Process Description – These fields are either blank, or set to one of these: 


 PE (Prior Edit):  Indicates that this service item was deleted (or had its procedure code or 
service date modified) after being sent to MOHLTC, and was later undeleted because it 
appeared in an MRO file (RA or error claim).  For example, suppose a provider enters a 
bill for an A001, and the bill is sent to MOHLTC.  Then the provider deletes that bill’s 
service item (in fact, the service item is just hidden, not deleted), and replaces it with an 
A003.  Then the bill is sent to MOHLTC again.  On that provider’s next RA, it’s possible 
that both the A001 and A003 will be paid.  In that case, the A001 service item will be 
restored (undeleted) automatically by the FMS during RA processing, but marked as a 
“Prior Edit.” 


 FS (Fee Substitution):  Indicates that this service item was not entered by a user, but 
instead was added to your database automatically by the FMS because it appeared in an 
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MRO file (RA or error claim).  This is most likely because MOHLTC “substituted” one 
procedure code for another, e.g. issued a payment for a procedure code that was never 
billed.  For example, if a provider bills an A003, but MOHLTC decides to reject the 
A003 but pay for an A004 instead, a second service item will be added to the relevant bill 
during RA processing, but marked as a “Fee Substitution.” 


These fields are not displayed by default. 
 
Notes 
 
At the bottom is the notes field (if enabled) which can be used to store any information specific 
to this bill.  See section “Notes Fields”. 
 


6.4.1.1 Copy Item Calendar Dialog Box 
 


 
 
This dialog box will open when you select Copy Item (or press Ctrl-V) in a Bill window, Invoice 
tab.  Select a date in the calendar (see section “Date Fields”) and then select OK. 
 


6.4.1.2 Unit Price and Quantity Fields 
 
On the Service Item List (see section “Service Item List”), HERO™ CMS automatically 
calculates the Unit Price field, and a default value for the Quantity field, according to the rules 
below.  The General, Speciality, Technical, Professional, Private, Base Technical, and Base 
Professional fields come from the procedure code setup.  To see the setup for a procedure code, 
see section “View/Modify a Procedure Code”.  If the service date is greater than or equal to the 
date field in the Historic section of the Procedure window, then the values from the Current 
section will be used, otherwise the values from the Historic section will be used. 
 


1. If the bill’s Type is HCP or WSIB: 
a. If the Suffix is A:  The default for the Quantity field will be 1.  The Unit Price 


field will equal the General field, unless the General field is zero, in which case 
the Unit Price field will equal the Speciality field. 
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b. If the Suffix is B, and the Base Technical field is greater than zero:  The default 
for the Quantity field will equal the Base Technical field.  The Unit Price field 
will equal the Technical field divided by the Base Technical field. 


c. If the Suffix is B, and the Base Technical field is zero:  The default for the 
Quantity field will be 1.  The Unit Price field will equal the Technical field. 


d. If the Suffix is C, and the Base Professional field is greater than zero:  The default 
for the Quantity field will equal the Base Professional field.  The Unit Price field 
will equal the Professional field divided by the Base Professional field. 


e. If the Suffix is C, and the Base Professional field is zero:  The default for the 
Quantity field will be 1.  The Unit Price field will equal the Professional field. 


2. If the bill’s Type is Private:  The default for the Quantity field will be 1.  The Unit Price 
field will equal the Private field. 


3. If the bill’s Type is Insurer:  The default for the Quantity field will be 1.  The Unit Price 
field will equal the Private field, unless the Private field is zero, in which case the amount 
from #1 above will be used instead. 


 
If the Premium % field in the procedure code setup is greater than 100, HERO™ CMS will 
subtract 100 from it, then divide by 100, then multiply by the total of all the Bill fields in all the 
service items above the current service item in the bill.  If the result is greater than the amount 
calculated above, then it will be used for the Unit Price.  See section “Procedure Window, 
Premium % field”. 
 
When you enter or modify a service item, the Unit Price field is calculated according to the rules 
above.  However, when you retrieve a bill from your database (see section “View/Modify a 
Bill”), the Unit Price is calculated by dividing the Bill field by the Quantity field. 
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6.4.2 Status Tab 
 


 
 
Shows a history of all responses (e.g. from an RA or error claim file) and payments for the bill.  
This tab uses a report called InvoiceStatus with the context Internal.  It is recommended that you 
not edit or delete this report.  See section “Reports”. 
 


6.5 Delete a Bill 
 
View/modify a bill as per section “View/Modify a Bill”, and then go in the File menu to Delete 
(see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section “Main 
Toolbar”), or press Ctrl-D. 
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6.6 List Bills 
 
Go in the File menu to List → Bill (see section “Pull-Down Menus”), or go to List → Bill in the 
Main Toolbar (see section “Main Toolbar”), or select List Bill in the Action Bar (see section 
“Action Bar”). 
 


 
 
Toolbar 
 
Provider – The provider/role whose bills to display (required).  (Bills associated with a different 
role for the same provider will not be displayed.)  If you select this, a Find Provider dialog box 
will open (see section “Find Provider Dialog Box”).  All local roles for all providers (that match 
the search criteria) will be displayed (see section “Provider Window, Demographic Tab, Role 
List”), i.e. a matching provider with multiple local roles will show multiple matches.  Select a 
provider/role and then select OK or press F9, or double-click on a provider/role.  To clear this 
field, select Clear and then OK. 
 
Insurer – The insurer whose bills to display.  This option is only available if the Type is set to 
Insurer.  If no insurer is selected, bills for all insurers will be displayed.  If you select this, a Find 
Insurer dialog box will open (see section “Find Insurer Dialog Box”).  Select an insurer and then 
select OK or press F9, or double-click on an insurer.  To clear this field, select Clear and then 
OK. 
 
From – The minimum date for bills to be displayed (see section “Date Fields”).  If this field is 
blank, all matching bills before the To date (inclusive) will be displayed. 
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To – The maximum date for bills to be displayed (see section “Date Fields”).  If this field is 
blank, all matching bills after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching bills will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) bill displayed on the 
Bill List.  This option is only available if 1000 bills are displayed on the Bill List. 
 
Status – The status of bills to display:  Incomplete (does not have enough information to be 
issued), Open (ready to be issued), Hold (contains enough information to be issued, but the Hold 
option in the Bill toolbar is on, so the bill can’t be issued – see section “Bill Window, Invoice 
Tab”), Pending (has been put in a batch to be sent to MOHLTC), Error (has been returned by 
MOHLTC due to incorrect information, with one or more 3-character error codes), Reconcile 
(has been partially paid, and/or returned in an RA with one or more 2-character explanatory 
codes), or Archive (all service items have been paid/reconciled).  See section “The Billing 
Cycle”.  Or, set to List to view/modify the contents of a bill list (see section “Bill Lists”). 
 
Type – The type of bills to display:  HCP, WSIB, Private, Insurer, or All. 
 
Auto-bill – Makes a copy of each bill on the selected bill list (Status must be set to List).  See 
section “Bill from a Bill List”. 
 
Insert – Add a bill to the selected bill list (in the List field).  If Status is not set to List, the 
selected bill will be added.  If Status is set to List, a Find Bill dialog box will open (see section 
“Find Bill Dialog Box”).  Select a bill and then select OK or press F9, or double-click on a bill.  
See section “Add a Bill to a Bill List”. 
 
Delete – Remove the selected bill from the selected bill list (Status must be set to List).  See 
section “Delete a Bill from a Bill List”.  NOTE:  This does not delete the bill. 
 
List – Select a bill list to view the contents of that bill list (Status must be set to List), or to add a 
bill to that bill list, or to remove a bill from that bill list (Status must be set to List).  See section 
“Add a Bill to a Bill List”, “View the Contents of a Bill List”, or “Delete a Bill from a Bill List”.  
Enter/modify any text (or double-click) in this field, and a Find Bill List dialog box will open 
(see section “Find Bill List Dialog Box”).  Select a bill list and then select OK or press F9, or 
double-click on a bill list.  To clear this field, select Clear and then OK. 
 
Bill List 
 
Lists bills that match the specified criteria (see section “Viewing a List of Items”).  The Bills 
window title bar will show (in brackets) the number of bills displayed.  If there are at least 1000 
bills to display, only the most recent 1000 bills will be displayed, and the title bar will say “Bills 
(1000+)”.  To view older bills, adjust the date in the “To” field, or select the “+” button. 
 
To view/modify a bill, select it and press Enter or F9, or double-click on it (see section “Bill 
Window”).  The fields are: 
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Date – The Date field from the Bill window, Invoice tab (see section “Bill Window, Invoice 
Tab”). 
 
Invoice # – The bill’s Site Invoice Number (see section “Invoice Numbers”). 
 
Last – The last name of the bill’s patient (who is not necessarily the same as the bill’s payor). 
 
First – The first name of the bill’s patient (who is not necessarily the same as the bill’s payor). 
 
Type – The bill’s type, e.g. HCP, WSIB, Private, or Insurer (not displayed by default). 
 


6.7 Invoice Numbers 
 
There are several ways to track invoices: 
 
Site Invoice Number 
 
When a bill (of any type) is created and saved to your database, it’s immediately assigned a Site 
Invoice Number (even before the bill is transmitted).  This is usually an 8-digit number starting 
with 2 (e.g. 2000001).  However, if invoices were imported from another billing program, their 
original invoice numbers (e.g. 11000001) will be used as the Site Invoice Numbers. 
 
When an invoice number is displayed in HERO™ CMS, it is usually the Site Invoice Number.  
For example, the Site Invoice Number appears in the Bill window, Invoice tab (see section “Bill 
Window, Invoice Tab”), in the Find Bill dialog box (see section “Find Bill Dialog Box”), in the 
Bills window (see section “List Bills”), and in the Patient window, Bill tab (see section “Patient 
Window, Bill Tab”). 
 
The Site Invoice Numbers are automatically unique throughout your database, i.e. you cannot 
have two invoices in the same database with the same Site Invoice Number, even for different 
providers, different patients, etc.  That way, if a patient asks a question, or makes a payment, 
regarding a particular invoice, he only needs to specify the Site Invoice Number, not the patient’s 
or provider’s name, etc., and you can look up the invoice by Site Invoice Number, e.g. using the 
Find Bill dialog box (see section “Find Bill Dialog Box”).  However, if a provider does billing 
from multiple HERO™ CMS databases (e.g. in different offices), that provider might have 
multiple bills with the same Site Invoice Number (in different databases), although the FMS 
Invoice Numbers will be different. 
 
Site Invoice Numbers are not sent to MOHLTC. 
 
FMS Invoice Number 
 
When an HCP/WSIB bill is batched by the FMS (see section “Data Flow Structure”), it is 
assigned an FMS invoice number, which is included in the batch (and sent to MOHLTC).  This 
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is usually an 8-digit number starting with 9 (e.g. 90000001).  However, if invoices were 
imported from another billing program, their original invoice numbers (e.g. 11000001) will be 
used as the FMS Invoice Numbers.  MOHLTC refers to the FMS Invoice Number as the 
“Accounting Number.”  Private/Insurer bills are not assigned FMS Invoice Numbers. 
 
The FMS Invoice Number is usually not displayed in HERO™ CMS, except in the Bill window, 
Status tab (see section “Bill Window, Status Tab”).  However, the FMS Invoice Number is 
included in some reports. 
 
The FMS Invoice Numbers are automatically unique for a particular provider, throughout all 
HERO™ CMS databases.  In other words, a provider cannot have two invoices with the same 
FMS Invoice Number, even in different databases (e.g. different offices).  This is why the FMS 
Invoice number cannot be the same as the Site Invoice Number.  If a provider had multiple 
invoices with the same FMS invoice number (even from different offices), and those invoices 
appeared in MRO files (e.g. RAs or error claims), especially if they appeared in the same MRO 
file, they would be impossible to reconcile, because there would be no way to tell them apart.  
However, a HERO™ CMS database could contain multiple bills with the same FMS Invoice 
Number, if they’re for different providers.  Therefore, if you are identifying a bill by its FMS 
Invoice Number, you must also specify the provider.  Specifying a group identifier is not 
adequate (a group MRO file could contain multiple bills with the same FMS Invoice Number, if 
they’re for different providers). 
 
If a bill is batched and sent to MOHLTC multiple times (e.g. because it was corrected), the FMS 
Invoice Number will be the same each time.  A new number will not be assigned. 
 
MOH Processing Number 
 
When an HCP/WSIB bill appears in an RA, MOHLTC assigns it an 11-digit “MOH Processing 
Number” (they call this a “Claim Number”).  This is usually a letter followed by 10 digits, e.g. 
P1234567890.  Private/Insurer bills are not assigned MOH Processing Numbers.  Also, if 
MOHLTC returns a bill as error, that bill will not appear on an RA, and therefore it will not be 
assigned an MOH Processing Number, unless it is resubmitted (e.g. corrected). 
 
The MOH Processing Number is usually not displayed in HERO™ CMS, except in the Bill 
window, Status tab (see section “Bill Window, Status Tab”).  However, the MOH Processing 
Number is included in some reports. 
 
If a bill appears in RAs multiple times (the same RA, or different RAs), it may be assigned 
different MOH Processing Numbers.  To see all MOH Processing Numbers for a single bill, 
open the bill (see section “View/Modify a Bill”) and go to the Status tab (see section “Bill 
Window, Status Tab”). 
 
Sample 
 
Here is a sample of invoice numbers for 9 bills, for 3 providers in 3 different databases/locations: 
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 Office “A” Clinic “B” Hospital “C”
Dr. Smith Site # 20000001


FMS # 90000001
Site # 20000001


FMS # 90000002
Site # 20000001


FMS # 90000003
Dr. Jones Site # 20000002


FMS # 90000001
Site # 20000002


FMS # 90000002
Site # 20000002


FMS # 90000003
Dr. McCoy Site # 20000003


FMS # 90000001
Site # 20000003


FMS # 90000002
Site # 20000003


FMS # 90000003
 
The Site Invoice Numbers are unique for each database/location, i.e. a database/location can’t 
use the same Site Invoice Number twice, even for different providers.  However, a provider can 
use the same Site Invoice Number twice (in different databases/locations). 
 
The FMS Invoice Numbers are unique for each provider, i.e. a provider can’t use the same FMS 
Invoice Number twice, even in different databases/locations.  However, a database/location can 
use the same FMS Invoice Number twice (for different providers). 
 


6.8 The Billing Cycle 
 
Below is a summary of the billing cycle in HERO™ CMS.  Generally, these rules apply to 
HCP/WSIB bills submitted by EDT.  They do not necessarily apply to Private, Insurer, or disk-
submitted bills. 
 


1. You enter bills into your database (see section “Add a Bill”).  Generally, their status will 
be Open (or first Incomplete or Hold, and then later changed to Open when you fill in the 
missing information or turn off the Hold option – see section “Bill Window, Invoice 
Tab”).  Or, if a bill has already been sent to MOHLTC (e.g. its status is most likely Error 
or Pending) and you modify it, its status will change to Open.  (Remember to check your 
Incomplete and Hold bills often, e.g. every day, to ensure that those bills do not get 
“forgotten”.) 


 
2. When you do a transmission (see section “Transmissions”), all bills that have been 


added/modified since your last transmission will be sent to the FMS (see section “Data 
Flow Structure”).  After the transmission, all eligible bills will be sent to MOHLTC, and 
their status will change from Open to Pending.  Remember to do transmissions often, e.g. 
every day. 


 
3. If any bills are returned as error, this will generally happen within a few days, and you 


will probably receive them on your next transmission (see section “Transmissions”).  The 
status of those bills will change (e.g. from Pending) to Error.  Be sure to check your Error 
bills often (e.g. every day or after every transmission).  Correct all error bills (for 
resubmission) as soon as possible. 


 
4. Any bill that is not returned as error (see above) should appear in your Remittance 


Advice (RA) files (see below) within a month or two (after it’s sent to MOHLTC).  If any 
bill still has status Pending for more than a couple of months, contact HTN immediately.  
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All service items become stale-dated (cannot be paid) 6 months after the service date, so 
don’t delay! 


 
5. Around the beginning of each month, MOHLTC should send out an RA for each 


provider/group.  RAs that are sent by EDT are automatically processed by the FMS (see 
section “Data Flow Structure”).  If you receive an RA by other means (e.g. disk, e-mail, 
etc.), see section “Process an RA or Error Claims File”.  In either case, do a transmission 
(see section “Transmissions”) to receive the results of the RA processing. 


 
6. If you want to run an RA (MRO) report (see section “Run a Report”), you can do this 


from the Provider window (see section “View/Modify a Provider”) and/or the Files 
window (see section “List Files”).  


 
7. Each RA generally contains all bills (except Error bills) that were sent to MOHLTC in the 


1-month period ending on the previous month’s cutoff date.  For example, bills that were 
sent between the January and February cutoff dates should appear in the March RA 
(which is sent out in early March, and the payment is made around the middle of March).  
The “cutoff” date is usually officially the first business day on or after the 18th of each 
month, but for EDT billing, the actual cutoff date is often much later, sometimes even 
approaching the end of the month.  For more information, contact MOHLTC. 


 
8. Each bill that appears in an RA file will have its status changed (e.g. from Pending) to 


Reconcile or Archive. 
 


9. For each bill of status Reconcile, you should do one of these: 
 


 Archive the bill, i.e. turn on the R (Reconcile) option for each service item on the 
Service Item List (see section “Bill Window, Invoice Tab, Service Item List”). 


 Delete the bill (see section “Delete a Bill”).  This is recommended only if the bill 
was entered erroneously, has not been paid at all, and will never be paid. 


 Resubmit the bill, i.e. make changes to the bill (see section “View/Modify a 
Bill”), or open the bill and turn on Re-transmit/submit in the Bill toolbar (see 
section “Bill Window, Invoice Tab”).  Then save the changes. 


 Ask MOHLTC to review the bill.  If you can convince them that they should have 
paid a different (e.g. higher) amount than was actually paid on that bill, then they 
will adjust the bill on a future RA (which may then change the bill’s status to 
Archive). 


 


7 Payments 


7.1 Add a Payment 
 
Go in the File menu to New → Payment (see section “Pull-Down Menus”), or go to New → 
Payment in the Main Toolbar (see section “Main Toolbar”), or select New Payment in the Action 
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Bar (see section “Action Bar”), or press Ctrl-Y.  A Payment window will open (see section 
“Payment Window”). 
 


7.2 View/Modify a Payment 
 
Go in the File menu to Open → Payment (see section “Pull-Down Menus”), or go to Open → 
Payment in the Main Toolbar (see section “Main Toolbar”), or select Open Payment in the 
Action Bar (see section “Action Bar”), or press Ctrl-Shift-Y.  A Find Payment dialog box will 
open (see section “Find Payment Dialog Box”).  Select a payment and then select OK or press 
F9, or double-click on a payment, and then a payment window will open.  See section “Payment 
Window”. 
 


7.3 Find Payment Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Patient – The Payor or Patient field from the Payment window (see section “Payment 
Window”).  If you select this, a Find Patient dialog box will open (see section “Find Patient 
Dialog Box”).  Select a patient and then select OK or press F9, or double-click on a patient.  To 
clear this field, select Clear and then OK. 
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Provider – The provider who received the payment.  If you select this, a Find Provider dialog 
box will open (see section “Find Provider Dialog Box”).  Only providers with at least one local 
role will be displayed on the list (see section “Provider Window, Demographic Tab, Role List”), 
however, each provider will only be displayed once on the list (even providers that have more 
than one local role), i.e. the payment will be associated with the provider in general, not a 
specific role (the payment can be applied to bills under any role(s) for the specified provider).  
Select a provider and then select OK or press F9, or double-click on a provider.  To clear this 
field, select Clear and then OK. 
 
Other 
 
OK button – Chooses the selected payment and closes the window.  If no payments are 
displayed, searches for payments that match the specified criteria, chooses the first one, and 
closes the window. 
  
Cancel button – Closes the window without choosing a payment. 
 
Clear button – Clears the payment list and all fields in the “Criteria” section. 
 
Find button – Searches for payments that match the specified criteria. 
 
Payment List 
 
Lists payments that match the specified criteria (see section “Viewing a List of Items”).  Select a 
payment and then select OK or press F9, or double-click on a payment, to choose that payment 
and close the window.  The fields are: 
 
Patient – The Payor or Patient field from the Payment window (see section “Payment 
Window”). 
 
Provider – The Provider field from the Payment window (see section “Payment Window”). 
 
Date – The Date field from the Payment window (see section “Payment Window”). 
 
Paid – The Paid field from the Payment window (see section “Payment Window”). 
 
Reference – The Reference field from the Payment window (see section “Payment Window”). 
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7.4 Payment Window 
 


 
 
Toolbar 
 


New Payment (Ctrl-N) – Add a payment. 
 
Open Payment (Ctrl-O) – View/modify a payment.  If you select this, a Find Payment 
dialog box will open (see section “Find Payment Dialog Box”).  Select a payment and then 


select OK or press F9, or double-click on a payment. 
 


Save (Ctrl-S) – Save the payment. 
 
Save and Close (Ctrl-L) – Save the payment and close the Payment window. 
 
LookUp Item (F9) – Choose a service item to apply this payment to.  This function is only 
available if the Manual option is on (see below), and a field (other than Date or Paid) is 


selected on the Service Item List (see below).  If you select this, a Find Bill Item dialog box will 
open (see section “Find Bill Item Dialog Box”).  Select a service item and then select OK or 
press F9, or double-click on a service item. 
  


Delete Item (Ctrl-Del) – Selecting this button will delete the selected service item on the 
Service Item List (if the Manual option is on).  Pressing Ctrl-Del will delete: 


 
 (in the Date field) the entire field. 
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 (on the Service Item List) the selected service item (the Manual option must be on). 
 (in a text field, including the expanded notes field) the selected text, or, if no text is 


selected, all text between the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the payment window). 


 
Other 
 
Date – The date of the payment (e.g. the date the payment was made/received).  See section 
“Date Fields”. 
 
Payor/Patient – If the Type is set to private, this field is called Payor, and refers to the patient 
making the payment, which is not necessarily the same as the patient who received the service 
being paid.  If the Type is set to Insurer, this field is called Patient, and refers to the patient who 
received the service being paid.  If you select this, a Find Patient dialog box will open (see 
section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or double-
click on a patient.  To clear this field, select Clear and then OK.  This field is required.  If there is 
a patient selected in this field, and you double-click in the field that contains the patient’s name, 
birthdate, age, health card number, and version code (not on the Payor/Patient button itself), a 
Patient window will open for that patient (see section “Patient Window”). 
 
Paid – The amount of the payment. 
 
Insurer – The insurer making the payment.  If the Type is set to insurer, this field is required, 
otherwise this field is not available.  If you select this, a Find Insurer dialog box will open (see 
section “Find Insurer Dialog Box”).  Select an insurer and then select OK or press F9, or double-
click on an insurer.  To clear this field, select Clear and then OK. 
 
Applied – How much of the payment has been applied to bills.  The payment will be applied 
automatically (to the oldest outstanding service items) unless the Manual option is enabled. 
 
Provider – The provider receiving the payment (required).  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role), i.e. the payment will be associated with the provider in general, not a 
specific role (the payment can be applied to bills under any role for the specified provider).  
Select a provider and then select OK or press F9, or double-click on a provider.  To clear this 
field, select Clear and then OK. 
 
Type – The payment type (private or insurer). 
 
Manual – Enable this to apply the payment manually.  Usually, payments are automatically 
applied (to the oldest outstanding service items).  This field supports defaults (see section 
“Defaults, Payment Window”). 
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Reference – A number or identifier for this payment such as a cheque/receipt number. 
 
Service Item List 
 
Lists the service items to which this payment was applied.  If the Manual option is off, the 
payment is automatically applied to the oldest outstanding service items, and the list (items) 
cannot be manually modified.  The Paid field shows how much of this payment was applied to 
that service item (not the total amount that has been paid for that service item).  For a description 
of the rest of the fields, see section “Bill Window, Invoice Tab”. 
 
To manually apply this payment (the Manual option must be on), select any field on the Service 
Item List (except Date or Paid) and then enter/modify any text, or press Enter or F2 or F9, or 
select LookUp Item in the Payment toolbar, or double-click in any field on the list (except Date 
or Paid).  A Find Bill Item dialog box will open (see section “Find Bill Item Dialog Box”).  
Select a service item and then select OK or press F9, or double-click on a service item, and that 
service item will be added to the Service Item List.  Then, in the Paid field, enter how much of 
this payment you want to apply to the selected service item.  (The total of the Paid fields on the 
Service Item List cannot exceed the Paid field above.) 
 
Notes 
 
At the bottom is the expanded notes field (if enabled) which can be used to store any information 
specific to this payment.  See section “Notes Fields”. 
 


7.4.1 Find Bill Item Dialog Box 
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See section “Searching for a Record”. 
 
Criteria Section 
 
Payor/Patient – If the Type in the Payment window is set to private, this field is called Payor, 
and refers to the patient making the payment, which is not necessarily the same as the patient 
who received the service.  If the Type is set to Insurer, this field is called Patient, and refers to 
the patient who received the service.  This will be the same as the Payor/Patient field in the 
Payment window.  See section “Payment Window”. 
  
Insurer – The insurer who is paying for the services (only applicable if the Type in the Payment 
window is set to Insurer).  This will be the same as the Insurer field in the Payment window.  See 
section “Payment Window”. 
 
Provider – The provider who provided the services.  This will be the same as the provider 
chosen in the Payment window (see section “Payment Window”). 
 
Other 
 
OK button – Chooses the selected service item and closes the window.  If no service items are 
displayed, searches for service items that match the specified criteria, chooses the first one, and 
closes the window. 
  
Cancel button – Closes the window without choosing a service item. 
 
Find button – Searches for service items that match the specified criteria. 
 
Service Item List 
 
Lists service items that match the specified criteria (see section “Viewing a List of Items”).  
Select a service item and then select OK or press F9, or double-click on a service item, to choose 
that service item and close the window.  The fields are: 
 
Invoice # – Site Invoice Number (see section “Invoice Numbers”). 
 
Date – The Date field from the Bill window, Invoice tab, Service Item List (see section “Bill 
Window, Invoice Tab, Service Item List”). 
 
Proc. – The Proc. field from the Bill window, Invoice tab, Service Item List (see section “Bill 
Window, Invoice Tab, Service Item List”). 
 
Open – The amount owing for that service item.  This is automatically calculated by adding the 
Bill, Pst, and Hst amounts for that service item, and subtracting the Adjust and Paid amounts.  
See section “Bill Window, Invoice Tab, Service Item List”. 
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Patient – Last name, then first initial of the patient who received the service (this is not 
necessarily the same as the Payor field above).  See section “Bill Window, Invoice Tab”. 
 


7.5 Delete a Payment 
 
View/modify a payment as per section “View/Modify a Payment”, and then go in the File menu 
to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D. 
 


7.6 List Payments 
 
Go in the File menu to List → Payment (see section “Pull-Down Menus”), or go to List → 
Payment in the Main Toolbar (see section “Main Toolbar”), or select List Payment in the Action 
Bar (see section “Action Bar”). 
 


 
 
Toolbar 
 
Provider – The provider whose payments to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one local role will be displayed on the list (see section “Provider Window, Demographic 
Tab, Role List”), however, each provider will only be displayed once on the list (even providers 
that have more than one local role).  Select a provider and then select OK or press F9, or double-
click on a provider.  To clear this field, select Clear and then OK. 
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Insurer – If Insurer is chosen in the Type field, you must choose an insurer.  If you select this, a 
Find Insurer dialog box will open (see section “Find Insurer Dialog Box”).  Select an insurer and 
then select OK or press F9, or double-click on an insurer.  To clear this field, select Clear and 
then OK. 
 
From – The minimum date for payments to be displayed (see section “Date Fields”).  If this field 
is blank, all matching payments before the To date (inclusive) will be displayed. 
 
To – The maximum date for payments to be displayed (see section “Date Fields”).  If this field is 
blank, all matching payments after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching payments will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) payment displayed on 
the Payment List.  This option is only available if 500 payments are displayed on the Payment 
List. 
 
Status – The status of payments display:  Open or Applied. 
 
Type – The type of payments display:  Private or Insurer, or All. 
 
Payment List 
 
Lists all payments that match the specified criteria (see section “Viewing a List of Items”).  The 
Payments window title bar will show (in brackets) the number of payments displayed.  If there 
are at least 500 payments to display, only the most recent 500 payments will be displayed, and 
the title bar will say “Payments (500+)”.  To view older payments, adjust the date in the “To” 
field, or select the “+” button. 
 
To view/modify a payment, select it and press Enter or F9, or double-click on it (see section 
“Payment Window”).  The fields are: 
 
Date – The Date field from the Payment window (see section “Payment Window”). 
 
Paid – The Paid field from the Payment window (see section “Payment Window”). 
 
Reference – The Reference field from the Payment window (see section “Payment Window”). 
 
Last – The last name of the patient selected in the Payor/Patient field from the Payment window 
(see section “Payment Window”). 
 
First - The first name of the patient selected in the Payor/Patient field from the Payment window 
(see section “Payment Window”). 
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8 Encounters 


8.1 Add an Encounter 
 
Go in the File menu to New → Encounter (see section “Pull-Down Menus”), or go to New → 
Encounter in the Main Toolbar (see section “Main Toolbar”), or select New Encounter in the 
Action Bar (see section “Action Bar”), or press Ctrl-E.  An Encounter window will open (see 
section “Encounter Window”). 
 


8.2 View/Modify an Encounter 
 
View/modify the patient with whom the encounter is associated (see section “View/Modify a 
Patient”) and go to the Encounter tab (see section “Patient Window, Encounter Tab”).  Or, go to 
List Encounters (see section “List Encounters”).  Then select an encounter and press Enter or F9 
(or double-click on an encounter).  An encounter window will open (see section “Encounter 
Window”). 
 


8.3 Encounter Window 
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Toolbar 
 


New → Encounter (Ctrl-N) – Add an encounter. 
 
New → Type – Add an encounter type (see section “(Encounter) Type 
Window”). 
 
New → Re – Add an encounter re code (see section “(Encounter) Re 


Window”). 
 


Open → Type – View/modify an encounter type.  If you select this, a Find 
(Encounter) Type dialog box will open (see section “Find (Encounter) Type Dialog 
Box”).  Select an encounter type and then select OK or press F9, or double-click on 
an encounter type.  See section “(Encounter) Type Window”. 
 


Open → Re – View/modify an encounter re code.  If you select this, a Find (Encounter) Re 
dialog box will open (see section “Find (Encounter) Re Dialog Box”).  Select an encounter re 
code and then select OK or press F9, or double-click on an encounter re code.  See section 
“(Encounter) Re Window”. 
 


Save (Ctrl-S) – Save the encounter. 
 
Save and Close (Ctrl-L) – Save the encounter and close the Encounter window. 
 
Goto Patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 
 
Rewind (F10) – Rewind audio playback. 
 
Play/Pause (F11) – Start or stop audio playback. 
 
Record/Stop (F12) – Start or stop audio recording. 
 
Delete Audio (Ctrl-Del) – Delete the audio recording associated with this encounter. 


 
Other 
 
Date – The date of the encounter (see section “Date Fields”).  This field is required.  This field 
supports defaults (see section “Defaults, Encounter Window”). 
 
Patient – The patient that was seen (required).  If you select this, a Find Patient dialog box will 
open (see section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or 
double-click on a patient.  To clear this field, select Clear and then OK.  If there is a patient 
selected in this field, and you double-click in the field that contains the patient’s name, birthdate, 
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age, health card number, and version code (not on the Patient button itself), a Patient window 
will open for that patient (see section “Patient Window”). 
 
Status – The encounter’s status:  Draft, Reviewed, or Archive.  This field supports defaults (see 
section “Defaults, Encounter Window”). 
 
Provider – The provider who saw the patient (required).  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role), i.e. the encounter will be associated with the provider in general, not a 
specific role.  Select a provider and then select OK or press F9, or double-click on a provider.  
To clear this field, select Clear and then OK. 
 
Referring – The provider that referred this patient to you.  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
Referring role will be displayed on the list (see section “Provider Window, Demographic Tab, 
Role List”).  Select a provider and then select OK or press F9, or double-click on a provider.  To 
clear this field, select Clear and then OK.  This field supports defaults (see section “Defaults, 
Encounter Window”).  If there is a provider selected in this field, and you double-click in the 
field that contains the provider’s name and billing number (not on the Referring button itself), a 
Provider window will open for that provider (see section “Provider Window”). 
 
Template – Displays the description of the last Notes template that was inserted into the Notes 
field (see below). 
 
Type –The general purpose of the encounter, e.g. Surgery, Consultation, Prescription, etc.  Select 
this field and enter the text.  Or, select this field and press F9, or double-click in this field, and a 
Find (Encounter) Type dialog box will open (see section “Find (Encounter) Type Dialog Box”).  
Select an encounter type and then select OK or press F9, or double-click on an encounter type.  
To clear this field, select Clear and then OK. 
 
Re –The specific purpose of the encounter, e.g. Back Pain, Check-up, Flu Shot, etc.  Select this 
field and enter the text.  Or, select this field and press F9, or double-click in this field, and a Find 
(Encounter) Re dialog box will open (see section “Find (Encounter) Re Dialog Box”).  Select an 
encounter re code and then select OK or press F9, or double-click on an encounter re code.  To 
clear this field, select Clear and then OK. 
 
Notes 
 
At the bottom is the expanded notes field which can be used to store any information specific to 
this encounter.  See section “Notes Fields”. 
 
If you right-click anywhere in this field (see section “Notes Fields, Context Menu”), and then 
select Insert, you will get a pop-up menu that looks like this: 
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Insert → Rx – Insert the contents of all prescriptions 
for the selected patient at the insertion point.  
Prescription items will only be inserted if the Date 
field in the Rx window, Script tab (see section “Rx 
Window, Script Tab”) matches the Date field in the 
Encounter window, and if the C (To CDS) option is 
on.  These fields will be inserted from the 
Prescription List (in order):  Begin, Drug, Strength, # 
(Quantity), SIG, Dose, L (Long Term), Dur. 
(Duration).  The font will be “Lucida Console”, font 
size 10. 
 
Insert → Requisition – Reserved for future use. 
 
Insert → Task – Insert the contents of all tasks for 
the selected patient at the insertion point.  Tasks will 
only be inserted if the Due field in the Task window 
(see section “Task Window”) matches the Date field 


in the Encounter window.  These fields will be inserted (in order):  Due, Status, Priority, Re, 
Assignee, Notes.  The font will be “Lucida Console”.  The font size will be 8 for the Notes field, 
and 10 for the other fields. 
 
Insert → Referral – Reserved for future use. 
 
Insert → Recall – Reserved for future use. 
 
Insert → All – Insert all of the above (prescriptions and tasks) at the insertion point. 
 


8.4 Delete an Encounter 
 
View/modify an encounter as per section “View/Modify an Encounter”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D. 
 


8.5 List Encounters 
 
Go in the File menu to List → Encounter (see section “Pull-Down Menus”), or go to List → 
Encounter in the Main Toolbar (see section “Main Toolbar”), or select List Encounter in the 
Action Bar (see section “Action Bar”). 
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Toolbar 
 
Provider – The provider whose encounters to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one local role will be displayed on the list (see section “Provider Window, Demographic 
Tab, Role List”), however, each provider will only be displayed once on the list (even providers 
that have more than one local role).  Select a provider and then select OK or press F9, or double-
click on a provider.  To clear this field, select Clear and then OK.  If this field is left blank, no 
encounters will be displayed. 
 
From – The minimum date for encounters to be displayed (see section “Date Fields”).  If this 
field is blank, all matching encounters before the To date (inclusive) will be displayed. 
 
To – The maximum date for encounters to be displayed (see section “Date Fields”).  If this field 
is blank, all matching encounters after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching encounters will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) encounter displayed 
on the Encounter List.  This option is only available if 500 encounters are displayed on the 
Encounter List. 
 
Status – The status of encounters to display:  Draft, Reviewed, or Archive. 
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Type – Select “Audio Only” to display only encounters that contain audio recording but no 
notes.  Select “Notes Only” to display only encounters that contain notes but no audio recording.  
Select “Audio & Notes” to display only encounters that contain both audio recording and notes.  
Select “All” to display encounters regardless of whether they contain notes and/or audio 
recording. 
 
Encounter List 
 
Lists all encounters that match the specified criteria (see section “Viewing a List of Items”).  The 
Encounters window title bar will show (in brackets) the number of encounters displayed.  If there 
are at least 500 encounters to display, only the most recent 500 encounters will be displayed, and 
the title bar will say “Encounters (500+)”.  To view older encounters, adjust the date in the “To” 
field, or select the “+” button. 
 
To view/modify an encounter, select it and press Enter or F9, or double-click on it (see section 
“Encounter Window”).  The fields are: 
 
Date – The Date field from the Encounter window (see section “Encounter Window”). 
 
Last – Patient’s last name. 
 
First – Patient’s first name. 
 
Template – The template field from the Encounter window (see section “Encounter Window”). 
 
Type – The Type field from the Encounter window (see section “Encounter Window”). 
 
Re – The Re field from the Encounter window (see section “Encounter Window”). 
 


9 Prescriptions (Rx) 


9.1 Add a Prescription 
 
Go in the File menu to New → Rx (see section “Pull-Down Menus”), or go to New → Rx in the 
Main Toolbar (see section “Main Toolbar”), or select New Rx in the Action Bar (see section 
“Action Bar”), or press Ctrl-R.  An Rx window will open (see section “Rx Window”). 
 


9.2 View/Modify a Prescription 
 
View/modify the patient with whom the prescription is associated (see section “View/Modify a 
Patient”) and go to the Rx tab (see section “Patient Window, Rx Tab”).  Or, go to List 
Prescriptions (see section “List Prescriptions”).  Then select a prescription and press Enter or F9 
(or double-click on a prescription).  An Rx window will open (see section “Rx Window”). 
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9.3 Rx Window 


9.3.1 Script Tab 
 


 
 
Toolbar 
 


New → Rx (Ctrl-N) – Add a prescription. 
 
New → Drug – Add a drug (see section “Drug Window”). 
 
New → SIG – Add a SIG (see section “SIG Window”). 
 


Open → Drug – View/modify a drug.  If you select this, a Find Drug dialog box 
will open (see section “Find Drug Dialog Box”).  Select a drug and then select OK 
or press F9, or double-click on a drug. 
 
Open → SIG – View/modify a SIG.  If you select this, a Find SIG dialog box will 


open (see section “Find SIG Dialog Box”).  Select a SIG and then select OK or press F9, or 
double-click on a SIG. 
 


Save (Ctrl-S) – Save the prescription.  If you select this, a Drug Utilization Review dialog 
box may open (see section “Drug Utilization Review Dialog Box”). 


 
Save and Close (Ctrl-L) – Save the prescription and close the Rx window.  If you select 
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this, a Drug Utilization Review dialog box may open (see section “Drug Utilization Review 
Dialog Box”). 
 


Goto Patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
LookUp on Item (F9) – Choose an entry for the selected field (Begin, Seq., Drug, Generic, 
Brand, SIG, SIG Description, or End) on the Prescription list. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected item on the 
Prescription list (if no item is selected, the first item will be deleted).  Pressing Ctrl-Del 


will delete: 
 


 (in the Date field) the entire field. 
 (on the Prescription list) the selected item. 
 (in the Notes field) the selected text, or, if no text is selected, all text between the 


insertion point and the end of the line. 
 
Notes – Display/hide the external notes field (below the Prescription list). 
 
Notes (Not printed) – Display/hide the internal notes field (at the bottom of the Rx 
window).  This option is only available if the Notes option is on (see above). 


 
Other 
 
Date – The date of the prescription (see section “Date Fields”).  This field is required. 
 
Patient – The patient who received the prescription (required).  If you select this, a Find Patient 
dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then select 
OK or press F9, or double-click on a patient.  To clear this field, select Clear and then OK.  If 
there is a patient selected in this field, and you double-click in the field that contains the patient’s 
name, birthdate, age, health card number, and version code (not on the Patient button itself), a 
Patient window will open for that patient (see section “Patient Window”). 
 
Date => Items – Copy the date in the Date field (see above) to the Begin Date for every item on 
the Prescription List (see below). 
 
Provider – The provider who made the prescription (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Each provider will only 
be displayed once on the list (even providers that have more than one role), i.e. the prescription 
will be associated with the provider in general, not a specific role.  Select a provider and then 
select OK or press F9, or double-click on a provider.  To clear this field, select Clear and then 
OK. 
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Prescription List 
 
Lists all drugs in this prescription (see section “Viewing a List of Items”).  The fields are: 
 
Begin – The date on which the patient should start taking the prescribed drug (required).  See 
section “Date Fields”. 
 
Seq. – A substance identification number assigned by First Data Bank (not displayed by default).  
This is not the same as the Din field in the Drug window (see section “Drug Window”). 
 
Drug – This field is the same as the Brand field (see below), unless the Brand field is blank, in 
which case this field is the same as the Generic field (see below). 
 
Generic – The generic name of the drug that was prescribed to the patient, e.g. acetaminophen 
(not displayed by default). 
 
Brand – The brand name of the drug that was prescribed to the patient, e.g. Tylenol (not 
displayed by default). 
 
Select any of the four fields above (Seq., Drug, Generic, or Brand) and press Enter or F2 or F9, 
or enter/modify any text, or right-click on any item in the list and select Edit or LookUp, or 
select LookUp on Item in the Rx toolbar, or double-click in any of those fields, and a Find Drug 
dialog box will open (see section “Find Drug Dialog Box”).  Select a drug and then select OK or 
press F9, or double-click on a drug.  To clear these fields, select Clear and then OK. 
 
Strength –The strength of the drug (e.g. how many milligrams per pill, etc.).  This field is not 
displayed by default.  This field is automatically set when a drug is selected (see above), and 
cannot be manually modified. 
 
Form – The form of the drug (e.g. tablet, paste, gel, solution, etc.).  This field is not displayed by 
default.  This field is automatically set when a drug is selected (see above), and cannot be 
manually modified. 
 
Route – The method (e.g. oral, topical, inhalation, etc.) that is used to administer the drug.  This 
field is not displayed by default.  This field is automatically set when a drug is selected (see 
above), and cannot be manually modified. 
 
# (Quantity) – The total number of doses of the specified drug the patient should take.  Any 
whole number from 0 to 999 can be entered, but a larger number may appear in this field, if 
calculated automatically (see below). 
 
SIG / SIG Description – A SIG relevant to this prescription item.  The SIG Description field is 
not displayed by default.  Select the Code field and enter the SIG.  (This will replace any existing 
text in that field.  To correct/delete a SIG code, select the SIG field and then press F2 or right-
click on any item in the list and select Edit, and then make the desired changes.)  Or, select the 
SIG field and press Enter or F2 (or right-click on any item in the list and select Edit), or select 
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either field and press F9 (or select LookUp on Item in the Rx toolbar, or right-click on any item 
in the list and select LookUp), or double-click in either field, and a Find SIG dialog box will 
open (see section “Find SIG Dialog Box”).  Select a SIG and then select OK or press F9, or 
double-click on a SIG.  To clear these fields, select Clear and then OK.  This field supports 
defaults (see section “Defaults, Rx Window”). 
 
Period (SIG Period (hrs.)) – The average number of hours the patient should wait before taking 
the drug again (not displayed by default).  For example, for the SIG “5X” (5 times a day), the 
Period should be 4.8 (24 ÷ 5).  This field is automatically set when the SIG and SIG Description 
are chosen (see above), and cannot be manually modified. 
  
Dose – The number of doses (e.g. pills) of the drug the patient should take at a time.  Any whole 
number from 0 to 999 can be entered, but a larger number may appear in this field, if calculated 
automatically (see below). 
 
Rep. (Repeat) – How many times this prescription can be renewed.  Must be a whole number 
from 0 to 999.  This field supports defaults (see section “Defaults, Rx Window”). 
 
L (Long Term) – Indicates that the patient should take this drug indefinitely, and therefore this 
prescription item will always be considered “active” (see section “Patient Window, Rx Tab”) and 
included in the Drug Utilization Review (see section “DUR Tab” or “Drug Utilization Review 
Dialog Box”).  Select this field and press Enter, F2, or Space, or double-click in this field, to 
toggle this option on/off. 
 
O (Compliance OK) – Indicates that the patient has been taking the drug as prescribed (not 
displayed by default).  Select this field and press Enter, F2, or Space, or double-click in this field, 
to toggle this option on/off. 
 
Dur. (Duration) – The number of days for which the patient should take the prescribed drug.  
Any whole number from 0 to 999 can be entered, but a larger number may appear in this field, if 
calculated automatically (see below).  This field supports defaults (see section “Defaults, Rx 
Window”). 
  
End – The date on which the patient should stop taking the prescribed drug (see section “Date 
Fields”).  This field is not displayed by default. 
 
C (To CDS) – Determines whether or not this prescription item will appear in the Patient 
window, Rx tab (see section “Patient Window, Rx Tab”).  By default, this field is off, but not 
displayed.  Select this field and press Enter, F2, or Space, or double-click in this field, to toggle 
this option on/off. 
 
Some of the fields above support automatic calculation, as follows: 
 


 If the Begin field is modified, the End field will be automatically modified as follows:  
take the Begin date and add the number of days in the Dur. (Duration) field, and the 
result will be entered into the End field.  For example, if the Begin date is January 1, and 
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the Dur. field says 10, then the End date will be automatically set to January 11 of the 
same year. 


 If the # (Quantity), Period (SIG Period (hrs.)), or Dose field is modified, the Dur. 
(Duration) field will be automatically modified as follows:  Take the # (Quantity) field, 
multiply by the Period field, divide by 24, divide by the Dose field (unless the Dose field 
is 0), and round down to the nearest integer, and the result will be entered into the Dur. 
field. 


 If the Dur. (Duration) field is modified (manually, or automatically calculated as above), 
the End field will be automatically modified as follows:  take the Begin date and add the 
number of days in the Dur. (Duration) field, and the result will be entered into the End 
field.  For example, if the Begin date is January 1, and the Dur. field says 10, then the 
End date will be automatically set to January 11 of the same year. 


 Also, if the Dur. (Duration) field is manually modified (not automatically calculated, as 
above), the # (Quantity) field will be automatically modified as follows:  Take the Dur. 
(Duration) field, multiply by the Dose field, multiply by 24, divide by the Period (SIG 
Period (hrs.)) field (unless the Period field is 0), round off to the nearest integer, and the 
result will be entered into the # field. 


 If the End field is modified, the Dur. (Duration) field will automatically change to the 
number of days between the Begin and End dates (if the End date is the same as or earlier 
than the Begin date, the Dur. field will be set to 0).  For example, if the Begin date is 
January 1, and the End date is set to January 11 of the same year, the Dur. field will be 
automatically set to 10. 


 
External Notes 
 
Below the Prescription list is the external notes field (if enabled).  This field can be used to store 
any information specific to this prescription.  If a report is run that includes this prescription (see 
section “Run a Report”), the external notes field will be included in the report output.  See 
section “Notes Fields”. 
 
Internal Notes 
 
At the bottom is the internal notes field (if enabled).  This field can be used to store any 
information specific to this prescription.  If a report is run that includes this prescription (see 
section “Run a Report”), the internal notes field will not be included in the report output.  See 
section “Notes Fields”. 
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9.3.2 DUR (Drug Utilization Review) Tab 
 


 
 
The DUR tab provides information such as: 
 


 Warns if the patient is allergic to (an ingredient of) a drug prescribed (see section “Patient 
Window, Allergy Tab”). 


 Warns if there is a possible conflict or redundancy between a drug prescribed and another 
drug that the patient is taking at the same time (i.e. the two drugs should not be or do not 
need to be taken together).  NOTE:  If the patient has been prescribed two conflicting 
drugs, but the End Date of one is before the Begin Date of the other, then this does not 
count as a conflict, unless the L (Long Term) field is enabled on the earlier prescription 
(see section “Script Tab”). 


 Gives recommendations regarding the prescription, e.g. dosage, duration, when/how the 
patient should take the drug(s), etc. 


 
This information will only be available if the Drug Utilization Review feature is enabled for the 
provider associated with this prescription.  To activate this feature, contact HTN (see section 
“HTN”). 
 
The text on the DUR tab is the same text that appears in the Drug Utilization Review Dialog Box 
(see section “Drug Utilization Review Dialog Box”). 
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9.3.3 Drug Utilization Review Dialog Box 
 


 
 
When you save a prescription (see section “Rx Window, Script Tab”), a Drug Utilization Review 
dialog box may open, containing information such as: 
 


 Warns if the patient is allergic to (an ingredient of) a drug prescribed (see section “Patient 
Window, Allergy Tab”). 


 Warns if there is a possible conflict or redundancy between a drug prescribed and another 
drug that the patient is taking at the same time (i.e. the two drugs should not be or do not 
need to be taken together).  NOTE:  If the patient has been prescribed two conflicting 
drugs, but the End Date of one is before the Begin Date of the other, then this does not 
count as a conflict, unless the L (Long Term) field is enabled on the earlier prescription 
(see section “Script Tab”). 


 Gives recommendations regarding the prescription, e.g. dosage, duration, when/how the 
patient should take the drug(s), etc. 


 
This information will only be available if the Drug Utilization Review feature is enabled for the 
provider associated with this prescription.  To activate this feature, contact HTN (see section 
“HTN”). 
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The text in the Drug Utilization Review dialog box is the same text that appears in the Rx 
window, DUR tab (see section “Rx Window, DUR Tab”). 
 
Select Accept to save the prescription, or Cancel to return to the Rx window without saving the 
prescription (see section “Rx Window, Script Tab”). 
 


9.4 Delete a Prescription 
 
View/modify a prescription as per section “View/Modify a Prescription”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D. 
 


9.5 List Prescriptions 
 
Go in the File menu to List → Rx (see section “Pull-Down Menus”), or go to List → Rx in the 
Main Toolbar (see section “Main Toolbar”), or select List Rx in the Action Bar (see section 
“Action Bar”). 
 


 
 
Toolbar 
 
Provider – The provider whose prescriptions to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one local role will be displayed on the list (see section “Provider Window, Demographic 
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Tab, Role List”), however, each provider will only be displayed once on the list (even providers 
that have more than one local role).  Select a provider and then select OK or press F9, or double-
click on a provider.  To clear this field, select Clear and then OK.  If this field is left blank, no 
prescriptions will be displayed. 
 
From – The minimum date for prescriptions to be displayed (see section “Date Fields”).  If this 
field is blank, all matching prescriptions before the To date (inclusive) will be displayed. 
 
To – The maximum date for prescriptions to be displayed (see section “Date Fields”).  If this 
field is blank, all matching prescriptions after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching prescriptions will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) prescription 
displayed on the Prescription List.  This option is only available if 500 prescriptions are 
displayed on the Prescription List. 
 
Prescription List 
 
Lists all prescriptions that match the specified criteria (see section “Viewing a List of Items”).  
The Prescriptions window title bar will show (in brackets) the number of prescriptions displayed.  
If there are at least 500 prescriptions to display, only the most recent 500 prescriptions will be 
displayed, and the title bar will say “Prescriptions (500+)”.  To view older prescriptions, adjust 
the date in the “To” field, or select the “+” button. 
 
To view/modify a prescription, select it and press Enter or F9, or double-click on it (see section 
“Rx Window”).  The fields are: 
 
Date – The Date field from the Rx window (see section “Rx Window”). 
 
Last – Patient’s last name. 
 
First – Patient’s first name. 
 


10 Lab Requisitions 


10.1 Add a Lab Requisition 
 
Go in the File menu to New → Requisition (see section “Pull-Down Menus”), or go to New → 
Requisition in the Main Toolbar (see section “Main Toolbar”), or select New Requisition in the 
Action Bar (see section “Action Bar”), or press Ctrl-Q.  A Requisition window will open (see 
section “Requisition Window”). 
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10.2 View/Modify a Lab Requisition 
 
View/modify the patient with whom the lab requisition is associated (see section “View/Modify 
a Patient”) and go to the Requisition tab (see section “Patient Window, Requisition Tab”).  Then 
select a lab requisition and press Enter or F9 (or double-click on a lab requisition).  A 
Requisition window will open (see section “Requisition Window”). 
 


10.3 Requisition Window 
 


 
 
Toolbar 
 


New → Requisition – Add a lab requisition. 
 
New → Test – Add a test code (see section “Test Window”). 
 
 


Open → Test – View/modify a test code.  If you select this, a Find Test dialog box 
will open (see section “Find Test Dialog Box”).  Select a test code and then select 
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OK or press F9, or double-click on a test code. 
 


Save (Ctrl-S) – Save the lab requisition. 
 
Save and Close (Ctrl-L) – Save the lab requisition and close the Requisition window. 
 
Goto Patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
LookUp on Item (F9) – Choose an entry for the selected field (Test or Description) on the 
Other Test List. 


 
Delete Item (Ctrl-Del) – Selecting this button will delete the selected test on the Other Test 
List.  Pressing Ctrl-Del will delete: 


 
 (in the Date field) the entire field. 
 (on the Other Test List) the selected test. 
 (in the expanded notes field) the selected text, or, if no text is selected, all text between 


the insertion point and the end of the line. 
 
Notes – Display/hide the expanded notes field (at the bottom of the Requisition window). 


 
Date – The date that the tests are being requested (see section “Date Fields”).  Required.  This 
field supports defaults (see section “Defaults, Requisition Window”). 
 
Patient – The patient for whom the tests should be performed (required).  If you select this, a 
Find Patient dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and 
then select OK or press F9, or double-click on a patient.  To clear this field, select Clear and then 
OK.  If there is a patient selected in this field, and you double-click in the field that contains the 
patient’s name, birthdate, age, health card number, and version code (not on the Patient button 
itself), a Patient window will open for that patient (see section “Patient Window”). 
 
Lab – The lab that should perform the tests.  If you change this field, this will clear all 
checkboxes in the Test Section, and delete all items on the Other Test List.  This field supports 
defaults (see section “Defaults, Requisition Window”). 
 
Provider – The provider requesting the tests (required).  If you select this, a Find Provider dialog 
box will open (see section “Find Provider Dialog Box”).  Only providers with at least one local 
role will be displayed on the list (see section “Provider Window, Demographic Tab, Role List”), 
however, each provider will only be displayed once on the list (even providers that have more 
than one local role), i.e. the requisition will be associated with the provider in general, not a 
specific role.  Select a provider and then select OK or press F9, or double-click on a provider.  
To clear this field, select Clear and then OK. 
 







 189


Test Section 
 
This section contains various checkboxes you can use to indicate which types of tests should be 
performed for the selected patient.  If you enable one of these checkboxes, a Find Test dialog 
box will open (see section “Find Test Dialog Box”). 
 
This section is not fully implemented, and is reserved for future use. 
 
Status – Choose a status for the lab requisition.  From the drop-down list box, select one of: 


 Pending – The results of the requested tests have not yet been received. 
 Completed – The results of the requested tests have been received. 
 Cancelled – The requested tests do not need to be performed. 
 No Show – The patient chose not to have the requested tests performed. 


 
Other Test List 
 
On this list you can specify any additional tests that should be performed for the selected patient 
(see section “Viewing a List of Items”).  This list is not fully implemented, and is reserved for 
future use. 
 
Notes 
 
At the bottom is the expanded notes field (if enabled).  This field can be used to store any 
information specific to this lab requisition.  See section “Notes Fields”. 
 


10.4 Delete a Lab Requisition 
 
View/modify a lab requisition as per section “View/Modify a Lab Requisition”, and then go in 
the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar 
(see section “Main Toolbar”), or press Ctrl-D. 
 


11 Lab Results 


11.1 List Lab Results 
 
Go in the File menu to List → Lab (see section “Pull-Down Menus”), or go to List → Lab in the 
Main Toolbar (see section “Main Toolbar”), or select List Lab in the Action Bar (see section 
“Action Bar”). 
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Toolbar 
 
Set Read/Unread – Toggles the status of the selected lab result between Unread and Read. 
 
Task – Opens a new Task window (see section “Task Window”) with the following properties: 


 The Patient field will be copied from the selected lab result to the Task window. 
 If a lab result with a non-blank “Req. #” is selected, then the Task window’s Re field will 


say “Lab Req. # ” followed by the “Req. #” field from the selected lab result. 
 If a lab result with a non-blank Date is selected, then the Task window’s Notes field will 


say “Book an appointment for patient to review lab report of ” followed by the Date field 
from the selected lab result. 


This new task is not automatically saved.  You can choose to save the task, or close the Task 
window.  The first time you save this task, the Notes field from the Task window will be copied 
into the Notes field in the Labs window (overwriting the existing notes for those lab results).  
NOTE:  If a task has already been created based on this lab result, the existing task will be 
opened (instead of a new task being created). 
 
Patient… – Assign the selected lab result to a particular patient (see section “Lab Results with 
no associated Patients”). 
 
Provider – The provider whose lab results to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at 
least one local role will be displayed on the list (see section “Provider Window, Demographic 
Tab, Role List”), however, each provider will only be displayed once on the list (even providers 
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that have more than one local role).  Select a provider and then select OK or press F9, or double-
click on a provider.  To clear this field, select Clear and then OK. 
 
From – The minimum date for lab results to be displayed (see section “Date Fields”).  If this 
field is blank, all matching lab results before the To date (inclusive) will be displayed. 
 
To – The maximum date for lab results to be displayed (see section “Date Fields”).  If this field 
is blank, all matching lab results after the From date (inclusive) will be displayed. 
 
If both of the above fields are blank, all matching lab results will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) lab result displayed 
on the Lab Result List.  This option is only available if 500 lab results are displayed on the Lab 
Result List. 
 
Status – Choose whether to display Unread or Read lab results. 
 
Type – Choose whether to display Abnormal or Normal lab results, or All lab results. 
 
Lab Result List 
 
Lists lab results that match the specified criteria (see section “Viewing a List of Items”).  The 
Labs window title bar will show (in brackets) the number of lab results displayed.  If there are at 
least 500 lab results to display, only the most recent 500 lab results will be displayed, and the 
title bar will say “Labs (500+)”.  To view older lab results, adjust the date in the “To” field, or 
select the “+” button. 
 
Select a lab result to display the full text of that lab result in the expanded Lab Field (below).  
Select a lab result and press Enter or F9, or double-click on a lab result, to view/modify the 
patient with whom the lab result is associated (see section “Patient Window”).  The fields are: 
 
Date – The date that the lab results were sent to the FMS (see section “Data Flow Structure”). 
 
Req. # – A unique serial number assigned by the lab to identify the lab requisition that requested 
the tests that produced these results. 
 
Lab/Loc. – The lab or location where the tests were performed. 
 
A (Abnormal) – Indicates that the results are outside the standard reference range for this type 
of test. 
 
E (Edited) – Indicates that these results are a modification or correction of previous results (for 
the same patient/sample/requisition).  This field is not displayed by default. 
 
F (Final) – Indicates that no further testing will be performed, i.e. these results are not subject to 
future modification. 
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Last – The patient’s last name. 
 
First – The patient’s first name. 
 
If the Last and First fields are blank, see section “Lab Results with no associated Patients”. 
 
Notes 
 
Below the Lab Result List is the expanded notes field (if enabled).  This field can be used to 
store any information specific to the selected lab result.  See section “Notes Fields”. 
 
If this field contains text such as: 
 
  ************ N.B.  PATIENT NOT FOUND AT FMS ************ 
 
     Name = … Health # = … 
 
see section “Lab Results with no associated Patients”. 
 
Lab Field 
 
At the bottom is the Lab field, which displays the full text of the selected lab result.  This field 
cannot be manually modified. 
 


11.2 Lab Results with no associated Patients 
 
Sometimes, on a provider’s list of lab results (see section “List Lab Results”), you may see lab 
results that have no associated patients, i.e. the Last and First fields will be blank, and the Notes 
field will probably contain text such as: 
 
  ************ N.B.  PATIENT NOT FOUND AT FMS ************ 
 
     Name = … Health # = … 
 
Also, these lab results will not show up in the Patient window, Lab tab (see section “Patient 
Window, Lab Tab”). 
 
There are several possible reasons for this: 
 


1. The patient has not (yet) been entered into your database.  Enter the patient record (see 
section “Add a Patient”). 


2. The patient’s health card number has not (yet) been (correctly) added into your database.  
Enter/correct the patient’s health card number (see section “View/Modify a Patient”, and 
then “Patient Window, Demographic Tab, Misc. Section”). 


3. The patient has not (yet) been transmitted to the FMS.  This can only happen if the 
patient record was not manually added into HERO™ CMS, but converted from another 
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medical database program.  In this case, open the patient record (see section 
“View/Modify a Patient”), and then, in the Patient window, on the Demographic tab (see 
section “Patient Window, Demographic Tab”), turn on “Re-transmit/OBEC” in the 
Patient toolbar, and save the patient. 


4. The patient has been entered into a different database (probably at a different office) for 
the same provider.  In that case, you may be required to forward these lab results to the 
appropriate office (unless that office also receives those same lab results, e.g. using 
HERO™ CMS), e.g. via e-mail (see section “E-mail a Report”), fax (see section “Fax a 
Report”), paper (see section “Print a Report”), etc. 


5. The patient has no (Ontario) health card, and therefore cannot be (automatically) matched 
up with a patient in your database.  In this case, select the lab in the Labs window, and 
then select the Patient… button (this option is only available if the text “PATIENT NOT 
FOUND AT FMS” appears in the lab’s Notes field).  A Find Patient dialog box will open 
(see section “Find Patient Dialog Box”).  Select a patient and then select OK (or double-
click on a patient), and then that lab result will be associated with the selected patient. 


 
After following the instructions in #1, #2, or #3 above, do a transmission (see section 
“Transmissions”).  The FMS (see section “Data Flow Structure”) will subsequently associate the 
lab results with the correct patient, and send the results to your database on your next 
transmission. 
 


12 Recalls 


12.1 Add a Recall 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Recall tab (see section “Patient Window, Recall Tab”), and then enter a new item on the 
Recall List. 
 
You can also add recalls by using the Auto-Generate feature in the Recalls window (see section 
“List Recalls”). 
 


12.2 View/Modify a Recall 
 
View/modify the patient with whom the recall is associated (see section “View/Modify a 
Patient”) and go to the Recall tab (see section “Patient Window, Recall Tab”).  You can 
view/modify the desired entry on the Recall List. 
 
Or, go to List Recalls (see section “List Recalls”).  You can view (but not modify) the recall on 
the Recall List. 
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12.3 Delete a Recall 
 
View/modify the patient with whom the recall is associated (see section “View/Modify a 
Patient”) and go to the Recall tab (see section “Patient Window, Recall Tab”).  Select the recall 
and then select Delete Item in the Patient toolbar, or right-click on any item in the list and select 
Delete Item, or press Ctrl-Del. 
 


12.4 List Recalls 
 
Go in the File menu to List → Recall (see section “Pull-Down Menus”), or go to List → Recall 
in the Main Toolbar (see section “Main Toolbar”), or select List Recall in the Action Bar (see 
section “Action Bar”). 
 


 
 
Toolbar 
 
Provider – The provider whose recalls to display (required).  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role).  Select a provider and then select OK or press F9, or double-click on a 
provider.  To clear this field, select Clear and then OK. 
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From – The minimum date for recalls to be displayed (see section “Date Fields”).  If this field is 
blank, all matching recalls before the To date (inclusive) will be displayed. 
 
To – The maximum date for recalls to be displayed (see section “Date Fields”).  If this field is 
blank, all matching recalls after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching recalls will be displayed. 
 
Status – The status of recalls to display.  Only recalls of the status selected will be displayed on 
the list.  You must choose one of these options: 
 


 Letter1 ToDo – A first letter needs to be sent to the patient regarding the recall. 
 Letter1 Sent – A first letter has been sent to the patient regarding the recall. 
 Letter2 ToDo – A second letter needs to be sent to the patient regarding the recall. 
 Letter2 Sent – A second letter has been sent to the patient regarding the recall. 
 PhoneToDo – The patient needs to be telephoned regarding the recall. 
 Phone Done – The patient has been telephoned regarding the recall. 
 Billable – The provider can bill MOHLTC for this recall. 
 Archive – The provider has billed MOHLTC for this recall. 


 
Type – The type of recalls to display, e.g. COL, PAP, MAM, FLU, IMM, etc. (required).  
Enter/modify any text (or double-click) in this field, and a Find Recall dialog box will open (see 
section “Find Recall Dialog Box”).  Select a recall type and then select OK or press F9, or 
double-click on a recall type.  To clear this field, select Clear and then OK.  Only recalls of the 
selected type will be displayed on the Recall List. 
  
Auto-generate – Automatically generates a recall for each eligible patient.  The recalls will be 
created by the following criteria: 
 


 If Type is set to COL, one recall will be created for each non-inactive patient rostered to 
the selected provider between the ages of 50 and 75 who has not had a COL recall (with 
the # field set to 0, indicating a colorectal screening – see below) in the past 2 years, or a 
COL recall (with the # field greater than 0, indicating a colonoscopy – see below) in the 
past 5 years. 


 If Type is set to PAP, one recall will be created for each non-inactive female patient 
rostered to the selected provider between the ages of 35 and 70 who has not had a PAP 
recall in the past 2 years. 


 If Type is set to MAM, one recall will be created for each non-inactive female patient 
rostered to the selected provider between the ages of 50 and 70 who has not had a MAM 
recall in the past 2 years. 


 If Type is set to FLU, one recall will be created for each non-inactive patient rostered to 
the selected provider over the age of 65 who has not had a FLU recall in the past 6 
months. 


 If Type is set to IMM, one recall will be created for each non-inactive patient rostered to 
the selected provider between the ages of 18 months and 2 years. 
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 If the Type is not set to COL, PAP, MAM, FLU, or IMM, a Query dialog box will open 
(see section “Query Dialog Box”).  Enter criteria to select the patients for which recalls 
will be automatically generated. 


 
One recall will be created for each patient matching the above criteria.  The status of the new 
recalls will be “Letter1 ToDo”. 
  
Letter 1 Sent – Automatically set the “Letter 1” date to the current date for each recall on the 
Recall List (this changes the status of those recalls to “Letter1 Sent”).  This function is only 
available if the Status field is set to “Letter1 ToDo”.  See section “How to use Recalls”, step #3. 
 
Letter 2 Sent – Automatically set the “Letter 2” date to the current date for each recall on the 
Recall List (this changes the status of those recalls to “Letter2 Sent”).  This function is only 
available if the Status field is set to “Letter2 ToDo”.  See section “How to use Recalls”, step #7. 
 
Auto-bill – For each recall on the Recall List, automatically create a bill (associated with the 
“logged in” role) and change the recall’s status to “Archive.”  This feature only works if the 
Status field is set to “Billable,” and the same provider is specified in both the Main Toolbar (see 
section “Log in as a Provider”) and the Recalls toolbar, and the Type field is set to COL, PAP, 
MAM, FLU, or IMM.  The bills will be associated with the role selected in the Main Toolbar.  
See section “How to use Recalls”, step #14. 
 
Recall List 
 
Lists all recalls that meet the criteria specified (above).  See section “Viewing a List of Items”.  
If you select a recall and select Enter or F9, or double-click on a recall, the Patient window will 
open (see section “Patient Window”). 
 
If the type field is set to COL, PAP, MAM, FLU, or IMM, only recalls for rostered patients (e.g. 
patients that have the PCRG option enabled – see section “Patient Window, Demographic Tab”) 
will be displayed.  For all other recall types, recalls for non-rostered patients may be displayed as 
well.  Also, any recall with the Ineligible field activated (see section “Patient Window, Recall 
Tab”) will not be displayed on this list. 
 
The fields are: 
 
Date – The date the recall was created.  This is the same as the “Due Date” field in the Patient 
window, Recall tab (see section “Patient Window, Recall Tab”). 
 
Completed – The date that the patient responded to the recall (letter or phone call), i.e. the date 
that the patient agreed or refused to have the selected medical procedure. 
 
# (# of Immunizations) – If the Type field (see above) is set to IMM (Immunization), this field 
indicates the number of immunizations the patient has had (babies are supposed to get 5 
immunizations).  If the Type field (see above) is set to COL (Colorectal screening), this field will 
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say 0 if the patient has had a colorectal screening, or any other number if the patient had a 
colonoscopy.  This field is not displayed by default. 
 
Code / Description – The recall type, e.g. COL, PAP, MAM, FLU, IMM, etc.  The description 
field is not displayed by default. 
 
Letter 1 – Indicates the date a first letter was sent to the patient, to remind them to get the 
required medical procedure.  See section “Date Fields”. 
 
(Letter 1 Code) / Letter 1 (Letter 1 Description) – Indicates the patient’s response to the first 
letter (see section “LookUp Response Dialog Box”).  The Letter 1 Description field is not 
displayed by default. 
 
Letter 2 – Indicates the date a second letter was sent to the patient, to remind them to get the 
required medical procedure.  See section “Date Fields”. 
 
(Letter 2 Code) / Letter 2 (Letter 2 Description) – Indicates the patient’s response to the 
second letter (see section “LookUp Response Dialog Box”).  The Letter 2 Description field is not 
displayed by default. 
 
Phone – Indicates the date the patient was telephoned, to remind them to get the required 
medical procedure.  See section “Date Fields”. 
 
(Phone Code) / Phone (Phone Description) – Indicates the patient’s response to the telephone 
call (see section “LookUp Response Dialog Box”).  The Phone Description field is not displayed 
by default. 
 
Name – Patient’s last name and first initial. 
 
Last – Patient’s last name (not displayed by default). 
 
First – Patient’s first name (not displayed by default). 
 


12.5 How to use Recalls 
 
The purpose of a recall is to remind a patient that a certain medical procedure needs to be 
performed, e.g. pap smear, mammogram, flu shot, immunization, etc.  In some cases, a provider 
can get paid just for reminding a patient about a medical procedure, even if the procedure is not 
actually performed (or if the procedure is performed by a different provider). 
 
A typical recall cycle works like this: 
 


1. The recalls are created/generated.  You can either create them manually in the Patient 
window, Recall tab (see section “Patient Window, Recall Tab”), or you can use the Auto-
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generate button in the Recalls window (see section “List Recalls”).  The status of the new 
recalls should be “Letter1 ToDo”. 


2. For each recall of status “Letter1 ToDo”, you send a letter to the patient reminding them 
about the required medical procedure.  You can include information such as the reasons 
for the procedure, its benefits/advantages, how/why/when/where to get it done, etc.  The 
letters (and mailing labels to send them out) can be automatically generated by running 
reports (see section “Run a Report”) from the Recalls window (see section “List 
Recalls”).  Each letter will include the contents of a template (see section “Template 
Window”) of context Referral whose name matches the recall type (see section “Recall 
Types”) selected in the Type field in the Recalls window. 


3. For the letters that were sent out in step #2 above, set the “Letter 1” dates for the 
associated recalls to the dates that the letters were sent out.  You can do this manually in 
the Patient window, Recall tab (see section “Patient Window, Recall Tab”), or you can 
use the Letter 1 Sent button in the Recalls window (see section “List Recalls”).  The 
status of those recalls will automatically change to “Letter1 Sent”. 


4. If any patient responds to the letter (i.e. either agrees or refuses to have the medical 
procedure performed), open the Patient window for that patient, and then go to the Recall 
tab (see section “Patient Window, Recall Tab”).  For the appropriate recall, set the Letter 
1 Code / Letter 1 Description fields to A (Accepted) or R (Refused).  The recall’s status 
will automatically change to Billable (skip to step #14 below). 


5. After a certain number of days has elapsed (after sending out the letters in step #2 above), 
the recalls that have had no response will have their status automatically changed to 
“Letter2 ToDo”.  The number of days is determined by the “Letter 1 Wait” field in the 
Miscellaneous dialog box (see section “Miscellaneous Dialog Box”). 


6. For each recall of status “Letter2 ToDo”, you send another letter to the patient reminding 
them about the required medical procedure.  You can include information such as the 
reasons for the procedure, its benefits/advantages, how/why/when/where to get it done, 
etc.  The letters (and mailing labels to send them out) can be automatically generated by 
running reports (see section “Run a Report”) from the Recalls window (see section “List 
Recalls”).  Each letter will include the contents of a template (see section “Template 
Window”) of context Referral whose name matches the recall type (see section “Recall 
Types”) selected in the Type field in the Recalls window. 


7. For the letters that were sent out in step #6 above, set the “Letter 2” dates for the 
associated recalls to the dates that the letters were sent out.  You can do this manually in 
the Patient window, Recall tab (see section “Patient Window, Recall Tab”), or you can 
use the Letter 2 Sent button in the Recalls window (see section “List Recalls”).  The 
status of those recalls will automatically change to “Letter2 Sent”. 


8. If any patient responds to the second letter (i.e. either agrees or refuses to have the 
medical procedure performed), open the Patient window for that patient, and then go to 
the Recall tab (see section “Patient Window, Recall Tab”).  For the appropriate recall, set 
the Letter 2 Code / Letter 2 Description fields to A (Accepted) or R (Refused).  The 
recall’s status will automatically change to Billable (skip to step #14 below). 


9. After a certain number of days has elapsed (after sending out the letters in step #6 above), 
the recalls that have had no response will have their status automatically changed to 
“Phone ToDo”.  The number of days is determined by the “Letter 2 Wait” field in the 
Miscellaneous dialog box (see section “Miscellaneous Dialog Box”). 
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10. For each recall of status “Phone ToDo”, you call the patient to remind them about the 
required medical procedure.  The list of patients to call (and their phone numbers) can be 
generated by running a report (see section “Run a Report”) from the Recalls window (see 
section “List Recalls”). 


11. For the phone calls that were made in step #10 above, set the Phone dates for the 
associated recalls to the dates that the phone calls were made.  You can do this manually 
in the Patient window, Recall tab (see section “Patient Window, Recall Tab”).  The status 
of those recalls will automatically change to “Phone Done”. 


12. If any patient responds to the phone call (i.e. either agrees or refuses to have the medical 
procedure performed), open the Patient window for that patient, and then go to the Recall 
tab (see section “Patient Window, Recall Tab”).  For the appropriate recall, set the Phone 
Code / Phone Description fields to A (Accepted) or R (Refused).  The recall’s status will 
automatically change to Billable (see step #14 below). 


13. After a certain number of days has elapsed (after making the phone calls in step #10 
above), the recalls that have had no response will have their status automatically changed 
to “Billable”.  The number of days is determined by the “Bill Wait” field in the 
Miscellaneous dialog box (see section “Miscellaneous Dialog Box”). 


14. For all recalls of status “Billable”, you can generate a bill for each one.  You can use the 
Auto-bill button in the Recalls window (see section “List Recalls”).  The status of those 
recalls will automatically change to “Archive”.  This feature is only available for recalls 
of type COL, PAP, MAM, FLU, or IMM. 


15. At the end of each fiscal year, the provider may be eligible for bonus payments, 
depending on how many of that provider’s patients were reminded to have certain 
medical procedures, and how many of those responded to the reminder.  There is a 
compliance report that calculates the necessary statistics, which can be run from the 
Recalls window (see section “Run a Report” or “List Recalls”). 


 


13 Tasks 
 
A task is a message/reminder/request sent from one HERO™ CMS user (see section “Before 
You Begin”) to another.  HERO™ CMS’s task function can effectively be used as an internal e-
mail system. 
 


13.1 Add a Task 
 
Go in the File menu to New → Task (see section “Pull-Down Menus”), or go to New → Task in 
the Main Toolbar (see section “Main Toolbar”), or select New Task in the Action Bar (see 
section “Action Bar”), or press Ctrl-K.  A Task window will open (see section “Task Window”). 
 


13.2 View/Modify a Task 
 
Go to List Tasks (see section “List Tasks”).  Or, if the task is associated with a patient, you can 
view/modify that patient (see section “View/Modify a Patient”) and go to the Task tab (see 
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section “Patient Window, Task Tab”).  Then select a task and press Enter or F9 (or double-click 
on a task).  A task window will open (see section “Task Window”). 
 


13.3 Task Window 
 


 
 
Toolbar 
 


New Task (Ctrl-N) – Add a task. 
 
Save (Ctrl-S) – Save the task. 
 
Save and Close (Ctrl-L) – Save the task and close the Task window. 
 
Goto Patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
Goto Source – Does one of these (if the task has already been saved): 
 


 If this task was originally created by selecting the Task button in an Attachment window 
(see section “Attachment Window”) or Attachments window (see section “List 
Attachments”), selecting Goto Source in the Task window will open that attachment. 


 If this task was originally created by selecting the Task button in a Referral window (see 
section “Referral Window”), selecting Goto Source in the Task window will open that 
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referral. 
 If this task was originally created by selecting the Task button in a Labs window (see 


section “List Lab Results”), then a Print Preview window will open, showing the contents 
of the selected lab results, as if you had previewed the report “Labs (Selected Item)” (see 
section “Preview a Report”) from the Labs window.  (It is recommended that you not edit 
or delete this report.  See section “Reports”.) 


 Otherwise, this button has no effect. 
 
 Rewind (F10) – Rewind audio playback. 
 
 Play/Pause (F11) – Start or stop audio playback. 
 
Record/Stop (F12) – Start or stop audio recording. 
 
Delete Audio (Ctrl-Del) – Delete the audio recording associated with this task. 


 
Other 
 
Due – The date by which the task must be completed (see section “Date Fields”).  This field is 
required.  This field supports defaults (see section “Defaults, Task Window”). 
 
Patient – The patient for whom the task will be performed.  If you select this, a Find Patient 
dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then select 
OK or press F9, or double-click on a patient.  To clear this field, select Clear and then OK.  If 
there is a patient selected in this field, and you double-click in the field that contains the patient’s 
name, birthdate, age, health card number, and version code (not on the Patient button itself), a 
Patient window will open for that patient (see section “Patient Window”). 
 
Priority – The task’s priority:  Low, Normal, or High.  This field is required.  This field supports 
defaults (see section “Defaults, Task Window”). 
 
Assignee – The user or group to whom this task is assigned (see section “Before You Begin”).  If 
you select this, a LookUp User/Role dialog box will open (see section “LookUp User/Role 
Dialog Box”).  This field is required.  This field supports defaults (see section “Defaults, Task 
Window”). 
 
Status – The task’s status:  Draft, Open, Complete, or Incomplete.  This field is required.  This 
field supports defaults (see section “Defaults, Task Window”). 
 
Assignor – The user who assigned this task (cannot be manually modified).  See section “Before 
You Begin”. 
 
Re – The purpose/description of the task. 
 
Reply – Creates a new task (in the same Task window).  The Patient and Priority fields are 
copied from the old task.  The Assignor from the old task becomes the Assignee for the new task.  
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The Re field from the old task, if not blank, becomes the Re field for the new task, with “Re: ” 
added in front.  The Notes field from the old task, if not blank, becomes the Notes field for the 
new task, with two blank lines and then “<Original Message>” added at the top. 
 
Notes 
 
At the bottom is the expanded notes field which can be used to store any information specific to 
this task.  See section “Notes Fields”. 
 


13.4 Delete a Task 
 
View/modify a task as per section “View/Modify a Task”, and then go in the File menu to Delete 
(see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section “Main 
Toolbar”), or press Ctrl-D. 
 


13.5 List Tasks 
 
Go in the File menu to List → Task (see section “Pull-Down Menus”), or go to List → Task in 
the Main Toolbar (see section “Main Toolbar”), or select List Task in the Action Bar (see section 
“Action Bar”). 
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Toolbar 
 
By Role – If this option is off, only tasks assigned specifically to you (or by you, if the By 
Assignor option is on) will be displayed.  If this option is on, tasks assigned to you or a user 
group you’re in (see section “Before You Begin”) will be displayed.  This option is only 
available if “By Assignor” is off (see below). 
 
By Assignor – If this option is on, only tasks assigned by you will be displayed.  If this option is 
off, only tasks assigned to you (or a user group you’re in, if the By Role option is on – see 
section “Before You Begin”) will be displayed. 
 
From – The minimum date for tasks to be displayed (see section “Date Fields”).  If this field is 
blank, all matching tasks before the To date (inclusive) will be displayed. 
 
To – The maximum date for tasks to be displayed (see section “Date Fields”).  If this field is 
blank, all matching tasks after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching tasks will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) task displayed on the 
Task List.  This option is only available if 500 tasks are displayed on the Task List. 
 
Status – The status of tasks to display:  Draft, Open, Complete, or Incomplete. 
 
Priority – The priority of tasks to display:  Low, Normal, High, or All. 
 
Task List 
 
Lists all tasks that match the specified criteria (see section “Viewing a List of Items”).  The 
Tasks window title bar will show (in brackets) the number of tasks displayed.  If there are at least 
500 tasks to display, only the most recent 500 tasks will be displayed, and the title bar will say 
“Tasks (500+)”.  To view older tasks, adjust the date in the “To” field, or select the “+” button. 
 
To view/modify a task, select it and press Enter or F9, or double-click on it (see section “Task 
Window”). 
 
The fields are: 
 
Due – The Due field from the Task window (see section “Task Window”).  See section “Date 
Fields”. 
 
Status – The Status field from the Task window (see section “Task Window”). 
 
Priority – The Priority field from the Task window (see section “Task Window”). 
 
Re – The Re field from the Task window (see section “Task Window”). 
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Name – The patient (last name and first initial) associated with this task. 
 
Last – The last name of the patient associated with this task (not displayed by default). 
 
First – The first name of the patient associated with this task (not displayed by default). 
 
Assignee – The Assignor field from the Task window (see section “Task Window”).  This field 
is not displayed by default. 
 
Assignor – The Assignor field from the Task window (see section “Task Window”). 
 


14 Referrals 


14.1 Add a Referral 
 
Go in the File menu to New → Referral (see section “Pull-Down Menus”), or go to New → 
Referral in the Main Toolbar (see section “Main Toolbar”), or select New Referral in the Action 
Bar (see section “Action Bar”), or press Ctrl-F.  A Referral window will open (see section 
“Referral Window”). 
 


14.2 View/Modify a Referral 
 
View/modify the patient with whom the referral is associated (see section “View/Modify a 
Patient”) and go to the Ref. tab (see section “Patient Window, Ref. Tab”).  Or, go to List 
Referrals (see section “List Referrals”).  Then select a referral and press Enter or F9 (or double-
click on a referral).  A referral window will open (see section “Referral Window”). 
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14.3 Referral Window 
 


 
 
Toolbar 
 


New Referral (Ctrl-N) – Add a referral. 
 
Save (Ctrl-S) – Save the referral. 
 
Save and Close (Ctrl-L) – Save the referral and close the Referral window. 
 
Goto patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
Rewind (F10) – Rewind audio playback. 
 
Play/Pause (F11) – Start or stop audio playback. 
 
Record/Stop (F12) – Start or stop audio recording. 
 
Delete Audio (Ctrl-Del) – Delete the audio recording associated with this referral. 
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Other 
 
Date – The date of the referral (required).  See section “Date Fields”.  This field supports 
defaults (see section “Defaults, Referral Window”). 
 
Patient – The patient being referred (required).  If you select this, a Find Patient dialog box will 
open (see section “Find Patient Dialog Box”).  Select a patient and then select OK or press F9, or 
double-click on a patient.  To clear this field, select Clear and then OK.  If there is a patient 
selected in this field, and you double-click in the field that contains the patient’s name, birthdate, 
age, health card number, and version code (not on the Patient button itself), a Patient window 
will open for that patient (see section “Patient Window”). 
 
Provider – The local provider who is either making or receiving the referral (required).  If you 
select this, a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  All 
local roles for all providers (that match the search criteria) will be displayed (see section 
“Provider Window, Demographic Tab, Role List”), i.e. a matching provider with multiple local 
roles will show multiple matches.  Select a provider/role and then select OK or press F9, or 
double-click on a provider/role.  To clear this field, select Clear and then OK. 
 
Referred – The other provider who is either making or receiving the referral (required).  If you 
select this, a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Only 
providers with at least one Referring role will be displayed on the list (see section “Provider 
Window, Demographic Tab, Role List”).  Select a provider and then select OK or press F9, or 
double-click on a provider.  To clear this field, select Clear and then OK.  If there is a provider 
selected in this field, and you double-click in the field that contains the provider’s name and 
billing number (not on the Referred button itself), a Provider window will open for that provider 
(see section “Provider Window”).  This field supports defaults (see section “Defaults, Referral 
Window”).  If you fax a report (see section “Fax a Report”) or e-mail a report (see section “E-
mail a Report”) from a Referral window, the “To” field will already be populated with 
information (fax number or e-mail address) taken from the provider selected in this field 
(Referred), if applicable. 
 
Template – If any template is selected in this field, the contents of that template may be included 
in any report (e.g. referral letter) run from this Referral window (see section “Run a Report”).  
To select a template, double-click (or enter/modify any text, or press Escape) in this field, and a 
Find Template dialog box will open (see section “Find Template Dialog Box”).  Only templates 
of context Referral will be displayed.  Select a template and then select OK or press F9, or 
double-click on a template.  To clear this field, select Clear and then OK.  See section “Template 
Window”. 
 
Task – Opens a new Task window (see section “Task Window”) with the following properties: 


 The Patient field will be copied from the Referral window to the Task window. 
 If the Referral window’s Referred field has a provider chosen, then the Task window’s 


Re field will say “Referral - ” followed by that provider’s last name and first initial. 
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 If the Referral window’s Referred field has a provider chosen, then the Task window’s 
Notes field will say “Book an appointment for patient for referral with ” followed by that 
provider’s last name and first initial. 


This new task is not automatically saved.  You can choose to save the task, or close the Task 
window.  NOTE:  If a task has already been created based on this referral, the existing task will 
be opened (instead of a new task being created). 
 
Re – The purpose of the referral. 
 
Encounter – Indicates whether or not to include the patient’s encounters in the referral report 
(letter).  See section “Patient Window, Encounter Tab”.  This field supports defaults (see section 
“Defaults, Referral Window”). 
 
Lab – Indicates whether or not to include the patient’s lab results in the referral report (letter).  
See section “Patient Window, Lab Tab”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
Risk – Indicates whether or not to include the patient’s risks in the referral report (letter).  See 
section “Patient Window, Risk Tab”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
All Items – Indicates whether or not to include inactive items (from the patient’s medical 
history) in the referral report (letter).  This field supports defaults (see section “Defaults, Referral 
Window”). 
 
Problem – Indicates whether or not to include the patient’s problems, procedures, and diagnoses 
in the referral report (letter).  See section “Patient Window, Problem Tab”.  This field supports 
defaults (see section “Defaults, Referral Window”). 
 
Immunize – Indicates whether or not to include the patient’s immunizations in the referral report 
(letter).  See section “Patient Window, Imm. Tab”.  This field supports defaults (see section 
“Defaults, Referral Window”). 
 
Alert – Indicates whether or not to include the patient’s alerts in the referral report (letter).  See 
section “Patient Window, Alert Tab”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
From – The minimum date for items (in the patient’s medical history) to include in the referral 
report (letter).  See section “Date Fields”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
To – The maximum date for items (in the patient’s medical history) to include in the referral 
report (letter).  See section “Date Fields”. 
 
If both of the above items are blank, all matching items (from the patient’s medical history) of 
the selected types will be included in the referral report (letter). 
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Rx – Indicates whether or not to include the patient’s prescriptions in the referral report (letter).  
See section “Patient Window, Rx Tab”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
Allergy – Indicates whether or not to include the patient’s allergies in the referral report (letter).  
See section “Patient Window, Allergy Tab”.  This field supports defaults (see section “Defaults, 
Referral Window”). 
 
Family – Indicates whether or not to include the patient’s family medical history in the referral 
report (letter).  See section “Patient Window, Family Tab”.  This field supports defaults (see 
section “Defaults, Referral Window”). 
 
Appt. – The date of the patient’s appointment with the referred provider (see section “Date 
Fields”). 
 
Time – The time of the patient’s appointment with the referred provider (see section “Time 
Fields”). 
 
Duration – The duration of the patient’s appointment with the referred provider.  Must be a 
whole number of minutes from 0 to 9999. 
 
Status – The status of the patient’s appointment with the referred provider:  To Book, Booked, 
Confirmed, Completed, Cancelled, No Show, or Faxed. 
 
Printed – Indicates whether this referral has been printed or sent to the referred provider.  (This 
option will be automatically enabled when you print a report from this Referral window.) 
 
Notes 
 
At the bottom is the expanded notes field which can be used to store any information specific to 
this referral.  See section “Notes Fields”. 
 


14.4 Delete a Referral 
 
View/modify a referral as per section “View/Modify a Referral”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D. 
 


14.5 List Referrals 
 
Go in the File menu to List → Referral (see section “Pull-Down Menus”), or go to List → 
Referral in the Main Toolbar (see section “Main Toolbar”), or select List Referral in the Action 
Bar (see section “Action Bar”). 
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Toolbar 
 
Printed – Choose “All” (display all matching referrals, regardless of their Printed field), 
“Printed” (display only referrals with the Printed field enabled), or “Not printed” (display only 
referrals with the Printed field disabled). 
 
Provider – The provider whose referrals to display (required).  If you select this, a Find Provider 
dialog box will open (see section “Find Provider Dialog Box”).  Only providers with at least one 
local role will be displayed on the list (see section “Provider Window, Demographic Tab, Role 
List”), however, each provider will only be displayed once on the list (even providers that have 
more than one local role).  Select a provider and then select OK or press F9, or double-click on a 
provider.  To clear this field, select Clear and then OK.  If this field is left blank, no referrals will 
be displayed. 
 
From – The minimum date for referrals to be displayed (see section “Date Fields”).  If this field 
is blank, all matching referrals before the To date (inclusive) will be displayed. 
 
To – The maximum date for referrals to be displayed (see section “Date Fields”).  If this field is 
blank, all matching referrals after the From date (inclusive) will be displayed. 
 
If both of the above items are blank, all matching referrals will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) referral displayed on 
the Referral List.  This option is only available if 500 referrals are displayed on the Referral List. 
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Status – The status of referrals to display:  To Book, Booked, Confirmed, Completed, Cancelled, 
No Show, or Faxed. 
 
Type – Select “Audio Only” to display only referrals that contain audio recording but no notes.  
Select “Notes Only” to display only referrals that contain notes but no audio recording.  Select 
“Audio & Notes” to display only referrals that contain both audio recording and notes.  Select 
“All” to display referrals regardless of whether they contain notes and/or audio recording. 
 
Referral List 
 
Lists all referrals that match the specified criteria (see section “Viewing a List of Items”).  The 
Referrals window title bar will show (in brackets) the number of referrals displayed.  If there are 
at least 500 referrals to display, only the most recent 500 referrals will be displayed, and the title 
bar will say “Referrals (500+)”.  To view older referrals, adjust the date in the “To” field, or 
select the “+” button. 
 
To view/modify a referral, select the referral and press Enter or F9, or double-click on the 
referral (see section “Referral Window”).  The fields are: 
 
Date – The Date field from the Referral window (see section “Referral Window”). 
 
Last – The patient’s last name. 
 
First – The patient’s first name. 
 


15 Attachments 


15.1 Add an Attachment 
 
Go in the File menu to New → Attachment (see section “Pull-Down Menus”), or go to New → 
Attachment in the Main Toolbar (see section “Main Toolbar”), or select New Attachment in the 
Action Bar (see section “Action Bar”), or press Ctrl-H.  An Attachment window will open (see 
section “Attachment Window”). 
 


15.2 View/Modify an Attachment 
 
Go to List Attachments (see section “List Attachments”).  Or, if the attachment is associated with 
a patient, you can view/modify that patient (see section “View/Modify a Patient”) and go to the 
Attach. tab (see section “Patient Window, Attach. Tab”).  Then select an attachment and press 
Enter or F9 (or double-click on an attachment).  An Attachment window will open (see section 
“Attachment Window”). 
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15.3 Attachment Window 
 


 
 
Toolbar 
 


New → Attachment (Ctrl-N) – Add an attachment 
 
New → Type – Add an attachment type (see section “(Attachment) 
Type Window”). 
 


Open Type – View/modify an attachment type.  If you select this, a Find (Attachment) 
Type dialog box will open (see section “Find (Attachment) Type Dialog Box”).  Select an 


attachment type and then select OK or press F9, or double-click on an attachment type.  See 
section “(Attachment) Type Window”. 
 


Save (Ctrl-S) – Save the attachment. 
 
Save and Close (Ctrl-L) – Save the attachment and close the Attachment window. 
 
Goto patient (F8) – View/modify the patient (patient must be selected first).  See section 
“Patient Window”. 


 
Other 
 
Created – The date the attached document was created (see section “Date Fields”). 







 212


 
Patient – The patient with whom the attachment is associated.  If you select this, a Find Patient 
dialog box will open (see section “Find Patient Dialog Box”).  Select a patient and then select 
OK or press F9, or double-click on a patient.  To clear this field, select Clear and then OK.  If 
there is a patient selected in this field, and you double-click in the field that contains the patient’s 
name, birthdate, age, health card number, and version code (not on the Patient button itself), a 
Patient window will open for that patient (see section “Patient Window”). 
 
Received – The date the attached document was received (see section “Date Fields”). 
 
Provider – The provider with whom the attachment is associated (required).  If you select this, a 
Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Each provider 
will only be displayed once on the list, even providers that have more than one role (see section 
“Provider Window, Demographic Tab, Role List”).  Select a provider and then select OK or 
press F9, or double-click on a provider.  To clear this field, select Clear and then OK. 
 
Type – The type of document e.g. consultation report, referral report, etc.  Enter/modify any text 
(or double-click) in this field, and a Find (Attachment) Type dialog box will open (see section 
“Find (Attachment) Type Dialog Box”).  Select an attachment type and then select OK or press 
F9, or double-click on an attachment type.  To clear this field, select Clear and then OK. 
 
Task – Opens a new Task window (see section “Task Window”) with the following properties: 


 The Patient field will be copied from the Attachment window to the Task window. 
 The Task window’s Re field will say “Attachment - ” followed by the Created field from 


the Attachment window. 
 The Task window’s Notes field will say “Book an appointment for patient to review 


attachment of ” followed by the Created field from the Attachment window. 
This new task is not automatically saved.  You can choose to save the task, or close the Task 
window.  NOTE:  If a task has already been created based on this attachment, the existing task 
will be opened (instead of a new task being created). 
 
Source (Refer) – The origin of the document.  Select this field and type in the text.  Or, to select 
a referring provider, select Refer, and a Find Provider dialog box will open (see section “Find 
Provider Dialog Box”).  Only providers with Referring roles will be displayed on the list (see 
section “Provider Window, Demographic Tab, Role List”).  Select a provider and then select OK 
or press F9, or double-click on a provider.  To clear this field, select Clear and then OK. 
 
Status – The status of the attachment:  Unread, Read, or Archive. 
 
Priority – The importance of the attachment:  Low, Normal, High, or Abnormal. 
 
Description – A description of the contents/purpose of the attachment. 
 
Clear – Delete the scanned document or imported file from this attachment.  This will also clear 
the file name field and Preview Area, and set the Page Number to zero (see below). 
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- – Zoom out the page in the Preview Area (see below). 
 
+ – Zoom in the page in the Preview Area (see below). 
 
Between the + and Scan buttons is the Page Number field.  This indicates which page of the 
scanned document to display in the Preview Area (see below).  If no document has been scanned, 
this field will be unavailable, and/or will show 0.  This field will be automatically incremented 
before each page is scanned, e.g. if you want to replace (or add) page number 3 of a scanned 
document, set this field to 2 and then select Scan (see below).  To enter a page number, type a 
whole number using the keyboard, or use the up/down arrow buttons or arrow keys to increase or 
decrease the page number displayed. 
 
Scan – Scan a document from a TWAIN-compliant device (e.g. scanner, camera).  To choose 
which device to scan from, first use the Src button (see below).  If you scan a document, you 
cannot import a file into this attachment (see below).  If you have already imported a file (see 
below), the Scan button is unavailable. 
 
OCR – …  “Set parameter is not acceptable.” ??? 
“OCR engine initialization error, or there is no appropriate license” 
 
Src… – Select which TWAIN-compliant device (e.g. scanner, camera) from which to scan a 
document (see above).  If you have already imported a file into this attachment (see below), the 
Src button is unavailable. 
 
Between the Src button and the UI option are two drop-down list boxes which determine the 
quality of the scanned document (when you select Scan – see above).  The first one indicates the 
resolution of the document (in Dots Per Inch), and the second one indicates the colour quality 
(e.g. Black and White, Gray, Colour, etc.).  The options on these lists depend on the capabilities 
of your TWAIN-compliant device (selected using the Src button – see above).  (In some cases, 
these options will be unavailable.)  For more information, check the documentation for your 
TWAIN-compliant device.  If you have already imported a file (see below), these options are 
unavailable. 
 
UI – If this option is on, when you select Scan (see above), your TWAIN-compliant device (e.g. 
scanner, camera) will use its own software to allow you to select advanced options (e.g. scan 
quality).  For more information, check the documentation for your TWAIN-compliant device.  If 
you have already imported a file (see below), the UI option is unavailable. 
 
Jpg – Determines if the image (from a TWAIN-compliant device) will be scanned/saved in 
JPEG format (on) or GIF format (off).  GIF is recommended for scanning documents in a 
scanner, whereas JPEG is recommended for taking photographs with a (digital) camera. 
 
View… – Open the file that was imported using the File button (see below), whose file name 
appears in the file name field (see below).  (If that field is blank, the View button is unavailable, 
or has no effect.)  Windows will automatically choose an external program to open the file based 
on the extension at the end of the file name.  For example, if the file name ends with “.TXT”, 







 214


Windows will most likely open it using a text editor such as Notepad.  For more information on 
file type associations, check your Windows help or documentation. 
 
File… – Import a file into this attachment.  If you select this, an Open dialog box will open (see 
section “Open Dialog Box”).  Select/enter a location and file name and select Open (or double-
click on a file), and then the name of that file will appear to the right of the File button (see 
below).  If you import a file, you cannot scan a document from a TWAIN-compliant device (see 
above), and you cannot view the file in the Preview Area (see below).  If you have already 
scanned a document from a TWAIN-compliant device (see above), the File button is unavailable. 
 
To the right of the File button appears the name of the file that was imported using the File 
button (if applicable). 
 
Notes 
 
The expanded notes field can be used to store any information specific to this attachment.  See 
section “Notes Fields”. 
 
Preview Area 
 
At the bottom is the preview area which displays (one page of) the scanned document (see 
above).  Select a page number in the Page Number field above, and that page will be displayed in 
the Preview Area.  If the Page Number field shows 0, the Preview Area will be blank. 
 
You can use the - and + buttons (see above) to zoom out or zoom in the page in the Preview 
Area. 
 
If an image is displayed in the Preview Area, three numbers will appear in brackets in the 
Attachment window’s title bar, for example the title bar might say “Attachment (850x1100: 
124,103)”.  The first two numbers are the resolution (i.e. size, in dots/pixels) of the image 
displayed (first width, then height).  The third number is the size of the image in bytes.  (Note 
that when the image is saved in your database, it is encoded, and as a result its size increases by 
1/3.  For example, an image that is 124,103 bytes in size would occupy 165,471 bytes in your 
database.) 
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15.3.1 OCR Result Dialog Box 
 


 
 
… 
 


15.3.2 Select Source Dialog Box 
 


 
 
Lists all TWAIN-complaint devices (e.g. scanners, cameras) set up on your computer.  Select the 
device from which you wish to capture an image, and then select the Select button. 
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15.4 Delete an Attachment 
 
View/modify an attachment as per section “View/Modify an Attachment”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D. 
 


15.5 List Attachments 
 
Go in the File menu to List → Attachment (see section “Pull-Down Menus”), or go to List → 
Attachment in the Main Toolbar (see section “Main Toolbar”), or select List Attachment in the 
Action Bar (see section “Action Bar”). 
 


 
 
Toolbar 
 
Set Read/Unread – Change the status of the selected attachment to Read or Unread. 
 
Task – Opens a new Task window (see section “Task Window”) with the following properties: 


 The Patient field will be copied from the selected attachment to the Task window. 
 The Task window’s Re field will say “Attachment - ” followed by the Created field from 


the selected attachment. 
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 The Task window’s Notes field will say “Book an appointment for patient to review 
attachment of ” followed by the Created field from the selected attachment. 


This new task is not automatically saved.  You can choose to save the task, or close the Task 
window.  NOTE:  If a task has already been created based on this attachment, the existing task 
will be opened (instead of a new task being created). 
 
Provider – The provider whose attachments to display (required).  If you select this, a Find 
Provider dialog box will open (see section “Find Provider Dialog Box”).  Each provider will only 
be displayed once on the list, even providers that have more than one role (see section “Provider 
Window, Demographic Tab, Role List”).  Select a provider and then select OK or press F9, or 
double-click on a provider.  To clear this field, select Clear and then OK. 
 
Type – The type of attachments to display.  If this field is blank, attachments of all types 
(including no type) will be displayed.  If you select this, a Find (Attachment) Type dialog box 
will open (see section “Find (Attachment) Type Dialog Box”).  Select an attachment type and 
then select OK or press F9, or double-click on an attachment type.  To clear this field, select 
Clear and then OK. 
 
From – The minimum date for attachments to be displayed (see section “Date Fields”).  If this 
field is blank, all matching attachments before the To date (inclusive) will be displayed. 
 
To – The maximum date for attachments to be displayed (see section “Date Fields”).  If this field 
is blank, all matching attachments after the From date (inclusive) will be displayed. 
 
If both of the above fields are blank, all matching attachments will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) attachment displayed 
on the Attachment List.  This option is only available if 500 attachments are displayed on the 
Attachment List. 
 
Status – The status of attachments to display:  Unread, Read, or Archive 
 
Type – The priority of attachments to display:  Low, Normal, High, Abnormal, or All. 
 
Attachment List 
 
Lists all attachments that match the specified criteria (see section “Viewing a List of Items”).  
The Attachments window title bar will show (in brackets) the number of attachments displayed.  
If there are at least 500 attachments to display, only the most recent 500 attachments will be 
displayed, and the title bar will say “Attachments (500+)”.  To view older attachments, adjust the 
date in the “To” field, or select the “+” button. 
 
To view/modify an attachment, select the attachment and press Enter or F9, or double-click on 
the attachment (see section “Attachment Window”).  The fields are: 
 
Created – The Created field from the Attachment window (see section “Attachment Window”). 
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Type / Type Description – The Type field from the Attachment window (see section 
“Attachment Window”).  The Type Description field is not displayed by default. 
 
Source – The Source field from the Attachment window (see section “Attachment Window”). 
 
Description – The Description field from the Attachment window (see section “Attachment 
Window”). 
 
Name – The patient (last name, first initial) with whom the attachment is associated. 
 
Last – The last name of the patient with whom the attachment is associated.  This field is not 
displayed by default. 
 
First – The first name of the patient with whom the attachment is associated.  This field is not 
displayed by default. 
 
View Toolbar 
 
- – Zoom out the page in the Preview Area (see below). 
 
+ – Zoom in the page in the Preview Area (see below). 
 
Between the + and View buttons is the Page Number field.  This indicates which page of the 
scanned document to display in the Preview Area (see below).  If no document has been scanned, 
this field will be unavailable, and/or will show 0.  To enter a page number, type a positive integer 
using the keyboard, or use the up/down arrow buttons or arrow keys to increase or decrease the 
page number displayed. 
 
View… – Open the file that was imported into the attachment selected on the Attachment List 
(see above), whose file name appears in the file name field (see below).  (If that field is blank, 
the View button is unavailable.)  Windows will automatically choose an external program to 
open the file based on the extension at the end of the file name.  For example, if the file name 
ends with “.TXT”, Windows will most likely open it using a text editor such as Notepad.  For 
more information on file type associations, check your Windows help or documentation. 
 
To the right of the View button appears the name of the file that was imported into the 
attachment selected on the Attachment List (see above), if applicable. 
 
Notes 
 
Below the View Toolbar is the expanded notes field (if enabled).  This field displays the Notes 
field from the selected attachment on the list (see above).  If there are no attachments on the list, 
this field will be blank.  This field cannot be manually modified.  To change the notes field for 
an attachment, view/modify the attachment (see above).  See section “Notes Fields”. 
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Preview Area 
 
At the bottom is the preview area which displays (one page of) the scanned document (if an 
attachment which contains a scanned document has been selected on the Attachment List – see 
above).  Select a page number in the Page Number field in the View Toolbar above, and that 
page will be displayed in the Preview Area.  If the Page Number field shows 0, the Preview Area 
will be blank. 
 
You can use the - and + buttons in the View Toolbar above to zoom out or zoom in the page in 
the Preview Area. 
 


16 Billing Files (Batches, RAs, Error Claims) 


16.1 Create a Batch 
 
For providers that use EDT, batches are automatically created by the FMS (see section “Data 
Flow Structure”). 
 
To create a batch on disk: 
 


1. View/modify a provider (see section “View/Modify a Provider”). 
2. In the Provider window, on the Demographic tab (see section “Provider Window, 


Demographic Tab”), in the Provider toolbar, turn on “Prepare MRI Disk”. 
3. Go in the File menu to Save or Save and Close (see section “Pull-Down Menus”), or 


select Save or Save and Close in the Provider toolbar, or press Ctrl-S or Ctrl-L. 
4. Do a transmission (see section “Transmissions”).  When asked “Do you want to send 


Bills in this replication?”, select Yes. 
5. Open a Files window as per section “List Files”. 
6. Select Provider. 
7. A Find Provider dialog box will open (see section “Find Provider Dialog Box”).  


Select the desired provider and then select OK (or double-click on a provider). 
8. Select a batch, and then select Copy, or press Enter or F9 (or double-click on a batch). 
9. A Save As dialog box will open (see section “Save As Dialog Box”).  Save the batch 


onto a floppy disk (e.g. A:\HA000000.001). 
 
If you are sending disk(s) to MOHLTC, it is not recommended to put more than one batch on a 
disk, or to put a batch on a disk that contains any other files (you might want to use only blank 
disks for submitting batches).  Also, each disk should have a label that contains this information: 
 


 The MOHLTC office to which the disk will be sent (e.g. “MoH Toronto District Office 
D.O.”) 


 Provider’s name 
 Provider’s billing number (6 digits) or group identifier (4 characters) 
 Provider’s telephone number 
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 Number of bills and records – these numbers are included in the Description column in 
the File List in the Files window (see section “List Files”) 


 A date 
 A sequence number (e.g. “1 of 1”) 


 
To get a report on a batch, once the batch has been created (as above), select the batch in the 
Files window (see section “List Files”) and then run a report (see section “Run a Report”). 
 


16.2 Process an RA or Error Claims File 
 
Files received via EDT are automatically processed by the FMS (see section “Data Flow 
Structure”). 
 
If you receive an RA or error claims file via a different method (e.g. floppy disk), and that file 
was not also received via EDT: 
 


1. Open a Files window as per section “List Files”. 
2. Select Provider. 
3. A Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Select 


the desired provider and then select OK (or double-click on a provider).  For group-
related files, you can select any provider in the relevant group. 


4. Set the Type to MRO. 
5. Select Add. 
6. An Open dialog box will open (see section “Open Dialog Box”).  Select a file (e.g. 


“A:\PA000000.001”) and select Open (or double-click on a file). 
7. Do a transmission (see section “Transmissions”).  The file will be automatically 


processed by the FMS. 
 
To get a report on an RA or error claims file, once the file has been added to the Files list (as 
above), select the file in the Files window (see section “List Files”) and then run a report (see 
section “Run a Report”).  Also, RA reports can be run from the Provider window (see section 
“View/Modify a Provider”). 
 


16.3 List Files 
 
Go in the File menu to List → File (see section “Pull-Down Menus”), or go to List → File in the 
Main Toolbar (see section “Main Toolbar”), or select List File in the Action Bar (see section 
“Action Bar”). 
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Toolbar 
 
Provider – The provider whose files to display.  If you select this, a Find Provider dialog box 
will open (see section “Find Provider Dialog Box”).  Select a provider and then select OK 
 
From – The start of the date range for files to be displayed.  If this field is blank, all files before 
the To date (inclusive) will be displayed.  See section “Date Fields”. 
 
To – The end of the date range for files to be displayed.  If this field is blank, all files after the 
From date (inclusive) will be displayed.  See section “Date Fields”. 
 
If both of the above items are blank, all files will be displayed. 
 
+ – Adjust the date in the “To” field to equal the date from the last (oldest) file displayed on the 
File List.  This option is only available if 500 files are displayed on the File List. 
 
Type – Which type of files to display:  MRI (batches) or MRO (RAs and error claims). 
 
Copy – Copy a file from HERO™ CMS (e.g. onto a floppy disk), e.g. to send a batch to 
MOHLTC, or to forward an RA or error claims file to another office (that doesn’t use HERO™ 
CMS) for the same provider/group.  If you select this, a Save As dialog box will open (see 
section “Save As Dialog Box”). 
 
Add – Copy a file (e.g. RA, error claim file, batch acknowledgment, etc.) into HERO™ CMS 
(e.g. from a floppy disk) for processing.  (This option is only available if the Type is set to 
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MRO.)  The file will be sent to the FMS on your next transmission (see section “Transmissions”) 
and then processed by the FMS.  It is not necessary to add a file which the FMS has already 
received (or will be receiving), e.g. by EDT, or from another HERO™ CMS database for the 
same provider/group.  However, if the FMS receives the same file twice, it will ignore the 
duplicate.  If you select this, an Open dialog box will open (see section “Open Dialog Box”).  If 
you add an RA (filename starts with P), it will be automatically renamed such that the file’s 
extension (last 3 characters of the filename) indicates the year and month when the RA was 
generated (e.g. PA123456.00A would be an RA from January, 2000). 
 
File List 
 
Lists all billing files that match the specified criteria (see section “Viewing a List of Items”).  
The Files window title bar will show (in brackets) the number of files displayed.  If there are at 
least 500 files to display, only the most recent 500 files will be displayed, and the title bar will 
say “Files (500+)”.  To view older files, adjust the date in the “To” field, or select the “+” button. 
 
If you double-click on a file, or select a file and press F9, you can copy that file from HERO™ 
CMS (e.g. onto a floppy disk), e.g. to send a batch to MOHLTC (on disk), or to forward an RA 
or error claims file to another office (that doesn’t use HERO™ CMS) for the same 
provider/group.  If you select this, a Save As dialog box will open (see section “Save As Dialog 
Box”). 
 
Date – The date that the file was created (MRI) or received (MRO). 
 
Name – The name of the file, e.g. HA123456.001 or PB7890.002.  Filenames generally consist 
of: 
 


1. A letter indicating the type of file, e.g. “H” for a batch, “P” for an RA, “E” for an error 
claims file, “B” for a batch acknowledgment, etc. 


2. A letter indicating the month in which the file was created (A = January, B = February, C 
= March, D = April, E = May, F = June, G = July, H = August, I = September, J = 
October, K = November, L = December).  (For batch acknowledgments, this letter 
indicates the month in which the original batch was created, which is not necessarily the 
same month in which the batch acknowledgment was created.) 


3. The provider’s billing number (6 digits) or group identifier (4 characters).  Or, in the case 
of a batch acknowledgment, a 5-digit file identifier may be used instead. 


4. A period (dot). 
5. A 3-character file identifier (usually all digits).  For RA files, this file identifier will 


consist of 2 digits indicating the year and a letter indicating the month (the same letter as 
in #2 above).  For example, PA123456.00A would be an RA from January, 2000. 


 
Description – This field has 3 possible values: 


 For batches, this field will say “Batch” followed by two numbers in square brackets (e.g. 
“Batch [1 : 2]”) that indicate the number of bills and records in the file (these numbers 
must be written on the floppy disk label if sending to MOHLTC). 
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 For MRO files (e.g. RAs, error claims files) that were added through the Files window, 
this field will be blank. 


 If this field says “Non-HERO claims(s) in MRO”, then the file is an RA or error claims 
file which contains bills that were not billed from HERO™ CMS (or an RA that contain 
no claims at all).  Most likely, the file belongs to a provider or group which has multiple 
offices, and at least one of those offices does not use HERO™ CMS, and therefore might 
not be receiving the MRO files by EDT.  In this situation, one of the HERO™ CMS users 
that has access to that file must forward the file on to the office(s) that did not receive it.  
The most common way to do this is to select the Copy button (see above) and then save 
the file onto a portable disk (e.g. floppy disk, CD, etc.) and send that portable disk to the 
other office(s).  Or, the file can be sent through some other means, e.g. e-mail, etc.  Or, 
you can select a file and then run a report (see section “Run a Report”), and then forward 
the report output (based on the contents of that file) to the office(s) that did not receive it. 


 


17 Insurers 


17.1 Add an Insurer 
 
Go in the File menu to New → Setup → Insurer (see section “Pull-Down Menus”).  An Insurer 
window will open (see section “Insurer Window”). 
 


17.2 View/Modify an Insurer 
 
Go in the File menu to Open → Setup → Insurer (see section “Pull-Down Menus”).  A Find 
Insurer dialog box will open (see section “Find Insurer Dialog Box”).  Select an insurer and then 
select OK or press F9, or double-click on an insurer, and then an Insurer window will open.  See 
section “Insurer Window”. 
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17.3 Find Insurer Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Name – Insurer’s name. 
 
Other 
 
OK button – Chooses the selected insurer and closes the window.  If no insurers are displayed, 
searches for insurers that match the specified criteria, chooses the first one, and closes the 
window. 
 
New button – Add an insurer (see section “Insurer Window”). 
 
Cancel button – Closes the window without choosing an insurer. 
 
Clear button – Clears the insurer list and all fields in the “Criteria” section. 
 
Find button – Searches for insurers that match the specified criteria. 
 
Insurer List – Lists insurers that match the specified criteria (see section “Viewing a List of 
Items”).  Select an insurer and then select OK or press F9, or double-click on an insurer, to 
choose that insurer and close the window.  The Name field on this list corresponds to the Name 
field in the Insurer window (see section “Insurer Window”). 
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17.4 Insurer Window 
 


 
 
Toolbar 
 


New Insurer (Ctrl-N) – Add an insurer. 
 
Open Insurer (Ctrl-O) – View/modify an insurer.  If you select this, a Find Insurer dialog 
box will open (see section “Find Insurer Dialog Box”).  Select an insurer and then select 


OK or press F9, or double-click on an insurer. 
 


Save (Ctrl-S) – Save the insurer. 
 
Save and Close (Ctrl-L) – Save the insurer and close the Insurer window. 


 
Name Section 
 
Name – The insurer’s name. 
 
Address Section 
 
Line 1 – The first line of the insurer’s address. 
 
Line 2 – The second line of the insurer’s address. 
 
City – Insurer’s city. 
 
Postal – Insurer’s postal code. 
 
Province – Insurer’s province.  Choose a province abbreviation from the drop-down list box, or 
enter a province abbreviation (up to 2 characters). 
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Country – Insurer’s country.  Choose a country from the drop-down list box, or enter a country. 
 
Contact Section 
 
Primary – Insurer’s primary area code, exchange, telephone number, extension, and phone 
number type (e.g. work, home, fax, cellular, etc.). 
 
Other – Insurer’s secondary area code, exchange, telephone number, extension, and phone 
number type (e.g. work, home, fax, cellular, etc.). 
 


17.5 Delete an Insurer 
 
View/modify an insurer as per section “View/Modify an Insurer”, and then go in the File menu 
to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  Because the insurer may be in use, it will not actually 
be deleted from the database, but “hidden” such that it can not be used or found again. 
 


18 Reports 


18.1 Run a Report 
 
Before you can run a report, first you must open a context (the information on which the report is 
based).  For example, if you want a report based on a single record (e.g. provider, patient, 
appointment, bill, payment, etc.), first open the record (see section “View/Modify a Provider”, 
“View/Modify a Patient”, “View/Modify an Appointment”, “View/Modify a Bill”, 
“View/Modify a Payment”, etc.).  If you want a report based on a list of records (e.g. patients, 
appointments, bills, etc.), first open the list of records (see section “List Patients”, “List 
Appointments”, “List Bills”, etc.). 
 
Note that the report is based on the data in your database, not the information displayed on your 
screen.  If you have unsaved/outdated data on your screen, it is recommended to save and/or 
refresh the record(s) before running a report.  To save a record, go in the File menu to Save (see 
section “Pull-Down Menus”), or press Ctrl-S.  To refresh a record, go in the View menu to 
Refresh (see section “Pull-Down Menus”), or press F5, or select Refresh in the Main Toolbar 
(see section “Main Toolbar”). 
 
Next, choose how you want to handle the report output:  send via e-mail (see section “E-mail a 
Report”), fax (see section “Fax a Report”), print (see section “Print a Report”), preview (see 
section “Preview a Report”), or export (see section “Export a Report”). 
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18.1.1 E-mail a Report 
 
Before you e-mail a report, it is recommended that you specify an SMTP server and return e-
mail address in the Configuration window (see section “Configuration”).  If these fields are not 
specified, Windows may use defaults from an e-mail program such as Outlook Express. 
 
To e-mail a report, go in the File menu to E-mail (see section “Pull-Down Menus”), or select 
Print → E-mail in the Main Toolbar (see section “Main Toolbar”).  A Find Report dialog box 
will open (see section “Find Report Dialog Box (to run a report)”).  Select a report and then 
select OK or press F9, or double-click on a report, and then an E-mail dialog box will open: 
 


 
 
To – The primary recipient(s) of the e-mail.  You can enter any number of e-mail addresses, 
separated by commas (,) or semicolons (;).  You can type the e-mail addresses in this field.  Or, 
to add an e-mail address from a provider/patient record, select Provider or Patient.  A Find 
Provider or Find Patient dialog box will open (see section “Find Provider Dialog Box” or “Find 
Patient Dialog Box”).  Select a provider or patient and then select OK, or double-click on a 
provider or patient, and that provider’s/patient’s e-mail address will be added to the To field.  If 
the report was run from a Referral window (see section “Referral Window”), the e-mail address 
for the Referred provider (if available) will be automatically added to the recipient list. 
 
Cc – Any additional recipient(s) of the e-mail.  You can enter any number of e-mail addresses, 
separated by commas (,) or semicolons (;).  You can type the e-mail addresses in this field.  Or, 
to add an e-mail address from a provider/patient record, select Provider or Patient.  A Find 
Provider or Find Patient dialog box will open (see section “Find Provider Dialog Box” or “Find 
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Patient Dialog Box”).  Select a provider or patient and then select OK, or double-click on a 
provider or patient, and that provider’s/patient’s e-mail address will be added to the Cc field. 
 
Attach – The format (PDF = Adobe Acrobat, RTF = Rich Text Format) of the attachment, and a 
name for the attachment. 
 
Subject – The subject line of the e-mail. 
 
Between the Subject field and the OK/Cancel buttons is the message body field.  Enter the text to 
be included in the body of the e-mail.  This is a notes field, but it does not support the advanced 
features that are available in other notes fields (see section “Notes Fields”). 
 
OK – Send the e-mail. 
 
Cancel – Close the E-mail dialog box without sending e-mail. 
 


18.1.2 Fax a Report 
 
Before you fax a report, it is recommended that you specify values for the Fax Server and Cover 
fields in the Configuration window (see section “Configuration”). 
 
To fax a report, go in the File menu to Fax (see section “Pull-Down Menus”), or select Print → 
Fax in the Main Toolbar (see section “Main Toolbar”).  A Find Report dialog box will open (see 
section “Find Report Dialog Box (to run a report)”).  Select a report and then select OK or press 
F9, or double-click on a report, and then a Fax dialog box will open: 
 







 229


 
 
To – The recipient(s) of the fax.  You can enter any number of recipients, separated by 
semicolons (;).  Each recipient should contain a fax number, then a comma, then a space, and 
then a name (e.g. “9998887777, JOHN SMITH”).  Or, you can: 


 Select Provider.  A Find Provider dialog box will open (see section “Find Provider 
Dialog Box”).  Select a provider and then select OK, or double-click on a provider.  That 
provider’s name and secondary (“Other”) phone number will be added to the recipient 
list. 


 Select Patient.  A Find Patient dialog box will open (see section “Find Patient Dialog 
Box”).  Select a patient and then select OK, or double-click on a patient.  That patient’s 
name and phone number (where the Type is set to Fax – see section “Patient Window, 
Demographic Tab, Contact Section”) will be added to the recipient list. 


 Select Insurer.  A Find Insurer dialog box will open (see section “Find Insurer Dialog 
Box”).  Select an insurer and then select OK, or double-click on an insurer.  That 
insurer’s name and secondary (“Other”) phone number will be added to the recipient list. 


If the report was run from a Referral window (see section “Referral Window”), the name and 
secondary (“Other”) phone number for the Referred provider (if available) will be automatically 
added to the recipient list. 
 
Attach – The format for the fax.  The report output will be saved into a temporary file using that 
format.  The workstation computer must have a program that is capable of converting that file 
into a format that the Windows fax service (on the fax server computer) can handle.  For 
example, if the file is saved in Portable Document Format (PDF), Adobe Acrobat or Adobe 
Acrobat Reader will probably be used.  If the file is saved in Rich Text Format (RTF), a word 
processor such as WordPad (which comes with Windows), Microsoft Word, or WordPerfect will 
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probably be used.  (Your Windows configuration will determine which program is used.)  For 
more information, check the help or documentation for Windows or for any Windows 
application you have that can view and print PDF and/or RTF documents. 
 
Subject – The subject of the fax (will appear on the fax cover page). 
 
Between the Subject field and the OK/Cancel buttons is the message body field.  You can enter 
any text to be included in the cover page of the fax.  This is a notes field, but it does not support 
the advanced features that are available in other notes fields (see section “Notes Fields”). 
 
OK – Send the fax. 
 
Cancel – Close the Fax dialog box without sending the fax. 
 


18.1.3 Print a Report 
 
Go in the File menu to Print (see section “Pull-Down Menus”), or select Print → Print in the 
Main Toolbar (see section “Main Toolbar”), or press Ctrl-P.  A Find Report dialog box will open 
(see section “Find Report Dialog Box (to run a report)”).  Select a report and then select OK or 
press F9, or double-click on a report, and then the report will print according to the options in 
your printer setup (see section “Printer Setup”). 
 


18.1.4 Preview a Report 
 
Go in the File menu to Print Preview (see section “Pull-Down Menus”), or select Print → Print 
Preview in the Main Toolbar (see section “Main Toolbar”), or press Ctrl-Shift-P.  A Find Report 
dialog box will open (see section “Find Report Dialog Box (to run a report)”).  Select a report 
and then select OK or press F9, or double-click on a report, and then a Print Preview window 
will open: 
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Toolbar 
 


 Print – Print the document.  If you select this, a Print dialog box will open (see section 
“Print Dialog Box”).  Select the desired print options (e.g. printer, print range, copies) and then 
select OK to print the report. 
 


 Single Page View – View only one page at a time. 
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 Multiple Page View – Controls how many pages are displayed at a 
time.  If you click on this, you can select up to 2 x 3 pages.  If you click 
and hold the left mouse button, and drag the mouse down and to the right, 
you can select up to 2 x 5 pages. 
 


 Continuous Scroll – Enables “Continuous Scroll” mode, which allows 
you to “scroll” from one page to another (e.g. by using the scroll bar, or a scroll wheel on a 
mouse, or the up/down arrow keys) instead of using the Page Up or Page Down keys or the 
Previous Page or Next Page buttons (see below). 
 


 Zoom Out – Decrease magnification. 
 


 Zoom In – Increase magnification. 
 
Zoom Combo – Specify magnification.  Enter a percentage value from 10 to 800 
(will be automatically rounded off to the nearest whole number) and press Enter, 
or select a magnification from the drop-down list box:  10%, 25%, 50%, 75%, 
100%, 200%, 400%, 800%, Page Width (display the entire width of the page), or 
Whole Page (display the entire page).  Also, in a multiple page view (see 
Multiple Page View button above), changing the size of the window will 
automatically change the Zoom Combo setting.  If you enter a number less than 
10, it will automatically become 10%.  If you enter a number greater than 800, it 
will automatically become 800%. 
 


 Previous Page (PageUp) – Go back one page. 
 


 Next Page (PageDown) – Go forward one page. 
 
Current Page Number – Displays the current page number, and the total number of pages, 
separated by a slash (e.g. “1/2”).  Enter a page number in this field and press Enter to jump to 
that page. 
 


Annotations – Reserved for future use. 


 
Preview Area 
 
Displays the report output.  In a single page view (see Single Page View / Multiple Page View 
buttons above), if the document is bigger than the viewing window (depending on the Zoom 
Combo setting above, and the size of the window), you can move the document around with the 
scroll bars, or by clicking and dragging it with the left mouse button.  In a multiple page view 
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(see Single Page View / Multiple Page View buttons above), you can double-click on a page to 
display only that page.  You can also navigate by using the arrow keys: 
 
Keystroke Meaning 
Up Arrow, Page Up Go back one page. 
Down Arrow, Page Down Go forward one page. 
Home, Ctrl-Home Go to the first page. 
End, Ctrl-End Go to the last page. 


 


18.1.5 Export a Report 
 
Go in the File menu to Export, and then select a format:  PDF, RTF, Text (plain text, can be 
opened in a text editor or word processor), XLS, or XML.  See section “Pull-Down Menus”.  (It 
is recommended that only advanced users use the XML option.)  A Find Report dialog box will 
open (see section “Find Report Dialog Box (to run a report)”).  Select a report and then select 
OK or press F9, or double-click on a report, and then a Save As dialog box will open (see section 
“Save As Dialog Box”). 
 


18.1.6 Find Report Dialog Box (to run a report) 
 


 
 
See section “Searching for a Record”. 
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Criteria Section 
 
The Criteria section allows you to select options for the report output e.g. what records (e.g. 
patients, appointments, bills, payments, etc.) should be included in the report output, printer 
settings, etc.  Note:  selecting a report on the report list (see below) resets the fields in the 
Criteria section.  You must select the report before choosing options in the Criteria section. 
 
From – A minimum date or time for records (e.g. appointments, bills, payments, etc.) to be 
included in the report output (see section “Date Fields” or “Time Fields”).  This field only 
applies to certain reports.  You must select the report before entering a date/time in this field. 
 
To – A maximum date or time for records (e.g. appointments, bills, payments, etc.) to be 
included in the report output (see section “Date Fields” or “Time Fields”).  This field only 
applies to certain reports.  You must select the report before entering a date/time in this field. 
 
Query – Allows you to specify criteria to determine exactly which records (e.g. appointments, 
bills, payments, etc.) will be included in the report output.  If you select this, a Query dialog box 
will open (see section “Query Dialog Box”).  This field only applies to certain reports.  You must 
select the report before entering Query criteria. 
 
Letterhead – Indicates that you are printing on pre-printed letterhead, and thus the report should 
omit the local provider’s information (e.g. name, address, etc.) at the top of the page, but leave a 
blank space instead.  This option only applies to certain reports.  You must select the report 
before choosing this option.  This option is only available for printing and previewing, not for 
exporting, faxing, or e-mailing. 
 
Printer – Choose print options (e.g. printer, print range, copies).  If you select this, a Print dialog 
box will open (see section “Print Dialog Box”).  You must select the report before choosing print 
options.  This option is only available for printing, not for previewing, exporting, faxing, or e-
mailing. 
 
Other 
 
OK button – Chooses the selected report and closes the window.  If no reports are displayed, 
closes the window without choosing a report (no report is run). 
 
Cancel button – Closes the window without choosing a report (no report is run). 
 
Find button – Searches for reports for the current context. 
 
Report List 
 
Lists available reports for the current context (see section “Viewing a List of Items”).  Select a 
report and then select OK or press F9, or double-click on a report, to choose that report and close 
the window.  Note:  selecting a report resets the fields in the Criteria section (see above).  You 
must select the report before choosing options in the Criteria section. 
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The fields are: 
 
Name – A brief name for the report, e.g. “Appointment List”. 
 
# - The number of copies of the report that were printed (the last time the report was printed).  
This same number of copies will be printed the next time that report is printed, unless you 
specify a different number of copies in the Print dialog box (see section “Print Dialog Box”).  
This field is only displayed if the report will be printed (not previewed, exported, faxed, or e-
mailed). 
  
Description – A full description of the purpose/function of the report. 
 


18.1.7 Printer Setup 
 
Go in the File menu to Printer setup (see section “Pull-Down Menus”).  Or, from a Find Report 
dialog box (see section “Find Report Dialog Box (to run a report)”), select Printer.  A Print 
dialog box will open (see section “Print Dialog Box”). 
 


18.1.8 Print Dialog Box 
 


This is a standard 
Windows Print dialog box.  
Select the desired print 
options (e.g. printer, print 
range, copies) and select 
OK.  For more 
information, check your 
Windows (or printer) help 
or documentation. 
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18.2 Add a Report 
 
Go in the File menu to New → Setup → Report (see section “Pull-Down Menus”).  A Report 
Designer window will open (see section “Report Designer Window”). 
 


18.3 View/Modify a Report 
 
To view/modify a report in your database, go in the File menu to Open → Setup → Report (see 
section “Pull-Down Menus”).  A Find Report dialog box will open (see section “Find Report 
Dialog Box (to view/modify a report)”).  Select a report and then select OK or press F9, or 
double-click on a report, and then a Report Designer window will open.  See section “Report 
Designer Window”. 
 
To view/modify a report from a file, open a Report Designer window as per section “Add a 
Report” (or use the instructions above), and then select Open → File in the Report Designer 
toolbar (see section “Report Designer Window”). 
 


18.4 Find Report Dialog Box (to view/modify a report) 
 


 
 
See section “Searching for a Record”. 
 







 237


Criteria Section 
 
Name – The name of the report. 
 
Description – The report’s description. 
 
Context – The information on which the report is based.  For example, to see reports based on a 
single record, enter the type of the record (e.g. patient, appointment, bill, payment).  To see 
reports based on a list of records, enter the type of the record in plural (e.g. patients, 
appointments, bills).  NOTE:  If this field is used, only reports whose context exactly matches 
(not starts with) the text entered will be displayed.  For example, if you enter “PAT” or “PATI”, 
instead of “PATIENT” or “PATIENTS”, no matches will be found.  (You can use wildcards, for 
example “PAT*”.) 
  
Other 
 
OK button – Chooses the selected report and closes the window.  If no reports are displayed, 
searches for reports that match the specified criteria, chooses the first one, and closes the 
window. 
 
New button – Add a report (see section “Report Designer Window”). 
 
Cancel button – Closes the window without choosing a report. 
 
Clear button – Clears the report list and all fields in the “Criteria” section. 
 
Find button – Searches for reports that match the specified criteria. 
 
Report List – Lists reports that match the specified criteria (see section “Viewing a List of 
Items”).  Select a report and then select OK or press F9, or double-click on a report, to choose 
that report and close the window.  For a description of the fields, see section “Report Designer 
Window”. 
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18.5 Report Designer Window 
 


 
 
Because of the complexity of designing database reports, this manual does not include full 
documentation for creating/modifying reports.  It is recommended that only users with relevant 
experience create/modify HERO™ CMS reports.  For customized reports, contact HTN (see 
section “HTN”). 
 
It is recommended that you not modify a report that came with HERO™ CMS, since the report 
might be overwritten (and your changes lost) on a future transmission (see section 
“Transmissions”).  Instead, you can create a new report from scratch, or make a copy of an 
existing report (e.g. go in the File menu to Copy – see section “Pull-Down Menus”, or select 
Copy in the Main Toolbar – see section “Main Toolbar”), save it under a different name, and 
modify the copy. 
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Name – A brief name for the report, e.g. “Appointment List”.  If you want to view/modify a 
report, you can double-click in this field, and a Find Report dialog box will open (see section 
“Find Report Dialog Box (to view/modify a report)”).  Select a report and then select OK or 
press F9, or double-click on a report.  This field cannot be modified if the report has been saved. 
 
Context – The window from which the report can be run.  This field cannot be modified if the 
report has been saved.  Valid options are: 
 
Context Window Relevant Manual Section 
Internal The only Internal report is InvoiceStatus, which is automatically run when you 


go to the Status tab in a Bill window (see section “Bill Window, Status Tab”).  
Adding, modifying, or deleting reports of this context is not recommended. 


General This context is for testing purposes only.  Reports of this context cannot be 
run. 


Subreport This context is for reports that are run from other reports.  Reports of this 
context cannot be run directly. 


Appointment Appointment Window Appointment Window 
Attachment Attachment Window Attachment Window 
Bill Bill Window Bill Window 
Encounter Encounter Window Encounter Window 
Insurer Insurer Window Insurer Window 
Patient Patient Window Patient Window 
Payment Payment Window Payment Window 
Provider Provider Window Provider Window 
Referral Referral Window Referral Window 
Requisition Requisition Window Requisition Window 
Rx Rx Window Rx Window 
Appointments Appts. Window List Appointments 
Bills Bills Window List Bills 
Files Files Window List Files 
Labs Labs Window List Lab Results 
Patients Patients Window List Patients 
Recalls Recalls Window List Recalls 
Tasks Tasks Window List Tasks 
 
Data – What type of data to request from the database.  For example:  For a report based on an 
appointment (or list of appointments), select Appointment;  For a report based on a bill (or a list 
of bills), select Bill;  etc.  Valid options are:  None, Appointment, Attachment, Bill, BillItem, 
CodeUsage, Encounter, FileItem, Insurer, Lab, LabItem, MRO, OmdCds, Patient, Patients, 
Payment, Provider, Recalls, RecallsCompliance, Referral, Requisition, Rx, RxItem, 
ScheduleDay, Statement, Summary, Tasks, Generic. 
 
Description – A full description of the purpose/function of the report.  If you want to 
view/modify a report, you can double-click in this field, and a Find Report dialog box will open 
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(see section “Find Report Dialog Box (to view/modify a report)”).  Select a report and then select 
OK or press F9, or double-click on a report. 
 
Path – Which branch of the XML data tree should be used to trigger the main (e.g. “Detail”) 
section of the report.  For example, if this is set to “//Patient”, then the main section of the report 
will run once for each <Patient> section in the report’s XML data set. 
 
Override – Controls which SQL Stored Procedure is used to generate the XML data set for this 
report. 
 
All Data – Leave this option off for reports that only include a minimal data set, e.g. patient 
demographic information.  Turn this option on for reports that include a high level of detail, e.g. 
full electronic medical records for each patient. 
 
Date Range – Determines whether the user is allowed to specify a date range (see section “Find 
Report Dialog Box (to run a report)”) when running this report.  Generally, if this option is on, 
only records within the specified date range (e.g. patients’ birth dates, appointment start dates, 
bill dates, etc.) will be included in the report output. 
 
Query – If this option is on, the user is allowed to specify query criteria (see section “Query 
Dialog Box”) when running the report.  Only certain reports in the Provider context (see above) 
support queries. 
 
Toolbar 
 


New Report (Ctrl-N) – Add a report. 
 


Open → Database (Ctrl-O) – View/modify a report in your database.  If 
you select this, a Find Report dialog box will open (see section “Find 
Report Dialog Box (to view/modify a report)”).  Select a report and then 
select OK or press F9, or double-click on a report. 


 
Open → File – View/modify a report from a file.  If you select this, an Open dialog box will 
open (see section “Open Dialog Box”). 
 


Save → Database (Ctrl-S) – Save the report to your database. 
 
Save → File – Save the report to a file.  If you select this, a Save As 
dialog box will open (see section “Save As Dialog Box”). 


 
Save and Close (Ctrl-L) – Save the report to your database and close the Report Designer 


window. 
 
The rest of the buttons in the Report toolbar are used to control the size and position of the fields 
in the report, and are not documented in this manual. 
 







 241


18.6 Delete a Report 
 
View/modify a report as per section “View/Modify a Report”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  It is recommended that you not delete any report that 
came with HERO™ CMS, or any subreport which is run from another report. 
 


19 Templates 


19.1 Add a Template 
 
Go in the File menu to New → Setup → Template (see section “Pull-Down Menus”).  A 
Template window will open (see section “Template Window”). 
 


19.2 View/Modify a Template 
 
Go in the File menu to Open → Setup → Template (see section “Pull-Down Menus”).  A Find 
Template dialog box will open (see section “Find Template Dialog Box”).  Select a template and 
then select OK or press F9, or double-click on a template, and then a Template window will 
open.  See section “Template Window”. 
 


19.3 Find Template Dialog Box 
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See section “Searching for a Record”. 
 
Criteria Section 
 
Name – The template’s name. 
 
Description – A full description of the template. 
 
Context – Indicates whether the template is used for referrals, recalls, or notes.  If the Find 
Template dialog box was launched from the Template field in a Referral window (see section 
“Referral Window”), the Context field will not be displayed, and only templates of context 
Referral will be displayed.  If the Find Template dialog box was launched from a Notes field (see 
section “Notes Fields”), the Context field will not be displayed, and only templates of context 
Notes will be displayed.  If the Find Template dialog box was launched from a Recalls window 
(see section “List Recalls”), the Context field will not be displayed, and only templates of 
context Recalls will be displayed. 
 
Other 
 
OK button – Chooses the selected template and closes the window.  If no templates are 
displayed, searches for templates that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a template (see section “Template Window”). 
 
Cancel button – Closes the window without choosing a template. 
 
Clear button – Clears the template list and all fields in the “Criteria” section. 
 
Find button – Searches for templates that match the specified criteria. 
 
Template List – Lists templates that match the specified criteria (see section “Viewing a List of 
Items”).  If the Find Template dialog box was launched from a Referral window (see section 
“Referral Window”), Recalls window (see section “List Recalls”), or Notes field (see section 
“Notes Fields”), the Context column will not be displayed, and only templates for that context 
(Referral, Recall, or Notes) will be displayed.  Select a template and then press Enter or F9, or 
double-click on a template, to choose that template and close the window.  For a description of 
the fields, see section “Template Window”. 
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19.4 Template Window 
 


 
 
Toolbar 
 


New Template (Ctrl-N) – Add a template. 
 
Open Template (Ctrl-O) – View/modify a template.  If you select this, a Find Template 
dialog box will open (see section “Find Template Dialog Box”).  Select a template and then 


select OK or press F9, or double-click on a template. 
 


Save (Ctrl-S) – Save the template. 
 
Save and Close (Ctrl-L) – Save the template and close the Template window. 


 
Other 
 
Name – A brief name for the template.  (If the Context field is set to Recall, the name should be 
COL, FLU, IMM, MAM, or PAP.)  NOTE:  This field cannot be modified if the template has 
been saved.  If you need to modify this field, you must add a new template (see section “Add a 
Template”), and, if desired, delete the old template (see section “Delete a Template”).  If you 
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want to view/modify a template, you can double-click in this field, and a Find Template dialog 
box will open (see section “Find Template Dialog Box”).  Select a template and then select OK 
or press F9, or double-click on a template. 
 
Context – Choose one of these options from the drop-down list box: 


 Notes:  Indicates that the contents of this template can be pasted into any Notes field (see 
section “Notes Fields, Templates”). 


 Recall:  Indicates that the contents of this template can be included in a report run from 
the Recalls window (see section “List Recalls” or “Run a Report”).  The name of the 
template (see above) must match the recall type (see section “Recall Types”) selected in 
the Type field. 


 Referral:  Indicates that the contents of this template can be included in a report run from 
a Referral window, if this template is selected in the Template field in the Referral 
window.  See section “Referral Window” or “Run a Report”. 


 
Description – A description/summary of the template.  If you want to view/modify a template, 
you can double-click in this field, and a Find Template dialog box will open (see section “Find 
Template Dialog Box”).  Select a template and then select OK or press F9, or double-click on a 
template. 
 
Keyword – Selecting an item from this list will automatically insert that item into the Template 
Text field below (at the insertion point).  This function is only available if the Context field is set 
to Notes (see above).  Available items are: 
 
Description Text to be Inserted Relevant Manual Section 
@LASTNAME @LASTNAME 
@FIRSTNAME @FIRSTNAME 
@MIDDLENAME @MIDDLENAME 
@TITLE @TITLE 
@SEX @SEX 
@BIRTHDATE @BIRTHDATE 
@AGE @AGE 
@HESHE @HESHE 
@HESHEUCASE @HESHEUCASE 
@HIMHER @HIMHER 
@HISHER @HISHER 
@HISHERUCASE @HISHERUCASE 
@DATE @DATE 
@DATEDOCUMENT @DATEDOCUMENT 
@TIME @TIME 
@USER @USER 
@DOMAIN @DOMAIN 


Notes Fields, Templates 


: + space :  
: + CRLF : (plus a new line) 
* * 


Notes Fields, Insertion 
Point Positioning 
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[ [ 
] ] 
| | 


Notes Fields, Choice Lists 


_ _ Notes Fields, Templates 
Date: + space Date:  Notes Fields, Codes 
Field -> Alpha : __________ (the underscores are 


in Lucida Console font, 9 point) 
Field -> Numeric : _____ (the underscores are in 


Courier New font, 10 point) 
Field -> Y/N : _ (the underscore is in Lucida 


Console font, 10 point) 


Notes Fields, Data Entry 
Fields 


LookUp -> Alert Alert: 
LookUp -> Allergy Allergy: 
LookUp -> Contact Contact: 
LookUp -> Diagnosis Diagnosis: 
LookUp -> Drug Drug: 
LookUp -> Facility Facility: 
LookUp -> Immunization Immunization: 
LookUp -> Location Location: 
LookUp -> Problem Problem: 
LookUp -> Procedure Procedure: 
LookUp -> Re (Appt.) Re (Appt.): 
LookUp -> Re (Encnt.) Re (Encnt.): 
LookUp -> Reaction Reaction: 
LookUp -> Recall Recall: 
LookUp -> Relation Relation: 
LookUp -> Risk Risk: 
LookUp -> SIG SIG: 
LookUp -> Test Test: 
LookUp -> Treatment Treatment: 
LookUp -> Type (Appt.) Type (Appt.): 
LookUp -> Type (Attach.) Type (Attach.): 
LookUp -> Type (Encnt.) Type (Encnt.): 


Notes Fields, Codes 


Weight (kg): Weight (kg): ______ 
Height (m): Height (m): ______ 
Temperate (C): Temperate (C): _____ 
Blood Pressure – Systolic 
(mmHg): 


Blood Pressure – Systolic 
(mmHg): ___ 


Blood Pressure – Diastolic 
(mmHg): 


Blood Pressure – Diastolic 
(mmHg): ___ 


Heart Rate (BPM): Heart Rate (BPM): ___ 
Respiratory Rate (RPM): Respiratory Rate (RPM): ___ 
Head Circumference (cm): Head Circumference (cm): _____ 
Waist (cm): Waist (cm): ______ 
Length (cm): Length (cm): ______ 


Notes Fields, Data Entry 
Fields (the underscores 
are in Courier New font, 
10 point) 







 246


 
Def. – In the Template Text field below, set the selected text, or the text about to be inserted at 
the insertion point’s current location, to Microsoft Sans Serif font, Regular font style, point size 
8, no effects (Strikeout or Underline), and script Western.  See section “Notes Fields, Rich Text 
Format”.  Text of this font will not be considered a Data Entry Field (see section “Notes Fields, 
Data Entry Fields”).  This function is only available if the Context field is set to Notes (see 
above). 
 
AAA – In the Template Text field below, set the selected text, or the text about to be inserted at 
the insertion point’s current location, to Lucida Console font, Regular font style, point size 9, no 
effects (Strikeout or Underline), and script Western, in order to create an Alphanumeric Data 
Entry Field (see section “Notes Fields, Data Entry Fields”).  This function is only available if the 
Context field is set to Notes (see above). 
 
999 – In the Template Text field below, set the selected text, or the text about to be inserted at 
the insertion point’s current location, to Courier New font, Regular font style, point size 10, no 
effects (Strikeout or Underline), and script Western, in order to create a Numeric Data Entry 
Field (see section “Notes Fields, Data Entry Fields”).  This function is only available if the 
Context field is set to Notes (see above). 
 
Y/N – In the Template Text field below, set the selected text, or the text about to be inserted at 
the insertion point’s current location, to Lucida Console font, Regular font style, point size 10, 
no effects (Strikeout or Underline), and script Western, in order to create a Checkbox Data Entry 
Field (see section “Notes Fields, Data Entry Fields”).  This function is only available if the 
Context field is set to Notes (see above). 
 
LookUp – In the Template Text field below, set the selected text, or the text about to be inserted 
at the insertion point’s current location, to Microsoft Sans Serif font, Regular font style, point 
size 8, Underline on, Strikeout off, and script Western, in order to create a Code Type (see 
section “Notes Fields, Codes”).  This function is only available if the Context field is set to Notes 
(see above). 
 
Template Text 
 
At the bottom is the Template Text field, which contains the actual contents of the template.  
This field is a Notes field (see section “Notes Fields”) which supports the following features: 
 


 You can use insertion point positioning (see section “Notes Fields, Insertion Point 
Positioning”). 


 You can use Choice Lists (see section “Notes Fields, Choice Lists”), but you cannot press 
Enter (or double-click, or right-click and select Enter Action) to confirm an option, or 
press Delete (or right-click and select Delete Action) to delete an entire Choice List. 


 You can use codes (see section “Notes Fields, Codes”). 
 You can insert a template into this field, but no “keyword replacement” will be done (see 


section “Notes Fields, Templates”). 
 You can use Rich Text Format (see section “Notes Fields, Rich Text Format”). 
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 You can use the Context Menu (see section “Notes Fields, Context Menu”), but not the 
LookUp or Insert sub-menu in the Context Menu. 


 You cannot use Data Entry Fields (see section “Notes Fields, Data Entry Fields”). 
 


19.5 Delete a Template 
 
View/modify a template as per section “View/Modify a Template”, and then go in the File menu 
to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  Because the template may be in use, it will not 
actually be deleted from the database, but “hidden” such that it can not be used or found again. 
 


20 Colours 
 
When viewing a list of items (see section “Viewing a List of Items”), some items may appear in 
different colours, depending on their status, date, type, etc.  This feature is optional.  You can 
choose between these three colour statuses: 
 


 No colours.  For this, disable “Color On/Off” in the View menu (see section “Pull-Down 
Menus”) or Main Toolbar (see section “Main Toolbar”). 


 All lists will have colours, even “homogenous” lists where every item is the same colour 
(e.g. because every item has the same status, date, type, etc.).  For this, enable “Color 
On/Off” and “Color All Views” in the View menu (see section “Pull-Down Menus”) or 
Main Toolbar (see section “Main Toolbar”). 


 Only “heterogeneous” lists, where items can have different colours (e.g. because they 
might have different statuses, dates, types, etc.), will have colours.  For this, enable 
“Color On/Off,” but disable “Color All Views,” in the View menu (see section “Pull-
Down Menus”) or Main Toolbar (see section “Main Toolbar”).  This is the default 
setting. 


 
The following items can have colours: 
 
Code Description Where It’s Used 
ALERT-ACT Alert (Active) 
ALERT-INACT Alert (Inactive) 


Patient Window, Alert Tab 


ALLERGY-MILD Allergy (Mild) 
ALLERGY-MOD Allergy (Moderate) 
ALLERGY-SEVERE Allergy (Severe) 


Patient Window, Allergy Tab 


APPT-ACT Appointment (Active) Patient Window, Appt. Tab 
APPT-HIGH Appointment (High Priority) Appts. Window, Day Tab 
APPT-INACT Appointment (Inactive) Patient Window, Appt. Tab 
APPTS-ARRIVED Appointment Status (Arrived) 
APPTS-CANCELLED Appointment Status (Cancelled) 
APPTS-CLOSED Appointment Status (Closed) 
APPTS-CLOSED/N. Appointment Status (Closed/N.S.) 


Appts. Window, Day Tab 
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APPTS-COMPLETED Appointment Status (Completed) 
APPTS-CONFIRMED Appointment Status (Confirmed) 
APPTS-EXAMINING Appointment Status (Examining) 
APPTS-NO SHOW Appointment Status (No Show) 
APPTS-RESCHEDUL Appointment Status (Reschedule) 
APPTS-TO CONFIR Appointment Status (To Confirm) 
ATT-ABNOR-ACT Attachment Abnormal Priority (Active) 
ATT-ABNOR-INAC Attachment Abnormal Priority (Inactive) 
ATT-HIGH-ACT Attachment High Priority (Active) 
ATT-HIGH-INACT Attachment High Priority (Inactive) 
ATT-LOW-ACT Attachment Low Priority (Active) 
ATT-LOW-INACT Attachment Low Priority (Inactive) 
ATT-NORM-ACT Attachment Normal Priority (Active) 
ATT-NORM-INACT Attachment Normal Priority (Inactive) 


Patient Window, Attach. Tab 
Attachments Window 


BILL-HCP Bill (HCP) 
BILL-INSURER Bill (Insurer) 
BILL-PRIVATE Bill (Private) 
BILL-WSIB Bill (WSIB) 


Patient Window, Bill Tab 
Bills Window 


ENCOUNTER-ACT Encounter (Active) 
ENCOUNTER-INACT Encounter (Inactive) 


Patient Window, Encounter Tab 
Encounters Window 


LAB-ABNOR-ACT Lab Abnormal (Active) 
LAB-ABNOR-INACT Lab Abnormal (Inactive) 
LAB-NORM-ACT Lab Normal (Active) 
LAB-NORM-INACT Lab Normal (Inactive) 


Patient Window, Lab Tab 
Labs Window 


PROB-ACT Problem (Active) 
PROB-ICD9-ACT Problem ICD-9 (Active) 
PROB-ICD9-INACT Problem ICD-9 (Inactive) 
PROB-INACT Problem (Inactive) 
PROB-MOH-ACT Problem MOHFEE (Active) 
PROB-MOH-INACT Problem MOHFEE (Inactive) 
PROB-UDF-ACT Problem UDF (Active) 
PROB-UDF-INACT Problem UDF (Inactive) 


Patient Window, Problem Tab 


PROGRESS-ACT Progress (Active) 
PROGRESS-INACT Progress (Inactive) 


Patient Window, Prog. Tab 


RECALL-ACT Recall (Active) 
RECALL-INACT Recall (Inactive) 
RECALL-OVER Recall Overdue 


Patient Window, Recall Tab 
Recalls Window 


REFERRAL-ACT Referral  (Active) 
REFERRAL-INACT Referral (Inactive) 


Patient Window, Ref. Tab 


REQ-ACT Requisition (Active) 
REQ-INACT Requisition (Inactive) 


Patient Window, Requisition Tab 


RISK-ACT Risk (Active) 
RISK-INACT Risk (Inactive) 


Patient Window, Risk Tab 


RX-ACT Rx (Active) 
RX-INACT Rx (Inactive) 


Patient Window, Rx Tab 
Rxs Window 


TASK-HIGH-ACT Task High Priority (Active) 
TASK-HIGH-INACT Task High Priority (Inactive) 
TASK-LOW-ACT Task Low Priority (Active) 


Patient Window, Task Tab 
Tasks Window 
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TASK-LOW-INACT Task Low Priority (Inactive) 
TASK-NORM-ACT Task Normal Priority (Active) 
TASK-NORM-INACT Task Normal Priority (Inactive) 


 
Also, appointment types can be associated with colours.  See section “(Appointment) Type 
Window”. 
 


20.1 View/Modify a Colour 
 
Go in the File menu to Open → Setup → Color (see section “Pull-Down Menus”).  A Find Color 
dialog box will open (see section “Find Color Dialog Box”).  Select a colour and then select OK 
or press F9, or double-click on a colour, and then a Color window will open.  See section “Color 
Window”. 
 


20.2 Find Color Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – A short description of the type of item with which the colour is associated. 
 
Description – A full description of the type of item with which the colour is associated. 
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Other 
 
OK button – Chooses the selected colour and closes the window.  If no colours are displayed, 
searches for colours that match the specified criteria, chooses the first one, and closes the 
window. 
 
Cancel button – Closes the window without choosing a colour. 
 
Clear button – Clears the colour list and all fields in the “Criteria” section. 
 
Find button – Searches for colours that match the specified criteria. 
 
Colour List – Lists colours that match the specified criteria (see section “Viewing a List of 
Items”).  Select a colour and then press Enter or F9, or double-click on a colour, to choose that 
colour and close the window. 
 


20.3 Color Window 
 


 
 
Toolbar 
 


Open Code (Ctrl-O) – View/modify a colour.  If you select this, a Find Color dialog box 
will open (see section “Find Color Dialog Box”).  Select a colour and then select OK or 


press F9, or double-click on a colour. 
 


Save (Ctrl-S) – Save the colour. 
 
Save and Close (Ctrl-L) – Save the colour and close the Color window. 


 
Other 
 
Code – A short description of the type of item with which the colour is associated.  NOTE:  This 
field cannot be manually modified. 
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Description – A full description of the type of item with which the colour is associated.  If you 
want to view/modify a colour, you can double-click in this field, and a Find Color dialog box 
will open (see section “Find Color Dialog Box”).  Select a colour and then select OK or press F9, 
or double-click on a colour. 
 
Color – The colour associated with the selected type of item.  If you select this, a Color dialog 
box will open (see section “Color Dialog Box”). 
 


20.4 Color Dialog Box 
 


This is a standard Windows Color dialog box.  Select the 
desired colour and then select OK.  For more information, 
check your Windows help or documentation. 


 


21 Diagnosis Codes 
 
HERO™ CMS usually comes with a database of standard diagnosis codes from MOHLTC. 
 


21.1 Add a Diagnosis Code 
 
Go in the File menu to New → Setup → Code → Diagnosis (see section “Pull-Down Menus”).  
A Diagnosis window will open (see section “Diagnosis Window”). 
 


21.2 View/Modify a Diagnosis Code 
 
Go in the File menu to Open → Setup → Code → Diagnosis (see section “Pull-Down Menus”).  
A Find Diagnosis dialog box will open (see section “Find Diagnosis Dialog Box”).  Select a 
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diagnosis code and then select OK or press F9, or double-click on a diagnosis code, and then a 
Diagnosis window will open.  See section “Diagnosis Window”. 
 


21.3 Find Diagnosis Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The diagnosis code. 
 
Description – A description of the diagnosis. 
 
Other 
 
OK button – Chooses the selected diagnosis code and closes the window.  If no diagnosis codes 
are displayed, searches for diagnosis codes that match the specified criteria, chooses the first one, 
and closes the window. 
 
New button – Add a diagnosis code (see section “Diagnosis Window”). 
 
Cancel button – Closes the window without choosing a diagnosis code. 
 
Clear button – Clears the diagnosis code list and all fields in the “Criteria” section. 
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Find button – Searches for diagnosis codes that match the specified criteria. 
 
Diagnosis Code List – Lists diagnosis codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select a diagnosis code and then press Enter or F9, or double-click 
on a diagnosis code, to choose that diagnosis code and close the window. 
 


21.4 Diagnosis Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a diagnosis code. 
 
Open Code (Ctrl-O) – View/modify a diagnosis code.  If you select this, a Find Diagnosis 
dialog box will open (see section “Find Diagnosis Dialog Box”).  Select a diagnosis code 


and then select OK or press F9, or double-click on a diagnosis code. 
 


Save (Ctrl-S) – Save the diagnosis code. 
 
Save and Close (Ctrl-L) – Save the diagnosis code and close the Diagnosis window. 


 
Other 
 
Code – The diagnosis code.  NOTE:  This field cannot be modified if the diagnosis code has 
been saved.  If you need to modify this field, you must add a new diagnosis code (see section 
“Add a Diagnosis Code”), and, if desired, delete the old diagnosis code (see section “Delete a 
Diagnosis Code”).  If you want to view/modify a diagnosis code, you can double-click in this 
field, and a Find Diagnosis dialog box will open (see section “Find Diagnosis Dialog Box”).  
Select a diagnosis code and then select OK or press F9, or double-click on a diagnosis code. 
 
Description – A description of the diagnosis.  If you want to view/modify a diagnosis code, you 
can double-click in this field, and a Find Diagnosis dialog box will open (see section “Find 
Diagnosis Dialog Box”).  Select a diagnosis code and then select OK or press F9, or double-click 
on a diagnosis code. 
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21.5 Delete a Diagnosis Code 
 
View/modify a diagnosis code as per section “View/Modify a Diagnosis Code”, and then go in 
the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar 
(see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the diagnosis code may be in 
use, it will not actually be deleted from the database, but “hidden” such that it can not be used or 
found again. 
 


22 Procedure Codes 
 
HERO™ CMS usually comes with a database of standard procedure codes from MOHLTC. 
 


22.1 Add a Procedure Code 
 
Go in the File menu to New → Setup → Code → Procedure (see section “Pull-Down Menus”).  
A Procedure window will open (see section “Procedure Window”). 
 


22.2 View/Modify a Procedure Code 
 
Go in the File menu to Open → Setup → Code → Procedure (see section “Pull-Down Menus”).  
A Find Procedure dialog box will open (see section “Find Procedure Dialog Box”).  Select a 
procedure code and then select OK or press F9, or double-click on a procedure code, and then a 
Procedure window will open.  See section “Procedure Window”. 
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22.3 Find Procedure Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The procedure code. 
 
Description – A full description of the procedure. 
 
Other Fields 
 
OK button – Chooses the selected procedure code and closes the window.  If no procedure 
codes are displayed, searches for procedure codes that match the specified criteria, chooses the 
first one, and closes the window. 
 
New button – Add a procedure code (see section “Procedure Window”). 
 
Cancel button – Closes the window without choosing a procedure code. 
 
Clear button – Clears the procedure code list and all fields in the “Criteria” section. 
 
Find button – Searches for procedure codes that match the specified criteria. 
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Procedure Code List – Lists procedure codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select a procedure code and then select OK or press F9, or double-
click on a procedure code, to choose that procedure code and close the window. 
 


22.4 Procedure Window 
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Toolbar 
 


New Code (Ctrl-N) – Add a procedure code. 
 
Open Code (Ctrl-O) – View/modify a procedure code.  If you select this, a Find Procedure 
dialog box will open (see section “Find Procedure Dialog Box”).  Select a procedure code 


and then select OK or press F9, or double-click on a procedure code. 
 


Save (Ctrl-S) – Save the procedure code. 
 
Save and Close (Ctrl-L) – Save the procedure code and close the Procedure window. 


 
Other 
 
Code – The procedure code.  NOTE:  This field cannot be modified if the procedure code has 
been saved.  If you need to modify this field, you must add a new procedure code (see section 
“Add a Procedure Code”), and, if desired, delete the old procedure code (see section “Delete a 
Procedure Code”).  If you want to view/modify a procedure code, you can double-click in this 
field, and a Find Procedure dialog box will open (see section “Find Procedure Dialog Box”).  
Select a procedure code and then select OK or press F9, or double-click on a procedure code. 
 
Description – A full description of the procedure.  If you want to view/modify a procedure code, 
you can double-click in this field, and a Find Procedure dialog box will open (see section “Find 
Procedure Dialog Box”).  Select a procedure code and then select OK or press F9, or double-
click on a procedure code. 
 
Current Section 
 
General – The amount to bill in an HCP/WSIB bill if the procedure code suffix is A (see section 
“Unit Price and Quantity Fields”) and the service date is greater than (or equal to) the date shown 
in the Historic section (see below). 
 
Speciality – The amount to bill in an HCP/WSIB bill if the procedure code suffix is A and the 
General amount is zero (see section “Unit Price and Quantity Fields”) and the service date is 
greater than (or equal to) the date shown in the Historic section (see below). 
 
Technical – The amount to bill in an HCP/WSIB bill if the procedure code suffix is B and the 
Base Technical value is zero (see section “Unit Price and Quantity Fields”) and the service date 
is greater than (or equal to) the date shown in the Historic section (see below). 
 
Professional – The amount to bill in an HCP/WSIB bill if the procedure code suffix is C and the 
Base Professional value is zero (see section “Unit Price and Quantity Fields”) and the service 
date is greater than (or equal to) the date shown in the Historic section (see below). 
 
Private – The amount to bill in a Private/Insurer bill (see section “Unit Price and Quantity 
Fields”). 
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Base Technical – The default number of units billable if the procedure code suffix is B (see 
section “Bill Window, Invoice Tab, Service Item List, Quantity field”) and the service date is 
greater than (or equal to) the date shown in the Historic section (see below). 
 
Base Professional – The default number of units billable if the procedure code suffix is C (see 
section “Bill Window, Invoice Tab, Service Item List, Quantity field”) and the service date is 
greater than (or equal to) the date shown in the Historic section (see below). 
 
Premium % – Indicates that the amount to bill should not be a flat rate, but instead should be 
calculated as a percentage of the service items above it in the bill (service items below the 
premium code are not included in the premium calculation).  This field indicates the percentage 
plus 100, e.g. enter 150 for a 50% premium (if you enter 100 or less, no premium calculation will 
be done).  For example, if a bill contains items billed at $100.00 and $200.00, and then an item 
with a 50% premium, the premium code will bill $150.00, which is 50% of $300.00 ($100.00 
plus $200.00).  If the relevant fixed dollar amount listed above (General, Speciality, Technical, 
Professional, or Private) is greater than the amount produced by the premium calculation (e.g. 
$150.00 in this example), then the flat rate amount will be used instead.  For example, in a 
Private/Insurer bill, if the premium is calculated at $150.00 (e.g. 50% of $300.00), and the 
Private field above shows $175.00, then $175.00 will be billed instead of $150.00.  This field 
will only be used in service items in which the service date is greater than (or equal to) the date 
shown in the Historic section (see below). 
 
Historic Section 
 
General – The amount to bill in an HCP/WSIB bill if the procedure code suffix is A (see section 
“Unit Price and Quantity Fields”) and the service date is earlier than the date shown in the 
Historic section (see below). 
 
Speciality – The amount to bill in an HCP/WSIB bill if the procedure code suffix is A and the 
General amount is zero (see section “Unit Price and Quantity Fields”) and the service date is 
earlier than the date shown in the Historic section (see below). 
 
Technical – The amount to bill in an HCP/WSIB bill if the procedure code suffix is B and the 
Base Technical value is zero (see section “Unit Price and Quantity Fields”) and the service date 
is earlier than the date shown in the Historic section (see below). 
 
Professional – The amount to bill in an HCP/WSIB bill if the procedure code suffix is C and the 
Base Professional value is zero (see section “Unit Price and Quantity Fields”) and the service 
date is earlier than the date shown in the Historic section (see below). 
 
Date – The date on which the current prices (in the Current section) for this procedure code 
came into effect.  Before that date, the historic prices (in the Historic section) were used.  See 
section “Unit Price and Quantity Fields”. 
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Base Technical – The default number of units billable if the procedure code suffix is B (see 
section “Bill Window, Invoice Tab, Service Item List, Quantity field”) and the service date is 
earlier than the date shown in the Historic section (see above). 
 
Base Professional – The default number of units billable if the procedure code suffix is C (see 
section “Bill Window, Invoice Tab, Service Item List, Quantity field”) and the service date is 
earlier than the date shown in the Historic section (see above). 
 
Premium % – Indicates that the amount to bill should not be a flat rate, but instead should be 
calculated as a percentage of the service items above it in the bill (service items below the 
premium code are not included in the premium calculation).  This field indicates the percentage 
plus 100, e.g. enter 150 for a 50% premium (if you enter 100 or less, no premium calculation will 
be done).  For example, if a bill contains an item billed at $100.00, and then an item billed at 
$200.00, and then an item with a 50% premium, the premium code will bill $150.00, which is 
50% of $300.00 ($100.00 plus $200.00).  If the relevant fixed dollar amount listed above 
(General, Speciality, Technical, Professional, or Private) is greater than the amount produced by 
the premium calculation (e.g. $150.00 in this example), then the flat rate amount will be used 
instead.  For example, in a Private/Insurer bill, if the premium is calculated at $150.00 (e.g. 50% 
of $300.00), and the Private field above shows $175.00, then $175.00 will be billed instead of 
$150.00.  This field will only be used in service items in which the service date is earlier than the 
date shown in the Historic section (see above). 
 
Restrict Section 
 
Count – Specifies the maximum number of times that this procedure code can be used (for the 
same patient) in a certain period of time (specified in the Period field).  For example, if the Count 
field shows 1, and the Period field shows 7, then each patient can only have this procedure once 
per week.  Must be a whole number from 0 to 999. 
 
Period – The number of days in which this procedure code can only be used (for the same 
patient) a certain number of times (specified in the Count field).  For example, if the Count field 
shows 1, and the Period field shows 7, then each patient can only have this procedure once per 
week.  Must be a whole number from 0 to 999. 
 
Stay – The maximum number of days a patient can be admitted to a facility before having this 
procedure (calculated based on the difference between the Admitted date in the bill and the date 
in the service item).  Must be a whole number from 0 to 999. 
 
Age Section 
 
Min. Years – The minimum age of the patient (in years) who can have this procedure.  Must be 
a whole number from 0 to 999. 
 
Max. Years – The maximum age of the patient (in years) who can have this procedure.  Must be 
a whole number from 0 to 999. 
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Max. Days – The maximum age of the patient (in days) who can have this procedure.  Must be a 
whole number from 0 to 999. 
  
Required Section 
 
Diagnosis – Prevents this procedure code from being used in any service item that does not have 
a diagnosis code. 
 
Facility – Prevents this procedure code from being used in any bill that does not have a facility 
chosen. 
 
Admitted – Prevents this procedure code from being used in any bill that does not specify the 
date that the patient was admitted to the facility. 
 
Referring – Prevents this procedure code from being used in any bill that does not have a 
referring provider selected. 
 
Other 
 
Substitute – An alternate procedure code to recommend if one of the billing rules above (e.g. 
Count, Period, Stay, etc.) is violated.  For example, if a patient has already had an A003 (General 
Assessment) in the past year, and a user tries to enter a second one, HERO™ CMS can warn the 
user about the violation, and recommend A004 (General re-assessment) instead. 
 


22.5 Delete a Procedure Code 
 
View/modify a procedure code as per section “View/Modify a Procedure Code”, and then go in 
the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar 
(see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the procedure code may be in 
use, it will not actually be deleted from the database, but “hidden” such that it can not be used or 
found again. 
 


22.6 Procedure Code Update File 
 
Occasionally (approximately once a year), MOHLTC releases a “NEW Schedule of Benefits” 
which is a file (available in their web site) containing a list of all procedure codes assigned by 
MOHLTC, and the amount to bill for each one, i.e. the values that go in the Code, General, 
Speciality, Technical, Professional, and Private fields in the Procedure window (see section 
“Procedure Window”).  If you receive a file like this, ignore it.  Those files are processed on the 
FMS (see section “Data Flow Structure”) by HTN (see section “HTN”), and your procedure code 
database will be automatically updated on your next transmission (see section “Transmissions”). 
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23 Drugs 
 
HERO™ CMS usually comes with a database of common drugs. 
 


23.1 Add a Drug 
 
Go in the File menu to New → Setup → Drug (see section “Pull-Down Menus”).  A Drug 
window will open (see section “Drug Window”). 
 


23.2 View/Modify a Drug 
 
Go in the File menu to Open → Setup → Drug (see section “Pull-Down Menus”).  A Find Drug 
dialog box will open (see section “Find Drug Dialog Box”).  Select a drug and then select OK or 
press F9, or double-click on a drug.  See section “Drug Window”.  Note:  All brand names for the 
drug that you select will be displayed in the Drug window, so you can select either a brand name 
or a generic name. 
  


23.3 Find Drug Dialog Box 
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See section “Searching for a Record”. 
 
Criteria Section 
 
Brand – The name assigned by the drug’s manufacturer, e.g. Tylenol.  This field is not available 
if the “Favourites Only” option is on. 
 
Generic – The drug’s generic name, e.g. acetaminophen.  This field is not available if the 
“Favourites Only” option is on. 
 
Provider – Select a provider to view (or add to) that provider’s favourite drugs.  If you select 
this, a Find Provider dialog box will open (see section “Find Provider Dialog Box”).  Each 
provider will only be displayed once on the list, even providers that have more than one role (see 
section “Role List”).  Select a provider and then select OK or press F9, or double-click on a 
provider.  To clear this field, select Clear and then OK.  This field is only available if the Find 
Drug dialog box was launched from an Rx window (see section “Rx Window”), not from the 
File menu (see section “Pull-Down Menus”), a Drug window (see section “Drug Window”), or a 
Notes field (see section “Notes Fields, Codes”). 
 
Show Brands for Generic – Display the brand names on the Drug List below. 
 
Favourites Only – Only display the selected provider’s favourite drugs.  This field is only 
available if the Find Drug dialog box was launched from an Rx window (see section “Rx 
Window”), not from the File menu (see section “Pull-Down Menus”), a Drug window (see 
section “Drug Window”), or a Notes field (see section “Notes Fields, Codes”). 
 
Insert – Add the selected drug to the selected provider’s favourite drugs. 
 
Delete – Deleted the selected drug from the selected provider’s favourite drugs. 
 
If any text is entered in the Brand field, the Generic and Show Brands for Generic fields are 
greyed out (unavailable).  If any text is entered in the Generic field, the Brand field is greyed out 
(unavailable). 
 
Other 
 
OK button – Chooses the selected drug and closes the window.  If no drugs are displayed, 
searches for drugs that match the specified criteria, chooses the first one, and closes the window. 
 
New button – Add a drug (see section “Drug Window”). 
 
Cancel button – Closes the window without choosing a drug. 
 
Clear button – Clears the drug list and all fields in the “Criteria” section. 
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Find button – Searches for drugs that match the specified criteria. 
 
Drug List – Lists drugs that match the specified criteria (see section “Viewing a List of Items”).  
Select a drug and then select OK or press F9, or double-click on a drug, to choose that drug and 
close the window.  For a description of the fields, see section “Drug Window”. 
 


23.4 Drug Window 
 


 
 
Toolbar 
 


New Drug (Ctrl-N) – Add a drug. 
 
Open Drug (Ctrl-O) – View/modify a drug.  If you select this, a Find Drug dialog box will 
open (see section “Find Drug Dialog Box”).  Select a drug and then select OK or press F9, 


or double-click on a drug. 
 


Save (Ctrl-S) – Save the drug. 
 
Save and Close (Ctrl-L) – Save the drug and close the Drug window. 
 


Generic – The drug’s generic name, e.g. acetaminophen. 
 
Strength – The strength of the drug (e.g. how many milligrams per pill, etc.). 
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Form – The form of the drug (e.g. tablet, paste, gel, solution, etc.). 
 
Route – The method (e.g. oral, topical, inhalation, etc.) that is used to administer the drug. 
 
Brand List 
 
Lists all brand names associated with this drug (see section “Viewing a List of Items”).  The data 
on this list is supplied by HTN (see section “HTN”) and updated through your transmissions (see 
section “Transmissions”), and cannot be manually modified.  The fields are: 
 
Din – Drug identification number. 
 
Brand – The drug’s brand name, assigned by the drug’s manufacturer. 
 
Manufacturer – The company that makes the drug. 
 


23.5 Delete a Drug 
 
View/modify a drug as per section “View/Modify a Drug”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  Because the drug record may be in use, it will not 
actually be deleted from the database, but “hidden” such that it can not be used or found again. 
 
NOTE:  You cannot delete a drug that has associated brand names. 
 


24 Cities 


24.1 Add a City 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”), and 
then, on the Demographic tab, in the Address section, double-click in the City field (see section 
“Patient Window, Demographic Tab, Address Section”).  A Find City dialog box will open (see 
section “Find City Dialog Box”).  Select New. 
 


24.2 View/Modify a City 
 
Open a City window as per section “Add a City”, then select Open in the City toolbar, or press 
Ctrl-O, or double-click in the Code or Description field (see section “City Window”). 
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24.3 Find City Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – An abbreviation for the city’s name. 
 
Description – The full name of the city. 
 
Other 
 
OK button – Chooses the selected city and closes the window.  If no cities are displayed, 
searches for cities that match the specified criteria, chooses the first one, and closes the window. 
 
New button – Add a city (see section “City Window”). 
 
Cancel button – Closes the window without choosing a city. 
 
Clear button – Clears the city list and all fields in the “Criteria” section. 
 
Find button – Searches for cities that match the specified criteria. 
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City List – Lists cities that match the specified criteria (see section “Viewing a List of Items”).  
Select a city and then press Enter or F9, or double-click on a city, to choose that city and close 
the window. 
 


24.4 City Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a city. 
 
Open Code (Ctrl-O) – View/modify a city.  If you select this, a Find City dialog box will 
open (see section “Find City Dialog Box”).  Select a city and then select OK or press F9, or 


double-click on a city. 
 


Save (Ctrl-S) – Save the city. 
 
Save and Close (Ctrl-L) – Save the city and close the City window. 


 
Other 
 
Code – An abbreviation for the city’s name.  NOTE:  This field cannot be modified if the city 
has been saved.  If you need to modify this field, you must add a new city (see section “Add a 
City”), and, if desired, delete the old city (see section “Delete a City”).  If you want to 
view/modify a city, you can double-click in this field, and a Find City dialog box will open (see 
section “Find City Dialog Box”).  Select a city and then select OK or press F9, or double-click 
on a city. 
 
Description – The full name of the city.  If you want to view/modify a city, you can double-click 
in this field, and a Find City dialog box will open (see section “Find City Dialog Box”).  Select a 
city and then select OK or press F9, or double-click on a city. 
 


24.5 Delete a City 
 
View/modify a city as per section “View/Modify a City”, and then go in the File menu to Delete 
(see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section “Main 
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Toolbar”), or press Ctrl-D.  NOTE:  Because the city may be in use, it will not actually be 
deleted from the database, but “hidden” such that it can not be used or found again. 
 


25 Appointment Types 
 
Appointment Types are used to describe the general purpose of an appointment (or a time slot), 
for example Surgery, Consultation, Prescription, etc. 
 


25.1 Add an Appointment Type 
 
Do one of these: 
 


(a) Add or view/modify an appointment (see section “Add an Appointment” or 
“View/Modify an Appointment”), then select New → Type in the Appointment toolbar.  
See section “Appointment Window”. 


(b) Add or view/modify a provider (see section “Add a Provider” or “View/Modify a 
Provider”), and then, on the Schedule tab (see section “Provider Window, Schedule 
Tab”), on the Schedule List, in a Type or Type Description field, do one of these 


a. Double-click. 
b. Press F2 
c. Press F9. 
d. Enter/modify any text. 
e. Select the field, and then select LookUp on Item in the Provider toolbar. 
f. Select the field, and then right-click on any item in the list and select Edit or 


LookUp. 
A Find (Appointment) Type dialog box will open (see section “Find (Appointment) 
Type Dialog Box”).  Select New. 


(c) Add or view/modify an appointment (see section “Add an Appointment” or 
“View/Modify an Appointment”), then enter/modify any text (or double-click) in the 
Type field (see section “Appointment Window”).  A Find (Appointment) Type dialog 
box will open (see section “Find (Appointment) Type Dialog Box”).  Select New. 


 
An (Appointment) Type window will open (see section “(Appointment) Type Window”). 
 


25.2 View/Modify an Appointment Type 
 
Do one of these: 
 


(a) Add or view/modify an appointment (see section “Add an Appointment” or 
“View/Modify an Appointment”), then select Open → Type in the Appointment toolbar.  
See section “Appointment Window”. 
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(b) Open an (Appointment) Type window as per section “Add an Appointment Type”, then 
select Open in the (Appointment) Type toolbar, or press Ctrl-O, or double-click in the 
Code or Description field (see section “(Appointment) Type Window”). 


(c) Add or view/modify a provider (see section “Add a Provider” or “View/Modify a 
Provider”), and go to the Schedule tab (see section “Provider Window, Schedule Tab”).  
Then select Open Type in the Provider toolbar (or press Ctrl-O). 


 
A Find (Appointment) Type dialog box will open (see section “Find (Appointment) Type Dialog 
Box”).  Select an appointment type and select OK or press F9, or double-click on an appointment 
type.  See section “(Appointment) Type Window”. 
 


25.3 Find (Appointment) Type Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The appointment type code. 
 
Description – A full description of the appointment type. 
 







 269


Other Fields 
 
OK button – Chooses the selected appointment type and closes the window.  If no appointment 
types are displayed, searches for appointment types that match the specified criteria, chooses the 
first one, and closes the window. 
 
New button – Add an appointment type (see section “(Appointment) Type Window”). 
 
Cancel button – Closes the window without choosing an appointment type. 
 
Clear button – Clears the appointment type list and all fields in the “Criteria” section. 
 
Find button – Searches for appointment types that match the specified criteria. 
 
Appointment Type List – Lists appointment types that match the specified criteria (see section 
“Viewing a List of Items”).  Select an appointment type and then select OK or press F9, or 
double-click on an appointment type, to choose that appointment type and close the window. 
 


25.4 (Appointment) Type Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an appointment type. 
 
Open Code (Ctrl-O) – View/modify an appointment type. If you select this, a Find 
(Appointment) Type dialog box will open (see section “Find (Appointment) Type Dialog 


Box”).  Select an appointment type and then select OK or press F9, or double-click on an 
appointment type. 
 


Save (Ctrl-S) – Save the appointment type. 
 
Save and Close (Ctrl-L) – Save the appointment type and close the (Appointment) Type 
window. 
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Other 
 
Code – An abbreviation representing the appointment type, e.g. “SUR” for “Surgery”.  NOTE:  
This field cannot be modified if the appointment type has been saved.  If you need to modify this 
field, you must add a new appointment type (see section “Add an Appointment Type”), and, if 
desired, delete the old appointment type (see section “Delete an Appointment Type”). If you 
want to view/modify an appointment type, you can double-click in this field, and a Find 
(Appointment) Type dialog box will open (see section “Find (Appointment) Type Dialog Box”).  
Select an appointment type and then select OK or press F9, or double-click on an appointment 
type. 
 
Description – A full description of the appointment type. If you want to view/modify an 
appointment type, you can double-click in this field, and a Find (Appointment) Type dialog box 
will open (see section “Find (Appointment) Type Dialog Box”).  Select an appointment type and 
then select OK or press F9, or double-click on an appointment type. 
 
Duration – The default duration (in minutes) for appointments of this type.  Must be a whole 
number from 1 to 999.  Or, if you don’t want to specify a default, enter 0.  (If you leave this field 
blank, 0 will be assumed.) 
 
Color – The colour to use to display appointments (and time slots) of this type on a list of 
appointments, i.e. the Appts. window, Day tab (see section “List Appointments, Day Tab”), and 
the Patient window, Appt. tab (see section “Patient Window, Appt. Tab”).  See section 
“Colours”.  If you select this, a Color dialog box will open (see section “Color Dialog Box”). 
 


25.5 Delete an Appointment Type 
 
View/modify an appointment type as per section “View/Modify an Appointment Type”, and then 
go in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the appointment type 
may be in use, it will not actually be deleted from the database, but “hidden” such that it can not 
be used or found again. 
 


26 Appointment Re Codes 
 
Appointment Re Codes are used to describe the specific purpose of an appointment, for example 
Back Pain, Check-up, Flu Shot, etc. 
 


26.1 Add an Appointment Re Code 
 
Add or view/modify an appointment (see section “Add an Appointment” or “View/Modify an 
Appointment”), and then do one of these: 
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(a) Go to New → Re in the Appointment toolbar. 
(b) Double-click in the Re field.  A Find (Appointment) Re dialog box will open (see section 


“Find (Appointment) Re Dialog Box”).  Select New. 
 
An (Appointment) Re window will open (see section “(Appointment) Re Window”). 
 


26.2 View/Modify an Appointment Re Code 
 
Add or view/modify an appointment (see section “Add an Appointment” or “View/Modify an 
Appointment”), then go to Open → Re in the Appointment toolbar.  Or, open an (Appointment) 
Re window as per section “Add an Appointment Re Code”, then select Open in the 
(Appointment) Re toolbar, or press Ctrl-O, or double-click in the Code or Description field (see 
section “(Appointment) Re Window”). 
 
A Find (Appointment) Re dialog box will open (see section “Find (Appointment) Re Dialog 
Box”).  Select an appointment re code and select OK or press F9, or double-click on an 
appointment re code.  See section “(Appointment) Re Window” . 
 


26.3 Find (Appointment) Re Dialog Box 
 


 
 
See section “Searching for a Record”. 
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Criteria Section 
 
Code – An abbreviation representing the specific appointment purpose 
 
Description – A full description of the specific appointment purpose 
 
Other Fields 
 
OK button – Chooses the selected appointment re code and closes the window.  If no 
appointment re codes are displayed, searches for appointment re codes that match the specified 
criteria, chooses the first one, and closes the window. 
 
New button – Add an appointment re code (see section “(Appointment) Re Window”). 
 
Cancel button – Closes the window without choosing an appointment re code. 
 
Clear button – Clears the appointment re code list and all fields in the “Criteria” section. 
 
Find button – Searches for appointment re codes that match the specified criteria. 
 
Appointment Re Code List – Lists appointment re codes that match the specified criteria (see 
section “Viewing a List of Items”).  Select an appointment re code and then select OK or press 
F9, or double-click on an appointment re code, to choose that appointment re code and close the 
window. 
 


26.4 (Appointment) Re Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an appointment re code. 
 
Open Code (Ctrl-O) – View/modify an appointment re code. If you select this, a Find 
(Appointment) Re dialog box will open (see section “Find (Appointment) Re Dialog 


Box”).  Select an appointment re code and then select OK or press F9, or double-click on an 
appointment re code. 
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Save (Ctrl-S) – Save the appointment re code. 
 
Save and Close (Ctrl-L) – Save the appointment re code and close the (Appointment) Re 
window. 


 
Other 
 
Code – An abbreviation representing the specific appointment purpose.  NOTE:  This field 
cannot be modified if the appointment re code has been saved.  If you need to modify this field, 
you must add a new appointment re code (see section “Add an Appointment Re Code”), and, if 
desired, delete the old appointment re code (see section “Delete an Appointment Re Code”). If 
you want to view/modify an appointment re code, you can double-click in this field, and a Find 
(Appointment) Re dialog box will open (see section “Find (Appointment) Re Dialog Box”).  
Select an appointment re code and then select OK or press F9, or double-click on an appointment 
re code. 
 
Description – A full description of the specific appointment purpose.  If you want to 
view/modify an appointment re code, you can double-click in this field, and a Find 
(Appointment) Re dialog box will open (see section “Find (Appointment) Re Dialog Box”).  
Select an appointment re code and then select OK or press F9, or double-click on an appointment 
re code. 
 


26.5 Delete an Appointment Re Code 
 
View/modify an appointment re code as per section “View/Modify an Appointment Re Code”, 
and then go in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the 
Main Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the appointment 
re code may be in use, it will not actually be deleted from the database, but “hidden” such that it 
can not be used or found again. 
 


27 Location Codes 
 
Location Codes are used to describe the location of an appointment, e.g. in what building or 
room the appointment will take place.  This is not necessarily the same as a 4-digit Location code 
assigned by MOHLTC (see section “Provider Window, Demographic Tab, Role List”). 
 


27.1 Add a Location Code 
 
Add or view/modify an appointment (see section “Add an Appointment” or “View/Modify an 
Appointment”), and then do one of these: 
 


(a) Go to New → Location in the Appointment toolbar. 
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(b) Double-click in the Location field.  A Find Location dialog box will open (see section 
“Find Location Dialog Box”).  Select New. 


 
A Location window will open (see section “Location Window”). 
 


27.2 View/Modify a Location Code 
 
Add or view/modify an appointment (see section “Add an Appointment” or “View/Modify an 
Appointment”), then go to Open → Location in the Appointment toolbar.  Or, open a Location 
window as per section “Add a Location Code”, then select Open in the Location toolbar, or press 
Ctrl-O, or double-click in the Code or Description field (see section “Location Window”). 
 
A Find Location dialog box will open (see section “Find Location Dialog Box”).  Select a 
Location code and select OK or press F9, or double-click on a Location code.  See section 
“Location Window” . 
 


27.3 Find Location Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – A short description of the location. 
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Description – A full description of the location. 
 
Other Fields 
 
OK button – Chooses the selected Location code and closes the window.  If no Location codes 
are displayed, searches for Location codes that match the specified criteria, chooses the first one, 
and closes the window. 
 
New button – Add a Location code (see section “Location Window”). 
 
Cancel button – Closes the window without choosing a Location code. 
 
Clear button – Clears the Location code list and all fields in the “Criteria” section. 
 
Find button – Searches for Location codes that match the specified criteria. 
 
Location Code List – Lists Location codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select a Location code and then select OK or press F9, or double-
click on a Location code, to choose that Location code and close the window. 
 


27.4 Location Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a Location code. 
 
Open Code (Ctrl-O) – View/modify a Location code. If you select this, a Find Location 
dialog box will open (see section “Find Location Dialog Box”).  Select a Location code 


and then select OK or press F9, or double-click on a Location code. 
 


Save (Ctrl-S) – Save the Location code. 
 
Save and Close (Ctrl-L) – Save the Location code and close the Location window. 
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Other 
 
Code – A short description of the location.  NOTE:  This field cannot be modified if the 
Location code has been saved.  If you need to modify this field, you must add a new Location 
code (see section “Add a Location Code”), and, if desired, delete the old Location code (see 
section “Delete a Location Code”). If you want to view/modify a Location code, you can double-
click in this field, and a Find Location dialog box will open (see section “Find Location Dialog 
Box”).  Select a Location code and then select OK or press F9, or double-click on a Location 
code. 
  
Description – A full description of the location.  If you want to view/modify a Location code, 
you can double-click in this field, and a Find Location dialog box will open (see section “Find 
Location Dialog Box”).  Select a Location code and then select OK or press F9, or double-click 
on a Location code. 
 


27.5 Delete a Location Code 
 
View/modify a Location code as per section “View/Modify a Location Code”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the Location code may be in use, it 
will not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


28 Facilities 


28.1 Add a Facility 
 
Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”).  Then do one of 
these: 
 


(a) Go to New → Facility in the Bill toolbar (see section “Bill Window, Invoice Tab”). 
(b) Select Facility.  A Find Facility dialog box will open (see section “Find Facility 


Dialog Box”).  Select New. 
 
A Facility window will open (see section “Facility Window”). 
 


28.2 View/Modify a Facility 
 
Do one of these: 
 


(a) Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”).  Then 
select Open → Facility in the Bill toolbar (see section “Bill Window, Invoice Tab”). 







 277


(b) Open a Facility window as per section “Add a Facility”.  Select Open Code in the 
Facility toolbar, or press Ctrl-O, or double-click in the Code or Description field (see 
section “Facility Window”). 


 
A Find Facility dialog box will open (see section “Find Facility Dialog Box”).  Select a facility 
and then select OK or press F9, or double-click on a facility.  See section “Facility Window”. 
 


28.3 Find Facility Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The code that includes a Master Number, and possibly an SLI. 
  
Description – The full name of the facility. 
 
Other 
 
OK button – Chooses the selected facility and closes the window.  If no facilities are displayed, 
searches for facilities that match the specified criteria, chooses the first one, and closes the 
window. 
 
New button – Add a facility (see section “Facility Window”). 
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Cancel button – Closes the window without choosing a facility. 
 
Clear button – Clears the facility list and all fields in the “Criteria” section. 
 
Find button – Searches for facilities that match the specified criteria. 
 
Facility List – Lists facilities that match the specified criteria (see section “Viewing a List of 
Items”).  Select a facility and then select OK or press F9, or double-click on a facility, to choose 
that facility and close the window. 
 


28.4 Facility Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a facility. 
 
Open Code (Ctrl-O) – View/modify a facility.  If you select this, a Find Facility dialog box 
will open (see section “Find Facility Dialog Box”).  Select a facility and then select OK or 


press F9, or double-click on a facility. 
 


Save (Ctrl-S) – Save the facility. 
 
Save and Close (Ctrl-L) – Save the facility and close the Facility window. 


 
Other 
 
Code – This should include a Master Number (4-digit code assigned by MOHLTC to identify a 
health facility), and, optionally, an SLI (e.g. HDS, HED, HIP, HOP, HRP, or OTN).  (Or, if the 
SLI starts with “H”, you can just enter the last 2 letters of the SLI (e.g. DS, ED, IP, OP, or RP), 
and the leading “H” will automatically be added as needed whenever a batch is made.)  NOTE:  
This field cannot be modified if the facility has been saved.  If you need to modify this field, you 
must add a new facility (see section “Add a Facility”), and, if desired, delete the old facility (see 
section “Delete a Facility”).  If you want to view/modify a facility, you can double-click in this 
field, and a Find Facility dialog box will open (see section “Find Facility Dialog Box”).  Select a 
facility and then select OK or press F9, or double-click on a facility. 
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Description – A full description of the health facility (and SLI) e.g. “General Hospital” or 
“Downtown Clinic – Hospital Day Surgery”.  If you want to view/modify a facility, you can 
double-click in this field, and a Find Facility dialog box will open (see section “Find Facility 
Dialog Box”).  Select a facility and then select OK or press F9, or double-click on a facility. 
 


28.5 Delete a Facility 
 
View/modify a facility as per section “View/Modify a Facility”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  Because the facility record may be in use, it will not 
actually be deleted from the database, but “hidden” such that it can not be used or found again. 
 


29 Encounter Types 
 
Encounter Types are used to describe the general purpose of an encounter, e.g. Surgery, 
Consultation, Prescription, etc. 
 


29.1 Add an Encounter Type 
 
Add or view/modify an encounter (see section “Add an Encounter” or “View/Modify an 
Encounter”), and then do one of these: 
 


(a) Go to New → Type in the Encounter toolbar. 
(b) Double-click in the Type field.  A Find (Encounter) Type dialog box will open (see 


section “Find (Encounter) Type Dialog Box”).  Select New. 
 
An (Encounter) Type window will open (see section “(Encounter) Type Window”). 
 


29.2 View/Modify an Encounter Type 
 
Add or view/modify an encounter (see section “Add an Encounter” or “View/Modify an 
Encounter”), then go to Open → Type in the Encounter toolbar.  Or, open an (Encounter) Type 
window as per section “Add an Encounter Type”, then select Open in the (Encounter) Type 
toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section 
“(Encounter) Type Window”). 
 
A Find (Encounter) Type dialog box will open (see section “Find (Encounter) Type Dialog 
Box”).  Select an encounter type and select OK or press F9, or double-click on an encounter 
type.  See section “(Encounter) Type Window”. 
 







 280


29.3 Find (Encounter) Type Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The encounter type code. 
 
Description – A full description of the encounter type. 
 
Other Fields 
 
OK button – Chooses the selected encounter type and closes the window.  If no encounter types 
are displayed, searches for encounter types that match the specified criteria, chooses the first one, 
and closes the window. 
 
New button – Add an encounter type (see section “(Encounter) Type Window”). 
 
Cancel button – Closes the window without choosing an encounter type. 
 
Clear button – Clears the encounter type list and all fields in the “Criteria” section. 
 
Find button – Searches for encounter types that match the specified criteria. 
 







 281


Encounter Type List – Lists encounter types that match the specified criteria (see section 
“Viewing a List of Items”).  Select an encounter type and then select OK or press F9, or double-
click on an encounter type, to choose that encounter type and close the window. 
 


29.4 (Encounter) Type Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an encounter type. 
 
Open Code (Ctrl-O) – View/modify an encounter type. If you select this, a Find 
(Encounter) Type dialog box will open (see section “Find (Encounter) Type Dialog Box”).  


Select an encounter type and then select OK or press F9, or double-click on an encounter type. 
 


Save (Ctrl-S) – Save the encounter type. 
 
Save and Close (Ctrl-L) – Save the encounter type and close the (Encounter) Type 
window. 


 
Other 
 
Code – An abbreviation representing the encounter type.  NOTE:  This field cannot be modified 
if the encounter type has been saved.  If you need to modify this field, you must add a new 
encounter type (see section “Add an Encounter Type”), and, if desired, delete the old encounter 
type (see section “Delete an Encounter Type”). If you want to view/modify an encounter type, 
you can double-click in this field, and a Find (Encounter) Type dialog box will open (see section 
“Find (Encounter) Type Dialog Box”).  Select an encounter type and then select OK or press F9, 
or double-click on an encounter type. 
 
Description – A full description of the encounter type. If you want to view/modify an encounter 
type, you can double-click in this field, and a Find (Encounter) Type dialog box will open (see 
section “Find (Encounter) Type Dialog Box”).  Select an encounter type and then select OK or 
press F9, or double-click on an encounter type. 
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29.5 Delete an Encounter Type 
 
View/modify an encounter type as per section “View/Modify an Encounter Type”, and then go 
in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the encounter type may 
be in use, it will not actually be deleted from the database, but “hidden” such that it can not be 
used or found again. 
 


30 Encounter Re Codes 
 
Encounter Re Codes are used to describe the specific purpose of an encounter, e.g. Back Pain, 
Check-up, Flu Shot, etc. 
 


30.1 Add an Encounter Re Code 
 
Add or view/modify an encounter (see section “Add an Encounter” or “View/Modify an 
Encounter”), and then do one of these: 
 


(a) Go to New → Re in the Encounter toolbar. 
(b) Double-click in the Re field.  A Find (Encounter) Re dialog box will open (see section 


“Find (Encounter) Re Dialog Box”).  Select New. 
 
An (Encounter) Re window will open (see section “(Encounter) Re Window”). 
 


30.2 View/Modify an Encounter Re Code 
 
Add or view/modify an encounter (see section “Add an Encounter” or “View/Modify an 
Encounter”), then go to Open → Re in the Encounter toolbar.  Or, open an (Encounter) Re 
window as per section “Add an Encounter Re Code”, then select Open in the (Encounter) Re 
toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section 
“(Encounter) Re Window”). 
 
A Find (Encounter) Re dialog box will open (see section “Find (Encounter) Re Dialog Box”).  
Select an encounter re code and select OK or press F9, or double-click on an encounter re code.  
See section “(Encounter) Re Window” . 
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30.3 Find (Encounter) Re Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The encounter re code. 
 
Description – A full description of the purpose of the encounter. 
 
Other Fields 
 
OK button – Chooses the selected encounter re code and closes the window.  If no encounter re 
codes are displayed, searches for encounter re codes that match the specified criteria, chooses the 
first one, and closes the window. 
 
New button – Add an encounter re code (see section “(Encounter) Re Window”). 
 
Cancel button – Closes the window without choosing an encounter re code. 
 
Clear button – Clears the encounter re code list and all fields in the “Criteria” section. 
 
Find button – Searches for encounter re codes that match the specified criteria. 
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Encounter Re Code List – Lists encounter re codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select an encounter re code and then select OK or press F9, or 
double-click on an encounter re code, to choose that encounter re code and close the window. 
 


30.4 (Encounter) Re Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an encounter re code. 
 
Open Code (Ctrl-O) – View/modify an encounter re code. If you select this, a Find 
(Encounter) Re dialog box will open (see section “Find (Encounter) Re Dialog Box”).  


Select an encounter re code and then select OK or press F9, or double-click on an encounter re 
code. 
 


Save (Ctrl-S) – Save the encounter re code. 
 
Save and Close (Ctrl-L) – Save the encounter re code and close the (Encounter) Re 
window. 


 
Other 
 
Code – The encounter re code.  NOTE:  This field cannot be modified if the encounter re code 
has been saved.  If you need to modify this field, you must add a new encounter re code (see 
section “Add an Encounter Re Code”), and, if desired, delete the old encounter re code (see 
section “Delete an Encounter Re Code”). If you want to view/modify an encounter re code, you 
can double-click in this field, and a Find (Encounter) Re dialog box will open (see section “Find 
(Encounter) Re Dialog Box”).  Select an encounter re code and then select OK or press F9, or 
double-click on an encounter re code. 
 
Description – A full description of the purpose of the encounter.  If you want to view/modify an 
encounter re code, you can double-click in this field, and a Find (Encounter) Re dialog box will 
open (see section “Find (Encounter) Re Dialog Box”).  Select an encounter re code and then 
select OK or press F9, or double-click on an encounter re code. 
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30.5 Delete an Encounter Re Code 
 
View/modify an encounter re code as per section “View/Modify an Encounter Re Code”, and 
then go in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the encounter re code 
may be in use, it will not actually be deleted from the database, but “hidden” such that it can not 
be used or found again. 
 


31 SIGs 


31.1 Add a SIG 
 
Add or view/modify a prescription (see section “Add a Prescription” or “View/Modify a 
Prescription”).  Then do one of these (see section “Rx Window”): 
 


(a) Go to New → SIG in the Rx toolbar. 
(b) On the Prescription List, do one of these: 


a. Select a SIG field and then press F9. 
b. Select a SIG Description field and then enter/modify any text, or press Enter or F2 


or F9. 
c. Select a SIG field and then right-click on an item in the list and select LookUp. 
d. Select a SIG Description field and then right-click on an item in the list and select 


Edit or LookUp. 
e. Select a SIG or SIG Description field and then select LookUp on Item in the Rx 


toolbar. 
f. Double-click in a SIG or SIG Description field. 
A Find SIG dialog box will open (see section “Find SIG Dialog Box”).  Select New. 


 
A SIG window will open (see section “SIG Window”). 
 


31.2 View/Modify a SIG 
 
Do one of these: 
 


(a) Add or view/modify a prescription (see section “Add a Prescription” or 
“View/Modify a Prescription”).  Then select Open → SIG in the Rx toolbar (see 
section “Rx Window”). 


(b) Open a SIG window as per section “Add a SIG”.  Select Open Code in the SIG 
toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section 
“SIG Window”). 


 
A Find SIG dialog box will open (see section “Find SIG Dialog Box”).  Select a SIG and then 
select OK or press F9, or double-click on a SIG.  See section “SIG Window”. 
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31.3 Find SIG Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The SIG. 
 
Description – The meaning of the SIG. 
 
Other 
 
OK button – Chooses the selected SIG and closes the window.  If no SIGs are displayed, 
searches for SIGs that match the specified criteria, chooses the first one, and closes the window. 
 
New button – Add a SIG (see section “SIG Window”). 
 
Cancel button – Closes the window without choosing a SIG. 
 
Clear button – Clears the SIG list and all fields in the “Criteria” section. 
 
Find button – Searches for SIGs that match the specified criteria. 
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SIG List – Lists SIGs that match the specified criteria (see section “Viewing a List of Items”).  
Select a SIG and then select OK or press F9, or double-click on a SIG, to choose that SIG and 
close the window. 
 


31.4 SIG Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a SIG. 
 
Open Code (Ctrl-O) – View/modify a SIG.  If you select this, a Find SIG dialog box will 
open (see section “Find Drug Dialog Box”).  Select a SIG and then select OK or press F9, 


or double-click on a SIG. 
 


Save (Ctrl-S) – Save the SIG. 
 
Save and Close (Ctrl-L) – Save the SIG and close the SIG window. 


 
Other 
 
Code – The SIG, e.g. “5X”.  NOTE:  This field cannot be modified if the SIG has been saved.  If 
you need to modify this field, you must add a new SIG (see section “Add a SIG”), and, if 
desired, delete the old SIG (see section “Delete a SIG”).  If you want to view/modify a SIG, you 
can double-click in this field, and a Find SIG dialog box will open (see section “Find SIG Dialog 
Box”).  Select a SIG and then select OK or press F9, or double-click on a SIG. 
 
Description – The meaning of the SIG, e.g. “5 times a day”.  If you want to view/modify a SIG, 
you can double-click in this field, and a Find SIG dialog box will open (see section “Find SIG 
Dialog Box”).  Select a SIG and then select OK or press F9, or double-click on a SIG. 
 
Period (hrs.) – The average number of hours the patient should wait before taking the drug 
again.  For example, for the SIG “5X” (5 times a day), the Period should be 4.8 (24 ÷ 5). 
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31.5 Delete a SIG 
 
View/modify a SIG as per section “View/Modify a SIG”, and then go in the File menu to Delete 
(see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section “Main 
Toolbar”), or press Ctrl-D.  NOTE:  Because the SIG may be in use, it will not actually be 
deleted from the database, but “hidden” such that it can not be used or found again. 
 


32 Contact Codes 


32.1 Add a Contact Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Contact Tab (see section “Patient Window, Contact Tab”).  Then do one of these: 
 


(a) Go to New → Contact in the Patient toolbar. 
(b) On the Contact List, do one of these: 


a. Select a Contact field and then press F9. 
b. Select a Description field and then enter/modify any text, or press Enter or F2 or 


F9. 
c. Select a Contact field and then right-click on an item in the list and select 


LookUp. 
d. Select a Description field and then right-click on an item in the list and select Edit 


or Lookup. 
e. Select a Contact or Description field and then select LookUp on Item in the 


Patient toolbar. 
f. Double-click in a Contact or Description field. 
A Find Contact dialog box will open (see section “Find Contact Dialog Box”).  Select 
New. 


 
A Contact window will open (see section “Contact Window”). 
 


32.2 View/Modify a Contact Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Contact tab (see section “Patient Window, Contact Tab”).  
Then go to Open → Contact in the Patient toolbar. 


(b) Open a Contact window as per section “Add a Contact Code”.  Then select Open 
Code in the Contact toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 
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A Find Contact dialog box will open (see section “Find Contact Dialog Box”).  Select a contact 
code and then select OK or press F9, or double-click on a contact code.  See section “Contact 
Window”. 
 


32.3 Find Contact Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The contact code. 
 
Description – A full description of the contact. 
 
Other Fields 
 
OK button – Chooses the selected contact code and closes the window.  If no contact codes are 
displayed, searches for contact codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a contact code (see section “Contact Window”). 
 
Cancel button – Closes the window without choosing a contact code. 
 
Clear button – Clears the contact code list and all fields in the “Criteria” section. 
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Find button – Searches for contact codes that match the specified criteria. 
 
Contact Code List – Lists contact codes that match the specified criteria (see section “Viewing 
a List of Items”).  Select a contact code and then select OK or press F9, or double-click on a 
contact code, to choose that contact code and close the window. 
 


32.4 Contact Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a contact code. 
 
Open Code (Ctrl-O) – View/modify a contact code. If you select this, a Find Contact 
dialog box will open (see section “Find Contact Dialog Box”).  Select a contact code and 


then select OK or press F9, or double-click on a contact code. 
 


Save (Ctrl-S) – Save the contact code. 
 
Save and Close (Ctrl-L) – Save the contact code and close the Contact window. 


 
Other 
 
Code – An abbreviation representing the contact.  NOTE:  This field cannot be modified if the 
contact code has been saved.  If you need to modify this field, you must add a new contact code 
(see section “Add a Contact Code”), and, if desired, delete the old contact code (see section 
“Delete a Contact Code”). If you want to view/modify a contact code, you can double-click in 
this field, and a Find Contact dialog box will open (see section “Find Contact Dialog Box”).  
Select a contact code and then select OK or press F9, or double-click on a contact code. 
 
Description – A full description of the contact.  If you want to view/modify a contact code, you 
can double-click in this field, and a Find Contact dialog box will open (see section “Find Contact 
Dialog Box”).  Select a contact code and then select OK or press F9, or double-click on a contact 
code. 
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32.5 Delete a Contact Code 
 
View/modify a contact code as per section “View/Modify a Contact Code”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the contact code may be in use, it 
will not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


33 Problem Codes 


33.1 Add a Problem Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Problem Tab or the Family Tab (see section “Patient Window, Problem Tab” or “Patient 
Window, Family Tab”).  Then do one of these: 
 


(a) Go to New → Problem in the Patient toolbar. 
(b) On the Problem List or the Family Medical History List, do one of these: 


a. Select a Problem or Description field and then enter/modify any text, or press 
Enter or F2 or F9. 


b. Select a Problem or Description field and then right-click on an item in the list 
and select Edit or LookUp. 


c. Select a Problem or Description field and then select LookUp on Item in the 
Patient toolbar. 


d. Double-click in a Problem or Description field. 
A Find Problem dialog box will open (see section “Find Problem Dialog Box”).  
Select New. 


 
A Problem window will open (see section “Problem Window”). 
 


33.2 View/Modify a Problem Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Problem Tab or the Family Tab (see section “Patient Window, 
Problem Tab” or “Patient Window, Family Tab”).  Then go to Open → Problem in 
the Patient toolbar. 


(b) Open a Problem window as per section “Add a Problem Code”.  Then select Open 
Code in the Problem toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 
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A Find Problem dialog box will open (see section “Find Problem Dialog Box”).  Select a 
problem code and then select OK or press F9, or double-click on a problem code.  See section 
“Problem Window”. 
 


33.3 Find Problem Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The problem/procedure/ICD-9 code. 
 
Description – A description of the problem/procedure/ICD-9 code. 
 
Other 
 
OK button – Chooses the selected problem/procedure/ICD-9 code and closes the window.  If no 
problem/procedure/ICD-9 codes are displayed, searches for problem/procedure/ICD-9 codes that 
match the specified criteria, chooses the first one, and closes the window. 
 
New button – Add a problem code (see section “Problem Window”). 
 
Cancel button – Closes the window without choosing a problem/procedure/ICD-9 code. 
 
Clear button – Clears the problem code list and all fields in the “Criteria” section. 
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Find button – Searches for problem/procedure/ICD-9 codes that match the specified criteria. 
 
Problem Code List 
 
Lists problem codes that match the specified criteria (see section “Viewing a List of Items”).  If 
the Find Problem dialog box was launched from a Patient Medical History List (see section 
“Patient Window, Problem Tab”), Family Medical History List (see section “Patient Window, 
Family Tab”), or from a Notes field (see section “Notes Fields”), not from a Patient toolbar (see 
section “Patient Window, Problem Tab” or “Patient Window, Family Tab”) or Problem toolbar 
(see section “Problem Window”), then matching procedure codes (see section “Procedure 
Codes”) and ICD-9 codes (see section “ICD-9 Codes”) will also be displayed.  Select a 
problem/procedure/ICD-9 code and then press Enter or F9, or double-click on a 
problem/procedure/ICD-9 code, to choose that problem/procedure/ICD-9 code and close the 
window.  The fields are: 
 
Code – The problem/procedure/ICD-9 code. 
 
Description – A full description of the problem/procedure/ICD-9 code. 
 
Class – This field is only displayed if the Find Problem dialog box was launched from a Patient 
Medical History List (see section “Patient Window, Problem Tab”), Family Medical History List 
(see section “Patient Window, Family Tab”), or from a Notes field (see section “Notes Fields”), 
not from a Patient toolbar (see section “Patient Window, Problem Tab” or “Patient Window, 
Family Tab”) or Problem toolbar (see section “Problem Window”).  This field indicates the type 
of code:  problem (“UDF”) (see section “Problem Codes”), procedure (“MOHFEE”) (see section 
“Procedure Codes”), or ICD-9 (“ICD-9”) (see section “ICD-9 Codes”). 
 


33.4 Problem Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a problem code. 
 
Open Code (Ctrl-O) – View/modify a problem code.  If you select this, a Find Problem 
dialog box will open (see section “Find Problem Dialog Box”).  Select a problem code and 
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then select OK or press F9, or double-click on a problem code. 
 


Save (Ctrl-S) – Save the problem code. 
 
Save and Close (Ctrl-L) – Save the problem code and close the Problem window. 


 
Other 
 
Code – An abbreviation representing the problem.  NOTE:  This field cannot be modified if the 
problem code has been saved.  If you need to modify this field, you must add a new problem 
code (see section “Add a Problem Code”), and, if desired, delete the old problem code (see 
section “Delete a Problem Code”).  If you want to view/modify a problem code, you can double-
click in this field, and a Find Problem dialog box will open (see section “Find Problem Dialog 
Box”).  Select a problem code and then select OK or press F9, or double-click on a problem 
code. 
 
Description – A description of the problem.  If you want to view/modify a problem code, you 
can double-click in this field, and a Find Problem dialog box will open (see section “Find 
Problem Dialog Box”).  Select a problem code and then select OK or press F9, or double-click 
on a problem code. 
 


33.5 Delete a Problem Code 
 
View/modify a problem code as per section “View/Modify a Problem Code”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the problem code may be in use, it 
will not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


34 ICD-9 Codes 
 
ICD-9 codes (International Classification of Diseases, 9th Edition/Revision) are similar to 
diagnosis codes (see section “Diagnosis Codes”).  They are numerical codes that represent 
medical problems/diagnoses/symptoms.  Each ICD-9 code consists of 3 digits, then a decimal, 
then 2 more digits (e.g. “100.00”).  ICD-9 codes are provided by HTN (see section “HTN”) and 
automatically updated through your transmissions (see section “Transmissions”).  You cannot 
add, modify, or delete an ICD-9 code.  ICD-9 codes can be used on the Problem List (see section 
“Patient Window, Problem Tab”) and the Family Medical History List (see section “Patient 
Window, Family Tab”), and in a Notes Field (see section “Notes Fields”), and they can be found 
using the Find Problem Dialog Box (see section “Find Problem Dialog Box”). 
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35 Test Codes 


35.1 Add a Test Code 
 
Add or view/modify a lab requisition (see section “Add a Lab Requisition” or “View/Modify a 
Lab Requisition”) and then do one of these: 
 


(a) Go to New → Test in the Requisition toolbar. 
(b) Enable one of the checkboxes in the Test Section.  A Find Test dialog box will open 


(see section “Find Test Dialog Box”).  Select New. 
(c) Select one of the checkboxes in the Test Section and then select LookUp on Item in 


the Requisition toolbar.  A Find Test dialog box will open (see section “Find Test 
Dialog Box”).  Select New. 


(d) On the Other Test List, in a Test or Description field, do one of these: 
a. Press Enter. 
b. Press F2. 
c. Press F9. 
d. Enter/modify any text. 
e. Select the field and then right-click on an item in the list and select Edit or 


LookUp. 
f. Select the field and then select LookUp on Item in the Requisition toolbar. 
g. Double-click. 
A Find Test dialog box will open (see section “Find Test Dialog Box”).  Select New. 


 
A Test window will open (see section “Test Window”). 
 


35.2 View/Modify a Test Code 
 
Do one of these: 
 


(a) Add or view/modify a lab requisition (see section “Add a Lab Requisition” or 
“View/Modify a Lab Requisition”) and then go to Open → Test in the Requisition 
toolbar. 


(b) Open a Test window as per section “Add a Test Code”.  Then select Open Code in the 
Test toolbar, or press Ctrl-O, or double-click in the Code or Description field. 


 
A Find Test dialog box will open (see section “Find Test Dialog Box”).  Select a test code and 
then select OK or press F9, or double-click on a test code.  See section “Test Window”. 
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35.3 Find Test Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – An abbreviation representing the test. 
 
Description – A full description of the test. 
 
Position – Where on the Lab Requisition form this test can be requested.  Reserved for future 
use. 
 
Lab – Which lab the test code is associated with. 
 
Other 
 
OK button – Chooses the selected test code and closes the window.  If no test codes are 
displayed, searches for test codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a test code (see section “Test Window”). 
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Cancel button – Closes the window without choosing a test code. 
 
Clear button – Clears the test code list and all fields in the “Criteria” section. 
 
Find button – Searches for test codes that match the specified criteria. 
 
Test Code List 
 
Lists test codes that match the specified criteria (see section “Viewing a List of Items”).  Select a 
test code and then press Enter or F9, or double-click on a test code, to choose that test code and 
close the window.  The fields are: 
 
Code – An abbreviation representing the test. 
 
Description – A full description of the test. 
 


35.4 Test Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a test code. 
 
Open Code (Ctrl-O) – View/modify a test code.  If you select this, a Find Test dialog box 
will open (see section “Find Test Dialog Box”).  Select a test code and then select OK or 


press F9, or double-click on a test code. 
 


Save (Ctrl-S) – Save the test code. 
 
Save and Close (Ctrl-L) – Save the test code and close the Test window. 


 
Other 
 
Code – An abbreviation representing the test.  NOTE:  This field cannot be modified if the test 
code has been saved.  If you need to modify this field, you must add a new test code (see section 
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“Add a Test Code”), and, if desired, delete the old test code (see section “Delete a Test Code”).  
If you want to view/modify a test code, you can double-click in this field, and a Find Test dialog 
box will open (see section “Find Test Dialog Box”).  Select a test code and then select OK or 
press F9, or double-click on a test code. 
 
Description – A description of the test.  If you want to view/modify a test code, you can double-
click in this field, and a Find Test dialog box will open (see section “Find Test Dialog Box”).  
Select a test code and then select OK or press F9, or double-click on a test code. 
 
Position – Where on the Lab Requisition form this test can be requested.  Reserved for future 
use. 
 
Lab – Which lab the test code is associated with.  NOTE:  This field cannot be modified if the 
test code has been saved.  If you need to modify this field, you must add a new test code (see 
section “Add a Test Code”), and, if desired, delete the old test code (see section “Delete a Test 
Code”). 
 


35.5 Delete a Test Code 
 
View/modify a test code as per section “View/Modify a Test Code”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the test code may be in use, it will 
not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


36 Immunization Codes 


36.1 Add an Immunization Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Imm. tab (see section “Patient Window, Imm. Tab”).  Then do one of these: 
 


(a) Go to New → Immunization in the Patient toolbar. 
(b) On the Immunization List, do one of these: 


a. Select an Immunization field and then press F9. 
b. Select a Description field and then enter/modify any text, or press Enter or F2 or 


F9. 
c. Select an Immunization field and then right-click on an item in the list and select 


LookUp. 
d. Select a Description field and then right-click on an item in the list and select Edit 


or LookUp. 
e. Double-click in an Immunization or Description field. 
f. Select an Immunization or Description field and then select LookUp on Item in 


the Patient toolbar. 
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A Find Immunization dialog box will open (see section “Find Immunization Dialog 
Box”).  Select New. 


 
An Immunization window will open (see section “Immunization Window”). 
 


36.2 View/Modify an Immunization Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Imm. tab (see section “Patient Window, Imm. Tab”).  Then go 
to Open → Immunization in the Patient toolbar. 


(b) Open an Immunization window as per section “Add an Immunization Code”.  Then 
select Open Code in the Immunization toolbar, or press Ctrl-O, or double-click in the 
Code or Description field. 


 
A Find Immunization dialog box will open (see section “Find Immunization Dialog Box”).  
Select an immunization code and then select OK or press F9, or double-click on an immunization 
code.  See section “Immunization Window”. 
 


36.3 Find Immunization Dialog Box 
 


 
 
See section “Searching for a Record”. 
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Criteria Section 
 
Code – The immunization code. 
 
Description – A full description of the immunization. 
 
Other Fields 
 
OK button – Chooses the selected immunization code and closes the window.  If no 
immunization codes are displayed, searches for immunization codes that match the specified 
criteria, chooses the first one, and closes the window. 
 
New button – Add an immunization code (see section “Immunization Window”). 
 
Cancel button – Closes the window without choosing an immunization code. 
 
Clear button – Clears the immunization code list and all fields in the “Criteria” section. 
 
Find button – Searches for immunization codes that match the specified criteria. 
 
Immunization Code List – Lists immunization codes that match the specified criteria (see 
section “Viewing a List of Items”).  Select an immunization code and then select OK or press F9, 
or double-click on an immunization code, to choose that immunization code and close the 
window. 
 


36.4 Immunization Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an immunization code. 
 
Open Code (Ctrl-O) – View/modify an immunization code. If you select this, a Find 
Immunization dialog box will open (see section “Find Immunization Dialog Box”).  Select 


an immunization code and then select OK or press F9, or double-click on an immunization code. 
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Save (Ctrl-S) – Save the immunization code. 
 
Save and Close (Ctrl-L) – Save the immunization code and close the Immunization 
window. 


 
Other 
 
Code – An abbreviation representing the immunization.  NOTE:  This field cannot be modified 
if the immunization code has been saved.  If you need to modify this field, you must add a new 
immunization code (see section “Add an Immunization Code”), and, if desired, delete the old 
immunization code (see section “Delete an Immunization Code”). If you want to view/modify an 
immunization code, you can double-click in this field, and a Find Immunization dialog box will 
open (see section “Find Immunization Dialog Box”).  Select an immunization code and then 
select OK or press F9, or double-click on an immunization code. 
 
Description – A full description of the immunization.  If you want to view/modify an 
immunization code, you can double-click in this field, and a Find Immunization dialog box will 
open (see section “Find Immunization Dialog Box”).  Select an immunization code and then 
select OK or press F9, or double-click on an immunization code. 
 


36.5 Delete an Immunization Code 
 
View/modify an immunization code as per section “View/Modify an Immunization Code”, and 
then go in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the immunization code 
may be in use, it will not actually be deleted from the database, but “hidden” such that it can not 
be used or found again. 
 


37 Allergy Codes 


37.1 Add an Allergy Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Allergy tab (see section “Patient Window, Allergy Tab”).  Then do one of these: 
 


(a) Go to New → Allergy in the Patient toolbar. 
(b) On the Allergy List, in an Allergy field, do one of these: 


a. Press Enter. 
b. Press F2. 
c. Press F9. 
d. Enter/modify any text. 
e. Select the field and then right-click on an item in the list and select Edit or 


LookUp. 
f. Select the field and then select LookUp on Item in the Patient toolbar. 
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g. Double-click. 
A Find Allergy dialog box will open (see section “Find Allergy Dialog Box”).  Select 
New. 


 
An Allergy window will open (see section “Allergy Window”). 
 


37.2 View/Modify an Allergy Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Allergy tab (see section “Patient Window, Allergy Tab”).  
Then go to Open → Allergy in the Patient toolbar. 


(b) Open an Allergy window as per section “Add an Allergy Code”.  Then select Open 
Code in the Allergy toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 


 
A Find Allergy dialog box will open (see section “Find Allergy Dialog Box”).  Select an allergy 
code and then select OK or press F9, or double-click on an allergy code.  See section “Allergy 
Window”. 
 


37.3 Find Allergy Dialog Box 
 


 


This is a Find Allergy dialog box 
launched from an Allergy List (see 
section “Patient Window, Allergy 
Tab”) or from a Notes field (see 
section “Notes Fields”). 
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This is a Find Allergy dialog box 
launched either by selecting Open 
Allergy in a Patient toolbar (see 
section “Patient Window, Allergy 
Tab”), or from an Allergy window 
(see section “Allergy Window”). 


 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – A code representing the allergy agent. 
 
Description – A full description of the allergy agent. 
 
Other Fields 
 
OK button – Chooses the selected allergy code and closes the window.  If no allergy codes are 
displayed, searches for allergy codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add an allergy code (see section “Allergy Window”). 
 
Cancel button – Closes the window without choosing an allergy code. 
 
Clear button – Clears the allergy code list and all fields in the “Criteria” section. 
 
Find button – Searches for allergy codes that match the specified criteria. 
 
Allergy Code List – Lists allergy codes that match the specified criteria (see section “Viewing a 
List of Items”).  Select an allergy code and then select OK or press F9, or double-click on an 
allergy code, to choose that allergy code and close the window. 
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37.4 Allergy Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an allergy code. 
 
Open Code (Ctrl-O) – View/modify an allergy code. If you select this, a Find Allergy 
dialog box will open (see section “Find Allergy Dialog Box”).  Select an allergy code and 


then select OK or press F9, or double-click on an allergy code. 
 


Save (Ctrl-S) – Save the allergy code. 
 
Save and Close (Ctrl-L) – Save the allergy code and close the Allergy window. 


 
Other 
 
Code – An abbreviation representing the allergy.  NOTE:  This field cannot be modified if the 
allergy code has been saved.  If you need to modify this field, you must add a new allergy code 
(see section “Add an Allergy Code”), and, if desired, delete the old allergy code (see section 
“Delete an Allergy Code”). If you want to view/modify an allergy code, you can double-click in 
this field, and a Find Allergy dialog box will open (see section “Find Allergy Dialog Box”).  
Select an allergy code and then select OK or press F9, or double-click on an allergy code. 
 
Description – A full description of the allergy.  If you want to view/modify an allergy code, you 
can double-click in this field, and a Find Allergy dialog box will open (see section “Find Allergy 
Dialog Box”).  Select an allergy code and then select OK or press F9, or double-click on an 
allergy code. 
 


37.5 Delete an Allergy Code 
 
View/modify an allergy code as per section “View/Modify an Allergy Code”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the allergy code may be in use, it 
will not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
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38 Reaction Codes 


38.1 Add a Reaction Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Allergy tab (see section “Patient Window, Allergy Tab”).  Then do one of these: 
 


(a) Go to New → Reaction in the Patient toolbar. 
(b) On the Allergy List, do one of these: 


a. Select a Reaction field and then press F9. 
b. Select a Reaction Description field and then enter/modify any text, or press Enter 


or F2 or F9. 
c. Select a Reaction field and then right-click on an item in the list and select 


LookUp. 
d. Select a Reaction Description field and then right-click on an item in the list and 


select Edit or LookUp. 
e. Select a Reaction or Reaction Description field and then select LookUp on Item in 


the Patient toolbar. 
f. Double-click in a Reaction or Reaction Description field. 
A Find Reaction dialog box will open (see section “Find Reaction Dialog Box”).  
Select New. 


 
A Reaction window will open (see section “Reaction Window”). 
 


38.2 View/Modify a Reaction Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Allergy tab (see section “Patient Window, Allergy Tab”).  
Then go to Open → Reaction in the Patient toolbar. 


(b) Open a Reaction window as per section “Add a Reaction Code”.  Then select Open 
Code in the Reaction toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 


 
A Find Reaction dialog box will open (see section “Find Reaction Dialog Box”).  Select a 
reaction code and then select OK or press F9, or double-click on a reaction code.  See section 
“Reaction Window”. 
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38.3 Find Reaction Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The reaction code. 
 
Description – A full description of the reaction. 
 
Other Fields 
 
OK button – Chooses the selected reaction code and closes the window.  If no reaction codes 
are displayed, searches for reaction codes that match the specified criteria, chooses the first one, 
and closes the window. 
 
New button – Add a reaction code (see section “Reaction Window”). 
 
Cancel button – Closes the window without choosing a reaction code. 
 
Clear button – Clears the reaction code list and all fields in the “Criteria” section. 
 
Find button – Searches for reaction codes that match the specified criteria. 
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Reaction Code List – Lists reaction codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select a reaction code and then select OK or press F9, or double-
click on a reaction code, to choose that reaction code and close the window. 
 


38.4 Reaction Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a reaction code. 
 
Open Code (Ctrl-O) – View/modify a reaction code. If you select this, a Find Reaction 
dialog box will open (see section “Find Reaction Dialog Box”).  Select a reaction code and 


then select OK or press F9, or double-click on a reaction code. 
 


Save (Ctrl-S) – Save the reaction code. 
 
Save and Close (Ctrl-L) – Save the reaction code and close the Reaction window. 


 
Other 
 
Code – An abbreviation representing the reaction.  NOTE:  This field cannot be modified if the 
reaction code has been saved.  If you need to modify this field, you must add a new reaction code 
(see section “Add a Reaction Code”), and, if desired, delete the old reaction code (see section 
“Delete a Reaction Code”). If you want to view/modify a reaction code, you can double-click in 
this field, and a Find Reaction dialog box will open (see section “Find Reaction Dialog Box”).  
Select a reaction code and then select OK or press F9, or double-click on a reaction code. 
 
Description – A full description of the reaction.  If you want to view/modify a reaction code, 
you can double-click in this field, and a Find Reaction dialog box will open (see section “Find 
Reaction Dialog Box”).  Select a reaction code and then select OK or press F9, or double-click 
on a reaction code. 
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38.5 Delete a Reaction Code 
 
View/modify a reaction code as per section “View/Modify a Reaction Code”, and then go in the 
File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the reaction code may be in use, it 
will not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


39 Risk Codes 


39.1 Add a Risk Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Risk tab (see section “Patient Window, Risk Tab”).  Then do one of these: 
 


(a) Go to New → Risk in the Patient toolbar. 
(b) On the Risk List, do one of these: 


a. Select a Risk field and then press F9. 
b. Select a Description field and then press Enter or F2 or F9. 
c. Select a Risk field and then right-click on an item in the list and select LookUp. 
d. Select a Description field and then right-click on an item in the list and select Edit 


or LookUp. 
e. Select a Risk or Description field and then select LookUp on Item in the Patient 


toolbar. 
f. Double-click in a Risk or Description field. 
A Find Risk dialog box will open (see section “Find Risk Dialog Box”).  Select New. 


 
A Risk window will open (see section “Risk Window”). 
 


39.2 View/Modify a Risk Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Risk tab (see section “Patient Window, Risk Tab”).  Then go 
to Open → Risk in the Patient toolbar. 


(b) Open a Risk window as per section “Add a Risk Code”.  Then select Open Code in 
the Risk toolbar, or press Ctrl-O, or double-click in the Code or Description field. 


 
A Find Risk dialog box will open (see section “Find Risk Dialog Box”).  Select a risk code and 
then select OK or press F9, or double-click on a risk code.  See section “Risk Window”. 
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39.3 Find Risk Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The risk code. 
 
Description – A full description of the risk. 
 
Other Fields 
 
OK button – Chooses the selected risk code and closes the window.  If no risk codes are 
displayed, searches for risk codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a risk code (see section “Risk Window”). 
 
Cancel button – Closes the window without choosing a risk code. 
 
Clear button – Clears the risk code list and all fields in the “Criteria” section. 
 
Find button – Searches for risk codes that match the specified criteria. 
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Risk Code List – Lists risk codes that match the specified criteria (see section “Viewing a List 
of Items”).  Select a risk code and then select OK or press F9, or double-click on a risk code, to 
choose that risk code and close the window. 
 


39.4 Risk Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a risk code. 
 
Open Code (Ctrl-O) – View/modify a risk code. If you select this, a Find Risk dialog box 
will open (see section “Find Risk Dialog Box”).  Select a risk code and then select OK or 


press F9, or double-click on a risk code. 
 


Save (Ctrl-S) – Save the risk code. 
 
Save and Close (Ctrl-L) – Save the risk code and close the Risk window. 


 
Other 
 
Code – An abbreviation representing the risk, e.g. “SM” for “SMOKING”.  NOTE:  This field 
cannot be modified if the risk code has been saved.  If you need to modify this field, you must 
add a new risk code (see section “Add a Risk Code”), and, if desired, delete the old risk code 
(see section “Delete a Risk Code”). If you want to view/modify a risk code, you can double-click 
in this field, and a Find Risk dialog box will open (see section “Find Risk Dialog Box”).  Select a 
risk code and then select OK or press F9, or double-click on a risk code. 
 
Description – A full description of the risk.  If you want to view/modify a risk code, you can 
double-click in this field, and a Find Risk dialog box will open (see section “Find Risk Dialog 
Box”).  Select a risk code and then select OK or press F9, or double-click on a risk code. 
 


39.5 Delete a Risk Code 
 
View/modify a risk code as per section “View/Modify a Risk Code”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
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section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the risk code may be in use, it will 
not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


40 Alert Codes 


40.1 Add an Alert Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Alert tab (see section “Patient Window, Alert Tab”).  Then do one of these: 
 


(a) Go to New → Alert in the Patient toolbar. 
(b) On the Alert List, do one of these: 


a. Select an Alert field and then press F9. 
b. Select a Description field and then enter/modify any text, or press Enter or F2 or 


F9. 
c. Select an Alert field and then right-click on an item in the list and select LookUp. 
d. Select a Description field and then right-click on an item in the list and select Edit 


or LookUp. 
e. Select an Alert or Description field and then select LookUp on Item in the Patient 


toolbar. 
f. Double-click in an Alert or Description field. 
A Find Alert dialog box will open (see section “Find Alert Dialog Box”).  Select 
New. 


 
An Alert window will open (see section “Alert Window”). 
 


40.2 View/Modify an Alert Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Alert tab (see section “Patient Window, Alert Tab”).  Then go 
to Open → Alert in the Patient toolbar. 


(b) Open an Alert window as per section “Add an Alert Code”.  Then select Open Code 
in the Alert toolbar, or press Ctrl-O, or double-click in the Code or Description field. 


 
A Find Alert dialog box will open (see section “Find Alert Dialog Box”).  Select an alert code 
and then select OK or press F9, or double-click on an alert code.  See section “Alert Window”. 
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40.3 Find Alert Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The alert code. 
 
Description – A full description of the alert. 
 
Other Fields 
 
OK button – Chooses the selected alert code and closes the window.  If no alert codes are 
displayed, searches for alert codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add an alert code (see section “Alert Window”). 
 
Cancel button – Closes the window without choosing an alert code. 
 
Clear button – Clears the alert code list and all fields in the “Criteria” section. 
 
Find button – Searches for alert codes that match the specified criteria. 
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Alert Code List – Lists alert codes that match the specified criteria (see section “Viewing a List 
of Items”).  Select an alert code and then select OK or press F9, or double-click on an alert code, 
to choose that alert code and close the window. 
 


40.4 Alert Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an alert code. 
 
Open Code (Ctrl-O) – View/modify an alert code. If you select this, a Find Alert dialog 
box will open (see section “Find Alert Dialog Box”).  Select an alert code and then select 


OK or press F9, or double-click on an alert code. 
 


Save (Ctrl-S) – Save the alert code. 
 
Save and Close (Ctrl-L) – Save the alert code and close the Alert window. 


 
Other 
 
Code – An abbreviation representing the alert.  NOTE:  This field cannot be modified if the alert 
code has been saved.  If you need to modify this field, you must add a new alert code (see section 
“Add an Alert Code”), and, if desired, delete the old alert code (see section “Delete an Alert 
Code”). If you want to view/modify an alert code, you can double-click in this field, and a Find 
Alert dialog box will open (see section “Find Alert Dialog Box”).  Select an alert code and then 
select OK or press F9, or double-click on an alert code. 
 
Description – A full description of the alert.  If you want to view/modify an alert code, you can 
double-click in this field, and a Find Alert dialog box will open (see section “Find Alert Dialog 
Box”).  Select an alert code and then select OK or press F9, or double-click on an alert code. 
 


40.5 Delete an Alert Code 
 
View/modify an alert code as per section “View/Modify an Alert Code”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
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section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the alert code may be in use, it will 
not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


41 Relation Codes 


41.1 Add a Relation Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Family tab (see section “Patient Window, Family Tab”).  Then do one of these: 
 


(a) Go to New → Relation in the Patient toolbar. 
(b) On the Family Medical History List, do one of these: 


a. Select a Relation field and then press F9. 
b. Select a Relation Description field and then press Enter or F2 or F9. 
c. Select a Relation field and then right-click on an item in the list and select 


LookUp. 
d. Select a Relation Description field and then right-click on an item in the list and 


select Edit or LookUp. 
e. Double-click in a Relation or Relation Description field. 
A Find Relation dialog box will open (see section “Find Relation Dialog Box”).  
Select New. 


 
A Relation window will open (see section “Relation Window”). 
 


41.2 View/Modify a Relation Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Family tab (see section “Patient Window, Family Tab”).  Then 
go to Open → Relation in the Patient toolbar. 


(b) Open a Relation window as per section “Add a Relation Code”.  Then select Open 
Code in the Relation toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 


 
A Find Relation dialog box will open (see section “Find Relation Dialog Box”).  Select a relation 
code and then select OK or press F9, or double-click on a relation code.  See section “Relation 
Window”. 
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41.3 Find Relation Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The relation code. 
 
Description – A full description of the relation. 
 
Other Fields 
 
OK button – Chooses the selected relation code and closes the window.  If no relation codes are 
displayed, searches for relation codes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a relation code (see section “Relation Window”). 
 
Cancel button – Closes the window without choosing a relation code. 
 
Clear button – Clears the relation code list and all fields in the “Criteria” section. 
 
Find button – Searches for relation codes that match the specified criteria. 
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Relation Code List – Lists relation codes that match the specified criteria (see section “Viewing 
a List of Items”).  Select a relation code and then select OK or press F9, or double-click on a 
relation code, to choose that relation code and close the window. 
 


41.4 Relation Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a relation code. 
 
Open Code (Ctrl-O) – View/modify a relation code. If you select this, a Find Relation 
dialog box will open (see section “Find Relation Dialog Box”).  Select a relation code and 


then select OK or press F9, or double-click on a relation code. 
 


Save (Ctrl-S) – Save the relation code. 
 
Save and Close (Ctrl-L) – Save the relation code and close the Relation window. 


 
Other 
 
Code – An abbreviation representing the relation.  NOTE:  This field cannot be modified if the 
relation code has been saved.  If you need to modify this field, you must add a new relation code 
(see section “Add a Relation Code”), and, if desired, delete the old relation code (see section 
“Delete a Relation Code”). If you want to view/modify a relation code, you can double-click in 
this field, and a Find Relation dialog box will open (see section “Find Relation Dialog Box”).  
Select a relation code and then select OK or press F9, or double-click on a relation code. 
 
Description – A full description of the relation.  If you want to view/modify a relation code, you 
can double-click in this field, and a Find Relation dialog box will open (see section “Find 
Relation Dialog Box”).  Select a relation code and then select OK or press F9, or double-click on 
a relation code. 
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41.5 Delete a Relation Code 
 
View/modify a relation code as per section “View/Modify a Relation Code”, and then and then 
go in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the relation code may 
be in use, it will not actually be deleted from the database, but “hidden” such that it can not be 
used or found again. 
 


42 Treatment Codes 


42.1 Add a Treatment Code 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Family tab (see section “Patient Window, Family Tab”).  Then do one of these: 
 


(a) Go to New → Treatment in the Patient toolbar. 
(b) On the Family Medical History List, do one of these: 


a. Select a Treatment field and then press F9. 
b. Select a Treatment Description field and then enter/modify any text, or press 


Enter or F2 or F9. 
c. Select a Treatment field and then right-click on an item in the list and select 


LookUp. 
d. Select a Treatment Description field and then right-click on an item in the list and 


select Edit or LookUp. 
e. Select a Treatment or Treatment Description field and then select LookUp on 


Item in the Patient toolbar. 
f. Double-click in a Treatment or Treatment Description field. 
A Find Treatment dialog box will open (see section “Find Treatment Dialog Box”).  
Select New. 


 
A Treatment window will open (see section “Treatment Window”). 
 


42.2 View/Modify a Treatment Code 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Family tab (see section “Patient Window, Family Tab”).  Then 
go to Open → Treatment in the Patient toolbar. 


(b) Open a Treatment window as per section “Add a Treatment Code”.  Then select Open 
Code in the Treatment toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 


 







 318


A Find Treatment dialog box will open (see section “Find Treatment Dialog Box”).  Select a 
treatment code and then select OK or press F9, or double-click on a treatment code.  See section 
“Treatment Window”. 
 


42.3 Find Treatment Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The treatment code. 
 
Description – A full description of the treatment. 
 
Other Fields 
 
OK button – Chooses the selected treatment code and closes the window.  If no treatment codes 
are displayed, searches for treatment codes that match the specified criteria, chooses the first one, 
and closes the window. 
 
New button – Add a treatment code (see section “Treatment Window”). 
 
Cancel button – Closes the window without choosing a treatment code. 
 
Clear button – Clears the treatment code list and all fields in the “Criteria” section. 
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Find button – Searches for treatment codes that match the specified criteria. 
 
Treatment Code List – Lists treatment codes that match the specified criteria (see section 
“Viewing a List of Items”).  Select a treatment code and then select OK or press F9, or double-
click on a treatment code, to choose that treatment code and close the window. 
 


42.4 Treatment Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a treatment code. 
 
Open Code (Ctrl-O) – View/modify a treatment code. If you select this, a Find Treatment 
dialog box will open (see section “Find Treatment Dialog Box”).  Select a treatment code 


and then select OK or press F9, or double-click on a treatment code. 
 


Save (Ctrl-S) – Save the treatment code. 
 
Save and Close (Ctrl-L) – Save the treatment code and close the Treatment window. 


 
Other 
 
Code – An abbreviation representing the treatment.  NOTE:  This field cannot be modified if the 
treatment code has been saved.  If you need to modify this field, you must add a new treatment 
code (see section “Add a Treatment Code”), and, if desired, delete the old treatment code (see 
section “Delete a Treatment Code”). If you want to view/modify a treatment code, you can 
double-click in this field, and a Find Treatment dialog box will open (see section “Find 
Treatment Dialog Box”).  Select a treatment code and then select OK or press F9, or double-click 
on a treatment code. 
 
Description – A full description of the treatment.  If you want to view/modify a treatment code, 
you can double-click in this field, and a Find Treatment dialog box will open (see section “Find 
Treatment Dialog Box”).  Select a treatment code and then select OK or press F9, or double-click 
on a treatment code. 
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42.5 Delete a Treatment Code 
 
View/modify a treatment code as per section “View/Modify a Treatment Code”, and then go in 
the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar 
(see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the treatment code may be in 
use, it will not actually be deleted from the database, but “hidden” such that it can not be used or 
found again. 
 


43 Recall Types 


43.1 Add a Recall Type 
 
Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”) and go 
to the Recall tab (see section “Patient Window, Recall Tab”).  Then do one of these: 
 
(a) Go to New → Recall in the Patient toolbar. 
(b) On the Recall List, in a Code or Description field, do one of these: 


a. Press Enter. 
b. Press F2. 
c. Press F9. 
d. Enter/modify any text. 
e. Select the field and then right-click on an item in the list and select Edit or LookUp. 
f. Select the field and then select LookUp on Item in the Patient toolbar. 
g. Double-click. 
A Find Recall dialog box will open (see section “Find Recall Dialog Box”).  Select New. 


 
A Recall window will open (see section “Recall Window”). 
 
Or, open a Recalls window (see section “List Recalls”), and then, in the Type field, enter/modify 
any text, or press Enter, or double-click.  A Find Recall dialog box will open (see section “Find 
Recall Dialog Box”).  Select New.  A Recall window will open (see section “Recall Window”). 
 


43.2 View/Modify a Recall Type 
 
Do one of these: 
 


(a) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a 
Patient”) and go to the Recall tab (see section “Patient Window, Recall Tab”).  Then 
go to Open → Recall in the Patient toolbar. 


(b) Open a Recall window as per section “Add a Recall Type”.  Then select Open Code 
in the Recall toolbar, or press Ctrl-O, or double-click in the Code or Description field. 
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A Find Recall dialog box will open (see section “Find Recall Dialog Box”).  Select a recall type 
and then select OK or press F9, or double-click on a recall type.  See section “Recall Window”. 
 


43.3 Find Recall Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – An abbreviation representing the purpose of the recall. 
 
Description – The purpose of the recall. 
 
Other Fields 
 
OK button – Chooses the selected recall type and closes the window.  If no recall types are 
displayed, searches for recall types that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a recall type (see section “Recall Window”). 
 
Cancel button – Closes the window without choosing a recall type. 
 
Clear button – Clears the recall type list and all fields in the “Criteria” section. 
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Find button – Searches for recall types that match the specified criteria. 
 
Recall Code List – Lists recall types that match the specified criteria (see section “Viewing a 
List of Items”).  Select a recall type and then select OK or press F9, or double-click on a recall 
type, to choose that recall type and close the window. 
 


43.4 Recall Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a recall type. 
 
Open Code (Ctrl-O) – View/modify a recall type. If you select this, a Find Recall dialog 
box will open (see section “Find Recall Dialog Box”).  Select a recall type and then select 


OK or press F9, or double-click on a recall type. 
 


Save (Ctrl-S) – Save the recall type. 
 
Save and Close (Ctrl-L) – Save the recall type and close the Recall window. 


 
Other 
 
Code – An abbreviation representing the purpose of the recall, e.g. “FLU”.  NOTE:  This field 
cannot be modified if the recall type has been saved.  If you need to modify this field, you must 
add a new recall type (see section “Add a Recall Type”), and, if desired, delete the old recall type 
(see section “Delete a Recall Type”). If you want to view/modify a recall type, you can double-
click in this field, and a Find Recall dialog box will open (see section “Find Recall Dialog Box”).  
Select a recall type and then select OK or press F9, or double-click on a recall type. 
 
Description – The purpose of the recall, e.g. “Influenza Vaccine”.  If you want to view/modify a 
recall type, you can double-click in this field, and a Find Recall dialog box will open (see section 
“Find Recall Dialog Box”).  Select a recall type and then select OK or press F9, or double-click 
on a recall type. 
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43.5 Delete a Recall Type 
 
View/modify a recall type as per section “View/Modify a Recall Type”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the recall type may be in use, it will 
not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


44 Attachment Types 


44.1 Add an Attachment Type 
 
Do one of these: 
 


(a) Add or view/modify an attachment (see section “Add an Attachment” or “View/Modify 
an Attachment”), and then do one of these: 


a. Go to New → Type in the Attachment toolbar. 
b. Enter/modify any text, or double-click, in the Type field.  A Find (Attachment) 


Type dialog box will open (see section “Find (Attachment) Type Dialog Box”).  
Select New. 


(b) Open an Attachments window (see section “List Attachments”) and select Type.  A Find 
(Attachment) Type dialog box will open (see section “Find (Attachment) Type Dialog 
Box”).  Select New. 


 
An (Attachment) Type window will open (see section “(Attachment) Type Window”). 
 


44.2 View/Modify an Attachment Type 
 
Add or view/modify an attachment (see section “Add an Attachment” or “View/Modify an 
Attachment”), then select Open in the Attachment toolbar.  Or, open an (Attachment) Type 
window as per section “Add an Attachment Type”, then select Open in the (Attachment) Type 
toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section 
“(Attachment) Type Window”). 
 
A Find (Attachment) Type dialog box will open (see section “Find (Attachment) Type Dialog 
Box”).  Select an attachment type and select OK or press F9, or double-click on an attachment 
type.  See section “(Attachment) Type Window”. 
 







 324


44.3 Find (Attachment) Type Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The attachment type code. 
 
Description – A full description of the attachment type. 
 
Other Fields 
 
OK button – Chooses the selected attachment type and closes the window.  If no attachment 
types are displayed, searches for attachment types that match the specified criteria, chooses the 
first one, and closes the window. 
 
New button – Add an attachment type (see section “(Attachment) Type Window”). 
 
Cancel button – Closes the window without choosing an attachment type. 
 
Clear button – Clears the attachment type list and all fields in the “Criteria” section. 
 
Find button – Searches for attachment types that match the specified criteria. 
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Attachment Type List – Lists attachment types that match the specified criteria (see section 
“Viewing a List of Items”).  Select an attachment type and then select OK or press F9, or double-
click on an attachment type, to choose that attachment type and close the window. 
 


44.4 (Attachment) Type Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add an attachment type. 
 
Open Code (Ctrl-O) – View/modify an attachment type. If you select this, a Find 
(Attachment) Type dialog box will open (see section “Find (Attachment) Type Dialog 


Box”).  Select an attachment type and then select OK or press F9, or double-click on an 
attachment type. 
 


Save (Ctrl-S) – Save the attachment type. 
 
Save and Close (Ctrl-L) – Save the attachment type and close the (Attachment) Type 
window. 


 
Other 
 
Code – An abbreviation representing the attachment type.  NOTE:  This field cannot be modified 
if the attachment type has been saved.  If you need to modify this field, you must add a new 
attachment type (see section “Add an Attachment Type”), and, if desired, delete the old 
attachment type (see section “Delete an Appointment Type”). If you want to view/modify an 
attachment type, you can double-click in this field, and a Find (Attachment) Type dialog box will 
open (see section “Find (Attachment) Type Dialog Box”).  Select an attachment type and then 
select OK or press F9, or double-click on an attachment type. 
 
Description – A full description of the attachment type. If you want to view/modify an 
attachment type, you can double-click in this field, and a Find (Attachment) Type dialog box will 
open (see section “Find (Attachment) Type Dialog Box”).  Select an attachment type and then 
select OK or press F9, or double-click on an attachment type. 
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44.5 Delete an Attachment Type 
 
View/modify an attachment type as per section “View/Modify an Attachment Type”, and then go 
in the File menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main 
Toolbar (see section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the attachment type 
may be in use, it will not actually be deleted from the database, but “hidden” such that it can not 
be used or found again. 
 


45 Patient Lists 


45.1 Add a Patient List 
 
Do one of these: 
 


(a) Open a Patients window (see section “List Patients”), and then enter/modify any text, or 
double-click, in the List field. 


(b) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”), 
and then, on the Demographic tab (see section “Patient Window, Demographic Tab”), 
select Insert into List in the Patient toolbar. 


(c) Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”), and then, 
on the Invoice tab (see section “Bill Window, Invoice Tab”), select Bill from List in the 
Bill toolbar. 


 
A Find Patient List dialog box will open (see section “Find Patient List Dialog Box”).  Select 
New.  A Patient List window will open (see section “Patient List Window”). 
 


45.2 View/Modify a Patient List (Code/Description) 
 
Open a Patient List window as per section “Add a Patient List”, then select Open Code in the 
Patient List toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section 
“Patient List Window”). 
 
A Find Patient List dialog box will open (see section “Find Patient List Dialog Box”).  Select a 
patient list and select OK or press F9, or double-click on a patient list.  See section “Patient List 
Window”. 
 







 327


45.3 Find Patient List Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The patient list code. 
 
Description – A full description of the patient list. 
 
Other 
 
OK button – Chooses the selected patient list and closes the window.  If no patient lists are 
displayed, searches for patient lists that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a patient list (see section “Patient List Window”). 
 
Cancel button – Closes the window without choosing a patient list. 
 
Clear button – Clears the patient list list and all fields in the “Criteria” section. 
 
Find button – Searches for patient lists that match the specified criteria. 
 
Patient List List – Lists patient lists that match the specified criteria (see section “Viewing a 
List of Items”).  Select a patient list and then select OK or press F9, or double-click on a patient 
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list, to choose that patient list and close the window.  For a description of the fields, see section 
“Patient List Window”. 
 


45.4 Patient List Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a patient list. 
 
Open Code (Ctrl-O) – View/modify a patient list. If you select this, a Find Patient List 
dialog box will open (see section “Find Patient List Dialog Box”).  Select a patient list and 


then select OK or press F9, or double-click on a patient list. 
 


Save (Ctrl-S) – Save the patient list. 
 
Save and Close (Ctrl-L) – Save the patient list and close the Patient List window. 


 
Other 
 
Code – An abbreviation representing the patient list.  NOTE:  This field cannot be modified if 
the patient list has been saved.  If you need to modify this field, you must add a new patient list 
(see section “Add a Patient List”), and, if desired, delete the old patient list (see section “Delete a 
Patient List”). If you want to view/modify a patient list, you can double-click in this field, and a 
Find Patient List dialog box will open (see section “Find Patient List Dialog Box”).  Select a 
patient list and then select OK or press F9, or double-click on a patient list. 
 
Description – A full description of the patient list.  If you want to view/modify a patient list, you 
can double-click in this field, and a Find Patient List dialog box will open (see section “Find 
Patient List Dialog Box”).  Select a patient list and then select OK or press F9, or double-click on 
a patient list. 
 


45.5 Add a Patient to a Patient List 
 
Do one of these: 
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(a) Open a Patients window (see section “List Patients”), and then enter/modify any text, or 
double-click, in the List field.  A Find Patient List dialog box will open (see section “Find 
Patient List Dialog Box”).  Select a patient list and then select OK or press F9, or double-
click on a patient list.  Then select a patient (the Status field must not be set to List) and 
select Insert in the Patients toolbar. 


(b) View the contents of a patient list, as per section “View the Contents of a Patient List”.  
Select Insert.  A Find Patient dialog box will open (see section “Find Patient Dialog 
Box”).  Select a patient and then select OK or press F9, or double-click on a patient. 


(c) Add or view/modify a patient (see section “Add a Patient” or “View/Modify a Patient”), 
and then, on the Demographic tab (see section “Patient Window, Demographic Tab”), 
select Insert into List in the Patient toolbar.  A Find Patient List dialog box will open (see 
section “Find Patient List Dialog Box”).  Select a patient list and then select OK or press 
F9, or double-click on a patient list. 


 
You can also add many patients at once to a patient list, by using the Query button in the Patients 
window (see section “List Patients”). 
 


45.6 View the Contents of a Patient List 
 
Open a Patients window (see section “List Patients”).  Set the Status field to List.  Enter/modify 
any text, or double-click, in the List field.  A Find Patient List dialog box will open (see section 
“Find Patient List Dialog Box”).  Select a patient list and then select OK or press F9, or double-
click on a patient list.  The Patient List will then display a list of patients in the selected patient 
list. 
 


45.7 Delete a Patient from a Patient List 
 
View the contents of a patient list as per section “View the Contents of a Patient List”.  Then 
select a patient and select Delete in the Patients toolbar (see section “List Patients”). 
 


45.8 Bill from a Patient List 
 
Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”), and then, on the 
Invoice tab (see section “Bill Window, Invoice Tab”), select Bill from List in the Bill toolbar.  A 
Find Patient List dialog box will open (see section “Find Patient List Dialog Box”).  Select a 
patient list and then select OK or press F9, or double-click on a patient list.  A dialog box will 
say “About to auto-generate bills for patients from list […].  Proceed?” 
 







 330


 
 
(The code for the selected patient list will appear in the square brackets.)  Select Yes.  One copy 
of the open bill will be created for each patient on the selected patient list.  The new bills will 
have status Open or Incomplete (depending on whether they have enough information to be 
batched), or Hold (if the Hold option is on).  Also, the new bills will have no payments applied to 
them, with the possible exception of applicable private/insurer payments (with the Manual Apply 
option off) which had not yet been (fully) applied (see section "Payment Window").  Other than 
that, the new bills will have no responses, i.e. their Status tabs will be blank (see section "Bill 
Window, Status Tab"), except for the Site Invoice Number (see section "Invoice Numbers").  
Also, the “To CDS” option will be off for all services items in the new bills (see section “Bill 
Window, Invoice Tab, Service Item List”), but other than that, the new bills will respect defaults 
(see section “Defaults, Bill Window”). 
 


45.9 Delete a Patient List 
 
View/modify a patient list as per section “View/Modify a Patient List”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  Because the patient list may be in use, it will 
not actually be deleted from the database, but “hidden” such that it can not be used or found 
again. 
 


46 Bill Lists 


46.1 Add a Bill List 
 
Open a Bills window (see section “List Bills”), and then enter/modify any text, or double-click, 
in the List field.  A Find Bill List dialog box will open (see section “Find Bill List Dialog Box”).  
Select New.  A Bill List window will open (see section “Bill List Window”). 
 


46.2 View/Modify a Bill List (Code/Description) 
 
Open a Bill List window as per section “Add a Bill List”, then select Open Code in the Bill List 
toolbar, or press Ctrl-O, or double-click in the Code or Description field (see section “Bill List 
Window”). 
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A Find Bill List dialog box will open (see section “Find Bill List Dialog Box”).  Select a Bill list 
and select OK or press F9, or double-click on a bill list.  See section “Bill List Window”. 
 


46.3 Find Bill List Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The bill list code. 
 
Description – A full description of the bill list. 
 
Other 
 
OK button – Chooses the selected bill list and closes the window.  If no bill lists are displayed, 
searches for bill lists that match the specified criteria, chooses the first one, and closes the 
window. 
 
New button – Add a bill list (see section “Bill List Window”). 
 
Cancel button – Closes the window without choosing a bill list. 
 
Clear button – Clears the bill list list and all fields in the “Criteria” section. 
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Find button – Searches for bill lists that match the specified criteria. 
 
Bill List List – Lists bill lists that match the specified criteria (see section “Viewing a List of 
Items”).  Select a bill list and then select OK or press F9, or double-click on a bill list, to choose 
that bill list and close the window.  For a description of the fields, see section “Bill List 
Window”. 
 


46.4 Bill List Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a bill list. 
 
Open Code (Ctrl-O) – View/modify a bill list. If you select this, a Find Bill List dialog box 
will open (see section “Find Bill List Dialog Box”).  Select a bill list and then select OK or 


press F9, or double-click on a bill list. 
 


Save (Ctrl-S) – Save the bill list. 
 
Save and Close (Ctrl-L) – Save the bill list and close the Bill List window. 


 
Other 
 
Code – An abbreviation representing the bill list.  NOTE:  This field cannot be modified if the 
bill list has been saved.  If you need to modify this field, you must add a new bill list (see section 
“Add a Bill List”), and, if desired, delete the old bill list (see section “Delete a Bill List”). If you 
want to view/modify a bill list, you can double-click in this field, and a Find Bill List dialog box 
will open (see section “Find Bill List Dialog Box”).  Select a bill list and then select OK or press 
F9, or double-click on a bill list. 
 
Description – A full description of the bill list.  If you want to view/modify a bill list, you can 
double-click in this field, and a Find Bill List dialog box will open (see section “Find Bill List 
Dialog Box”).  Select a bill list and then select OK or press F9, or double-click on a bill list. 
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46.5 Add a Bill to a Bill List 
 
Open a Bills window and select a provider in the Provider field (see section “List Bills”).  Then 
enter/modify any text, or double-click, in the List field.  A Find Bill List dialog box will open 
(see section “Find Bill List Dialog Box”).  Select a bill list and then select OK or press F9, or 
double-click on a bill list.  Then do one of these: 
 


(a) If the Status field is set to List:  Select Insert.  A Find Bill dialog box will open (see 
section “Find Bill Dialog Box”).  Select a bill and then select OK or press F9, or double-
click on a bill. 


(b) If the Status field is not set to List:  Select a bill and select Insert in the Bills toolbar. 
 


46.6 View the Contents of a Bill List 
 
Open a Bills window and select a provider in the Provider field (see section “List Bills”).  Set the 
Status field to List.  Enter/modify any text, or double-click, in the List field.  A Find Bill List 
dialog box will open (see section “Find Bill List Dialog Box”).  Select a bill list and then select 
OK or press F9, or double-click on a bill list.  (You can also select other criteria in the Bills 
toolbar, such as From, To, and Type.)  The Bill List will then display a list of bills in the selected 
bill list that match the criteria in the Bills toolbar. 
 


46.7 Delete a Bill from a Bill List 
 
View the contents of a bill list as per section “View the Contents of a Bill List”.  Then select a 
bill and select Delete in the Bills toolbar. 
 


46.8 Bill from a Bill List 
 
View the contents of a bill list as per section “View the Contents of a Bill List”.  Set the “To” 
field in the Bills toolbar to the date desired for the new bills.  Then select Auto-bill in the Bills 
toolbar.  A dialog box will say “About to auto-generate bills from list […] for date ….  
Proceed?” 
 


 
 
(The code for the selected bill list will appear in the square brackets.)  Select Yes.  One new copy 
of each bill on the list will be created.  In the new bills, the bill dates and service dates (see 
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section “Bill Window, Invoice Tab”) will be set to the date in the “To” field in the Bills window 
(see section “List Bills”). 
 
The new bills will have status Open or Incomplete (depending on whether they have enough 
information to be batched), or Hold (if the Hold option is on).  Also, the new bills will have no 
payments applied to them, with the possible exception of applicable private/insurer payments 
(with the Manual Apply option off) which had not yet been (fully) applied (see section "Payment 
Window").  Other than that, the new bills will have no responses, i.e. their Status tabs will be 
blank (see section "Bill Window, Status Tab"), except for the Site Invoice Number (see section 
"Invoice Numbers").  Also, the “To CDS” option will be off for all services items in the new 
bills (see section “Bill Window, Invoice Tab, Service Item List”), and the new bills will not 
respect defaults (see section “Defaults, Bill Window”). 
 


46.9 Delete a Bill List 
 
View/modify a bill list as per section “View/Modify a Bill List”, and then go in the File menu to 
Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see section 
“Main Toolbar”), or press Ctrl-D.  NOTE:  Because the bill list may be in use, it will not actually 
be deleted from the database, but “hidden” such that it can not be used or found again. 
 


47 SuperCodes 


47.1 Add a SuperCode 
 
Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”), and then, on the 
Invoice tab (see section “Bill Window, Invoice Tab”), do one of these: 
 


(a) Go to New → SuperCode in the Bill toolbar. 
(b) Select SuperCode in the Bill toolbar.  A Find SuperCode dialog box will open (see 


section “Find SuperCode Dialog Box”).  Select New. 
 
A SuperCode window will open (see section “SuperCode Window”). 
 


47.2 View/Modify a SuperCode 
 
Do one of these: 
 


(a) Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”), and 
then, on the Invoice tab (see section “Bill Window, Invoice Tab”), go to Open → 
SuperCode in the Bill toolbar. 
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(b) Open a SuperCode window as per section “Add a SuperCode”.  Then select Open 
Code in the SuperCode toolbar, or press Ctrl-O, or double-click in the Code or 
Description field. 


 
A Find SuperCode dialog box will open (see section “Find SuperCode Dialog Box”).  Select a 
SuperCode and then select OK or press F9, or double-click on a SuperCode.  See section 
“SuperCode Window”. 
 


47.3 Find SuperCode Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – An abbreviation representing the SuperCode. 
 
Description – A full description of the SuperCode. 
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Other 
 
OK button – Chooses the selected SuperCode and closes the window.  If no SuperCodes are 
displayed, searches for SuperCodes that match the specified criteria, chooses the first one, and 
closes the window. 
 
New button – Add a SuperCode (see section “SuperCode Window”). 
 
Cancel button – Closes the window without choosing a SuperCode. 
 
Clear button – Clears the SuperCode list and all fields in the “Criteria” section. 
 
Find button – Searches for SuperCodes that match the specified criteria. 
 
SuperCode List – Lists SuperCodes that match the specified criteria (see section “Viewing a 
List of Items”).  Select a SuperCode and then select OK or press F9, or double-click on a 
SuperCode, to choose that SuperCode and close the window.  For a description of the fields, see 
section “SuperCode Window”. 
 


47.4 SuperCode Window 
 


 
 
Toolbar 
 


New Code (Ctrl-N) – Add a SuperCode. 
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Open Code (Ctrl-O) – View/modify a SuperCode. If you select this, a Find SuperCode 
dialog box will open (see section “Find SuperCode Dialog Box”).  Select a SuperCode and 


then select OK or press F9, or double-click on a SuperCode. 
 


Save (Ctrl-S) – Save the SuperCode. 
 
Save and Close (Ctrl-L) – Save the SuperCode and close the SuperCode window. 


 
Other 
 
Code – An abbreviation representing the SuperCode.  NOTE:  This field cannot be modified if 
the SuperCode has been saved.  If you need to modify this field, you must add a new SuperCode 
(see section “Add a SuperCode”), and, if desired, delete the old SuperCode (see section “Delete a 
SuperCode”).  If you want to view/modify a SuperCode, you can double-click in this field, and a 
Find SuperCode dialog box will open (see section “Find SuperCode Dialog Box”).  Select a 
SuperCode and then select OK or press F9, or double-click on a SuperCode. 
 
Description – A full description of the SuperCode.  If you want to view/modify a SuperCode, 
you can double-click in this field, and a Find SuperCode dialog box will open (see section “Find 
SuperCode Dialog Box”).  Select a SuperCode and then select OK or press F9, or double-click 
on a SuperCode. 
 
Service Item List 
 
Lists service items to be inserted into a bill whenever this SuperCode is used.  For a description 
of the fields, see section “Bill Window, Invoice Tab, Service Item List”. 
 


47.5 Use a SuperCode 
 
Add or view/modify a bill (see section “Add a Bill” or “View/Modify a Bill”), and then, on the 
Invoice tab (see section “Bill Window, Invoice Tab”), select SuperCode in the Bill toolbar (or 
press Ctrl-U).  A Find SuperCode dialog box will open (see section “Find SuperCode Dialog 
Box”).  Select a SuperCode and then select OK or press F9, or double-click on a SuperCode.  
The service items in the selected SuperCode will be added to the bill. 
 


47.6 Delete a SuperCode 
 
View/modify a SuperCode as per section “View/Modify a SuperCode”, and then go in the File 
menu to Delete (see section “Pull-Down Menus”), or select Delete in the Main Toolbar (see 
section “Main Toolbar”), or press Ctrl-D.  NOTE:  The SuperCode will not actually be deleted 
from the database, but “hidden” such that it can not be used or found again. 
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48 Transmissions 
 
Transmissions are used to transfer data (that has been added/modified since your last 
transmission) between your Site Server and the FMS (see section “Data Flow Structure”). 
 
To start a transmission, go in the File menu to Transmit (see section “Pull-Down Menus”), or 
select Transmit in the Main Toolbar (see section “Main Toolbar”). 
 
If you are in the user group “Hero 
Administrators,” “Hero Providers,” and/or “Hero 
Billers” (see section “Before You Begin”), a 
dialog box will ask “Do you want to send Bills in 
this replication?”  If you select Yes, then the 
transmission may send bills (which might then be 
sent to MOHLTC).  If you select No (or you are 
not in any of those user groups), then bills will not 
be sent. 
 
A dialog box will ask “Start sending and 
receiving data to be replicated?”  Select Yes. 
 


 
The Site Server will contact the FMS and send/receive data that has been added/modified since 
your last transmission.  (The workstation does not contact the FMS directly, but merely instructs 
the Site Server to contact the FMS.)  The status will be displayed in the status bar (see section 
“Status Bar”). 
 
While the transmission is in progress, you can continue to use HERO™ CMS normally.  During 
the transmission, a checkmark will appear beside Transmit in the File menu (see section “Pull-
Down Menus”), and the Transmit button in the Main Toolbar will stay pressed (see section 
“Main Toolbar”). 
 
Usually, transmissions are done through a dedicated Internet connection (e.g. DSL, cable).  
However, if necessary they can also be done through some other connection type, e.g. dial-up, 
Virtual Private Network, etc.  Windows can be configured such that your HERO™ CMS 
transmission will automatically trigger the necessary connection as needed.  (For more 
information, contact HTN – see section “HTN”.)  If you want this automatically-triggered 
connection to be automatically disconnected when the transmission is finished, turn on “RAS 
Disconnect” in the Miscellaneous dialog box (see section “Miscellaneous Dialog Box”). 
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To stop a transmission, go in the File menu to Transmit, 
or select Transmit in the Main Toolbar (as above).  A 
dialog box will ask “Stop sending and receiving data?”  If 
you select Yes, the transmission will be aborted. 
 


 
Once the transmission is complete, you will be 
notified: 
 


 
Occasionally, a new version of HERO™ CMS is released which might cause your Site Server 
(with the old version) to no longer be compatible with the FMS (with the new version).  When 
this occurs, you will not be able to do a transmission until you update to the latest version.  See 
section “Update”. 
 
You must do a transmission at least once every 90 days (although more often is recommended). 
 


49 Lock Session 
 
Lock Session is a feature that allows you to leave your computer unattended, while leaving 
HERO™ CMS running, and yet protecting your HERO™ CMS session from unauthorized use. 
 
This feature is only available if “Require Log On” is enabled (see section “Configuration”). 
 
To lock your session, go in the 
File menu to Lock Session 
(see section “Pull-Down 
Menus”), or select Lock 
Session in the Main Toolbar 
(see section “Main Toolbar”), 
or press F1.  A dialog box will 
ask “LOCK SESSION:  Are 
you really sure you want to lock the session?”  Select Yes.  The HERO™ CMS window will be 
minimized. 
 
When you restore the HERO™ CMS window, a 
HERO Unlock Session dialog box will open, which is 
similar to a HERO Log On dialog box (see section 
“HERO Log On Dialog Box”).  Enter your password 
(see section “Before You Begin”) and then select OK 
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or press Enter.  Or, select Exit to close HERO™ CMS. 
 
You can also have your workstation automatically locked after a certain period of inactivity.  In 
the Configuration window (see section “Configuration”), enter a whole number (from 1 to 99) in 
the Auto Lock field.  If your workstation is idle for that many minutes, HERO™ CMS will 
automatically minimize itself, and when you restore the HERO™ CMS window, a HERO 
Unlock Session dialog box will open, as above.  Enter your password and then select OK or 
press Enter.  Or, select Exit to close HERO™ CMS. 
 


50 Reorganize 
 
Reorganizing is a maintenance procedure which reorganizes the data in your database (to 
improve database performance), and frees up wasted space in the database (making the database 
smaller).  
 
To reorganize your database, go in the File menu to Reorganize (see section “Pull-Down 
Menus”). 
 
Only users in the user group “Hero Administrators” can reorganize the database (see section 
“Before You Begin”). 
 


51 Backup 
 
To protect against (accidental/malicious) loss of your important (medical/financial) data, it is 
critical that you make backup copies of your HERO™ CMS database, and do so often (e.g. at 
least once a day).  In the event of data loss, it may be possible to restore some of your data from 
the FMS (see section “Data Flow Structure”), but this cannot be guaranteed.  Ultimately it is 
your responsibility to maintain backup copies of your database. 
 
The HERO™ CMS database is stored in two files, generally called HEROCMS.MDF and 
HEROCMS.LDF and located in a folder such as “C:\Program Files\Microsoft SQL 
Server\MSSQL.1\MSSQL\Data” on your Site Server computer.  To make a backup, these files 
need to be copied to another location.  The backups should be stored in a safe location (e.g. a 
locked fireproof vault) as far away from your Site Server as possible.  DO NOT STORE THE 
BACKUPS IN THE SAME BUILDING AS THE ORIGINAL!  There are many disasters that could 
easily affect an entire building or more:  fire, theft, vandalism, terrorism, flood, tornado, 
hurricane, tsunami, earthquake, etc.  The best place to store your backups is on a different 
continent (e.g. send it over the Internet, securely), or at least a different city. 
 
If you do use physical media to store/transport your backups (instead of sending them 
electronically, e.g. over the Internet), there are many options:  DVD, HD-DVD, Blu-Ray DVD, 
tape, portable (external/removable) hard disk, CD, ZIP disk, USB flash drive, etc.  Whichever 
you use, you should have at least two of them (e.g. while one is in use, the others should remain 
in your “safe location”, and then swap them before the next backup).  Of course you must ensure 
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that whatever media you use has enough storage space available for your HERO™ CMS 
database (you can compress the database, if desired).  Most likely, each backup will overwrite a 
previous backup.  You cannot use an “incremental” or “differential” backup on a HERO™ CMS 
database, i.e. you cannot back up only data that has changed since a previous backup – you must 
back up the entire database every time.  To discuss your specific needs, contact your hardware 
supplier or HTN (see section “HTN”). 
 
As for your backup method (i.e. software), there are several options: 
 


1. Use HERO™ CMS’s internal backup function.  Only users in the user group “Hero 
Administrators” can use this function (see section “Before You Begin”).  Go in the File 
menu to Backup (see section “Pull-Down Menus”).  This procedure can be triggered from 
any workstation (although the backup will actually be performed on the Site Server 
computer – see section “Data Flow Structure”).  Your HERO™ CMS database will be 
copied into a file such as “C:\Program Files\Microsoft SQL 
Server\MSSQL.1\MSSQL\Backup\######.BAK” on your Site Server computer, where 
###### represents your database name and Site Number (see section “Configuration”), 
separated by a dot.  For example, if your database name is HEROCMS, and your site 
number is Demo.01, then the backup file will be called HEROCMS.Demo.01.bak.  Once 
the backup is complete, it is your responsibility to copy this backup file to a safe location 
(see above).  Do NOT simply leave the backup on the same computer as the original! 


2. Some kind of “Volume Shadow Service,” “Virtual Machine”, or “SQL Agent” 
software/service can be used (on your Site Server computer) to ensure that both database 
files (e.g. HEROCMS.MDF and HEROCMS.LDF) are backed up simultaneously, which 
is necessary to ensure a proper backup. 


3. Stop the SQL service, then perform a standard backup using any backup software (e.g. 
the Windows backup utility), or manually (e.g. using Windows Explorer or the command 
prompt), and then re-start the SQL service.  (This procedure can be automated.)  During 
this procedure, you cannot use HERO™ CMS.  This method requires familiarity with 
Microsoft SQL Server. 


 
For more information on backup procedures/methods, software, hardware, and services, contact 
your local hardware/software distributor or HTN (see section “HTN”). 
 
If you restore from a backup, you might need to re-attach your database (see section “Server 
Initialization Dialog Box”).  Also, if you restore from a backup, you should immediately do a 
transmission (see section “Transmissions”) before adding, modifying, or deleting any data in 
your database. 
 


52 Audit 
 
The audit is a feature that can keep track of three different types of events: 
 


1. Every time a user launches the HERO™ CMS client and connects to the database.  To 
log these events, enable “Audit LogOn” in the Miscellaneous dialog box. 
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2. Every time a user opens any patient-specific data in the database.  To log these events, 
enable “Audit Access” in the Miscellaneous dialog box. 


3. Every time a user saves any patient-specific or provider-specific data in the database.  To 
log these events, enable the desired option(s) in the Miscellaneous dialog box, according 
to the record type(s) you want to audit:  Provider (“Audit Provider”), Patient (“Audit 
Cds”), Bill/Payment (“Audit Bill”), Prescription (“Audit Rx”), Requisition (“Audit 
Lab”), Referral (“Audit Referral”), Encounter (“Audit Encounter”), Attachment (“Audit 
Attachment”), Appointment (“Audit Appointment”), and/or Task (“Audit Task”). 


 
To enable/disable the various types of audit, open the Configuration window (see section 
“Configuration”), then select the “Misc…” button (see section “Miscellaneous Dialog Box”), 
and then enable/disable the desired options (as above). 
 
The audit has various advantages: 
 


 If erroneous or falsified data is entered into your database, or data is accidentally or 
maliciously deleted from your database, the audit may be able to help track down the 
cause of the problem, and/or reconstruct the missing or altered data. 


 To protect privacy of confidential (patient medical) data, certain laws/regulations might 
require you to keep track of who accessed what data, when, from where, etc.  The audit 
can meet this requirement. 


 
The audit can also have disadvantages:  It will increase (perhaps double or more) the size of your 
database, and it will slow down your access to the database. 
 
To obtain an audit log: 
  


1. To obtain a LogOn Audit, open the Configuration window (see section “Configuration”) 
and then go in the File menu to Audit → Access (see section “Pull-Down Menus”).  A 
Save As dialog box will open (see section “Save As Dialog Box”).  The audit log will be 
saved into the selected file. 


2. To obtain a record of accesses for a particular patient, first open that patient (see section 
“View/Modify a Patient”).  Then choose a tab (Demographic, Contact, Insurance, Appt., 
Bill, Encounter, Problem, Rx, Requisition, Lab, Imm., Allergy, Risk, Alert, Family, 
Recall, Task, Ref., Attach., or Prog. – not CPP or Import), depending on which type of 
data you want to audit.  Then go in the File menu to Audit → Access (see section “Pull-
Down Menus”).  A Save As dialog box will open (see section “Save As Dialog Box”).  
The audit log will be saved into the selected file. 


3. To obtain a record of writes to your database, first open a patient (see section 
“View/Modify a Patient”), and then choose a tab (Demographic, Contact, Insurance, 
Appt., Bill, Encounter, Problem, Rx, Requisition, Lab, Imm., Allergy, Risk, Alert, 
Family, Recall, Task, Ref., Attach., or Prog. – not CPP or Import), depending on which 
type of data you want to audit.  Or, open a provider (see section “View/Modify a 
Provider”), and then choose a tab (Demographic or Security – not Schedule), depending 
on which type of data you want to audit.  Then go in the File menu to Audit → Edit (see 
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section “Pull-Down Menus”).  A Save As dialog box will open (see section “Save As 
Dialog Box”).  The audit log will be saved into the selected file. 


 
Only users in the user group “Hero Administrators” can obtain an audit log (see section “Before 
You Begin”). 
 
Audit logs are saved in XML format, and can be viewed in a web browser.  Note that XML files 
may be confusing to some users.  For assistance in interpreting/understanding the contents of an 
audit log, contact HTN (see section “HTN”). 
 


53 Data Port 


53.1 Export 
 
This function is used to export electronic medical records from your HERO™ CMS database 
into files which can then be viewed/imported using a different program.  To export data: 
 


1. Log in as a provider (see section “Log in as a Provider”). 
2. Go in the File menu to Data Port → Export (see section “Pull-Down Menus”). 
3. A dialog box will ask 


“Export using OntarioMD 
Data Portability format?”  
Your answer to this 
question (Yes or No) will 
determine the format of 
the output files (see 
below). 


4. A Query dialog box will open (see section “Query Dialog Box”).  Enter criteria to specify 
which patients to export, and then select OK.  Only patients for the logged-in provider 
will be exported, unless you remove that criteria from the SQL field (e.g. by selecting 
“Clear Criteria”). 


5. A Browse For Folder dialog box will open (see section “Browse For Folder Dialog 
Box”).  Choose a folder where the exported data will be stored.  (It is recommended that 
you choose an empty folder.) 


 
Only users in the user group “Hero Administrators” can use this Export feature (see section 
“Before You Begin”). 
 
Export using OntarioMD Data Portability Format 
 
The format of the files is determined by OntarioMD’s “Data Portability” specifications.  These 
files can be imported into any Electronic Medical Records software that has been “validated” by 
OntarioMD. 
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Each patient exported will be exported into a different file in the selected folder.  The names of 
the files will be in the format “####################.xml” (without the quotes), where each # 
represents any digit in hexadecimal (0, 1, 2, 3, 4, 5, 6, 7, 8, 9, a, b, c, d, e, or f).  There will also 
be two text files, ExportEventLog.txt and ReadMe.txt, in that same folder, containing 
information about the exported data. 
 
Export without using OntarioMD Data Portability Format 
 
The selected folder will contain one subfolder for each patient exported.  The name of the 
subfolder will be based on the patient’s health card number, unless the patient has no health card, 
in which case a GUID (unique random number/code such as 4803949e48abddafe3e0) will be 
used instead.  Each subfolder will contain: 
 


1. Cds.Pdf – This is the same as the output you would have received if you had run the 
report "CDS" from the Patient window (see section “Patient Window”), and saved the 
output in PDF format (see section “Export a Report”).  (It is recommended that you not 
edit or delete this report.  See section “Reports”.) 


2. Cds.Xml – This is the same as the output you would have received if you had run the 
report "CDS" from the Patient window (see section “Patient Window”), and saved the 
output in XML format (see section “Export a Report”). 


3. If the patient had any Attachments (see section “Attachments”), they'll be saved into a 
subfolder called Attachments.  The files are automatically renamed to ensure that the 
filenames are unique (in case there are multiple files with the same names).  If any 
Attachment contained data that was scanned by a TWAIN-compliant device (using the 
Scan button in the Attachment window – see section “Attachment Window”), that data 
will be saved into a file with a unique name such as 10001.gif. 


 


53.2 Import 
 
This function is used to import electronic medical records into your HERO™ CMS database 
from (XML) files (which were presumably exported from another medical database).  The 
format of the files is determined by OntarioMD’s “Data Portability” specifications.  To import 
data: 
 


1. Log in as a provider (see section “Log in as a Provider”). 
2. Go in the File menu to Data Port → Import (see section “Pull-Down Menus”). 
3. A Browse For Folder dialog box will open (see section “Browse For Folder Dialog 


Box”).  Choose a folder where the files you want to import are located. 
 
All valid XML files (in the proper format) will be imported.  If the health card number in the 
XML file matches a health card number of a patient in your database, then the relevant data will 
be associated with that patient record.  If the health card number does not match, then a NEW 
patient will be created in your database, with the patient’s primary provider set to match the 
“logged in” provider (see step #1 above).  In either case, information from the XML file is 
imported into the appropriate area/tab in the Patient Window (see section “Patient Window”) 
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wherever possible, and all of the information from the XML file is imported into the Patient 
window, Import tab (see section “Patient Window, Import Tab”). 
 
Only users in the user group “Hero Administrators” can use this Import feature (see section 
“Before You Begin”). 
 
 


54 Change Password 
 
In order to reduce the risk of someone finding out (or guessing) your HERO™ CMS password, 
and/or to minimize the damage in case this does happen, it is recommended that you change your 
password often, and never tell anyone your password.  To change your password: 
 


 If you are logged into the Site Server computer (or its domain – see section “Domain”) 
under the same account you use to log into HERO™ CMS (see section “Before You 
Begin”), follow #1 or #2 below. 


 If you are not logged into the Site Server computer (or its domain – see section 
“Domain”) under the same account you use to log into HERO™ CMS (see section 
“Before You Begin”): 


o If “Require Log On” is enabled (see section “Configuration”), follow #1 below. 
o If “Require Log On” is disabled (see section “Configuration”): 


 If the first Password field in the Configuration window (see section 
“Configuration”) is blank, follow #1 and #2 below. 


 If the first Password field in the Configuration window (see section 
“Configuration”) is not blank, follow #1 below, and then change the 
password in the first Password field in the Configuration window. 


 
1. Go in the File menu to Change 


Password (see section “Pull-
Down Menus”).  A Change 
Password dialog box will open.  
Enter your current password 
under “Old Password”, and your 
desired new password under 
“New Password” and “Confirm 
Password”, and then select OK 
(or press Enter). 


2. Change your password through Windows (e.g. press Ctrl-Alt-Del and then select 
“Change Password…”, or go in the Control Panel to Passwords or User Accounts).  For 
more information, check your Windows help or documentation. 
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55 Update 
 
Periodically, a new version of HERO™ CMS will be released, to add new features to the 
program, etc.  To see which version you are currently using, and to find out the latest version 
available (as of your last transmission – see section “Transmissions”), go in the Help menu to 
About Hero CMS (see section “Pull-Down Menus”).  If you wish to update to the latest version 
(e.g. so you can use the latest features), follow this procedure: 
 


1. Download an update file (e.g. HeroWebService.msi) from HTN (e.g. probably over the 
web) and install it on your Site Server computer.  For more information, contact HTN 
(see section “HTN”). 


 
2. On each 


workstation, 
go in the File 
menu to 
Update (see 
section “Pull-
Down 
Menus”).  A 
dialog box 
will ask “Are you sure you want to exit and update the application?”  Select OK.  
HERO™ CMS will close and launch your default web browser (for more information on 
default web browsers, check your Windows help or documentation), which will 
download a file called HEROCMS.msi (which contains the latest version of the HERO™ 
CMS client) from the Site Server to the workstation (see section “Data Flow Structure”).  
If you are asked for a username and password, use the same username and password that 
you use to log in to HERO™ CMS (see section “Before You Begin”).  Your web browser 
will then either automatically start the update procedure, or you will have to save the file 
(e.g. to a temporary folder, or your Windows desktop, etc.), and then run it manually (e.g. 
double-click on it). 


 
3. Do a transmission (see section “Transmissions”). 


 
Occasionally, a new version of HERO™ CMS is released which might cause your Site Server 
(with the old version) to no longer be compatible with the FMS (with the new version).  When 
this occurs, you will not be able to do a transmission (see section “Transmissions”) until you 
follow step #1 above.  (Note that you must do a transmission at least once every 90 days.)  Other 
than this issue, however, all updates are optional, i.e. you only need to install them if they 
contain new features that you wish to use. 
 
Occasionally, a new version of HERO™ CMS is released which might cause your workstations 
(with the old version) to no longer be compatible with your Site Server (with the new version, 
after step #1 above has been completed).  When this occurs, once step #1 above has been 
completed, each workstation will not be able to run the HERO™ CMS client until step #2 above 
has been completed.  However, most new versions of HERO™ CMS do not have this 
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incompatibility, i.e. you can continue using the old version on the workstations with the new 
version on the Site Server (i.e. step #2 above can be skipped or delayed). 
 
If you launch HERO™ CMS and a dialog 
box opens that says “Update for 
application detected at Site server.”, this 
indicates that the version of HERO™ 
CMS running on the workstation is older 
than the version of HERO™ CMS running 
on the Site Server, i.e. step #1 above has 
been completed, but step #2 above hasn’t.  
Select OK, and another dialog box will ask “Are you sure you want to exit and update the 
application?” (see step #2 above).  Select OK to upgrade the workstation to the same version as 
the Site Server, or select Cancel to continue using the old version on the workstation. 
 


56 OBEC (Overnight Batch Eligibility Check) 
 
OBEC is a system you can use to determine if a patient’s health card number (and version code) 
are correct before you provide medical services to that patient.  You can only use OBEC if you 
are approved for OBEC with HTN (see section “HTN”). 
 
HERO™ CMS will send out an OBEC request when: 


 You add a new patient (with an Ontario health card number).  See section “Add a 
Patient”. 


 You change a patient’s Ontario health card number or version code.  See section “Patient 
Window, Demographic Tab, Misc. Section”. 


 You change a patient’s health card jurisdiction to ON (from any other option).  See 
section “Patient Window, Demographic Tab, Misc. Section”. 


 You enable “Re-transmit/OBEC” in a Patient toolbar.  See section “Patient Window, 
Demographic Tab”. 


 A patient has an upcoming appointment in the next few days.  The exact number of days 
is determined by the “OBEC Freq.” field in the Miscellaneous dialog box (see section 
“Configuration, Miscellaneous Dialog Box”). 


 
Once an OBEC request has been sent, you will usually receive a response within a day or two.  
OBEC responses are displayed: 
 


 In the Patient window, Demographic tab, Misc. section, on the second line, right side (see 
section “Patient Window, Demographic Tab, Misc. Section”). 


 In the Appts. window, Day tab (see section “List Appointments, Day Tab”), in the EC 
(Patient Status # X) fields. 


 In the Patients window (see section “List Patients”), patients are listed according to their 
OBEC status:  Incomplete (patient cannot be OBEC verified due to missing health card 
number), Open (patient is ready for OBEC verification), Pending (an OBEC request has 
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been sent, but no response has been received), or Error (patient failed OBEC 
verification). 


 Some reports (e.g. patient information or list of patients) may include OBEC responses 
(see section “Reports”). 


 
Note that OBEC requests are generated by the FMS, and OBEC responses are received and 
processed by the FMS (see section “Data Flow Structure”).  Therefore, if you want to use OBEC, 
you should do transmissions often (e.g. every day) in order to keep your data on the FMS up to 
date, and to receive the OBEC responses in a timely manner.  See section “Transmissions”. 
 


57 Mail Merge 
 
A Mail Merge is a function that allows you to export specific patients to a file, which can then be 
imported into another program (e.g. spreadsheet, database, etc.).  There are two ways to perform 
a Mail Merge: 
 
Mail Merge from a Patients Window 
 


1. Add a Patient List (see section “Add a Patient List”), or use an existing Patient List. 
2. Modify the contents of that patient list to contain (only/all) the patients you want to 


include in the Mail Merge.  See sections “Add a Patient to a Patient List”, “View the 
Contents of a Patient List”, and “Delete a Patient from a Patient List”. 


3. View the contents of the Patient List (see section “View the Contents of a Patient List”). 
4. Export a report (see section “Export a Report”).  For the file format, “Text” is 


recommended.  You can use a report such as “Mail Merge”. 
 
Mail Merge from a Provider Window 
 


1. View/modify a provider (see section “View/Modify a Provider”). 
2. Export a report (see section “Export a Report”).  For the file format, “Text” is 


recommended.  You can use a report such as “Mail Merge”. 
3. Optional:  From the Find Report dialog box (see section “Find Report Dialog Box”), 


select Query.  A Query dialog box will open (see section “Query Dialog Box”).  You can 
use this dialog box to select which patients you want included in the mail merge.  Then 
select OK. 


 


58 General Help 


58.1 Date Fields 
 
The layout of the date (e.g. mm/dd/yyyy or dd-mm-yy, etc.) depends on your Windows “Short 
Date Format”, e.g. in the Windows Control Panel under Regional Settings or Regional and 
Language Options.  For more information, check your Windows help or documentation. 
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If the date field is in a list (see section “Viewing a List of Items”), in order to edit the date you 
must do one of these: 
 


 Select the date field and then do one of these: 
o Enter any text. 
o Press Enter or F2 or F9. 
o Select LookUp on Item in the active window’s toolbar, if applicable. 
o Right-click on any item in the list and select Edit or LookUp. 


 Double-click in the date field. 
 
To enter a segment of the date (e.g. month, day, or year), use the number keys, or use the 
up/down arrow keys, or + and - (on the keypad), to increase/decrease the value, or press Home 
for the lowest possible value (e.g. 01) or End for the highest possible value (e.g. 12, 31, etc.).  To 
move between the different segments of the date, use the left/right arrow keys or click with the 
mouse.  You can also jump to the next segment by pressing one of these keys:  , . / : - 
 
To jump to the current day, press Ctrl-Home.  To delete the date, press Backspace (or Delete). 
 
You can omit any leading zeroes, e.g. enter “1” instead of “01” (zeroes may be automatically 
added as needed).  The year must be from 1900 to 9998.  Years from 0 to 99 will automatically 
be converted according to your Windows Calendar settings (“When a two-digit year is entered, 
interpret it as a year between…”), e.g. in the Windows Control Panel under Regional Settings or 
Regional and Language Options.  For more information, check your Windows help or 
documentation. 
 
Or, you can click on the down-arrow on the right side 
of the date field and select the date from the pop-up 
calendar. 
 
The pop-up calendar will look and function differently 
depending on which version of Windows you are 
using.  For more information, check your Windows 
help or documentation. 


 
If a date field is left blank, a default date such as January 1, 1900 or December 30, 1899 may be 
assumed. 
 


58.2 Time Fields 
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The layout of the time has 3 segments:  hour (12-hour time only), minute, and AM/PM.  The 
symbols used for AM/PM depend on your Windows settings (e.g. in the Windows Control Panel 
under Regional Settings or Regional and Language Options – for more information check your 
Windows help or documentation).  However, the rest of the time format is fixed and does not 
depend on your Windows settings. 
 
To enter a segment of the time, use the number keys (or A for AM or P for PM), or use the 
up/down arrow keys, or + and – (on the keypad), or the up/down buttons in the time field to 
increase/decrease the value, or press Home for the lowest possible value (e.g. 12AM or 00) or 
End for the highest possible value (e.g. 11PM or 59).  To move between the different segments 
of the time, use the left/right arrow keys or click with the mouse.  You can also jump to the next 
segment by pressing one of these keys:  , . / : - 
 
If you enter the hour as 00, it will be converted to 12.  If you enter the hour as 12, it will 
automatically change the AM to PM.  If you enter an hour from 13 to 23, it will automatically 
subtract 12 from the hour and change the AM to PM. 
 
If a time field is left blank, a default time of 12:00 AM may be assumed. 
 


58.3 Money Fields 
 
The layout of a money field depends on your Windows number/currency format, e.g. in the 
Windows Control Panel under Regional Settings or Regional and Language Options.  For more 
information, check your Windows help or documentation. 
 


58.4 Notes Fields 
 
Most editable notes (multi-line text) fields support the features described in the sections below. 
 


58.4.1 Insertion Point Positioning 
 
If the insertion point is in a notes field, and you press Tab, the insertion point will jump forward 
until it finds one of these: 
 


 A colon (:) followed by a space:  The insertion point will be positioned to the right of the 
space. 


 A colon (:) at the end of a line (unless it’s the last line in the notes field):  The insertion 
point will be positioned at the beginning of the next line. 


 An asterisk (*):  The insertion point will be positioned just before the asterisk.  Also, the 
asterisk will automatically disappear when new text is typed (but not pasted). 


 A Choice List, i.e. any text enclosed in square brackets (see section “Choice Lists”):  the 
next option in the Choice List will be selected. 
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If none of the above is found, the next field in the current window will be selected instead. 
 
If you press Shift-Tab, the insertion point will jump backward until it finds one of the four items 
above.  If none of them are found, the previous field in the current window will be selected 
instead. 
 
If you hold down Ctrl while clicking in a notes field with the mouse, the insertion point will 
jump backward (from where you clicked) until it finds one of the items above.  If none of them 
are found, the insertion point will be positioned exactly where you clicked. 
 


58.4.2 Choice Lists 
 
You can enter a Choice List, which is a list of one or more options, enclosed in square brackets, 
and separated by pipes, for example: 
 


[Option 1|Option 2|Option 3|Option 4] 
 
You can pres Tab or Shift-Tab to select the next/previous option in the list (see section “Insertion 
Point Positioning”). 
 
When an option is selected, you can press Enter (or right-click and select Enter Action – see 
section “Context Menu”) to confirm it (which deletes all the other options, along with the square 
brackets and pipes).  Or, you can double-click on an option to confirm it (which deletes all the 
other options, along with the square brackets and pipes).  Or, if the entire list is selected 
(everything in between the square brackets), you can press Delete (or right-click and select 
Delete Action – see section “Context Menu”) to delete the entire list (including the square 
brackets and pipes).  The features in this paragraph are not available in the Template window 
(see section “Template Window”). 
 
Also, a Choice List can be “nested” inside another choice list, for example: 
 
 [ Temperature is [Low|Normal|High] | Temperature Not Taken ] 
 


58.4.3 Codes 
 
If any line in a notes fields contains an underlined “code type”, followed by a colon (the colon 
should not be underlined), if you double-click (or press F9) anywhere on that line or the next 
line, a Find dialog box will open.  Select a code in that Find dialog box, and that code will be 
copied into the notes field.  The following code types are supported: 
 
Code Type Explanation Find Dialog Box 
Alert Alert Find Alert Dialog Box 
Allergy Allergy Find Allergy Dialog Box 
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Contact Contact Find Contact Dialog Box 
Diagnosis Diagnosis Find Diagnosis Dialog Box 
Drug Drug Find Drug Dialog Box 
Facility Facility Find Facility Dialog Box 
Immunization Immunization Find Immunization Dialog Box 
Location Location Find Location Dialog Box 
Problem Problem Find Problem Dialog Box 
Procedure Procedure Find Procedure Dialog Box 
Re (Appt.) Appointment Re Find Appointment Re Dialog Box 
Re (Encnt.) Encounter Re Find Encounter Re Dialog Box 
Reaction Reaction Find Reaction Dialog Box 
Recall Recall Type Find Recall Dialog Box 
Relation Relation Find Relation Dialog Box 
Risk Risk Find Risk Dialog Box 
SIG SIG Find SIG Dialog Box 
Test Test Find Test Dialog Box 
Treatment Treatment Find Treatment Dialog Box 
Type (Appt.) Appointment Type Find (Appointment) Type Dialog Box 
Type (Attach.) Attachment Type Find (Attachment) Type Dialog Box 
Type (Encnt.) Encounter Type Find (Encounter) Type Dialog Box 
 
If you use the word “Date” as the code type, double-clicking (or pressing F9) anywhere on that 
line or the next line creates a date field, which can be used to enter a date as per section “Date 
Fields”.  Once a date has been selected, it is stored as plain text, i.e. cannot be edited as a date 
field. 
  
If you use a code type that’s not mentioned above, then you have created a new (custom) code 
type, which can only be used in a notes field.  For example, suppose you want a way of tracking 
your patients’ religions (certain religions have certain beliefs about medical procedures), but 
there is no field to store a patient’s religion.  To create a new code type called “Religion”: 
 


 In any notes field, enter the word “Religion”, followed by a colon (:).  The colon should 
be at the end of a line, or followed by a space.  Underline the word “Religion” (e.g. select 
it and press Ctrl-U), but don’t underline the colon.  Double-click on the word “Religion”.  
A Find Religion dialog box will open, which will look and function like other Find dialog 
boxes, such as the Find Diagnosis dialog box (see section “Find Diagnosis Dialog Box”). 


o If you want to insert a religion into the notes field you were typing in (see above), 
select a religion and then press Enter or F9, or double-click on a religion. 


o Or, if you want to add, modify, or delete a religion, select New.  A Religion 
window will open, which will look and function like other code entry windows, 
such as the Diagnosis window (see section “Diagnosis Window”). 
 In the Religion window, you can add a new religion:  enter a code (and 


description, if desired), and select Save or Save and Close in the Religion 
toolbar, or go in the File menu to Save or Save and Close (see section 
“Pull-Down Menus”), or press Ctrl-S or Ctrl-L. 
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 Or, to modify or delete a religion, select Open in the Religion toolbar, or 
press Ctrl-O, or double-click in the Code or Description field in the 
Religion window.  A Find Religion dialog box will open (see above).  
Select a religion and then press Enter or F9, or double-click on a religion.   


 You can now modify (or add/delete) the religion’s description, and 
then select Save or Save and Close in the Religion toolbar, or go in 
the File menu to Save or Save and Close (see section “Pull-Down 
Menus”), or press Ctrl-S or Ctrl-L. 


 Or, if you want to delete the religion, select Delete in the Main 
Toolbar (see section “Main Toolbar”), or go in the File menu to 
Delete (see section “Pull-Down Menus”), or press Ctrl-D.  NOTE:  
Because the religion code may be in use, it will not actually be 
deleted from the database, but “hidden” such that it can not be used 
or found again. 


 
You can create any customized code types, and create, modify, and delete codes of those 
customized types.  Simply follow the instructions above, but substitute any code type in place of 
the word “Religion”. 
 


58.4.4 Templates 
 
To add the contents of a notes template to a notes field, do one of these: 


 Double-click anywhere in the field, except after an underlined “code type” followed by a 
colon (see section “Codes”) or in a Choice List (see section “Choice Lists”). 


 Press F9. 
 Right-click and select LookUp → Template (see section “Context Menu”). 


A Find Template dialog box will open (see section “Find Template Dialog Box”).  Select a 
template and then select OK or press F9, or double-click on a template, and the contents of that 
template will be inserted at the insertion point. 
 
When a template is inserted, certain “keywords” in the template are replaced with relevant data, 
namely: 
 
Keyword Replacement Data Relevant Manual Section 
@LASTNAME Patient’s last name 
@FIRSTNAME Patient’s first name 
@MIDDLENAME Patient’s middle name 
@TITLE Patient’s title 
@SEX Patient’s sex (M/F/X) 
@BIRTHDATE Patient’s birth date 
@AGE Patient’s age (automatically calculated) 
@HESHE “he”, “she”, or nothing 
@HESHEUCASE “He”, “She”, or nothing 
@HIMHER “him”, “her”, or nothing 
@HISHER “his”, “her”, or nothing 


Depends on 
the patient’s 
sex (M/F/X)


Patient Window, 
Demographic Tab 
(These keywords can only be 
used in a document that 
already has a patient 
selected.) 
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@HISHERUCASE “His”, “Her”, or nothing 
@DATE Current date Date Fields 


@DATEDOCUMENT 
The Date field in a Referral or 
Encounter window, or the current date 
in any other window. 


Encounter Window 
Referral Window 


@TIME Current time Time Fields 
@USER The user who pasted the template Before You Begin 
@DOMAIN The user’s domain Domain 
Underscore (_) Space ( ) Data Entry Fields 
 
This “keyword replacement” does not work in the Template window (see section “Template 
Window”), Labs window (see section “List Lab Results”) or Attachments window (see section 
“List Attachments”). 
  


58.4.5 Rich Text Format 
 
Rich Text Format allows you to choose font, size, style, and colour of text (in a notes field), and 
even include graphics as well. 
 
Notes fields support these formatting features: 


 Press Ctrl-B to toggle Bold on/off (or use the Font dialog box – see below). 
 Press Ctrl-I to toggle Italics on/off (or use the Font dialog box – see below). 
 Press Ctrl-U to toggle Underline on/off (or use the Font dialog box – see below). 
 Right-click and select “Foreground…” or “Background…” from the pop-up menu (see 


section “Context Menu”), and a Color dialog box will open (see section “Color Dialog 
Box”) allowing 
you to choose a 
colour for the text 
or the text’s 
background. 


 Right-click and 
select “Font…” 
from the pop-up 
menu (see section 
“Context Menu”), 
and a Font dialog 
box will open, 
allowing you to 
choose a font, 
style, and/or size 
for the text.  This is 
a standard 
Microsoft Font 
dialog box, i.e. 
very similar to a 
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Font dialog box that appears in Microsoft applications such as WordPad (which comes 
with Windows).  For more information, check Microsoft’s help or documentation.   
NOTE:  Certain fonts have special functionality (see section “Data Entry Fields”). 


 
If text is selected (e.g. highlighted), any feature in the list above will be applied only to the 
selected text.  (Text can be selected by clicking and dragging with the mouse, or by holding 
down Shift while moving the insertion point with the arrow keys, etc.)  If no text is selected, then 
any feature in the list above will be applied to any new text entered (or pasted in from another 
program or field that does not support Rich Text Format – see below) until/unless the insertion 
point is moved to a new location that has different formatting. 
 
When you cut/copy/paste data (e.g. graphics and/or text) to/from another program or field, the 
text formatting (e.g. font, size, and style) and graphics will be included only if the other 
program/field supports Rich Text Format.  For example, word processors such as WordPad 
(comes with Windows), Microsoft Word, and WordPerfect support Rich Text Format, but text 
editors such as Notepad (comes with Windows) do not. 
 


58.4.6 Context Menu 
 
If you right-click anywhere in a notes field, you will get a pop-up menu like the one described 
below. 
 
If the insertion point is located in a Data Entry Field within the Notes field (see section “Data 
Entry Fields”), the context menu may be unavailable. 
 







 356


LookUp → Template – Insert the contents of a 
notes template at the insertion point.  If you select 
this, a Find Template dialog box will open (see 
section “Find Template Dialog Box”).  Select a 
template and then select OK or press F9, or 
double-click on a template.  This function is not 
available in the Template window (see section 
“Template Window”). 
 
LookUp → Date – Insert a date at the insertion 
point.  The date can then be selected as per 
section “Date Fields”.  Once a date has been 
selected, it is stored as plain text, i.e. cannot be 
edited as a date field.  This function is not 
available in the Template window (see section 
“Template Window”). 
 
LookUp → Alert – Insert an alert code at the 
insertion point.  If you select this, a Find Alert 
dialog box will open (see section “Find Alert 
Dialog Box”).  Select an alert code and then select 
OK or press F9, or double-click on an alert code.  
This function is not available in the Template 
window (see section “Template Window”). 
 


LookUp → Allergy – Insert an allergy code at the insertion point.  If you select this, a Find 
Allergy dialog box will open (see section “Find Allergy Dialog Box”).  Select an allergy code 
and then select OK or press F9, or double-click on an allergy code.  This function is not available 
in the Template window (see section “Template Window”). 
 
LookUp → Contact – Insert a contact code at the insertion point.  If you select this, a Find 
Contact dialog box will open (see section “Find Contact Dialog Box”).  Select a contact code and 
then select OK or press F9, or double-click on a contact code.  This function is not available in 
the Template window (see section “Template Window”). 
 
LookUp → Diagnosis – Insert a diagnosis code at the insertion point.  If you select this, a Find 
Diagnosis dialog box will open (see section “Find Diagnosis Dialog Box”).  Select a diagnosis 
code and then select OK or press F9, or double-click on a diagnosis code.  This function is not 
available in the Template window (see section “Template Window”). 
 
LookUp → Drug – Insert a drug code at the insertion point.  If you select this, a Find Drug 
dialog box will open (see section “Find Drug Dialog Box”).  Select a drug code and then select 
OK or press F9, or double-click on a drug code.  This function is not available in the Template 
window (see section “Template Window”). 
 
LookUp → Facility – Insert a facility code at the insertion point.  If you select this, a Find 
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Facility dialog box will open (see section “Find Facility Dialog Box”).  Select a facility code and 
then select OK or press F9, or double-click on a facility code.  This function is not available in 
the Template window (see section “Template Window”). 
 
LookUp → Immunization – Insert an immunization code at the insertion point.  If you select 
this, a Find Immunization dialog box will open (see section “Find Immunization Dialog Box”).  
Select an immunization code and then select OK or press F9, or double-click on an immunization 
code.  This function is not available in the Template window (see section “Template Window”). 
 
LookUp → Location – Insert a location code at the insertion point.  If you select this, a Find 
Location dialog box will open (see section “Find Location Dialog Box”).  Select a location code 
and then select OK or press F9, or double-click on a location code.  This function is not available 
in the Template window (see section “Template Window”). 
 
LookUp → Problem – Insert a problem/procedure/ICD-9 code at the insertion point.  If you 
select this, a Find Problem dialog box will open (see section “Find Problem Dialog Box”).  
Select a problem/procedure/ICD-9 code and then select OK or press F9, or double-click on a 
problem/procedure/ICD-9 code.  This function is not available in the Template window (see 
section “Template Window”). 
 
LookUp → Procedure – Insert a procedure code at the insertion point.  If you select this, a Find 
Procedure dialog box will open (see section “Find Procedure Dialog Box”).  Select a procedure 
code and then select OK or press F9, or double-click on a procedure code.  This function is not 
available in the Template window (see section “Template Window”). 
 
LookUp → Re – Insert a re code at the insertion point.  If you select this, a Find Re dialog box 
will open (see section “Find Re Dialog Box”…).  Select a re code and then select OK or press 
F9, or double-click on a re code…    This function is not available in the Template window (see 
section “Template Window”). 
 
LookUp → Reaction – Insert a reaction code at the insertion point.  If you select this, a Find 
Reaction dialog box will open (see section “Find Reaction Dialog Box”).  Select a reaction code 
and then select OK or press F9, or double-click on a reaction code.  This function is not available 
in the Template window (see section “Template Window”). 
 
LookUp → Recall – Insert a recall type at the insertion point.  If you select this, a Find Recall 
dialog box will open (see section “Find Recall Dialog Box”).  Select a recall type and then select 
OK or press F9, or double-click on a recall type.  This function is not available in the Template 
window (see section “Template Window”). 
 
LookUp → Relation – Insert a relation code at the insertion point.  If you select this, a Find 
Relation dialog box will open (see section “Find Relation Dialog Box”).  Select a relation code 
and then select OK or press F9, or double-click on a relation code.  This function is not available 
in the Template window (see section “Template Window”). 
 
LookUp → Risk – Insert a risk code at the insertion point.  If you select this, a Find Risk dialog 
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box will open (see section “Find Risk Dialog Box”).  Select a risk code and then select OK or 
press F9, or double-click on a risk code.  This function is not available in the Template window 
(see section “Template Window”). 
 
LookUp → SIG – Insert a SIG at the insertion point.  If you select this, a Find SIG dialog box 
will open (see section “Find SIG Dialog Box”).  Select a SIG and then select OK or press F9, or 
double-click on a SIG.  This function is not available in the Template window (see section 
“Template Window”). 
 
LookUp → Test – Insert a test code at the insertion point.  If you select this, a Find Test dialog 
box will open (see section “Find Test Dialog Box”).  Select a test code and then select OK or 
press F9, or double-click on a test code.  This function is not fully implemented, and is reserved 
for future use.  This function is not available in the Template window (see section “Template 
Window”). 
 
LookUp → Treatment – Insert a treatment code at the insertion point.  If you select this, a Find 
Treatment dialog box will open (see section “Find Treatment Dialog Box”).  Select a treatment 
code and then select OK or press F9, or double-click on a treatment code.  This function is not 
available in the Template window (see section “Template Window”). 
 
LookUp → Type (Appt.) – Insert an appointment type at the insertion point.  If you select this, 
a Find (Appointment) Type dialog box will open (see section “Find (Appointment) Type Dialog 
Box”).  Select an appointment type and then select OK or press F9, or double-click on an 
appointment type.  This function is not available in the Template window (see section “Template 
Window”). 
 
LookUp → Type (Attach.) – Insert an attachment type at the insertion point.  If you select this, 
a Find (Attachment) Type dialog box will open (see section “Find (Attachment) Type Dialog 
Box”).  Select an attachment type and then select OK or press F9, or double-click on an 
attachment type.  This function is not available in the Template window (see section “Template 
Window”). 
 
Insert – These features are only available in the Encounter window.  See section “Encounter 
Window”. 
  
Enter Action – If an option on a choice list is selected (see section “Choice Lists”), Enter Action 
will delete the rest of the choice list (all the other options, plus the pipes and square brackets).  
This function is not available in the Template window (see section “Template Window”). 
 
Delete Action – If an entire Choice List (everything between two square brackets) is selected 
(see section “Choice Lists”), Delete Action will delete the selected text, plus the square brackets 
surrounding it.  This function is not available in the Template window (see section “Template 
Window”). 
 
Undo (Ctrl-Z) – Undo the last action, e.g. the last key pressed.  This is not the same as Undo in 
the Edit menu (see section “Pull-Down Menus”) or in the Main Toolbar (see section “Main 
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Toolbar”). 
 
Cut (Ctrl-X) – Delete the selected text and send it to the Windows clipboard (to be pasted into a 
different location, field, window, application, etc.). 
 
Copy (Ctrl-C or Ctrl-Insert) – Send a copy of the selected text to the Windows clipboard (to be 
pasted into a different location, field, window, application, etc.). 
 
Paste (Ctrl-V or Shift-Insert) – Copy all text/graphics in the Windows clipboard to the insertion 
point’s location.  (Any selected text will be replaced.) 
 
Select All – Select (e.g. highlight) everything in the notes field (e.g. for cutting, copying, 
deleting/replacing, etc.). 
 
Font… – Open a Font dialog box which allows you to change the font, style, or size of the 
selected text (or text to be entered).  See section “Rich Text Format”.     NOTE:  Certain fonts 
have special functionality (see section “Data Entry Fields”). 
 
Foreground… – Open a Color dialog box (see section “Color Dialog Box”), which allows you 
to change the colour of the selected text (or text to be entered).  See section “Rich Text Format”. 
 
Background… – Open a Color dialog box (see section “Color Dialog Box”), which allows you 
to change the background colour of the selected text (or text to be entered).  See section “Rich 
Text Format”. 


 
Default Font Size – Sets the default font size for all notes 
fields in HERO™ CMS.  All text entered in any notes field 
will be the selected size (unless otherwise specified).  
Choose 7, 8, 9, 10, 11, 12, 14, or 16.  This setting is stored 
in the Windows registry (see section “Defaults”). 
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58.4.7 Data Entry Fields 
 
There are three types of data entry fields that can be used in a notes field: 
 


 Alphanumeric field:  Any text in Lucida Console font (except a Checkbox field – see 
below).  In this field, any character typed will automatically overwrite (erase) the 
character to the right of the insertion point (if that character is in Lucida Console font). 


 Numeric field:  Any text in Courier New font.  In this field, only numbers and periods 
can be typed, and any character typed will automatically overwrite (erase) the character 
to the right of the insertion point (if that character is in Courier New font). 


 Checkbox field:  Any single character in Lucida Console font, 10 point, in between two 
spaces in any other font.  If you double-click on that field, the character will change to Y 
(or if it’s already Y, will change to N).  If the insertion point is to the left of the character, 
typing any character (e.g. letter, number, symbol) will have the same effect as double-
clicking.  If the insertion point is to the left of the first space, or on either side of the 
second space, typing any character (e.g. letter, number, symbol) will have no effect. 


 
These features are not available in the Template window (see section “Template Window”). 
 
If the insertion point is located in one of the above fields, the context menu may be unavailable 
(see section “Context Menu”). 
 
To change the font, see section “Context Menu”. 
 


58.5 Searching for a Record 
 
When searching for a record (e.g. patient, appointment, bill, payment), the Find dialog box will 
have a Criteria section in which you can enter search criteria.  The criteria fields are not case-
sensitive (i.e. both uppercase and lowercase matches will be displayed). 
 
If all fields are left blank, no matching items will be found.  Otherwise, any field left blank will 
be ignored.  Any text field containing data will be used to limit the search results to only those 
records in which that field starts with the text entered.  For example, if you enter “SM” in the 
“Last Name” field, only records that have a Last Name starting with “SM” will be displayed.  If 
you enter multiple criteria, only records that match all non-empty search criteria will be 
displayed.  For example, if you enter “SM” in the “Last Name” field and “J” in the “First Name” 
field, only records that have a Last Name starting with “SM” and a first name starting with “J” 
will be displayed. 
 
Wildcards 
 
You can use these wildcards in your search criteria: 
 


 An asterisk (*) can be used to represent ANY text (or no text).  For example, “D*E” will 
match “DE”, “DOE”, “DADE”, “DENISE”, etc. 
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 A question mark (?) can be used to represent exactly one character.  For example, “D?E” 
will match “DOE” but not “DE”, “DADE”, “DENISE”, etc., and “D??E” will match 
“DADE” but not “DE”, “DOE”, “DENISE”, etc. 


 
For example, to display all records, enter only an asterisk in one of the criteria fields, and leave 
the other (non-required) criteria fields blank. 
 
Character Ranges 
 
You can also search for a single character that matches a range of characters.  For example, 
[AEIOU] means A, E, I, O, or U, and [A-E] means A, B, C, D, or E.  So “SM[IY]TH” will 
match “SMITH” and “SMYTH”, but not “SMIYTH” or “SMATH”, etc., and “DE[B-D]” will 
match “DEB”, “DEC”, and “DED”, but not “DEA”, “DEE”, “DEZ”, etc.  Also, [A-C,S,X] 
means A, B, C, S, or X (the commas are optional). 
 
You can also search for a single character that does not match a range of characters.  For 
example, [^AEIOU] means any character other than A, E, I, O, or U, and [^B-F] means any 
character other than B, C, D, E, or F.  So “SM[^IY]TH” will match “SMATH”, “SMOTH”, etc., 
but not “SMITH”, “SMYTH”, “SMOOTH”, etc., and “DE[^B-D]” will match “DEA”, “DEE”, 
and “DEZ”, etc., but not “DEB”, “DEC”, or “DED”. 
 
Once you have entered search criteria, select Find (or OK) to search for matching records. 
 
Post Data Retrieval Convergence 
 
After you select Find, if too many matches are displayed, you can sometimes narrow down the 
list of results by entering additional search criteria.  For example, suppose you’re searching for a 
patient, but you can’t remember how to spell his name.  So you enter “FA” in the Last field and 
select Find.  All patients whose last name starts with “FA” will be displayed.  You can then enter 
additional characters in the Last field (after the “FA”), or in the First field, and the patient list 
will be reduced to display only the patients that match the additional criteria.  If you then delete 
any of the additional criteria (characters that you typed after the last time you selected Find), the 
patient list will broaden to again display the patients that were removed when you entered the 
additional criteria.  However, if you delete/modify any of the original criteria (the criteria that 
you entered before the last time you selected Find), the patient list will not broaden beyond what 
was displayed when you last selected Find.  For example, suppose you enter “FA” in the Last 
field and select Find, and only 5 patients are displayed on the list.  If you delete the “A”, no other 
patients (besides those 5) will appear on the list (until you select Find again).  In other words, the 
list will still only display patients whose last name starts with “FA”.  If you want to display all 
patients whose last name starts with “F”, select Find again. 
 
Maximum Results 
 
In order to provide a response in a timely fashion and avoid degrading network performance, the 
HERO™ CMS database will only return a limited number of records (e.g. 100, 500, or 1000), so 
always be as specific as possible.  If your search returns too many matches, you will receive the 
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error message “Search criteria too wide.  Please narrow search.” in which case you must specify 
additional information in the Criteria section. 
 


58.6 Viewing a List of Items 
 
When viewing a list of items (e.g. patients, appointments, bills, payments, etc.), some or all of 
these features may be available: 
 


 To select a field, click on it.  Or, to navigate within the list, use these keys: 
Keystroke Meaning 
Up Arrow Move one field up 
Down Arrow Move one field down 
Left Arrow Move one field to the left 
Right Arrow Move one field to the right 
Tab Move one field to the right 
Home Jump to the first field in the current row 
End Jump to the last field in the current row 
Ctrl-Home Jump to the first row on the list 
Ctrl-End Jump to the last row on the list 
Page Up Jump up one page* 
Page Down Jump down one page* 
*A “page” depends on the height of the list, which may be resizable. 


 To control which columns are displayed, right-click on one of the column headings and 
select the field you want to add/remove. 


 To change the order of the columns, click and drag one of the column headings to a new 
location (between two other column headings). 


 To change the width of a column (not all fields can be resized), click and drag the border 
on the right side of the column’s heading to a new location.  Or, if you double-click on 
the border on the right side of a column’s heading, the column will automatically become 
just wide enough to display all the text in it (but no wider). 


 To reset the list to its original (default) format, right-click on one of the column headings 
and select “Reset”.  Or, to reset all lists to their original (default) formats, go in the View 
menu to Reset → Grid Layouts (see section “Pull-Down Menus”). 


 If modifying the information on the list is allowed, you can select a field on the list and 
press F2 (to modify the contents of the field), F9 (to open a dialog box in order to choose 
an entry for the field), or Ctrl-Del (to delete the item from the list). 


 If modifying the information on the list is allowed, you can 
select a field on the list and then right-click on any item in the 
list and select Edit (to modify the contents of the selected 
field), LookUp (to open a dialog box in order to choose an 
entry for the selected field), or Delete Item (to delete the 
selected item from the list).  NOTE:  This action will apply to the selected field/item, not 
the one on which you right-clicked. 
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 To sort the list by a particular column, click on the heading at the top of that column.  A 
triangle will appear in the column heading, pointing upward ( ) to indicate that the 
column is sorted in ascending order (lowest to highest).  If you click on that same column 
heading again, the triangle will point downward ( ), and the column will be re-sorted in 
descending order (highest to lowest). 


 Items on the list may be displayed in different colours, depending on their status, date, 
type, etc.  See section “Colours”. 


 


58.7 Viewing a Tree of Items 
 
The rules below apply when viewing a tree of items, i.e.: 


 in the TreeView bar (see section “TreeView Bar”) 
 in the field tree on the left side of a Query dialog box (see section “Query Dialog Box”) 
 in a Browse For Folder dialog box (see section “Browse For Folder Dialog Box”) 


Also, some (but not all) of these rules apply in the Patient window, Import tab (if Import, not 
Report, is selected in the Patient Toolbar) (see section “Patient Window, Import Tab, Import”). 
 
To expand or collapse a branch of the tree (to show/hide the items under that branch), double-
click on the branch title, or select the branch title and press the left arrow key (to collapse the 
branch) or the right arrow key (to expand the branch), or click on the plus or minus sign to the 
left of the branch title (a minus sign indicates an expanded branch;  a plus sign indicates a 
collapsed branch).  You can also navigate within the tree by using these keys: 
 
Keystroke Meaning 
Up Arrow Move up to the next visible item. 
Down Arrow Move down to the next visible item. 
Left Arrow Jump to the title of the current branch, or, if an expanded branch title is 


selected, collapse that branch. 
Right Arrow If a collapsed branch title is selected, expand that branch. 


If an expanded branch title is selected, move down to the next item. 
Home Jump to the first item in the tree. 
End Jump to the last visible item in the tree. 
Page Up Jump up one page* (to a visible item). 
Page Down Jump down one page* (to a visible item). 
*A “page” depends on the height of the tree, which may be resizable. 


 


58.8 Health Card Readers 
 
HERO™ CMS supports magnetic health card readers that connect to your computer’s keyboard 
port or USB port (not a serial port).  The recommended procedure for swiping an Ontario health 
card is: 
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 If the patient’s health card number has already been added to your database (e.g. from a 
previous visit, or from a phone call or fax, etc.), swipe the card (see #1 below). 


 If the patient has already been added to your database, but the health card number in your 
database (is blank or) does not match the health card number on the card, then: 


o View/Modify the Patient (see section “View/Modify a Patient”). 
o In the Patient window, Demographic tab, Misc. section (see “Patient Window, 


Demographic Tab, Misc. Section”), if the Health # field is not blank, then erase it, 
and then save the changes. 


o Swipe the card (see #2 below). 
o When asked “Replace existing patient Health # information?”, select “Yes” (see 


#2 below). 
 If the patient has not already been added to your database: 


o Swipe the card. 
o If asked “Replace existing patient Health # information?”, select No (see #2 


below).  Otherwise, see #3 below. 
 If you don’t know whether or not the patient has already been added to your database: 


o Make sure a provider is logged in (see section “Log in as a Provider”). 
o Swipe the card. 
o If asked “Replace existing patient Health # information?”, select No (see #2 


below). 
o A Patient 


window will 
open (as per 
either #1 or 
#3 below). 


o If the health 
card number 
from the 
card was not 
found in 
your database, but the name on the card (or a similar name) was found in your 
database, then a dialog box will open saying “NEW FAILED:  Similar record(s) 
exist.  Find record(s)?”  In that case: 
 Select Yes. 
 A Find Patient dialog box will open (see section “Find Patient Dialog 


Box”) showing a list of patients with similar names. 
 Select the correct patient and then select OK (or double-click on the 


correct patient). 
 In the Patient window, Demographic tab, Misc. section (see “Patient 


Window, Demographic Tab, Misc. Section”), if the Health # field is not 
blank, then erase it, and then save the changes. 


 Swipe the card again (see #2 below). 
 When asked “Replace existing patient Health # information?”, select 


“Yes” (see #2 below). 
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When you swipe an Ontario health card, one of these happens: 
 


1. If your database contains a patient with the same (Ontario) health card number that 
appears on the health card, then that patient record will be opened in a Patient window.  
The version code, expiry date, birth date, and sex displayed come from the health card 
(which may not necessarily match the information in your database), but the rest of the 
patient information (e.g. name, address, etc.) comes from your database (and may not 
match the information on the health card).  Note that the new (scanned) data is 
automatically saved to your database, overwriting the old data. 


2. If the above condition is not true, and the active window is a Patient window displaying a 
patient that has already been saved in your database, but does not have a health card 
number saved in your database (even if a health card number is displayed on the screen), 
then a dialog box will open asking  
“Replace existing patient Health # 
information?”  If the owner of the health 
card swiped is the same as the patient 
displayed in the active window, select 
Yes, and the health card number, version 
code, sex, expiry date, and birth date (but 
not the name) will be read from the health card into the active window.  Otherwise, select 
No, and a new Patient window will open with the information (e.g. name, health card 
number, version code, birth date, expiry date, etc.) from the health card.  In either case, 
this new information is not automatically saved to your database.  You can choose to save 
the (new or modified) patient record, or close the Patient window. 


3. If neither of the above conditions is true, a new Patient window will open with the 
information (e.g. name, health card number, version code, birth date, expiry date, etc.) 
from the health card.  If a provider is logged in (see section “Log in as a Provider”), 
HERO CMS™ will then immediately save this information to your database. 


 
See section “Patient Window, Demographic Tab”. 
 
Note that you don’t need to tell HERO™ CMS that you’re going to swipe a health card.  
HERO™ CMS will automatically recognize that the data comes from the magnetic card reader 
and not from the keyboard.  If you have a health card reader, you must enable the “Card Reader” 
option in the Configuration window (see section “Configuration”). 
 
Swiping any card other than an Ontario health card is not recommended and may produce 
unpredictable results. 
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58.9 Open Dialog Box 
 


 
 
This is a standard Windows Open dialog box.  Select/enter a location and file name and select 
Open (or double-click on a file).  For more information, check your Windows help or 
documentation. 
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58.10 Save As Dialog Box 
 


 
 
This is a standard Windows Save As dialog box.  Select/enter a location and file name and select 
Save (or double-click on an existing file to overwrite it).  For more information, check your 
Windows help or documentation. 
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58.11 Browse For Folder Dialog Box 
 


 
 
This is a standard Windows Browse For Folder dialog box.  All available folders are displayed in 
a tree (see section “Viewing a Tree of Items”).  Select a folder and select OK.  For more 
information, check your Windows help or documentation. 
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58.12 Query Dialog Box 
 


 
 
The Query dialog box allows you to specify: 
 


1. Which records (e.g. patients, appointments, bills, payments, etc.) to include in your report 
output (see section “Reports”).  For example, you might want a list of patients of a certain 
gender or age, who have had a certain medical procedure, etc., or a list of all of 
appointments of a certain type within a certain date range, etc. 


2. Patients to add to a Patient List (see section “List Patients”). 
3. Patients for creating recalls (see section “Recalls”).  For example, you might want to 


create recalls for all patients of a certain gender or age, who have had a certain medical 
diagnosis, etc. 


4. Patients to export (see section “Export”). 
 
The field tree on the left starts at the top with the type of record you are working with (see 
section “Viewing a Tree of Items”).  For patient lists, recalls, or patient export, this is always 
“Patient”.  For reports, it depends on which report you selected (e.g. “Query Patients”, “Query 
Appointments”, etc.).  Underneath that appears all the fields associated with that record.  For 
example, under “Patient” would appear all fields associated with a patient, e.g. demographic data 
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(name, address, phone numbers, etc.), and full medical history e.g. Problem, Immunization, 
Allergy, Risk, Alert, Family, etc.  Under “Appointment” would appear all the fields associated 
with an appointment, e.g. start date/time, end date/time, description, location, provider, patient, 
etc.  To specify criteria, first select a field, and then proceed to the Selection section (see below). 
 
The Selection section is where the criteria are actually specified.  First, select a data field in the 
field tree on the left (see above).  Then, in the Selection section, specify what value(s) that field 
should have, and then Select “Include Selection”.  If you want to select only records that meet 
ALL of the selection criteria, then the “AND/OR” field should be set to AND.  If you want to 
select all records that meet ANY of the selection criteria, then the “AND/OR” field should be set 
to OR. 
 
You can also use negative criteria, i.e. get a list of all records that match certain criteria, but 
don’t match other criteria.  For example, you could get a list of all patients who do have diabetes, 
but don’t have an upcoming (follow-up) appointment, etc.  To do this: 


 Enter the negative criteria (e.g. all patients who have upcoming appointments). 
 Select the “NOT IN” button. 
 Enter the positive criteria (e.g. all patients who have diabetes). 


 
The Fields section is only used for the “Query Generic” report (which can only be run from a 
Provider window – see section “Provider Window”).  This is where you can choose what fields 
you want to appear in the report output.  For example, if you want to see a list of patients’ first 
name, last name, birth date, and postal code, you would add those four fields to the list in the 
Fields section.  To add a field to the list, select a field in the field tree on the left (see above), and 
then select “Add >”.  To remove a field on the list, select a field on the list and then select “< 
Remove”. 
 
In the bottom right is the SQL field, where the Query dialog box automatically translates your 
selection criteria into SQL, which the database can understand.  You can make minor 
modifications to this field, for example changing the brackets or the operators (e.g. <, >, <=, >=), 
etc., but you cannot type (or paste) in your own criteria.  Only advanced users familiar with SQL 
should modify this field.  To clear this field, select “Clear Criteria”. 
 
A query can also be saved into your database, so that you can use it again in future.  This can be 
useful for auto-generating recalls (see section “List Recalls”), or for a report that you might want 
to run more than once (see section “Run a Report”).  Use these instructions: 


 To save a query, first enter the query criteria (and, if applicable, the Fields you want to 
appear in the report output), as above.  Then enter a code and description in the Code and 
Description fields, and then select Save. 


 To retrieve a saved query, double-click (or press F9) in the Code field.  A Find Query 
dialog box will open (see section “Find Query Dialog Box”).  Select a query and then 
select OK or press F9, or double-click on a query. 


 To delete a saved query, retrieve it (as above), and then select Delete. 
 To modify a saved query, retrieve it (as above), change the query criteria, and then select 


Save. 
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 To make a copy of a query (i.e. save it under a different code, and possibly modify the 
query in the process), retrieve it (as above), then select the Copy button, then you can 
modify the query criteria (optional), and then save the query (as above). 


 
The Remove Provider and Add Provider buttons (below the Code and Description fields in the 
top-right corner) have not yet been implemented, and are reserved for future use. 
 
… fields within notes fields … 
 


58.12.1 Find Query Dialog Box 
 


 
 
See section “Searching for a Record”. 
 
Criteria Section 
 
Code – The code that was assigned to the query (see section “Query Dialog Box”). 
 
Description – The description that was assigned to the query (see section “Query Dialog Box”) 
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Other 
 
OK button – Chooses the selected query and closes the window.  If no queries are displayed, 
searches for queries that match the specified criteria, chooses the first one, and closes the 
window. 
 
Cancel button – Closes the window without choosing a query. 
 
Clear button – Clears the query list and all fields in the “Criteria” section. 
 
Find button – Searches for queries that match the specified criteria. 
 
Query List – Lists queries that match the specified criteria (see section “Viewing a List of 
Items”).  Select a query and then select OK or press F9, or double-click on a query, to choose 
that query and close the window.  For a description of the fields, see section “Query Dialog 
Box”. 
 


58.13 HERO Log On Dialog Box 
 


 
 
The HERO Log On dialog box is used for authentication (to identify yourself using a username 
and password).  See section “Before You Begin”. 
 
The HERO Log On dialog box will appear every time you launch HERO™ CMS, but only if 
“Require Log On” is enabled (see section “Configuration”). 
 
Enter your username (assigned by your server/network administrator) and password and then 
select OK or press Enter.  Or, select Exit to close HERO™ CMS. 
 
To change your password, see section “Change Password”. 
 


59 Defaults 
 
A “default” is data that is automatically entered for you, to save time in entering data.  HERO™ 
CMS supports defaults in these windows: 
 


 Patient (see section “Defaults, Patient Window”) 
 Appointment (see section “Defaults, Appointment Window”) 
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 Bill (see section “Defaults, Bill Window”) 
 Payment (see section “Defaults, Payment Window”) 
 Encounter (see section “Defaults, Encounter Window”) 
 Rx (see section “Defaults, Rx Window”) 
 Requisition (see section “Defaults, Requisition Window”) 
 Task (see section “Defaults, Task Window”) 
 Referral (see section “Defaults, Referral Window”) 


 
To undo a default, select the relevant field and then go in the Edit menu to Clear Default (see 
section “Pull-Down Menus”).  That field will then have no default, as before.  To clear all 
defaults, go in the View menu to Reset → Defaults. 
 
NOTE:  Defaults are stored in the Windows registry, specific to the user that is logged on to 
Windows.  If all or part of the Windows registry is lost/deleted/altered, or HERO™ CMS is 
transferred/reinstalled to a new computer/disk or fresh copy of Windows, or you log into 
Windows using a different username or on a different computer, you may need to re-configure 
these defaults. 
 
If you want chart numbers to be automatically assigned to new patients, see section “Chart 
Numbers”. 
 


59.1 Patient Window 
 
In a Patient window, Demographic tab (see section “Patient Window, Demographic Tab”):  
Position the insertion point in the Title field (Name section), City or Postal field (Address 
section), Sex field (Misc. section), or in the area code or exchange fields for the first or second 
phone number (Contact section).  Then go in the Edit menu to Set Default (see section “Pull-
Down Menus”).  The text in the selected field will be set as a default, such that any new patient 
entered in the future will have that same text in that field (unless otherwise specified). 
 


59.2 Appointment Window 
 
The Appointment window (see section “Appointment Window”) supports defaults as described 
below. 
 
Specified Defaults 
 
The Date and Status fields support specified defaults.  Select either of these fields and then go in 
the Edit menu to Set Default (see section “Pull-Down Menus”).  The data in the selected field 
will be set as a default, such that any new appointment entered in the future will have that same 
text in that field (unless otherwise specified). 
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Patient Defaults 
 
Select the Referring field (if a Find Provider dialog box opens, close it – see section “Find 
Provider Dialog Box”).  Then go in the Edit menu to Default from Patient.  From now on, any 
time you select a patient in an Appointment window, the Referring field will automatically be set 
to match the patient’s referring provider (see section “Patient Window, Demographic Tab, 
Other”). 
 


59.3 Bill Window 
 
The Bill window, Invoice tab (see section “Bill Window, Invoice Tab”) supports defaults as 
described below. 
 
These defaults are applied when entering a bill manually (see section “Add a Bill”), and when 
billing from a Patient List (see section “Bill from a Patient List”), but not when billing from a 
Bill List (see section “Bill from a Bill List”). 
 
Specified Defaults 
 
The Date, Admitted, Referring, Type, Facility, Close Appointment, Proc., Diag., C (To CDS), 
and Hst fields support specified defaults.  Select any one of those fields and then go in the Edit 
menu to Set Default (see section “Pull-Down Menus”).  The data in the selected field will be set 
as a default, associated with the provider/role selected in the Provider field.  After that, any time 
you open a new bill window (see section “Add a Bill”), or select New → Bill in a Bill Toolbar, 
or press Ctrl-N in a Bill window (Invoice tab), if that same provider is logged in (see section 
“Log in as a Provider”), then that same data will be automatically entered in the selected field. 
 
For example, suppose that Dr. Smith does mostly Private billing, and Dr. Jones does mostly 
Insurer billing.  In a bill window, select Dr. Smith in the Provider field, then set the Type field to 
Private, and then go in the Edit menu to Set Default.  Then select Dr. Jones in the Provider field, 
then set the Type field to Insurer, and then go in the Edit menu to Set Default.  From now on, 
whenever you create a bill for Dr. Smith, it will automatically be a Private bill (unless otherwise 
specified), and whenever you create a bill for Dr. Jones, it will automatically be an Insurer bill 
(unless otherwise specified). 
 
Note that for the Admitted, Facility, Proc., and Diag. fields, these Specified Defaults may be 
overridden by the Patient Defaults (see below). 
 
Patient Defaults 
 
The Admitted, Facility, Referring, Payor, Proc., and Diag. fields support patient defaults.  Select 
any one of those fields (if a Find dialog box opens, close it) and then go in the Edit menu to 
Default from Patient (see section “Pull-Down Menus”).  This sets a default for that field, 
associated with the provider/role selected in the Provider field.  From now on, in any Bill 
window (with that same provider/role selected in the Provider field), any time you select a 
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patient, the data in that field will either be copied from the patient information (Referring) or 
from the patient’s last bill (Admitted, Facility, Payor, Proc., Diag.), where “last bill” means the 
bill with the highest (latest) invoice date (the Date field in the Bill window, Invoice tab).  These 
defaults will also be applied when opening a bill (see section “View/Modify a Bill”) that has no 
service items (see section “Bill Window, Invoice Tab, Service Item List”). 
 
Note that for the Admitted, Facility, Proc., and Diag. fields, these Patient Defaults may override 
the Specified Defaults (see above). 
 


59.4 Payment Window 
 
In a Payment window (see section “Payment Window”):  Select the Manual checkbox.  Then go 
in the Edit menu to Set Default (see section “Pull-Down Menus”).  The selection in that field (on 
or off) will be set as a default, such that any new payment entered in the future will have that 
same selection (unless otherwise specified). 
 


59.5 Encounter Window 
 
The Encounter window (see section “Encounter Window”) supports defaults as described below. 
 
Specified Defaults 
 
The Date and Status fields support specified defaults.  Select either of those fields and then go in 
the Edit menu to Set Default (see section “Pull-Down Menus”).  The data in the selected field 
will be set as a default.  After that, any time you open a new Encounter window (see section 
“Add an Encounter”), or select New → Encounter in an Encounter Toolbar, or press Ctrl-N in an 
Encounter window, then that same data will be automatically entered in the selected field. 
 
Patient Defaults 
 
Select the Referring field (if a Find Provider dialog box opens, close it – see section “Find 
Provider Dialog Box”).  Then go in the Edit menu to Default from Patient.  From now on, any 
time you select a patient in an Encounter window, the Referring field will automatically be set to 
match the patient’s referring provider (see section “Patient Window, Demographic Tab, Other”). 
 


59.6 Rx Window 
 
In an Rx window, on the Script tab (see section “Rx Window, Script Tab”):  Select the SIG, 
Rep., or Dur. field, and then go in the Edit menu to Set Default (see section “Pull-Down 
Menus”).  The data in the selected field will be set as a default, such that any new drugs entered 
on a prescription in the future will have that same data in that field (unless otherwise specified). 
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59.7 Requisition Window 
 
In a Requisition window (see section “Requisition Window”):  Select the Date or Lab field and 
then go in the Edit menu to Set Default (see section “Pull-Down Menus”).  The data in the 
selected field will be set as a default, such that any new lab requisition entered in the future will 
have that same data in that field (unless otherwise specified). 
 


59.8 Task Window 
 
In a Task window (see section “Task Window”):  Select the Due, Priority, Status, or Assignee 
field (if a LookUp User/Role dialog box opens, close it – see section “LookUp User/Role Dialog 
Box”), and then go in the Edit menu to Set Default (see section “Pull-Down Menus”).  The data 
in the selected field will be set as a default, such that any new task entered in the future will have 
that same data in that field (unless otherwise specified). 
 


59.9 Referral Window 
 
The Referral window (see section “Referral Window”) supports defaults as described below. 
 
Specified Defaults 
 
The Date, Encounter, Lab, Risk, All Items, Problem, Immunize, Alert, From, Rx, Allergy, and 
Family fields support specified defaults.  Select any one of those fields and then go in the Edit 
menu to Set Default (see section “Pull-Down Menus”).  The data in the selected field will be set 
as a default.  After that, any time you open a new Referral window (see section “Add a 
Referral”), or select New in a Referral Toolbar, or press Ctrl-N in a Referral window, then that 
same data will be automatically entered in the selected field. 
 
Patient Defaults 
 
Select the Referred field (if a Find Provider dialog box opens, close it – see section “Find 
Provider Dialog Box”).  Then go in the Edit menu to Default from Patient.  From now on, any 
time you select a patient in a Referral window, the Referred field will automatically be set to 
match the patient’s referring provider (see section “Patient Window, Demographic Tab, Other”). 
 


60 LookUp Dialog Boxes 
 
To choose an entry in a LookUp dialog box, select the entry and select OK (or press Enter or 
F9), or double-click on the entry.  To close the window without choosing an entry, select Cancel 
or press Escape.  See section “Viewing a List of Items”. 
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60.1 LookUp Access Dialog Box (Configuration) 
 


 
 


60.2 LookUp Role Dialog Box 
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60.3 LookUp Speciality Dialog Box 
 


 
 


60.4 LookUp Suffix Dialog Box 
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60.5 LookUp User/Role Dialog Box 
 


 
 
Lists all users that have used HERO™ CMS, and all groups supported by HERO™ CMS.  See 
section “Before You Begin”. 
 


60.6 LookUp Access Dialog Box (Provider) 
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60.7 LookUp Status Dialog Box (For Problems) 
 


 
 


60.8 LookUp Severity Dialog Box 
 


 
 


60.9 LookUp Response Dialog Box 
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60.10 LookUp Status Dialog Box (For Appointments) 
 


 
 
Select an appointment status and then select OK (or press Enter) to change the status of the 
selected appointment. 
 
If you select Closed, the appointment status will not change immediately.  Instead, a new Bill 
window will open (see section “Bill Window”) with the same patient and date as the selected 
appointment.  When the bill is saved, this will automatically close appointments according to the 
rules described in section “Closing Appointments”. 
 
If you want to change an appointment’s status to Closed/N.S., first set it to No Show, and then 
set it to Closed (as above). 
 
If you want to change an appointment’s status to Closed or Closed/N.S. without entering a bill, 
you can make the change directly in the Appointment window (see section “Appointment 
Window”). 
 


61 HTN (Health Transaction Network) 
 
For more information on HERO™ CMS or HTN’s other products and services, please contact 
us.  Our current contact information is: 
 
Address:  41 Horner Avenue, Unit 1, Toronto, Ontario, Canada, M8Z 4X4 
Web site:  www.htninc.com 
 
Main 
 
Phone:  416-975-0975 / 888-I’M-A-HERO (888-462-4376) 
Fax:  416-975-0225 
E-mail:  sales@htninc.com 
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Support 
 
Phone:  416-975-4891 / 888-HERO-SPT (888-437-6778) 
Fax:  416-975-0307 
E-mail:  support@htninc.com 
 


62 Glossary 
 
Active – Refers to an item (e.g. appointment, problem, etc.) which is in the future (or recent) or 
has not been completed/resolved/read/archived. 
 
Batch – A file containing bills which is sent by a provider to MOHLTC.  HERO™ CMS batches 
are created by the FMS. 
 
Batch Acknowledgment – A file sent by MOHLTC to a provider in response to a batch, which 
indicates whether that batch was accepted or rejected.  The FMS automatically processes batch 
acknowledgments, allowing HTN staff (see section “HTN”) to ensure that your batches are 
accepted by MOHLTC. 
 
Bill – An invoice from a single provider for services provided to a single patient.  Also known as 
a claim.  A bill can contain any number of service items.  See section “Bills”. 
 
Blocking appointment – An appointment that does not specify a patient, but just reserves time 
for a generic purpose e.g. a break, a meeting, unscheduled work, etc. 
 
Claim – An invoice from a single provider for services provided to a single patient.  Also known 
as a bill.  A claim can contain any number of service items.  See section “Bills”.  Alternately, 
“claim” can refer to a request for payout/compensation on an insurance policy.  Multiple bills 
can be associated with a single insurance claim. 
 
Clipboard – An area of memory which is used to (temporarily) store data that is being copied or 
moved from one area/location/window/program to another.  Usually, whenever you cut, copy, or 
paste data (e.g. text) in HERO™ CMS (e.g. by pressing Ctrl-X, Ctrl-C, Ctrl-Insert, Ctrl-V, or 
Shift-Insert, or by right-clicking and selecting Cut, Copy, or Paste), the data is either sent to, or 
retrieved from, the Windows clipboard (for more information, check your Windows help or 
documentation).  However, when copying or pasting time slots (e.g. in an Appts. window, Month 
tab – see section “List Appointments, Month Tab”), HERO™ CMS uses its own clipboard, 
which is separate from the Windows clipboard. 
 
CDS – Core Data Set.  A compilation of all types of medical records for (a) patient(s).  Does not 
usually include bills/payments. 
 
CML – CML Healthcare, a medical laboratory.  Their web site is currently at 
http://www.cmlhealthcare.com/ 
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CPP – Cumulative Patient Profile.  A compilation of medical records of certain types, e.g. 
problems, alerts, prescriptions, risks, allergies, and family medical history (see section “Patient 
Window, CPP Tab”). 
 
Diagnosis code – A numerical code that represents the cause (not symptom) of a medical 
problem.  Also known as a diagnostic code.  This is not the same as a problem code.  Each 
service item contains at most one diagnosis code.  See section “Diagnosis Codes”. 
 
DIN – Drug Identification Number.  A number assigned to a drug by the Therapeutic Products 
Directorate (their web site is currently at http://www.hc-sc.gc.ca/ahc-asc/branch-dirgen/hpfb-
dgpsa/tpd-dpt/index_e.html).  Every drug available for sale legally in Canada is assigned a 
unique DIN. 
 
Domain – A Windows Server Domain is a database (on a central server) that controls security 
settings on a network.  This is not the same thing as a domain name on the Internet (e.g. 
htninc.com).  See section “Domain”. 
 
DUR – Drug Utilization Review.  See section “Rx Window, DUR Tab” or “Drug Utilization 
Review Dialog Box”.  A database that provides information regarding prescriptions (see section 
“Prescriptions”), such as: 
 


 Warns if the patient is allergic to (an ingredient of) a drug prescribed. 
 Warns if there is a possible reaction between a drug prescribed and another drug that the 


patient is taking at the same time. 
 Gives recommendations regarding the drug/prescription, e.g. dosage, duration, when/how 


the patient should take the drug, etc. 
 
EDT – Electronic Data Transmission.  A method for providers to communicate with MOHLTC 
via modem instead of on disk, tape, etc.  Used for sending batches and OBEC requests, and 
receiving RAs, error claim files, batch acknowledgments, and OBEC responses.  HERO™ CMS 
clients do not use EDT directly, but instead transmit their data to the FMS (see section “Data 
Flow Structure”) which uses EDT to communicate with MOHTLC.  In order to use EDT, a 
provider/group must first send application forms to MOHLTC. 
 
Facility – A code that includes a Master Number, and possibly an SLI code as well.  See section 
“Facilities”. 
 
Fee code – A code that represents a medical service.  Also known as a procedure code.  HCP 
claims can only use fee codes assigned by MOHLTC, which each contain a letter followed by 3 
digits, for example, A003 for “General assessment”.  Each service item contains exactly one fee 
code.  See section “Procedure Codes”. 
 
First Data Bank – A company that provides HTN (see section “HTN”) with a database of drugs 
and allergy agents.  This information is included in your HERO™ CMS database, and upgraded 
through your regular transmissions (see section “Transmissions”).  Their web site is currently at 
http://www.firstdatabank.com/ 
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FMS – Facility Management Site.  A powerful system run by HTN which acts as the liaison 
between your HERO™ CMS database and the MOHLTC server and the labs, sends out updates 
(e.g. software updates, procedure codes, diagnosis codes, etc.), and maintains a partial backup 
copy of your HERO™ CMS database.  See section “Data Flow Structure”. 
 
GDML – Gamma-Dynacare Medical Laboratories.  Their web site is currently at 
http://www.gammadynacare.com/ 
 
Group – A group of providers that are paid collectively rather than individually.  MOHLTC 
identifies groups using 4-character codes. 
 
HCP – Health Care Plan.  Health care that is funded by a central organization (e.g. OHIP) rather 
than private insurance companies or individual patients.  In Ontario, HCP refers to OHIP billing. 
 
HTN – Health Transaction Network.  The company that makes HERO™ CMS.  See section 
“HTN”. 
 
Inactive – Refers to an item (e.g. appointment, problem, etc.) which is in the past and/or has 
been completed/resolved. 
 
Insertion Point – A blinking vertical line that indicates where typed (or pasted) text will be 
inserted.  In general, the insertion point can be positioned by clicking with the mouse, or by 
using the arrow keys, etc.  Or, press Tab or Shift-Tab to make the insertion point jump to the 
next or previous field.  For more information, check your Windows help or documentation. 
 
LAN – Local Area Network.  A group of computers, usually in a single location (e.g. 
office/building), that are connected to each other in order to share information or hardware (e.g. 
printers, disk drives, etc.). 
 
LifeLabs – A medical laboratory.  Formerly known as MDS.  Their web site us currently at 
http://www.lifelabs.com/ 
 
Local Provider – A provider who exists in your database for billing, scheduling, electronic 
medical records, etc.  The other type of provider is a referring provider. 
 
Manual Review Notes – A note that is sent to MOHLTC to explain why a particular bill should 
be paid, perhaps due to an unusual situation in which MOHLTC policy would normally reject the 
bill.  Manual review notes cannot be sent electronically.  They are usually sent by fax or mail. 
 
Master Number – A 4-digit code used to identify a health facility (e.g. hospital).  In HERO™ 
CMS, the Master Number is included in the facility code (see section “Facilities”). 
 
MDS – A medical laboratory.  Now known as LifeLabs.  Their web site us currently at 
http://www.lifelabs.com/ 
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Microsoft SQL Server – Database software that is used to store and manage the HERO™ CMS 
database.  Its web site is currently at http://www.microsoft.com/sql/ 
 
MOH – Ministry of Health.  A government agency that handles health-related issues.  In 
Ontario, MOH is known as MOHLTC. 
 
MOHLTC – Ministry of Health and Long Term Care.  An Ontario government agency that 
handles health-related issues.  Its web site is currently at http://www.health.gov.on.ca/ 
 
Mouse – In this manual, “mouse” can refer to any pointing device such as a mouse, trackball, 
track pad, etc.  (Depending on your pointing device, it is possible for the buttons to be 
reconfigured such that the “left” button is on the right or in the middle, and the “right” button is 
on the left or in the middle, etc.) 
 
MRI – Machine Readable Input.  The format in which data (e.g. batches, OBEC request files) is 
sent electronically from providers to MOHLTC. 
 
MRO – Machine Readable Output.  The format in which data (e.g. batch acknowledgments, 
error claims files, Remittance Advices, OBEC response files) is sent electronically from 
MOHLTC to providers. 
 
OBEC – Overnight Batch Eligibility Check.  A system that allows providers to check if an 
Ontario health card number is valid (presumably, before sending any bills using that health card 
number).  See section “OBEC”. 
 
OCR – Optical Character Recognition.  Converting an image (e.g. scanned document) into text, 
which can then be edited. 
 
OHIP – Ontario Health Insurance Plan/Program.  A department of MOHLTC that provides 
health insurance. 
 
OntarioMD – A subsidiary of the Ontario Medical Association, which receives funding from 
MOHLTC, that was established to support physician adoption of information technology.  One 
of their functions is to set standards for data portability, i.e. to allow for sharing of electronic 
medical records among separate medical databases.  Their web site is currently at 
http://www.ontariomd.ca/ or http://www.ontariomd.com/. 
  
Patient – A person/organization that receives or pays for (medical) service from a provider. 
 
PDF – Portable Document Format.  A file format developed by Adobe Systems.  PDF files 
include formatting information, making it possible to send formatted documents and have them 
appear to the recipient exactly as they were intended.  PDF files can be viewed using Adobe 
Acrobat or Adobe Acrobat Reader.  See http://www.adobe.com/. 
 
Problem code – A code that represents a symptom (not cause) of a medical problem.  This is not 
the same as a diagnosis/diagnostic code.  Problem codes are not included in batches. 
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Procedure code – A code that represents a medical service.  Also known as a fee code.  HCP 
bills can only use procedure codes assigned by MOHLTC, which each contain a letter followed 
by 3 digits, for example, A003 for “General assessment”.  Each service item contains exactly one 
procedure code.  See section “Procedure Codes”. 
 
Provider – A health care professional such as a doctor, physician, dentist, physiotherapist, 
chiropractor, nurse, etc.  See section “Providers”. 
 
Province – A province or territory in Canada, or a similar geographical region (e.g. state) 
elsewhere.  Standard abbreviations are: 
 
AB – Alberta 
BC – British Columbia 
MB – Manitoba 
NB – New Brunswick 
NL – Newfoundland and Labrador 
NS – Nova Scotia 
NT – Northwest Territories 
NU – Nunavut 
ON – Ontario 
PE – Prince Edward Island 
QC – Quebec 
SK – Saskatchewan 
YT – Yukon 
XX – Other 
 
RA – Remittance Advice.  A file sent by MOHLTC to a provider/group around the beginning of 
each month listing all bills that were submitted to MOHLTC from that provider/group in the 
previous billing month, the amount paid for each service item, and (for some service items) a 2-
character explanatory code explaining how the amount paid was calculated.  The RA also 
indicates the total amount that will be paid to that provider/group that month. 
 
Recall – A reminder that a certain patient needs to have a certain medical service performed on 
(or by) a certain date, and it is the provider’s responsibility to contact the patient to remind 
him/her about this necessity.  See section “Recalls”. 
 
Referring Provider – A provider who exists in your database because (s)he refers patient(s) to 
your local providers, or vice versa.  A referring provider does not use your database for billing, 
scheduling, electronic medical records, etc., unless (s)he is also a local provider. 
 
Registry – A database used by Windows to store configuration information. 
 
Rejected – A bill included in an RA that was not paid (usually accompanied by a 2-character 
explanation code). 
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Report – A procedure which extracts information from a database into a linear/text document 
which can be displayed, printed, e-mailed, faxed, or exported into another program (e.g. a word 
processor, spreadsheet, web browser, etc.).  A report can be a list of items (e.g. patients, 
appointments, bills, payments), or information about a single item, etc.  See section “Reports”. 
 
RMB – Reciprocal Medical Billing.  A system in Canada for handling medical care for patients 
who travel to other provinces/territories.  Not all provinces/territories in Canada participate in 
RMB.  In Ontario, RMB bills are sent to MOHLTC, which forwards them to the appropriate 
province, and the responses are included in the provider’s regular RAs and error reports.  For the 
most part, the same rules and procedures that apply to HCP bills also apply to RMB bills. 
 
Roster – Refers to a patient enrolling in a Primary Care Renewal Group (such as a Family 
Health Network/Team/Organization/Group), and choosing a primary provider.  See section 
“Patient Window, Demographic Tab”, PCRG and Primary fields. 
 
RTF – Rich Text Format.  A standard formalized by Microsoft Corporation for specifying 
formatting of documents.  RTF files are actually plain text files with special commands to 
indicate formatting information, such as fonts and margins.  RTF files can be opened in 
Microsoft Word.  See http://www.microsoft.com/. 
 
Rx – Prescription.  See section “Prescriptions”. 
 
Service item – A single type of service (identified by a procedure code) that is performed by a 
single provider for a single patient on a single day.  Each service item is included in a bill, which 
can contain any number of service items.  See section “Bill Window, Invoice Tab, Service Item 
List”. 
 
SIG (Signatura) – A Latin abbreviation which gives a patient instructions regarding a 
prescription, e.g. how, how much, when, and how long the drug is to be taken.  Also called a 
transcription.  See section “SIGs”. 
 
SLI – Service Location Indicator.  A 3-letter code used to identify the hospital setting of insured 
diagnostic services.  All HCP/WSIB billings for hospital diagnostic services must include an SLI 
code.   In HERO™ CMS the SLI is included in the facility code (see section “Facilities”).  
Possible SLIs are: 


HDS Hospital Day Surgery 
HED Hospital Emergency Department 
HIP Hospital In Patient 
HOP Hospital Out Patient 
HRP Hospital Referred Patient 
OTN Ontario Telemedicine Network 


Or, if the SLI starts with “H”, you can just enter the last 2 letters of the SLI (e.g. DS, ED, IP, OP, 
or RP), and the leading “H” will automatically be added as needed whenever a batch is made. 
 
SQL – Structured Query Language.  A computer language that HERO™ CMS uses to add, 
modify, delete, and retrieve information in its database. 
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SuperCode – A “macro” or “shortcut” that includes one or more service items, which can be 
added to a bill.  See section “SuperCodes”. 
 
Template – A block of text that can be included in a Referral/Recall report, or automatically 
inserted into any Notes field.  See section “Templates”. 
 
TWAIN – A computer standard for capturing images from an external device, e.g. scanner, 
camera, etc.  Although not officially an acronym, TWAIN is widely known as 
Technology/Toolkit/Thing Without An(y) Interesting/Important/Intelligent Name. 
 
WCB – Workers’ Compensation Board.  Now known as WSIB. 
 
Web browser – A program used to access the World Wide Web, such as Internet Explorer, 
Netscape, FireFox, etc. 
 
Windows – Microsoft Windows.  The operating system required to run HERO™ CMS. 
 
WSIB – Workplace Safety and Insurance Board.  An Ontario government agency that ensures 
safety in the workplace, and funds health care for workers injured on the job.  Their web site is 
currently at http://www.wsib.on.ca/.  Also refers to bills that are sent electronically to WSIB.  
For the most part, the same rules and procedures that apply to HCP bills also apply to WSIB 
bills. 
 
XLS – Microsoft Excel spreadsheet.  See http://www.microsoft.com/. 
 
XML – eXtensible Markup Language.  A language that was designed to allow easy interchange 
of various types of documents on the World Wide Web.  HERO™ CMS uses XML for 
communication between the workstation, Site Server, and FMS (see section “Data Flow 
Structure”).  XML documents can be opened in a web browser. 
 


63 Error Messages 
 
A … item begin time is greater than the end time. 
 
In a Provider window, on the Schedule tab (see section “Provider Window, Schedule Tab”), on 
the Schedule List, you entered an item with a Begin Time after the End Time.  Change one of the 
times, or delete the entry. 
 
An error occurred while establishing a connection to the server.  When connecting to SQL 
Server 2005, this failure may be caused by the fact that under the default settings SQL 
Server does not allow remote connections.  (provider:  SQL Network Interfaces, error:  26 
– Error locating Server/Instance Specified) 
 
There may be a problem with your Site Server.  Contact your server/network administrator. 
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Another session is already doing (or within the last 90 seconds) a transmission. 
 
You tried to do a transmission (see section “Transmissions”), but another transmission was 
already in progress (within the past 90 seconds), possibly triggered from a different workstation.  
Most likely, since a transmission was already done recently, you don’t need to do another one.  
However, if you want to initiate a second transmission, you must wait at least 90 seconds after 
the first transmission finishes. 
 
At Fms URL:  … - Already processing Provider # = ….  Please retry later. 
 
You were doing a transmission (see section “Transmissions”) which triggered batching on the 
FMS (see section “Data Flow Structure”).  However, the FMS was already making a batch for 
that same provider.  There are two possible reasons for this: 
 


 You (or someone else in your office/database) was recently (e.g. in the past few minutes) 
doing a transmission, which triggered batching on the FMS for that same provider.  The 
transmission was aborted (either by the user, or due to some kind of communication 
problem, etc.) before the batching was finished.  Now, when you tried to do a (second) 
transmission, the FMS tried to make another batch for the same provider, before the first 
batch was finished. 


 The provider has multiple HERO CMS™ databases (e.g. in different offices), and at least 
two of them tried doing transmissions (and batching) simultaneously. 


 
In either case, the batching was disallowed, because the FMS cannot make two simultaneous 
batches for the same provider, as this would cause problems with invoice numbers (see section 
“Invoice Numbers”).  Wait a few minutes, and then try the transmission again. 
 
At Fms URL:  … - Cannot open database requested in login ‘…’.  Login fails.  Login failed 
for user ‘sa’. 
 
You tried to do a transmission (see section “Transmissions”), but there is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At Fms URL: … - Site # … does not exist at the FMS. 
 
The site number in your database does not exist on the FMS (see section “Data Flow Structure”).  
Contact HTN (see section “HTN”) to resolve the discrepancy. 
 
At Fms URL: … - STOP:  Provider licencing violation encountered.  Please contact HTN 
Inc. customer support 
 
A feature has been left active (possibly by accident) in your database, but it should be inactive, 
according to HTN’s records (see section “HTN”).  Contact HTN to resolve the discrepancy. 
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At Fms URL: … - STOP:  Site licencing violation encountered.  Please contact HTN Inc. 
customer support 
 
A feature has been left active (possibly by accident) in your database, but it should be inactive, 
according to HTN’s records (see section “HTN”).  Contact HTN to resolve the discrepancy. 
 
At Fms URL:  … - The underlying connection was closed:  The remote name could not be 
resolved. 
 
You tried to do a transmission (see section “Transmissions”), but there is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At Fms URL:  … - The underlying connection was closed:  The server committed an HTTP 
protocol violation. 
 
You tried to do a transmission (see section “Transmissions”), but there is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At Fms URL:  … - The underlying connection was closed:  Unable to connect to the remote 
server. 
 
You tried to do a transmission (see section “Transmissions”), but there is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At Fms URL:  … - Unable to read from the transport connection. 
 
You tried to do a transmission (see section “Transmissions”), but there is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At Fms URL: … - The request failed with… 
 
You tried to do a transmission (see section “Transmissions”), but is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
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At Fms URL: … - The underlying connection was closed:  An unexpected error occurred 
on a send. 
 
You tried to do a transmission (see section “Transmissions”), but is a problem with your 
network/Internet connection, or the FMS (see section “Data Flow Structure”), or your database 
does not know the correct URL (address) to use to contact the FMS.  Try again later, or contact 
your server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
At least one of the From or Sender fields is required, and neither was found. 
 
You tried to e-mail a report (see section “E-mail a Report”), but you did not specify a value in 
the Return field in the Configuration window (see section “Configuration”), and HERO™ CMS 
was unable to determine your return address from your e-mail program.  Either check your e-
mail software configuration, or enter a value for Return in the Configuration window. 
 
Can not copy the record. 
 
You went in the File menu to Copy (see section “Pull-Down Menus”), or selected Copy in the 
Main Toolbar (see section “Main Toolbar”), but the active window does not contain a record that 
can be copied.  Enter the new record manually. 
 
Can not edit a pre-loaded drug record. 
 
You tried to save changes to a drug (see section “Drug Window”) that is part of the drug 
database provided by HTN (see section “HTN”).  This database cannot be modified, however, 
you can add new drugs to it (see section “Add a Drug”). 
 
Can not edit a RA archived bill. 
 
You tried to save changes to a bill, but that bill’s status had already been set to Archive because 
it was fully paid on an RA, and therefore the bill cannot be modified. 
 
Cannot open database requested in login ‘…’.  Login fails.  Login failed for user ‘sa’. 
 
HERO™ CMS was able to connect to the Site Server (see section “Data Flow Structure”), but 
was unable to access the database.  You might have an incorrect value for “Site URL” or “Site 
DB” (see section “Configuration”), or there could be a problem with the Site Server (in which 
case you should contact your server/network administrator or HTN (see section “HTN”)). 
 
Client found response content of type ‘…’, but expected ‘text/xml’.  The request failed with 
the error message… 
 
HERO™ CMS was able to connect to the Site Server (see section “Data Flow Structure”), but 
was unable to access the database.  You might have an incorrect value for “Site URL” (see 
section “Configuration”), or there could be a problem with the Site Server (in which case you 







 392


should contact your server/network administrator or HTN – see section “HTN”).  Or there may 
be a problem with your username/password (see section “Before You Begin”). 
 
Code … does not exist. 
 
You entered a code (on a list – see section “Viewing a List of Items”) that does not exist.  
Correct the invalid code, or add a new code. 
 
Columns (…) are identical to those on another row. 
 
You have multiple entries on a list of items that are too similar.  Delete (or don’t save) the 
duplicate item, or modify one of the fields mentioned. 
 
Could not change password.  Could be invalid Old Password, blank New Password, or 
operation not permitted. 
 
You tried to change your HERO™ CMS password using the HERO™ CMS change password 
feature, but you did not enter your correct current password in the “Old Password” field, or you 
left the “New Password” field blank.  Correct one (or both) of those fields, and then try again.  
See section “Change Password”. 
 
Document does not have a selected patient for replacement keywords. 
 
In a Notes field (see section “Notes Fields”), you inserted a template (see section “Notes Fields, 
Templates”) which contains a patient-specific “keyword”, but the current document does not 
have a patient selected, so those keywords were not replaced.  It is advisable to select a patient 
before inserting a template with patient-specific keywords. 
 
Document does not support patient replacement keywords. 
 
In a Labs window (see section “List Lab Results”) or Attachments window (see section “List 
Attachments”), in the Notes field, you attempted to insert a template (see section “Notes Fields, 
Templates”) with patient-specific keywords.  That field does not support that feature.  Insert the 
template in a different window, or use a template without patient-specific keywords. 
 
ERROR:  A transmission has not been done to the FMS for the last 90 days.  Please exit 
HERO. 
 
You have not done a transmission (see section “Transmissions”) in the last 90 days.  Contact 
HTN (see section “HTN”) for assistance.  To avoid this error message, do transmissions often. 
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ERROR:  Access is denied.  Domain (local machine) user is from has not been 
authenticated.  Please exit Hero. 
 
The computer you are using has not been granted access to your HERO™ CMS database on your 
Site Server (see section “Data Flow Structure”).  Contact your server/network administrator (or 
HTN) to enable access, and then restart HERO™ CMS. 
 
ERROR:  Access is denied.  Non-domain user … can not be authenticated. 
 
There is a problem with your username/password (see section “Before You Begin”). 
 
Error:  Access is denied.  Please retype your credentials. 
 
There is a problem with your username/password (see section “Before You Begin”). 
 
ERROR:  Access is denied. User … belongs to a role that is not permitted or is not from an 
authorized domain. 
 
You have violated a security setting in the Domain Users dialog box table (see section “Domain 
Users Dialog Box”). 
 
ERROR: Access is denied.  User … can not be authenticated. 
 
There is a problem with your username/password (see section “Before You Begin”). 
 
ERROR:  Access is denied.  User does not have sufficient permissions. 
 
You tried to access data in your database, but your security configuration does not allow you 
access to that information.  Ask an authorized user (e.g. your server/network administrator) to 
allow you access to the required data.  Security permissions are generally set in the Provider 
window, Security tab (see section “Provider Window, Security Tab”).  Also, see section “Before 
You Begin”. 
 
ERROR:  Access is denied.  User is not a member of a HERO group with sufficient 
permissions. 
 
You tried to perform an action in HERO™ CMS logged in as a user that is not a member of one 
of the groups listed in section “Before You Begin” necessary to access that function.  For access, 
contact your server/network administrator. 
 
ERROR:  Access is denied.  User or domain (local machine) user is from has not been 
authenticated.  Please exit Hero. 
 
You have not properly logged into HERO™ CMS.  Exit and HERO™ CMS and launch it again. 
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ERROR:  Can not update record.  User does not have sufficient permissions. 
 
You tried to save/modify data in your database, but your security configuration does not allow 
you to save/modify that information.  Ask an authorized user (e.g. your server/network 
administrator) to allow you access to save/modify that information.  Security permissions are 
generally set in the Provider window, Security tab (see section “Provider Window, Security 
Tab”).  Also, see section “Before You Begin”. 
 
ERROR:  File/Open/Setup/Configuration’s SiteUser value is non-blank and not the same 
as current user’s name. 
 
A username has been entered in the “Site User” field in the Configuration window (see section 
“Configuration”), but that username does not match your Windows username (see section 
“Before You Begin”).  Either change your Windows username to match your HERO CMS™ 
username (or vice versa), or use “Require LogOn” instead. 
 
ERROR:  Logon failure:  unknown user name or bad password. 
 
There is a problem with your username/password (see section “Before You Begin”). 
 
ERROR:  Report […] does not exist. 
 
You attempted to open a Bill window, Status tab (see section “Bill Window, Status Tab”), which 
uses a report called InvoiceStatus with context Internal, but that report has been deleted (see 
section “Reports”).  Contact HTN for assistance (see section “HTN”). 
 
OR, you selected Goto Source in a Task window’s toolbar (see section “Task Window”), which 
uses a report called “Labs (Selected Item)” with context Labs, but that report has been deleted 
(see section “Reports”).  Contact HTN for assistance (see section “HTN”). 
 
OR, you attempted to run a report (see section “Run a Report”), but the report was deleted before 
you could run it.  Try running a different report instead, or contact HTN for assistance (see 
section “HTN”). 
 
ERROR:  The bill has been transmitted to the FMS.  Deleting it is not allowed. 
 
You tried to delete a bill (see section “Delete a Bill”), but the bill was already transmitted (see 
section “Transmissions”) to the FMS (see section “Data Flow Structure”).  The deletion was 
prevented, because the bill might have already been sent to MOHLTC, and might have already 
received a response (e.g. might have already been paid).  Instead of deleting the bill, you might 
want to archive it instead.  To archive the bill, turn on “R” (Reconcile) for each item on the 
Service Item List (see section “Bill Window, Invoice Tab, Service Item List”), and then save the 
bill. 
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Exception has been thrown by the target of an invocation… 
 
You tried to run a report (see section “Run a Report”), but there is a problem with that report.  
Or, you attempted to open a Bill window, Status tab (see section “Bill Window, Status Tab”), 
which uses a report called InvoiceStatus with context Internal, but there is a problem with that 
report.  Or, you tried to export data without using OntarioMD data portability format (see section 
“Export”), which uses a report called “CDS” with context Patient, but there is a problem with 
that report.  Fix the report (see section “View/Modify a Report”), or contact HTN for assistance 
(see section “HTN”). 
 
Failed to update database “…” because the database is read-only. 
 
There is a problem with your HERO™ CMS database file (e.g. HEROCMS.MDF).  Contact 
your server/network administrator or HTN (see section “HTN”). 
 
File appears not to be a proper EDT file. 
 
In a Files window (see section “List Files”), you attempted to add a file (e.g. RA or error claims) 
to the list, but the file you added does not seem to be in the correct format for a file created by 
MOHLTC.  If you selected the wrong file, try again, and double-check the file’s name and 
location.  Or, the file may be corrupt, in which case you may need to obtain another copy of it 
(e.g. from MOHLTC). 
 
General network error.  Check your network documentation. 
 
There is a problem with your Site Server, or your connection to your Site Server.  Contact your 
server/network administrator, Internet provider, or HTN (see section “HTN”). 
 
Health # already exists. 
 
You tried to re-save an existing patient record (not a new patient record) with a health card 
number that already exists in your database.  Change the health card number, and then try again.  
See section “Patient Window, Demographic Tab, Misc. Section”. 
 
Incorrect syntax near ‘…’. 
 
When running a report (see section “Run a Report”), you entered invalid text in the SQL field in 
the bottom-right corner of the Query dialog box (see section “Query Dialog Box”).  You can 
only make minor modifications to this field, for example changing the brackets or the operators 
(e.g. <, >, <=, >=), etc., but you cannot type (or paste) in your own criteria.  Run the report again, 
but be more careful modifying (or don’t modify) the SQL field. 
 
Input string was not in a correct format. 
 
A problem was most likely caused by an update that was downloaded from Microsoft.  
Download (or reinstall) the latest version of HERO™ CMS.  See section “Update”. 
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Invalid column name ‘…’. 
 
When running a report (see section “Run a Report”), you entered invalid text in the SQL field in 
the bottom-right corner of the Query dialog box (see section “Query Dialog Box”).  You can 
only make minor modifications to this field, for example changing the brackets or the operators 
(e.g. <, >, <=, >=), etc., but you cannot type (or paste) in your own criteria.  Run the report again, 
but be more careful modifying (or don’t modify) the SQL field. 
 
Message type (… write) can NOT write a … record. 
 
You have an incorrect site number entered in your configuration (see section “Configuration”).  
Enter the correct site number, and then try again.  Or, there is a problem with the Site Server (see 
section “Data Flow Structure”).  Contact HTN (see section “HTN”) or your server/network 
administrator. 
 
Or, you tried to save a record which is associated with another record that no longer exists.  For 
example, suppose you were entering a bill (see section “Add a Bill”), and you selected a patient 
in the Patient field in the Bill window (see section “Bill Window, Invoice Tab”), but before you 
could save the bill, someone (you or another user) deleted that patient (see section “Delete a 
Patient”).  When you try to save the bill, you’ll get an error message, because the bill is 
associated with a patient that no longer exists.  Either select a different patient, or close the Bill 
window without saving the bill. 
 
NEW FAILED:  Record with same identifier already exists.  Look it up. 
 
You tried to save a record (e.g. diagnosis code, report), but a record of the same type already 
exists in the database with the same information in a field (e.g. Code, Name/Context) that is 
supposed to be unique.  Change the data in that field, and then try again.  Or, instead of saving a 
new record, open the existing record instead. 
 
New Password different than Confirm Password.  Please try again. 
 
You tried to change your HERO™ CMS password using the HERO™ CMS change password 
feature, but your new password in the “New Password” field did not match your new password 
in the “Confirm Password” field.  Correct one (or both) of those fields, and then try again.  See 
section “Change Password”. 
 
New Record.  Please save it before adding a related task. 
 
In an Attachment window (see section “Attachment Window”) or Referral window (see section 
“Referral Window”), you selected the Task button, but the Attachment or Referral had not yet 
been saved.  Save the Attachment or Referral, and then try again. 
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New Record.  Please save it before running a report. 
 
You tried to run a report (see section “Run a Report”) on a record that hasn’t been saved.  Save 
the record, or open an existing record, and then try again. 
 
No [Default from Patient]’s for this document. 
 
In a Patient window (see section “Patient Window”), Payment window (see section “Payment 
Window”), Rx window (see section “Rx Window”), Requisition window (see section 
“Requisition Window”), or Task window (see section “Task Window”), you went in the Edit 
menu and selected Default from Patient (see section “Pull-Down Menus”), but that feature is not 
available in those windows.  Either go in the Edit menu to Set Default, or open an Appointment 
window (see section “Appointment Window”), Bill window (see section “Bill Window”), 
Encounter window (see section “Encounter Window”), or Referral window (see section 
“Referral Window”) instead.  See section “Defaults”. 
 
No access auditing for currently selected tab. 
 
From a Patient window, CPP tab (see section “Patient Window, CPP Tab”) or Import tab (see 
section “Patient Window, Import Tab”), or from a Provider window (see section “Provider 
Window”), you went in the File menu to Audit → Access.  That feature can only be run from the 
Configuration window (see section “Configuration”) or from any other tab in a Patient window 
(see section “Patient Window”).  See section “Audit”. 
 
No auditing for a new document. 
 
You tried to view an audit log for a record (e.g. patient, provider) that has not been saved.  Open 
an existing record (see section “View/Modify a Patient” or “View/Modify a Provider”) and then 
try again.  See section “Audit”. 
 
No auditing for this document. 
 
You tried to obtain an audit log from a window that does not support auditing.  You can only 
obtain an audit log from a Configuration window (see section “Configuration”), Patient window 
(see section “Patient Window”), or Provider window (see section “Provider Window”).  See 
section “Audit”. 
 
No changing the Provider after the bill has been transmitted to the FMS. 
 
You tried to change a bill’s provider (see section “Bill Window, Invoice Tab”), but the bill has 
already been transmitted (see section “Transmissions”) to the FMS (see section “Data Flow 
Structure”).  This type of change is not allowed (unless you selected a different role for the same 
provider), in order to prevent payments/responses for one provider (e.g. from an RA) from being 
applied to bills for a different provider.  Also, such a change could cause problems with the FMS 
invoice numbers (see section “Invoice Numbers”).  Instead of changing the bill’s provider, you 
can make a copy of the bill instead (go in the File menu to Copy, or select Copy in the Main 
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Toolbar – see section “Pull-Down Menus” or “Main Toolbar”), and possibly archive or delete 
the original bill.  To archive a bill, turn on the R (Reconcile) option for each service item on the 
Service Item List (see section “Bill Window, Invoice Tab, Service Item List”). 
 
No changing the Type after the bill has been transmitted to the FMS. 
 
You tried to change a bill’s type (see section “Bill Window, Invoice Tab”), but the bill has 
already been transmitted (see section “Transmissions”) to the FMS (see section “Data Flow 
Structure”).  This type of change is not allowed, in order to prevent payments/responses of one 
type (e.g. from an RA) from being applied to bills of a different type (e.g. Private).  Instead of 
changing the bill’s type, you can make a copy of the bill instead (go in the File menu to Copy, or 
select Copy in the Main Toolbar – see section “Pull-Down Menus” or “Main Toolbar”), and 
possibly archive or delete the original bill.  To archive a bill, turn on the R (Reconcile) option for 
each service item on the Service Item List (see section “Bill Window, Invoice Tab, Service Item 
List”). 
 
No code can be opened from this document. 
 
…   
 
No defaults for this document. 
 
You tried to set/clear a default in a window that doesn’t support defaults.  Only the Patient, 
Appointment, Bill, Payment, Encounter, Rx, Requisition, Task, and Referral windows support 
defaults.  See section “Defaults”. 
 
No deleting this record. 
 
You tried to delete a record that hasn’t been saved.  If you don’t want the record to exist in your 
database, don’t save it (e.g. close the window without saving changes).  Or, you tried to delete a 
record that can’t be deleted, e.g. a colour (see section “Colours”).  Colours can only be modified, 
not added or deleted. 
 
No edit auditing for currently selected tab. 
 
You attempted to view a record of writes to your database, either from the Configuration window 
(see section “Configuration”), or from a Patient window, CPP tab (see section “Patient Window, 
CPP Tab”) or Import tab (see section “Patient Window, Import Tab”), none of which supports 
that feature.  To view that log, select any other tab in a Patient window (see section “Patient 
Window”), or open a Provider window (see section “Provider Window”).  See section “Audit”. 
 
No editing the Beg Date or Code of a Problem item generated from Invoice # … 
 
In a Patient window, on the Problem tab, on the … list… (…)  you tried to… 
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No editing/deleting role with… 
 
In a Provider window, on the Demographic tab, on the Role List (see section “Provider Window, 
Demographic Tab, Role List”), you tried to delete or modify a role (and save the provider), but 
there are records (e.g. patients, appointments, bills, payments, etc.) associated with that role.  If 
you want to delete or modify that role, you must first delete those records, or associate them with 
a different role (and/or a different provider).  Or, instead of modifying a role, you might want to 
create a new role. 
 
No items exist to copy. 
 
In a Files window, you selected the Copy button, but there were no files on the Files List.  
Change the criteria (e.g. Provider, From, To, Type) in the Files toolbar, and then try again.  See 
section “List Files”. 
 
No items exist to open. 
 
In a Patient window (see section “Patient Window”), one of these happened: 
 


 On the Appt. tab (see section “Patient Window, Appt. Tab”), you selected Open → 
Appointment in the Patient toolbar (or pressed Ctrl-O), but no appointment was selected 
on the appointment list.  Select an appointment, and then try again. 


 On the Bill tab (see section “Patient Window, Bill Tab”), you selected Open → Source in 
the Patient toolbar (or pressed Ctrl-O), but no item was selected on the bill/payment list 
or service item list.  Select an item, and then try again. 


 On the Encounter tab (see section “Patient Window, Encounter Tab”), you selected Open 
→ Encounter in the Patient toolbar (or pressed Ctrl-O), but no encounter was selected on 
the encounter list.  Select an encounter, and then try again. 


 On the Problem tab (see section “Patient Window, Problem Tab”), you selected Open → 
Bill in the Patient toolbar (or pressed Ctrl-O), but no item was selected on the problem 
list.  Select an item, and then try again. 


 On the Rx tab (see section “Patient Window, Rx Tab”), you selected Open → Rx in the 
Patient toolbar (or pressed Ctrl-O), but no prescription was selected on the prescription 
list.  Select a prescription, and then try again. 


 On the Requisition tab (see section “Patient Window, Requisition Tab”), you selected 
Open → Requisition in the Patient toolbar (or pressed Ctrl-O), but no lab requisition was 
selected on the lab requisition list.  Select a requisition, and then try again. 


 On the Task tab (see section “Patient Window, Task Tab”), you selected Open → Task in 
the Patient toolbar (or pressed Ctrl-O), but no task was selected on the task list.  Select a 
task, and then try again. 


 On the Ref. tab (see section “Patient Window, Ref. Tab”), you selected Open → Referral 
in the Patient toolbar (or pressed Ctrl-O), but no referral was selected on the referral list.  
Select a referral, and then try again. 


 On the Attach. tab (see section “Patient Window, Attach. Tab”), you selected Open → 
Attachment in the Patient toolbar (or pressed Ctrl-O), but no attachment was selected on 
the attachment list.  Select an attachment, and then try again. 
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 On the Prog. tab (see section “Patient Window, Prog. Tab”), you selected Open → 
Source in the Patient toolbar (or pressed Ctrl-O), but no item was selected on the progress 
list.  Select an item, and then try again. 


 
No items exist to report on. 
 
In a Files window (see section “List Files”), you tried to run a report (see section “Run a 
Report”), but no file was selected.  Select a file, and then try again. 
 
No running reports for this document. 
 
You attempted to run a report (see section “Run a Report”) from a window that does not support 
reports.  Open a different window, and then try again. 
 
No source document exists for the current item. 
 
… 
“Patient Window, Problem Tab” 
 
Not implemented yet. 
 
You have attempted to use a function that is reserved for future development.  Make sure you 
have the latest version of HERO™ CMS (see section “Update”), or contact HTN (see section 
“HTN”) for more information about that feature or future development. 
 
Nothing to send or receive. 
 
A transmission was requested (see section “Transmissions”), but no data has been added or 
changed on the Site Server or FMS (see section “Data Flow Structure”) since the last 
transmission. 
 
Object reference not set to an instance of an object. 
 
This error message can occur when you perform multiple consecutive actions too quickly in 
HERO™ CMS.  For example, when you open or save a record (e.g. patient, appointment, bill, 
payment, etc.), or run a report (see section “Run a Report”), there may be a small delay while 
your workstation contacts the Site Server to send/receive the necessary data (see section “Data 
Flow Structure”).  During that delay, you may have attempted to either abort the operation, or 
perform another operation which caused a conflict.  In such cases, it may be advisable to wait for 
one operation to complete before attempting to perform another operation. 
 
Ontario Health # is invalid. 
 
You tried to save a patient record, but the Health # field is invalid (or the Prov. field is incorrect).  
See section “Patient Window, Demographic Tab, Misc. Section”.  Correct the data (or clear the 
Health # and version code fields, or change the Prov. field), and then try again. 
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Operation failed. 
 
You tried to fax a report (see section “Fax a Report”), but you have an invalid value specified in 
the Fax Server and/or Cover fields in the Configuration window (see section “Configuration”), or 
there is a problem with your Windows fax service.  For more information, check your Windows 
help or documentation.  Or, your computer does not have a program that can convert the report 
output (e.g. the temporary file in PDF or RTF format) into a format that the Windows fax service 
can understand, such as Adobe Acrobat (Reader) or Microsoft Word, etc.  Make sure one of 
those programs is properly installed/configured, and then try again. 
 
Parameter value ‘…’ is out of range. 
 
You tried to save a record (e.g. Bill – see section “Bill Window”) with a number (e.g. the Bill 
field on the Invoice tab, Service Item List – see section “Bill Window, Invoice Tab, Service Item 
List”) that’s too big or too small.  Change the number and then try again. 
 
Please add (or position on) a valid item before using Copy Item. 
 
In a Bill window, on the Invoice tab (see section “Bill Window, Invoice Tab”), you selected 
Copy Item in the Bill toolbar (or pressed Ctrl-V), but you had not selected a valid service item 
(with a date and procedure code) to copy.  Select (or enter) a valid service item, and then try 
again. 
 
Please do a transmission to the FMS to update the database and then exit the application. 
 
You are using an older version of HERO™ CMS, which must be updated.  Do a transmission 
(see section “Transmissions”) and then restart HERO™ CMS.  See section “Update”. 
 
Please edit the template bill and add information for auto-generated bills. 
 
In a Bill window, on the Invoice tab (see section “Bill Window, Invoice Tab”), you selected Bill 
From List (see section “Bill from a Patient List”), but there were no service items on the Service 
Item List (each service item must have a service date and a procedure code).  Add a service item, 
and then try again. 
 
Please ensure a provider is selected on the Main Toolbar. 
 
In a Patients window (see section “List Patients”), you selected the Query button.  Or, in an 
Appts. window (on the Day tab), you selected the Auto-bill button (see section “List 
Appointments”), or you tried to change the status of an appointment to Closed.  Or, in a Recalls 
window, you selected the Auto-bill button (see section “List Recalls”).  However, no provider 
was selected on the Main Toolbar.  Log in as a provider (see section “Log in as a Provider”) and 
then try again. 
 







 402


Please ensure the same provider is selected on the main and Appts. toolbars. 
 
In an Appts. window (on the Day tab), you selected the Auto-bill button (see section “List 
Appointments”), but two different providers were selected on the main and Appts. toolbars.  
Either log in as the provider selected on the Appts. toolbar (see section “Log in as a Provider”), 
or select the Provider button in the Appts. toolbar and select the same provider that is selected in 
the Main Toolbar.  Then try again. 
 
Please ensure the same provider is selected on the main and Recalls toolbars. 
 
In a Recalls window, you selected the Auto-bill button (see section “List Recalls”).  However, 
two different providers were selected on the main and Recalls toolbars.  Either log in as the 
provider selected on the Recalls toolbar (see section “Log in as a Provider”), or select the 
Provider button in the Recalls toolbar and select the provider that is selected in the Main 
Toolbar.  Then try again.   
 
Please enter a … for procedure… 
 
In a Bill window, on the Invoice tab (see section “Bill Window, Invoice Tab”), on the Service 
Item List, you entered a procedure code which requires a diagnosis code, facility, admitted date, 
and/or referring provider (see section “Procedure Window”), but the required information has 
not been specified.  Specify the missing information, or change the procedure code, or delete the 
service item (or the bill).  Or you can change the requirements for the selected procedure code 
(see section “View/Modify a Procedure Code”). 
 
Please enter a date for PCRG enrollment. 
 
You tried to save a patient with the PCRG option on, but with no date specified for the PCRG 
option (see section “Patient Window, Demographic Tab”).  Specify a date, or disable the PCRG 
option, and then try again. 
 
Please enter a date on or after admitted date for procedure… 
 
You tried to save a bill (see section “Bill Window, Invoice Tab”), but (at least) one of the service 
items has a date that is earlier than the Admitted date.  Correct/delete the service date(s) and/or 
the Admitted date, and then try again. 
 
Please enter a legal name. 
 
You tried to save a provider or patient, but no text was entered in the Name section on the 
Demographic tab (see section “Provider Window, Demographic Tab, Name Section”, or “Patient 
Window, Demographic Tab, Name Section”).  Enter text in the Name section and try again. 
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Please enter a name. 
 
You tried to save an insurer (see section “Insurer Window”), but no text was entered in the Name 
field.  Enter text in the Name field and try again. 
 
Please enter a valid Provider #. 
 
You tried to save a provider, but no Provider # was entered (see section “Provider Window, 
Demographic Tab, Misc. Section”).  Enter a Provider # and try again. 
 
Please enter an office code. 
 
You tried to save a local provider (see section “Provider Window, Demographic Tab”), but no 
Office Code was entered.  Enter an Office Code, or remove the provider’s local role(s) on the 
Role List. 
 
Please enter at least one Group No. and Role combination. 
 
You tried to save a provider with no entries on the role list (see section “Provider Window, 
Demographic Tab, Role List”).  Add at least one entry to the role list and try again. 
 
Please enter non-duplicate phone # types. 
 
You tried to save a patient with multiple phone numbers of the same type (Other, Home, Work, 
Cell, Fax, Alt. 1, Alt. 2).  Change one of the phone number types and try again.  See section 
“Patient Window, Demographic Tab, Contact Section”. 
 
Please position on one of fields (Admitted, Facility, Referring, Payor, Proc., or Diag.). 
 
In a Bill window (see section “Bill Window”), you went in the Edit menu and selected Default 
from Patient, but that feature is not available for the selected field.  Select a different field (or 
window), and then try again.  Or, use Set Default instead.  See section “Defaults”. 
 
Please position on one of fields (Date, Admitted, Type, Facility, Referring, Close 
Appointment, Hst, Payor, Proc., Diag., or ToCds). 
 
In a Bill window (see section “Bill Window”), you went in the Edit menu and selected Clear 
Default (see section “Pull-Down Menus”), but that feature is not available for the selected field.  
Select a different field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Date, Admitted, Type, Facility, Referring, Close 
Appointment, Hst, Proc., Diag., or ToCds). 
 
In a Bill window (see section “Bill Window”), you went in the Edit menu and selected Set 
Default (see section “Pull-Down Menus”), but that feature is not available for the selected field.  
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Select a different field (or window), and then try again.  Or, use Default from Patient instead.  
See section “Defaults”. 
 
Please position on one of fields (Date, All Items, From, Encounter, Problem, Rx, Lab, 
Immunize, Allergy, Risk, Alert, or Family). 
 
In a Referral window (see section “Referral Window”), you went in the Edit menu and selected 
Set Default (see section “Pull-Down Menus”), but that feature is not available for the selected 
field.  Select a different field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Date, or Lab). 
 
In a Requisition window (see section “Requisition Window”), you went in the Edit menu and 
selected Set Default (see section “Pull-Down Menus”), but that feature is not available for the 
selected field.  Select a different field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Date, or Status). 
 
In an Appointment window (see section “Appointment Window”) or Encounter window (see 
section “Encounter Window”), you went in the Edit menu and selected Set Default (see section 
“Pull-Down Menus”), but that feature is not available for the selected field.  Select a different 
field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Date, Referred, All Items, From, Encounter, Problem, Rx, 
Lab, Immunize, Allergy, Risk, Alert, or Family). 
 
In a Referral window (see section “Referral Window”), you went in the Edit menu and selected 
Clear Default (see section “Pull-Down Menus”), but that feature is not available for the selected 
field.  Select a different field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Date, Status, or Referring). 
 
In an Appointment window (see section “Appointment Window”) or Encounter window (see 
section “Encounter Window”), you went in the Edit menu and selected Clear Default (see section 
“Pull-Down Menus”), but that feature is not available for the selected field.  Select a different 
field (or window), and then try again.  See section “Defaults”. 
 
Please position on one of fields (Due, Priority, Status, or Assignee). 
 
In a Task window (see section “Task Window”), you went in the Edit menu and selected Set 
Default or Clear Default (see section “Pull-Down Menus”), but those features are not available 
for the selected field.  Select a different field (or window), and then try again.  See section 
“Defaults”. 
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Please position on one of fields (Manual). 
 
In a Payment window (see section “Payment Window”), you went in the Edit menu and selected 
Set Default or Clear Default (see section “Pull-Down Menus”), but those features are not 
available for the selected field.  Select a different field (or window), and then try again.  See 
section “Defaults”. 
 
Please position on one of fields (Referred). 
 
In a Referral window (see section “Referral Window”), you went in the Edit menu to Default 
from Patient (see section “Pull-Down Menus”), but that feature is not available for the selected 
field.  Select the Referred field, and then try again.  See section “Defaults”. 
 
Please position on one of fields (Referring). 
 
In an Appointment window (see section “Appointment Window”) or Encounter window (see 
section “Encounter Window”), you went in the Edit menu and selected Default from Patient (see 
section “Pull-Down Menus”), but that feature is not available for the selected field.  Select the 
Referring field, and then try again.  Or, use Set Default instead.  See section “Defaults”. 
 
Please position on one of fields (SIG, Rep., or Dur.). 
 
In an Rx window (see section “Rx Window”), you went in the Edit menu and selected Set 
Default or Clear Default (see section “Pull-Down Menus”), but those features are not available 
for the selected field.  Select a different field (or window), and then try again.  See section 
“Defaults”. 
 
Please position on one of fields (Title, City, Postal, or first 2 Phone #’s Area or Prefix). 
 
In a Patient window (see section “Patient Window”), you went in the Edit menu and selected Set 
Default or Clear Default (see section “Pull-Down Menus”), but those features are not available 
for the selected field.  Select a different field (or window), and then try again.  See section 
“Defaults”. 
 
Please save a configuration from menu item File/Open/Setup/Configuration. 
 
HERO™ CMS has not been configured.  See section “Configuration”. 
 
Please select a patient. 
 
You tried to save a record (e.g. bill, encounter, prescription), but no patient was selected.  Select 
a patient, and then try again. 
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Please select a payor. 
 
You tried to save a Private or Insurer bill, but no payor was selected (see section “Bill Window, 
Invoice Tab”).  Select a payor and then try again. 
 
Please select a payor/patient. 
 
You tried to save a payment, but no payor/patient was selected (see section “Payment Window”).  
Select a payor/patient and then try again. 
 
Please select a provider before exporting or importing. 
 
You tried to export data (see section “Export”) or import data (see section “Import”), but no 
provider was logged in.  Log in as a provider (see section “Log in as a Provider”), and then try 
again. 
 
Please select a provider before running a report. 
 
You opened a list of provider-specific records (e.g. bills, appointments, recalls, etc.) and tried to 
run a report (see section “Run a Report”), but no provider was selected in the Provider field.  
Select a provider, and then try again. 
 
Please select a provider. 
 
You tried to save a record (e.g. appointment, bill, payment) with no provider selected.  Select a 
provider, and then try again. 
 
Please select a query of the proper data type. 
 
In a Query dialog box (see section “Query Dialog Box”), you double-clicked in the Code or 
Description field, or pressed F9 in the Code field, which opened a Find Query Dialog Box (see 
section “Find Query Dialog Box”).  Then you selected a query of the wrong type, one that had 
originally been associated with a different type of record.  For example, a query that was 
designed to use with the report “Query Patients” cannot be used with the report “Query Bills”.  
Select a different query, and then try again.  Or, enter the query criteria manually in the Query 
dialog box. 
 
Please select a referred. 
 
You tried to save a referral (see section “Referral Window”), but no provider was selected in the 
Referred field.  Select a provider, and then try again. 
 
Please select a type of either COL, PAP, MAM, FLU, or IMM. 
 
In a Recalls window, you selected the Auto-bill button (see section “List Recalls”), or you tried 
to run a Compliance report (see section “How to use Recalls”, step #15, or “Run a Report”), but 







 407


the type was not set to COL, PAP, MAM, FLU, or IMM.  Select one of those five recall types, 
and then try again. 
 
Please select an insurer 
 
You tried to save a payment with the Type set to Insurer, but no insurer was selected (see section 
“Payment Window”).  Select an insurer (or change the Type) and then try again. 
 
Please set the server system time to: … 
 
You tried to do a transmission (see section “Transmissions”), but the transmission cannot 
complete, because the date, time, and/or time zone setting on your Site Server computer (see 
section “Data Flow Structure”) is inaccurate.  Fix the incorrect setting(s), and then try again.  For 
more information, check your Windows help or documentation. 
 
Please specify a date for Letter 1 before one for Letter 2. 
 
In a Patient window, on the Recall tab (see section “Patient Window, Recall Tab”), on the Recall 
List, you entered a recall with a date for Letter 2 but no date for Letter 1, and then tried to save 
the patient record.  Enter a date for Letter 1, or delete the date for Letter 2, or delete the recall, 
and then try again. 
 
Please specify a date for Letter 1 before one for Phone. 
 
In a Patient window, on the Recall tab (see section “Patient Window, Recall Tab”), on the Recall 
List, you entered a recall with a date for Phone but no date for Letter 1, and then tried to save the 
patient record.  Enter a date for Letter 1, or delete the date for Phone, or delete the recall, and 
then try again. 
 
Please specify a date on the Appts. toolbar. 
 
In the Appts. window (on the Day tab), you selected the Auto-bill button (see section “List 
Appointments”), but no date (or an invalid date) was selected on the Appts. toolbar.  Select a 
date on the Appts. toolbar, and then try again. 
 
Please specify a date. 
 
You tried to save a record (e.g. appointment, bill, payment) with no date specified.  Specify a 
date, and then try again. 
 
Please specify a drug. 
 
You tried to save a prescription (see section “Rx Window”) with no drug specified.  Specify a 
drug, and then try again. 
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Please specify a due date. 
 
You tried to save a task (see section “Task Window”), but no date was specified in the Due field.  
Specify a date in the Due field, and then try again. 
 
Please specify a duration less than or equal to 1440 minutes. 
 
You tried to save an appointment (see section “Appointment Window”), but the number in the 
Duration field was too big.  Enter a whole number (of minutes) from 0 to 1440 in the Duration 
field, and then try again. 
 
Please specify an assignee. 
 
You tried to save a task (see section “Task Window”) with no assignee chosen.  Select the 
Assignee button to choose an assignee and then try again. 
 
Please specify at least one field in generic query.  Incorrect syntax near ‘Role’. 
 
You tried to run the report “Query Generic” (see section “Run a Report”), but no fields were 
selected in the Fields section of the Query dialog box (see section “Query Dialog Box”).  Select 
at least one field to include in the report output, and then try again. 
 
Please specify either a last or first name. 
 
You tried to save a provider or patient with no first name and no last name (see section “Provider 
Window, Demographic Tab” or “Patient Window, Demographic Tab”).  Specify a first and/or 
last name and then try again. 
 
Please specify Payor/Patient, Provider, and, if applicable, an Insurer. 
 
You tried to manually apply a payment (see section “Payment Window, Service Item List”), but 
you did not specify a patient/payor, insurer, and/or provider.  Specify a patient and provider (and, 
for Insurer payments, an insurer), and then try again. 
 
Procedure or function ‘…’ expects parameter ‘@Filter’, which was not supplied. 
 
You tried to run a report (see section “Run a Report”) from a Provider window (see section 
“Provider Window”), but that report requires the Query option to be enabled in the Report 
Designer window (see section “Report Designer Window”), and that option was not enabled.  
Enable the Query option, and then try again. 
 
Record has been edited by another user.  Refresh & re-edit. 
 
You opened a record (e.g. patient, appointment, bill, payment, etc.), modified it, and tried to save 
the changes, but in the meantime, someone else (e.g. another user on another computer) saved 
changes to the same record.  If you were to save your changes, they would overwrite the other 
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user’s changes, which cannot be allowed.  Instead, you should first refresh the record, i.e. go in 
the View menu to Refresh (see section “Pull-Down Menus”), or press F5, or select Refresh in the 
Main Toolbar (see section “Main Toolbar”).  Then re-enter your changes, and then save the 
record again. 
 
Record to be updated NOT found. 
 
You tried to save (changes to) a record (e.g. patient, appointment, bill, payment, etc.), but the 
record has already been deleted (through another window in your HERO™ CMS, or by another 
HERO™ CMS user).  You may be able to save a new record of the same type with the same 
information by selecting Copy in the File menu (see section “Pull-Down Menus”) or Main 
Toolbar (see section “Main Toolbar”) and then saving the copy. 
 
Restored database detected.  STOP ALL DATA ENTRY IMMEDIATELY. Please contact 
HTN Inc. support. 
 
You tried to do a transmission (see section “Transmissions”), but you have lost data from your 
database, i.e. you restored from an old backup (see section “Backup”) that was made before your 
last transmission.  Contact HTN for assistance (see section “HTN”).  Do not add, modify, or 
delete any data in your database until you have done a successful transmission! 
 
Search criteria too wide.  Please narrow search. 
  
You searched for a list of records (see section “Searching for a Record”), but so many items were 
found matching your search criteria (e.g. over 500 or 1000) that to display them all could 
consume an unreasonably large amount of time, memory, disk space, network bandwidth, etc.  
Instead, try making your search criteria more specific.  For example, instead of searching for 
“SM”, search for “SMITH”. 
 
Or, you ran a report (see section “Run a Report”), but there were so many records to include in 
the report output (e.g. over 500 or 1000) that to display them all could consume an unreasonably 
large amount of time, memory, disk space, network bandwidth, etc.  Instead, run a different 
report, or use the Query dialog box (see section “Query Dialog Box”) to specify which records to 
include in the report output. 
 
Server was unable to process request.  --> General network error.  Check your network 
documentation. 
 
There may be a problem with your Site Server or network/Internet connection.  Contact your 
server/network administrator or Internet provider. 
 
Site # has improper case. 
 
The Site # field in your Configuration window (see section “Configuration”) contains incorrect 
casing (e.g. uppercase letters that should be lowercase, and/or vice versa).  Correct the Site # and 
then restart HERO™ CMS. 
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SQL Server does not exist or access denied. 
 
There may be a problem with your Site Server or network/Internet connection.  Contact your 
server/network administrator or Internet provider. 
 
STOP:  Number of machines exceeds licenced count of ….  Please contact HTN Inc. 
customer support.  Application will now exit. 
 
HERO™ CMS has been installed on too many computers.  Contact HTN (see section “HTN”) to 
modify your contract to allow more workstations (there may be an extra cost for this).  Or, 
remove HERO™ CMS on one computer before installing it on another. 
 
STOP:  Number of operators exceeds licenced count of ….  Please contact HTN Inc. 
customer support.  Application will now exit. 
 
Too many users are using HERO™ CMS simultaneously.  Contact HTN (see section “HTN”) to 
modify your contract to allow more users (there may be an extra cost for this).  Or, one user 
should close HERO™ CMS and wait a minute before another user can open HERO™ CMS. 
 
STOP:  Provider is not licenced for ….  Please contact HTN Inc. customer support 
 
The provider you have selected has not been enabled for the feature you are trying to use (e.g. 
billing, scheduling, etc.).  Contact HTN (see section “HTN”) to activate that feature.  There may 
be an extra cost associated with each feature. 
 
System.Web.Services.Protocols.SoapException:  There was an exception running the 
extensions specified in the config file… 
 
You tried to import a file into an attachment (see section “Attachment Window”), but the file 
was bigger than the maximum file size (e.g. 16MB).  Import a smaller file instead. 
 
The application failed to initialize properly (0xc0000135).  Click on OK to terminate the 
application. 
 
You do not have Microsoft’s .NET Framework installed.  You can download this from 
Microsoft’s web site (e.g. http://www.microsoft.com/netframework/). 
 
The data types text and varchar are incompatible in the … operator. 
 
In a Query dialog box (see section “Query Dialog Box”), in the field tree on the left, you selected 
a notes (multi-line) text field, and then, in the Selection section, you chose “<>” or “<” or “>” or 
“<=” or “>=”.  Those comparisons cannot be used with notes fields.  Go back into the Query 
dialog box, but use “LIKE”, “CONTAINS”, “NOT LIKE”, or “NOT CONTAINS” instead, or 
choose a different field to compare. 
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The DELETE statement conflicted with… 
 
You tried to delete a record (e.g. provider, patient), but that record cannot be deleted because it’s 
associated with other records.  For example, you can’t delete a provider that is associated with 
patients, appointments, bills, payments, encounters, prescriptions, lab requisitions, lab results, 
referrals, or attachments, and you can’t delete a patient that is associated with appointments, 
bills, payments, encounters, prescriptions, lab requisitions, lab results, tasks, referrals, or 
attachments. 
 
The health card has expired. 
 
You opened a patient (see section “View/Modify a Patient”) or swiped a health card (see section 
“Health Card Readers”) with an expiry date in the past (see section “Patient Window, 
Demographic Tab, Misc. Section”).  Ask the patient for their latest health card (expiry date), or 
tell the patient to renew their health card. 
 
The multi-part identifier “PatientID.Identifier” could not be bound. 
 
When running a report (see section “Run a Report”), you entered invalid text in the SQL field in 
the bottom-right corner of the Query dialog box (see section “Query Dialog Box”).  You can 
only make minor modifications to this field, for example changing the brackets or the operators 
(e.g. <, >, <=, >=), etc., but you cannot type (or paste) in your own criteria.  Run the report again, 
but be more careful modifying (or don’t modify) the SQL field. 
 
The operation timed-out. 
 
There may be a problem with your Site Server or network/Internet connection.  Contact your 
server/network administrator or Internet provider. 
 
The request failed with… 
 
HERO™ CMS connected to the Site Server (see section “Data Flow Structure”) but received an 
error message when trying to access the database.  You might have an incorrect value for “Site 
URL” (see section “Configuration”), or there could be a problem with the Site Server (in which 
case you should contact your server/network administrator or HTN (see section “HTN”)).  Or, 
there might be a problem with the username/password you are using to authenticate (see section 
“Before You Begin”), in which case you should try again, or contact your server/network 
administrator. 
 
The “SendUsing” configuration value is invalid. (no smtp server) 
 
You tried to e-mail a report (see section “E-mail a Report”), but you did not specify a value in 
the SMTP field in the Configuration window (see section “Configuration”), and HERO™ CMS 
was unable to determine your SMTP server from your e-mail program.  Either check your e-mail 
software configuration, or enter a value for SMTP in the Configuration window. 
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The underlying connection was closed:  An unexpected error occurred on a receive. 
 
You tried to copy a file (e.g. RA, error claim file, batch acknowledgment, etc.) into HERO™ 
CMS (e.g. from a floppy disk) for processing (see section “List Files”), but the file was bigger 
than the maximum file size (e.g. 3MB).  Contact HTN for assistance (see section “HTN”). 
 
The underlying connection was closed:  Could not establish trust relationship for the 
SSL/TLS secure channel. 
 
There may be a problem with your Site Server.  Contact your server/network administrator or 
Internet provider.  Or, you might have an incorrect value for “SSL” or “Site URL” (see section 
“Configuration”). 
 
The underlying connection was closed:  The remote name could not be resolved. 
 
You might have an incorrect value for “Site URL” (see section “Configuration”), or there could 
be a DNS problem (in which case you should contact your Internet provider or server/network 
administrator). 
 
The underlying connection was closed:  The server committed an HTTP protocol violation. 
 
HERO™ CMS was able to connect to the Site Server (see section “Data Flow Structure”), but 
was unable to access the database.  You might have an incorrect value for “Site URL” (see 
section “Configuration”), or there could be a problem with the Site Server (in which case you 
should contact your server/network administrator or HTN (see section “HTN”)). 
 
The underlying connection was closed:  Unable to connect to the remote server. 
 
HERO™ CMS was unable to connect to the Site Server (see section “Data Flow Structure”).  
You might have an incorrect value for “Site URL” (see section “Configuration”), or there could 
be a problem with your network or Internet connection (in which case you should contact your 
network administrator or Internet access provider), or with the Site Server (in which case you 
should contact your server/network administrator or HTN (see section “HTN”)). 
 
Unable to connect to the remote server. 
 
There may be a problem with your Site Server or network/Internet connection.  Contact your 
server/network administrator or Internet provider. 
 
Unable to open the physical file “….LDF”.  Operating system error 2: “2(The system 
cannot find the file specified.)”.  Could not locate entry in sysdatabases for database ‘…’.  
No entry found with that name.  Make sure that the name is entered correctly. 
 
You tried to attach a database (see section “Server Initialization Dialog Box”) but one of the two 
database files is missing.  For example, if you selected a file called HEROCMS.MDF, there 
should also be a file called HEROCMS.LDF in the same folder.  Make sure those two files exist 
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(in the same folder), with the same name (except for the three-letter extensions on the end, i.e. 
MDF/LDF), and then try again. 
 
Update for application detected at Site server. 
 
The version of HERO™ CMS running on the workstation is older than the version of HERO™ 
CMS running on the Site Server (see section “Update”).  Select OK, and another dialog box will 
ask “Are you sure you want to exit and update the application?”.  Select OK to upgrade the 
workstation to the same version as the Site Server, or select Cancel to continue using the old 
version on the workstation. 
 
WAIT:  Still authenticating the user and domain (local machine). 
 
HERO™ CMS is trying to connect to the Site Server (see section “Data Flow Structure”), or has 
connected and is waiting for permission to access the database.  Wait a moment before trying to 
access the database. 
 
WARNING:  Please specify a proper … date range. 
 
In a Provider window, on the Schedule tab (see section “Provider Window, Schedule Tab”), you 
selected Copy Selection (in the Repeat section), but the date range specified in the Select or 
Repeat section is invalid (because the From date is after the To date).  Fix the incorrect date(s) 
and try again. 
 
WARNING:  Please specify a repeat date range past select date range. 
 
In a Provider window, on the Schedule tab (see section “Provider Window, Schedule Tab”), you 
selected Copy Selection (in the Repeat section), but the From date in the Repeat section is before 
(or the same as) the To date in the Select section.  Fix the incorrect date(s) and try again. 
 
WARNING:  Please specify a select date range with schedule items. 
 
In a Provider window, on the Schedule tab (see section “Provider Window, Schedule Tab”), you 
selected Copy Selection (in the Repeat section), but there are no schedule items to copy (in the 
date range specified in the Select section).  Change the date range in the Select section, or add 
schedule items in the specified date range before using the Copy Selection function. 
 
WARNING:  Please specify and save provider demographics first of all. 
 
In a Provider window, on the Schedule tab (see section “Provider Window, Schedule Tab”), you 
selected Copy Selection (in the Repeat section), but the Provider has not yet been saved.  Save 
the provider and try again. 
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You must have permission to create/write HKEY_LOCAL_MACHINE registry entries 
 
You tried to save changes in the Configuration window (see section “Configuration”), but you do 
not have administrator access to your computer, so the changes could not be saved.  Contact your 
computer’s owner/administrator (or your server/network administrator) for assistance. 






